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Goldfish 4: Quick Start Tutorial
Get to know Goldfish and create a sample website with blog, contact form and an

animation on the start page. Create a mobile view for smart phones.

In this tutorial, we are developing an unique layout. If you don't want that, you can select a

pre-built design in the Design window and fill it with content. This shortens the development time.

But in Goldfish you can unleash your creativity and develop the complete design of the website by

yourself. We suggest to create a sample website with the help of this guide and you will get an

introduction to Goldfish.

The Page Model of Goldfish
Goldfish creates websites in an innovative and unique way. There are flexible components

available such as pages, page areas, text boxes, or image items.

A page is made up of 3 different levels. A page (gray) is the base. There are page areas (yellow)

on a page, that represent different areas of your website (header, footer, navigation, main area,

etc.). A page area contains items (green). Items represent the content of your website such as

images, films or text.
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In order to build a planned layout, you must divide (cut) it into different page areas at first. In the

example above we have a header area (on the top), an area for the content of the page (in the

middle left), an area for the navigation (in the middle right) and a footer (on the bottom). For a

different layout you will need a different breakdown of the areas. Divide the layout always so in

areas that the main area with the main content stands as a single area for itself.

The Layout for the Sample Website
For sample website, you will need 4 different photos, one of them should be suitable as a

background image. The layout will be completely created in Goldfish. You do not need any

additional software for this example.
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As described earlier in The Page Model of Goldfish, the layout will be divided into areas. The 

Navigation (blue stripe) and the Header (directly below) are the same on each page. Below this

there is the main area, on that is displayed different content on all sub pages. The Footer at the

bottom is again the  same on every page. There will be copyright information on it.

Creating the Layout for Computers and Tablets
Start a new project and click on New Goldfish Project or select File > New ... from the menu. A

project window and the Design window will be opened.

Make sure that Add page for mobile devices is checked and double click on Blank because we

want to create a unique design. You will see the project list on the left. All the pages and

components for your website are listed here. First, click on Master Page, to change basic settings

such as the background color.
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The properties for the Master Page appear on the right. Change Margin Left, Margin Right, 

Margin Top and Margin Bottom to 0 because the website does not require a page margin.

Change the color from Background Color to white. To do this, click in the gray box to bring up a

color picker.

We will need an Area Template for each area, that we get by cutting up the layout. An area

template represents a section of the website and can be used on any sub page, so that you have

to create everything only once.

We will need four area templates for Navigation, Header, Main and Footer, and the area template 

Main for the content already exists. Click on + at the bottom left and select Add Area Template.

Repeat this step two more times so that you have created a total of three new area templates.
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Double click on the new templates in the project list, and change the name to Navigation, Header

and Footer. In the next step we will choose the correct settings for the area templates. First, click

on Navigation.

The properties of the area template Navigation are visible. Change the property Height (min) to 

60, because the navigation should be only 60 pixels high. Change the Background Color to blue,

and select the check box before Stretch background to border. So the background will be drawed

to the edges of browser windows, that are larger than the 1000 pixel wich are set as the Width.

Next, click on the page template Header. Change the Height (min) to 200 here. The header

should contain a photo as background. Because of this, turn off the Background Color by

removing the selection from the check box and click ? after Background Picture. Select a picture

from your computer for the background. Enter the value 1300 in both boxes at Reduce image size

to max. in the Import Media window. Thus, the image will be automatically scaled down during the

import. Click on OK to import the picture.

Choose the option Cut to Fill at Repeat, so that the background is displayed over the whole area.
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At last, enable the checkbox Stretch background to border.

Next, click on the page template Main. Change only the Height (min) to 300 here.

Click on the page template Footer. Change the property Border Top Width to 3 and a three pixel

wide, black border appears on the top of the footer. Now, change the Height (min) to 50.

The next step is to build the layout on the start page from the area templates. Click on the Start

Page in the project list. Drag the Navigation, then the Header and the Footer from the

components at the bottom to the page. You can move the areas around with the mouse and can

drag them into the correct order. At the top the Navigation, below that the Header, Main and the 

Footer.

Choose Preview from the toolbar on the top and see the result. The basic layout is already done.

In the next step the menu, headlines and copyright text will be added.
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We start on the area template Footer. Click on it and drag a Text item from the components to the

area template. Double click on the item, delete the text Lorem ipsum... and write © My Cool

Website, instead. Reduce size of the item by dragging the corners and move it to the position Left

of 0, and Top of 15. For this you can use alignment guides by dragging them from the rulers to

the Editor.

Go to the area template Header, and use again a text item for the headline and the sub headline.

You can choose the font size and color by selecting some text and clicking on Edit Text > Font

Style > Choose ... in the properties.

Go to the area template Navigation. A navigation menu should be there. Drag a Menu from the

components to the template and increase its length but decrease its height by dragging the

corners until it looks like in the picture above.
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Change the property Menu > Menu Type to Simple Menu (displays no subfolders) in the

properties. Then add a 3 pixel and white border with Item > Border Left Width.

Go to the category Main Menu Entry. Add a 3 pixel and white border at Main Menu Entry > Border

Right Width. After that, turn off the Background Color.

When you move the mouse over a menu entry the the font color and style should change. Disable

the property Change Background at  Moving Mouse Over Link Effect,  enable Change Font  and

click on Choose... behind that. Select white as the font color and Bold as the font style.

Choose exactly the same at Clicking On Link Effect.

The menu shows still Untitled as the only entry for the start page. Go to the start page and

change the property Page > Title to My Website - Welcome. This text will be displayed in the title

bar of the browser window. Change Page > Menu Title to Welcome. This will change the text in

the menu.

INFO: If the properties of the page are not visible after a single click on Start Page, you

have to click a second time on it.
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Choose Preview from the toolbar on the top and see the result. The layout for computers and

tablets is done.

Creating Sub Pages
In the next step, the website has to be filled with content. In addition, we need a total of 3 sub

pages (including the start page).

Add a new sub page. Click on + on the bottom left and select Add page. A new page below the

start page will be created.
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Double click on the page name and rename the new page to blog. Again, the page must be filled

with the layout. Click on the new page.

Select the template Master Page in the properties at Page > Page Template. The background

color and page margins change  Immediately, to that you have chosen on the Master Page.

Now drag again template by template from the components to the page. At first the Navigation,

then Header, Main and the last one Footer. Change the Title in the properties to My Website -

Blog and the Menu Title to Blog.

It is simple to create the next new page. Select the page blog.htm and click on Duplicate on the

bottom. Change Title to My Website - Contact and Menu Title to Contact in the properties of the

new page.

An Animation on the Start Page
For the start page, we will build an animation. Click the start page and double click on the empty

main area on the page.

Drag three Picture items to the start page and select a picture from your computer at Picture >

Picture in the properties for each of the three items. Activate Picture > Shadow for all three

images to create a shadow effect. Drag the images smaller and arrange them side by side. With 

Item > Rotation, you can rotate the pictures a bit.
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Place a Text item below the pictures for a link to the sub page with the blog. Change the text to 

Blog and choose center as the text format.

Select the complete text and enable Use as link. Click on Choose ... behind that the Link window

will be opened. Select at /blog.html at Internal Link to Page.

The three images should be swirled in when the page is loaded. Each of the images must be

named for that. Click on each image and change the name at Item > Identifier (Id) to Picture1, 

Picture2 and Picture3. Then drag an Animation item to the editor. Place it below the images. The 

Animation item itself is invisible on the finished website.
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Click on Animation > Animation > Choose... in the properties and the window Animation will be

opened. Click on + in this window and add Picture1, Picture2 and Picture3 to the animation.

Change the animations to Drive in in the list. Change the Direction for the first image to Left, for

the second image to Right and for the third image to Top in the options on the right. Then, enable

clockwise or counterclockwise rotation for each animation.

The images should drive in with a delay. Because of this, enter 2, 3 and 4 seconds in the column

at Delay (Sec.). Click on OK when you are done and have a look the preview if you want.

Setting Up a Blog
A blog should be installed on the page blog.html, that you can fill with content from a login area in

the browser while on the move. Click on the page blog.html and click a second time on it, so that

only the page is selected.

Select the main area on the page (click it once in the editor) and delete it with the delete key.

Instead, drag a Blog area to the place where the main area has been deleted.
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Choose Main as the Area Template In the properties of the Blog area. Change Padding Top to 40

and Padding Bottom to 20. So the blog entries have some space.

Contact Form and Terms & Conditions
There should be a contact form and the Terms & Conditions on the contact page. Go to the

Contact page and double click on the main area there.

Drag a Text item to the editor and fill it with a Terms & Conditions text. Then drag Form item to

the editor and place it next to the Terms & Conditions.

If your site visitors fill out the form and send it, the data will be sent via email to you. For this

purpose you have to enter your e-mail address in the form properties. Do this in the properties of

the form at E-Mail > E-Mail Address.
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Creating the Layout for Smartphones
The website for computers and tablets is now done. But the view for smart phones is still missing.

Goldfish has already automatically created a start page for smartphones and a redirection. All

visitors with a smartphone will be automatically redirected to mobile/. The layout for Smartphones

has to be separated in sections too. When doing this similar areas as for the large website can be

used.

Create three new area templates for the layout for smartphones. To do this, duplicate the already

existing area template Mobile Area with Duplicate on the bottom left. You now have a total of four

area templates together with the template Mobile Area.

Rename each area template to Mobile Main, Mobile Navigation, Mobile Header and Mobile

Footer. In the next step you have to choose the correct settings for each area template.

Set the Height (min) to 50 and choose blue as the Background Color for the area template Mobile

Navigation. Choose the header background picture also for Mobile Header and set Repeat to Cut

to Fill. For this template the Height (min) should be 150. Set the Height (min) to 300 for the Mobile

Main template. For Mobile Footer, add a 3 pixel wide black border and set the Height (min) to 50.
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Go to the page mobile (the start page for smartphones). Build layout  here by dragging the

missing area templates from the components to the page. That are from top to bottom Mobile

Navigation, Mobile Header, Mobile Main and Mobile Footer. Explore the result in the preview. The

basic layout is done. Now you have to create the menu,  headlines and copyright text.

Click on the area template Mobile Navigation and drag a Menu item to it. In its properties, select 

Drawer Menu (displays no subfolders) as Menu > Type. A drawer menu is compact and perfectly

suited for smartphones.
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To display all sub pages below mobile/ in the drawer menu and not the normal website, you need

to select /mobile as Base Folder in the properties.

Now you have to adjust the look of the menu items. Choose again blue in the properties as the

background color at Main Menu Entry > Background Color. Choose exactly the same setting as in

the menu for the normal website for Moving Mouse Over Link Effekt and Clicking on Link Effect

(disable Change Background, Change Font to a white font color and bold).

Switch to the area template Header and choose Edit > Select All from the menu. The Text item

with the title and the subtitle will be selected. Now choose Edit > Copy from the menu and copy

both to the clipboard. Switch to the area template Mobile Header and paste both with Edit > Paste

. Arrange the text items so that they fit into the template.

Also copy the copyright information from the area template Footer to the area template Mobile

Footer. Click on to the page mobile and change the title to My Website - Welcome.
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You can not change the menu title here, because it is disabled for mobile so that it does not

appear in the normal website menu. Select the next entry in the project list instead, the navigation

menu link mobile, and change the property Menu Title to Welcome there.

Go back to the page mobile and choose Preview from the toolbar at the top and see the result.

The layout for smartphones is complete.

Creating Sub Pages
You have to fill the website with content. In addition, we need a total of 3 sub pages (including 

mobile).

Select + on the bottom left, and choose Add Page. Drag the new page on mobile if it is not

already inside it. Select Mobile Page as Page Template and drag again the four area templates 

Mobile Navigation, Mobile Header, Mobile Main and Mobile Footer to it.

Duplicate this newly added page two times. Rename the two new pages to blog.html and 

contact.html, and change the properties Title and Menu Title according to the page names.
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Copying the Contents
Go to the start page, double click on the main area and select all (Edit > Select All from the

menu). Copy the selection and paste it on the page mobile into the main area there. Now you

have to rearrange and resize the items there. Don't forget to change the link destination of the link

Blog to blog.html below mobile.

Copy all items from the main area of the page contact.html to the main area of contact.html of the

mobile website. Rearrange the Terms and Conditions and the contact form one below the other

instead of side by side.

Replace the main area on the page blog.html with a Blog area. Choose Main as the Area

Templatein the properties of the blog area.
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Explore the finished mobile website in the preview. By clicking on the drawer menu, it will be

opened and you can move to a different page.

Publish the Website on the Internet
The finished website can be published on the Internet now. Choose Publish from the toolbar.

An error message will appear, because the admin password has not been set yet. Enter a

password, which is required for adding and editing blog entries on the go.

- 20 -



Goldfish 4: Quick Start Tutorial

In the second error message, Goldfish asks for the internet address (URL) of the Web server,

under which the website will be accessible. You must enter the complete address, including http://

.

In the next window, the FTP login from your web server is required. Enter your login data

consisting of server, user name and password and click on OK.
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Goldfish connects to the server and displays a folder list from the web server. Double click on a

folder to get in there. On many web servers, you have to navigate into the correct subfolder at

first, on other servers there are no sub folders or that is not necessary. Ask your web hosting

service for the correct sub folder.

Click on Publish if you are in the correct folder. Goldfish uploads your website to your web server

now. When the process is finished, you can visit the website immediately with a computer, tablet

or smartphone and test it.
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