Goldfish 2
Offizielles Benutzerhandbuch

Ein großes Dankeschön an
Tobias Pellot

© 2023 Fishbeam Software
Texte, Grafiken: Yves Pellot
Korrektur, Fotos: Tobias Pellot
Auflagen-Code: #230108
www.fishbeam.com
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1. Tutorial: Your first Website
This is a tutorial for Goldfish beginners. Create your first Website right from the start without using
a design.
2. Register and Unlock
Learn how to register and unlock Goldfish, so that it works without limitations.
3. Project
Learn how to start a Golfish project. This is the first step if you want to create a website with
Goldfish.
4. Page
Learn how to create the page stucture of your website with pages and subpages.
5. Page Template
Learn how to use page templates. Set the default background and size for all pages of your
website.
6. Page Area
Seperate the pages of your website in areas. E.g. an area for header, navigation, footer and
content.
7. Area Template
Learn how to use area templates. Create the default layout for all pages of your website.
8. Text
Fill your website with content and add text.
9. Picture
Pictures are very important for the design of your website. The picture item in Goldfish has smart
functions for processing and showing pictures.
10. Media
Add QuickTime, Flash, RealMedia and Windows Media files to your website.
11. Navigation Menu
Add a navigation menu to your website. A navigation menu is the most important element what
visitors can use to navigate at your website.
12. Shape
With shapes you can draw, rectangles, rounded rectangles, ovals and lines directly on your
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website.
13. Gallery
With a gallery you can present dozens of photos to the visitors of your website in a slide show.
14. Visitor Counter
Add a visitor counter to your website. With a visitor counter you can show how many visitors
where on your website.
15. Form
Add a contact form to yor website. With this form the visitor can send you messages.
16. Website Frame
With a website frame, you can show an external page directly within your website.
17. HTML Code
Use a html code container to add your own html code to a page and extend Goldfish's
functionality.
18. Import Media
Learn how you can import and process media files like images, movies and documents in
Goldfish.
19. Working with Fonts
There are several things you should know if you work with fonts and font styles on websites.
20. Build your Website
Build your website on the desktop and get all neccessary files, which you can upload to a
webserver.
21. Publish Website
Publish your website immedialtely on the internet with the built in ftp client.
22. Export a Design
Export your work as Goldfish design. Build websites from your design or deliver it to your clients.
23. Preferences
In the preferences, you can change the behavior of Goldfish.
24. Trouble and Errors
Learn what you can do if errors occure, if you find bugs or if you have trouble using Goldfish.
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25. Goldfish Short Keys
Learn how to use Short Keys in Goldfish. This article contains a full list of all short keys for
Goldfish.
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1. Tutorial: Your first Website
This is a tutorial for Goldfish beginners. Create your first Website right from the start
without using a design.
There are some files required, to build a website with this tutorial. Please download our demo files
(/mediaComponents/help/goldfish2/common/tutorial_website/First_Website.zip). The zip archive
contains demo images for this tutorial.
Let's start with your first Goldfish website. Start Goldfish with a double click on the application.
Since you have Goldfish installed, it is located in Applications/Goldfish 2/Goldfish. If the design's
windows appears, click on Cancel, because we don't want to build a website from a design now.
INFO: If you want to build a website from a design, try out the tutorial: Build Your Website
From a Design.
A new, blank project appears. On the left, there is the project list, which contains pages and
templates. On the right there is the property palette where you can change the properies of all
elements of your website. The editor itself is in the middle and on the top the tools. At the moment
there is only one tool available: Page Area.

Creating The Layout
Before we add content to the website, we need a layout, which is on all pages the same. It
contains a header, a navigation, a footer and of course the main area where all the content of
your website, like pictures and text is displayed.

You are very flexible with Goldfish and can build nearly every possible layout, but for the tutorial
we will use a simple layout. The yellow space is the main area with the content of your website.
On the left (blue) is the navigation where you can browse through the pages of your website. We
will also create a header (red) with logo and title and a footer with copyright information (green).
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1: Tutorial: Your first Website

To start with the layout, take a look on the project list on the left. There are three categories: Start
Page for all pages of your website. Start page is the front page of your website.
A page consists of the page itself and page areas where you can define areas of your page
(header, navigation, main etc. like in the colored image above). Inside of a page area are page
items with text, images, galleries, movies etc. (the content of your website).
The category Page Templates contains layout templates for pages. This is useful, because
websites have usually a consistent layout on every single page. We will store a page template
there and use it for all pages of your website. Click on Page Templates, it will be selected. Then
on the + button on the left bottom side of the window. A new page template will be created. Just
rename it to Page, because it is the only page template that we will use for this project. Double
click on the page template and you can rename it.
Now click on Area Templates. Here you can store templates for page areas, which are for all
pages the same. Remember the areas for your website? We have four areas: Header, navigation,
main and footer. So click four times on the + button and rename the area templates with their
correct labels.
We have created all neccessary templates for the layout, but we have not yet set the style. The
style will be set in the properties on the right side of the window. The shown properties change
depending on the item which you have selected. If you have selected nothing (the editor shows
the Goldfish logo) all project properties are shown. If you select a page, the page's properties are
shown.
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1: Tutorial: Your first Website
Now select in the section Page Templates the template Page. The properties of the template
Page are visible.

We want a larger website: Change the value of Page Width (min) to 780. The page with sets the
total width of the space for page areas and page items. We want a website with a white
background color. So click on the color picker behind "Background Color" and change it to white.
Now we change the style of the area templates. Select the template area Main. The properties
change to Page Area. Change Margin Top and Margin Bottom to 15. This defines 15 px space to
the next top and bottom page area. Then Width to 565 and Height (min) to 430. the width is a fix
value, but the height depends on the content of the area (long texts make it larger). The minimum
height is 430 px. Change the Background Color to yellow. Instead of using the color picker, you
can enter a html color value in the field. Enter #ffff00 for yellow.
Let's go to the Footer template. Set Width to 780, Height (min) to 30 and Background Color to
orange (#ff8000). Here we need some copyright information. Go to the tools on the top of the
window and drag from the first tool Text a text item to the editor. The text item shows the text
Lorem ipsum dolor..., but not the text that we want. So double click on the text and you can edit it.
Write something like © 2007 Fishbeam Software.
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1: Tutorial: Your first Website

Change the font style of the text field. Select the text and click on Edit Text > Font Style >
Choose... in the properties.
You will see all avialable font style properties with a checkbox in front of every property. The font
system in Goldfish is very flexible. Goldfish uses always the style of a font template (here Master
Template). But you can overwrite every single style property of the template. Set the style like in
the screenshot above. Learn more about fonts and font template in the font templates help.
Let's go to the next area template Header. Here should be a logo and the title of the website. But
at first change the properties: Set Width to 780 and Height (min) to 150. Enable Background
Picture and click on the question mark behind. Choose background.png from the downloaded
tutorial files. Now the media importer window opens. Deactivate Reduce image size to max. and
click OK.

Notice the blue lines in the screenshot: This are alignment guides. You can drag alignment guides
from the rulers to create your layout. To delete an alignment guide, drag it back into the ruler.
Now we want to add a logo: Drag a picture item from the tools to the editor. Go to "Picture >
Picture" and choose "car.png" from the tutorial files.
For the title, drag a text item to the editor and write Car Speed and in the next line This is my new
website.. Go to Edit Text > Font Style and set Font to Moby Bold and Line Space to 12. Click OK.
Now we want to make the first line bigger. Select only the first line, choose Edit Text > Font Style
and set Size to 60. Repeat this for the second line and set Size to 30.
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1: Tutorial: Your first Website
Important: After you have edited the text, click outside of the text field, to stop the text edit mode.
Enable Text > Render as Picture in the properties. This is because Moby Bold is a special font
which is not installed on the computers from most of your website visitors. Goldfish will then
generate an image from the text so that all visitors can see the correct font. Please use this option
always if you have headlines and titles with special fonts.
Now go to the last template area: Naviagtion. Here should be a navigation menu. At first change
the properties of the area: Change Margin Right, Margin Top and Margin Bottom to 15, Width to
215, Height (min) to 430 and Background Color to #ff8000 (orange). Drag a navigation menu from
the tools to the editor.
A navigation menu shows one entry for every page of your website. At the moment only Untitled
for the start page, because there are not more pages at the moment. Let's change the style of the
menu. Deactivate Menu > Highlight Parent Entry. Then open the Mainmenu Entry section. This
sets the style for a menu entry of the main menu. Set Alignment to Left, Font Style > Style to Bold
and font Style > Color to #ffffff (white), Padding Left to 10, deactivate Background Color, Set
Border Bottom Width to 2 and Boder Bottom Color to #ffffff (white).

Now take a look at the effects section. Effects are used to change the appearance if the user
reacts. (eg. if the user moves the mouse over a link or menu item). This link, for example,
changes the color, if you move your mouse on it. Let's set the effects for menu items: Go to
Mainmenu Entry > Effect by Moving Mouse on Link in the properties. Enable Change Font and
choose #000000 (black) as font color. Set Background Color to #ffff00 (yellow). Repeat this for
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1: Tutorial: Your first Website
Effect by Clicking on Link.
Now go to Submenu Entry. Sub menu entries show sub pages of a page. Set the style of
Submenu Entry exactly to the style of the Mainmenu Entry (repeat the steps above). But there is
one exception: Set Padding Left to 20 and not to 10 like in the main menu. This is because the
user should see a difference between the main and submenu.

Creating Pages
The layout is complete now. In the next step we will build the start page: Select Start Page in the
page list. At the moment the page is empty. Drag 4 page areas from the tools to the editor. Of
course they are for our four templates. Select the first page area.

Go To Page Area > Area Template in the properties and select Header. The header template
appears in the new page area. Set Area Template for the second page area to Navigation, Main
for the third and Footer for the last. We have an empty page with our own layout, now. For the
tutorial we want three page. So go to the bottom of the page list an click Duplicate Item two times.
Our navigation menu shows for every entry Untitled. Select Start Page in the page list, click on
the gray border so that the properties for Page are shown and change Page > Title and Page >
Menu Title" to "Welcome. And for the other two pages: Pictures for the second page and Contact
for the third.
The second page has the name page.htm in the page list. That is not very specific. Change it to
pictures.htm and the name for the third page to contact.htm (remember, rename it with a double
click on the page name).
You have many pictures? No problem: Let's create subpages. Select the page pictures.htm and
enable Page > Page Has Subpages in the properties. Now, the page has a triangle in front of the
page name (.htm disappears). Duplicate the page contact.htm two times and move it into pictures
.

- 10 -

1: Tutorial: Your first Website

It's time to check the layout. Choose Format > Preview in Browser in the menu. Your webbrowser
opens your new website.

Fill The Website With Content
The page structure is complete now. Let's fill the pages. On the start page we want two text items
and a visitor counter. Add two text items. You can enter text, but here in the tutorial I will use the
default fill text.

Now drag a visitor counter from the tools to the editor. The visitor counter counts the total number
of visitors from your website. We don't want to use the default style of the counter. Go to Visitor
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1: Tutorial: Your first Website
Counter > Style in the properties and select Custom Style. Enable Counter Picture and choose
the image counter.png from the tutorial files. Change Size to 8.
Next Page: Select pictures.htm. Here should be a gallery with our favourite pictures. Drag a
gallery item from the tools to the editor. Then go to the properties and click on Gallery > Read
From Folder > Choose.... Here you can choose a folder with images for your gallery. Choose
Gallery Pictures from the tutorial files. Activate For All in the bottom left corner of the media import
window, so that the window will not pop up for every file. Then click OK.

Set a title for your gallery. Go to Gallery > Title in the properties and change it. The last thing we
need to to is to change the size of the thumbnails so that the gallery fits exactly into the page. Go
to Preview Icon in the properties and change the values Icon Width (Max), Icon Height (Max) (the
width and height of the thumbnail), Margin Horizontal and Margin Vertical (the space between the
thumbnails).
There should be a contact form on the contact page. Drag a form item from the tools to your
page. By default there are form elements, which you need for a contact form. Go to Send Page >
E-Mail Address in the properties and enter your e-mail address. To this addess the form will be
sent.
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1: Tutorial: Your first Website

Let's add a form element: Say you have a newsletter. Double click on the form item. The toolbar
changes and shows more form elements. Drag a checkbox to the form. You can change the
postion of the elements with drag and drop and delete an element by clicking on the x-button.
Double click on the checkbox to edit the element. Change Name and Display Name (the name of
the checkbox and the caption which is shown on the website). Enable Checked so that the
checkbox is checked by default. Click OK
Now your website is complete (we haven't filled the subpages of Pictures, because they also
should contain galleries only). Choose Format > Preview in Browser in the menu to check it.

Publish Your Website
It's time to publish your website on the internet. Therefore we will use the build in ftp publisher.
For this chapter you will need the ftp login for a website hosting service. Your ftp login data should
be something in this form:
- Server: ftp://myftpaccount.hostingservice.com
- Username: myloginname
- Password: mypassword
INFO: If you don't have webspace at a website hosting service, just Choose "File > Build
Website..." in the menu and publish your website on the desktop.
Choose File > Publish Website... and the publish window will pop up. Enter Server (without ftp://
prefix if it is part of the server address), Username, and Password. Click OK.
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1: Tutorial: Your first Website

Now you can see a list of the folders from your ftp server. browse through the folders
(doublecklick) and select the destination for your website. In my case I have to publish it in /www
/webroot/. If you have selected the destinantion, click on Publish. Goldfish publishes now your
website.
That's it. Your website is online on the internet now. Try out your internet domain, the website
should be there.
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2. Register and Unlock
Learn how to register and unlock Goldfish, so that it works without limitations.
If you work with the test version of Goldfish, you will see the following window on startup. Building
websites and publishing websites is deactivated. Please purchase the full version if you want to
build your website with Goldfish.

Click on Purchase License. This will lead you to our website where you can purchase Goldfish.
You can choose between Goldfish Standard and Goldfish Professional.

If you have purchased Goldfish, you will receive your serial via e-mail. Copy both, the name at
registered to and the serial, and paste it into the corresponding fields. Then click on Unlock.
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2: Register and Unlock

Goldfish works without limitations now. If you have entered a serial for an upgrade, you will be
asked for the serial of the earlier version, which you have purchased. Enter the old serial (if the
fields are not filled yet) and click on OK.

If you have purchased Goldfish Standard, you can always upgrade to Goldfish Professional.
Choose Goldfish > Purchase Goldfish... in the menu (Macintosh) or Help > Purchase Goldfish...
(Windows).
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2: Register and Unlock

Click on Purchase License and buy a license for the upograde to Goldfish Professional. You can
unlock Goldfish Professional like an upgrade from an earlier version.
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3. Project
Learn how to start a Golfish project. This is the first step if you want to create a website
with Goldfish.
To start a new project, you have to decide if you want to start it from a design or a blank website.
With a design, you don't have to create the design of your website. With a blank website it will be
more work, but the result will be a website with a custom design.
To start a website from a design, choose File > Designs... The design window opens, and you
can choose one of Goldfish's default designs.

There are many more designs available on our website. Click on More Designs and you will be
directed to our design download website. If you have choosen a design, click on OK. A new
project window opens.
If you want to start a project from a blank website, choose File > New. A new project window
opens.
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3: Project
The project window is seperated into 3 different areas: The project list (1). Here are all
components of your website listed. Pages (with Start Page as first page), Page templates and
area templates. In the editor (2) you can enter text, and edit the content of your website.
The editor is empty at the moment (the Goldfish icon appears), because you have selected
nothing. In the properties (3) you can see and set all properties for the components of your
website. Here are always the properties of the selected component visible. At the moment the
properies for the project are visible, because you have selected nothing.

Goldfish's Page Model
Goldfish builds pages in an innovative and unique way. You have flexible components to create
your website. E.g. pages, page areas, text frames, picture frames etc. A page is built out of 3
different layers.

A page (grey) is the base. On a page, there are page areas (yellow), which represent areas of
your website (header, footer, navigation, main area etc.). A page area contains page items
(green). Page items store the content of your website like images, movies, text...

The Project List
Lets take a look on the project list. If you have started your project from a design, there are
already pages, page templates and area templates. Otherewise it is empty. The start page is the
first page of your website. If visitors enter your website, the start page will be shown.
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3: Project

Usually a website has on all pages the same style. You can store a layout template in Page
Templates and use it on all pages to overwrite their properties with the layout of the page
template. You can store a layout template in Area Templates and use it in page areas on all
pages.
Templates store the design and style for different pages or page areas in one place. This is useful
if you want to change something. Let's say the background color of all pages. If you don't use
page templates, you have to change it for every page seperately. If you have defined a page
template, you can only change it in the template and it will be applied to all pages, which use this
template.
If you have started your project from a design, the next step is to create pages. If you have
started your project from a blank website, you should create page templates and area templates
for your layout and in the last step pages.

Properties for Project
These properties can be set for the project. Select nothing (the Goldfish icon appears in the
editor), to show the properties of the project.
Project > Meta Tags
Meta tags are used by old styled search engines to find your website. Here you can enter project
wide meta tags. Project wide meta tags appear on every page of your website. If you want to set
specifical meta tags for a page, you have to use the meta tag property of a page.
Add a meta tag.
Delete a selected meta tag.
Enter the value of name or http-equiv at Meta Tag Name in the list. Enter the value of content at
Meta Tag Value. If the meta tag begins with meta http-equiv=, enable the checkbox at http-equiv.
If you have edited your meta tags, click on OK.
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3: Project
Project > Page Address (URL)
Enter the absolute page URL of your website here. E.g. http://mydomain.com. This is required if
you use rss feeds on your website.
Project > Favorite Icon
Here you can choose a FavIcon for your website. A FavIcon is a small graphic in the adressbar
(this website uses a small fish as FavIcon). FavIcons must be windows .ico files to show up in
Internet Explorer, Firefox, Safari and the others accept .gif and .png as well.
Project > Embedded Media
Click on Choose to see a list of all embedded media files of your project. All images, movies and
other files, which you use on your website are included.
The description of every media file is used differently. E.g. as subtitle of a picture in a picture
gallery, as alt parameter for images or as title for download links. Doubleclick on a name or
description to edit it. Note that there are restrictions for the name (no blanks, no special
characters, correct suffix). If you have entered a bad name, a beep occures and the old name will
be used.
Click on OK to close the embedded media window.
Project > Font Templates
You can use font templates to store font styles which you use permanently in your website.
Usually a website has only a few different font styles. Click on Choose to open the font templates
window.
The first template on the list is the "Master Template". Here you can store the default font style for
your website. If you don't set a special font for all other font templates, or components, the style of
the master template is used.
Add a font template.
Duplicate a selected font template.
Delete a selected font template.
Opens the font editor and you can edit the font template.
Double click on a font template to rename it. Please read the fonts documentation to learn how to
work with fonts.
Google > Google Analytics
Google Analytics is a free service from Google. With Google Analytics you can receive complete
and detaild user acess statistics for your website. Google will provide you a Google Analytics
tracker id to identify your website. Enter the id here in Goldfish. The is coms in this form:
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3: Project
UA-XXXXXX-X.
Google > Webmaster Tools
Google Analytics is a free service from Google. With Google Webmaster Tools, you can optimize
your website for the Google search engine. Google will provide you a meta tag in this form: \.
Enter only the content of this meta tag: XXXXXXXXXXXXX.
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4. Page
Learn how to create the page stucture of your website with pages and subpages.
Every website consitst of several pages, which are ordered hierarchically. All pages of your
project are listed in the project list on the left side of your window.

The first page is the start page of your project (the world icon). This is the page which will be
loaded if the user enters your page address (e.g. http://www.fishbeam.com). All other pages are
sub pages of the start page.
Add a Page. A new page will appear under start page.
Duplicate a selected page with its content.
Delete a selected page.
A website contains usually a complex page structure with pages and subpages. To create
subpages, select the page for which you want to create subpages and go to the properties.
Enable Page > Page Has Subpages. Now you will see a triangle (+ in Windows XP) in front of the
page icon. Now you can add sub pages.
INFO: You can reoder the project list with drag and drop. Move pages up and down to build
the correct page structure.
By default, pages are named page.htm, page_1.htm... To rename a page double click on it's
name. Note that you can only letters, numbers and _ for the name. If the page has a suffix (pages
with sub pages have not, because they are actually folders with a index file), don't remove the
suffix. If you have entered a bad name, it won't be accepted.

Properties for Page
These properties can be set for a page. Select a page, but select nothing on the page, to show
the properties of the page.
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4: Page
Page > Title
The title of the page. The title will be shown as caption of the browser window.
Page > Menu Title
The menu title will be displayed in all navigation menus, who contain a link to this page. Disable it
and the page is not shown a the menu.
Page > Meta Tags
Here you can edit the meta tags for a page. Unlinke the project wide meta tags, the page meta
tags are only for this page. Please read the documentation for the project, to learn how the meta
tag editor works.
Page > Page Template
Select a page template, if you want to overwrite the style of the page with a template. Note that all
style properties for this page are hidden, if a page template is selected, because the style will be
set in the template then.
Page > Page Width (min)
Sets the minimal width of the page (pixel). If the browser window is smaller, scrollbars will be
shown. The width of a page area must be smaller or the same like the page with. You can't set a
minimal heigt of the page, because the height will be calculated by the minimal height of all page
areas.
Page > Content Alignment
Choose the alignment of the content if the browser window is larger than Page Width (min).
Page > Margin Left
Sets an offset from the left side of the page content.
Page > Margin Right
Sets an offset from the right side of the page content.
Page > Margin Top
Sets an offset from the top side of the page content.
Page > Margin Bottom
Sets an offset from the bottom side of the page content.
Page > Background Color
Select a background color for the page.
Page > Background Picture
Select a background picture for the page. With "Repeat", you can choose how the picture will be
displayed.
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4: Page
Page > Add Header HTML Code PRO
Add custom html code to your page in the header section to extend Goldfish's functionality.
Page > Add HTML Code PRO
Add custom html code to your page in the body section to extend Goldfish's functionality.
Page > Add CSS Code PRO
Add custom css code to your page. The code will be stored in the css section of your website.
You can't change the css code of internal items, but you can use the css code in your custom
html code.
RSS > Enable Newsfeed
Enable this option, if you want to create a blog or newsfeed. A feed icon is displayed in the
webbrowser to show that there is a blog available for this page. With click on this icon, the blog
will be loaded.

The entries of the feed are all text items of the page. If the page has sub pages, the text items of
all subpages will be included too. To prevent a text field from being included into the feed, you
can disable it in the preferences of the text item. Disable RSS > Add Text To Feed.
INFO: You can only create one feed per page. If you are on a sub page and the parent page
contains a feed, you can't create a feed on this page.
RSS > Feed Description
Enter a short description for your news feed.
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5. Page Template
Learn how to use page templates. Set the default background and size for all pages of your
website.
Every website comes with a single layout and style. You can create page templates to store your
layout and style. Apply the page template to all pages of your website so that they have all the
same layout. If you change the layout later on the template page, the changes will automatically
apply on all pages of your website.
All page templates of your project are listed under Page Templates in the project list on the left
side of your window.

Select the folder Page Templates and click creates a new page template.
Duplicate a selected page template.
Delete a selected page template.
The page template has the same properties as a page (but only those properties regarding the
style and layout).

To applay a page template to a page, select the page in the project list and look at the properties.
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5: Page Template
Select your page template at Page > Page Template. All properties regarding the style and layout
will disappear. They are now controlled by the page template.

Properties for Page Template
These properties can be set for a page template. Select a page template to show its properties.
Page Template > Page Width (min)
Sets the minimal width of the page (pixel). If the browser window is smaller, scrollbars will be
shown. The width of a page area must be smaller or the same like the page with. You can't set a
minimal heigt of the page, because the height will be calculated by the minimal height of all page
areas.
Page Template > Content Alignment
Choose the alignment of the content if the browser window is larger than Page Width (min).
Page Template > Margin Left
Sets an offset from the left side of the page content.
Page Template > Margin Right
Sets an offset from the right side of the page content.
Page Template > Margin Top
Sets an offset from the top side of the page content.
Page Template > Margin Bottom
Sets an offset from the bottom side of the page content.
Page Template > Background Color
Select a background color for the page.
Page Template > Background Picture
Select a background picture for the page. With "Repeat", you can choose how the picture will be
displayed.
Page Template > Add Header HTML Code PRO
Add custom html code to your page in the header section to extend Goldfish's functionality.
Page Template > Add HTML Code PRO
Add custom html code to your page in the body section to extend Goldfish's functionality.
Page Template > Add CSS Code PRO
Add custom css code to your page. The code will be stored in the css section of your website.
You can't change the css code of internal items, but you can use the css code in your custom
html code.
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6. Page Area
Seperate the pages of your website in areas. E.g. an area for header, navigation, footer and
content.
On every page of your website there are several page areas (e.g. for header, footer, navigation
and content).

Every page area (yellow) contains the content of your website like menus, images and text. to
understand Goldfish's page model, read the documentation for project.
There are usually more than one page areas on a page. You can set a fixed with and a minimum
height for every page area. The real high of a page area depends on its content and the height of
the other page areas in the row.

To add page areas to a page, select the page and drag a page area from the tools on your page.
Deletes the selected page area.
If you add page areas, the page will be filled row-wise from top to bottom. There are as many
page areas in a row as their with is smaller than the width of the page. If the row is "full", the next
area will be displayed below in the next row.
INFO: The high of all page areas in a row is the same. Always the hight of the biggest page
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6: Page Area
area will be choosen.

Properties for Page Area
These properties can be set for a page area. Select a page area to show its properties.
Page Area > Area Template
Select an area template, if you want to overwrite the style of the page area with a template. Note
that all style properties for this page area are hidden, if a area template is selected, because the
style will be set in the template then.
Page Area > Width
Sets the width of the page area (pixel). The width of a page area must be smaller or the same like
the page with.
Page Area > Height (min)
Sets the minimal height of the page area (pixel). The real height is calculated by the height of the
content and the height of other page areas in the same row.
Page Area > Margin Left
Sets an offset from the left side of the page area content.
Page Area > Margin Right
Sets an offset from the left side of the page area content.
Page Area > Margin Top
Sets an offset from the top side of the page area content.
Page Area > Margin Bottom
Sets an offset from the left side of the page area content.
Page Area > Background Color
Select a background color for the Page Area.
Page Area > Background Picture
Select a background picture for the Page Area. With "Repeat", you can choose how the picture
will be displayed.
Page Area > Border Left Width
Displays a border on the left side of the Page Area in the choosen width (pixels).
Page Area > Border Left Color
Select a color for the left border.
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Page Area > Border Right Width
Displays a border on the right side of the Page Area in the choosen width (pixels).
Page Area > Border Right Color
Select a color for the right border.
Page Area > Border Top Width
Displays a border on the top side of the Page Area in the choosen width (pixels).
Page Area > Border Top Color
Select a color for the top border.
Page Area > Border Bottom Width
Displays a border on the bottom side of the Page Area in the choosen width (pixels).
Page Area > Border Bottom Color
Select a color for the bottom border.
Page Area > Add HTML Code PRO
Add custom html code to the Page Area to extend Goldfish's functionality.
Page Area > Add CSS Code PRO
Add custom css code to the Page Area. The code will be stored in the css section of your
website. You can't change the css code of internal items, but you can use the css code in your
custom html code.
Content > Edit Content
Edit the content of your Page Area and add images, text or other content to your website.
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7. Area Template
Learn how to use area templates. Create the default layout for all pages of your website.
On every page of your website there are several page areas (e.g. for header, footer, navigation
and content). Some of these areas are on every page the same (e.g. navigation, footer, header).
Create area templates for these areas, and display them on every page.
All area templates of your project are listed under Area Templates in the project list on the left
side of your window.

Select the folder Area Templates and click creates a new page area.
Duplicate a selected area template.
Delete a selected area template.
The area template has the same properties as a page area (but only those properties regarding
the style and layout).

To applay an area template to a page area, select the page area and look at the properties.
Select your area template at Page Area > Area Template. All properties regarding the style and
layout will disappear. They are now controlled by the area template.
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Properties for Area Template
These properties can be set for an area template. Select an area template to show its properties.
Area Template > Width
Sets the width of the page area (pixel). The width of a page area must be smaller or the same like
the page with.
Area Template > Height (min)
Sets the minimal height of the page area (pixel). The real height is calculated by the height of the
content and the height of other page areas in the same row.
Area Template > Margin Left
Sets an offset from the left side of the page area content.
Area Template > Margin Right
Sets an offset from the left side of the page area content.
Area Template > Margin Top
Sets an offset from the top side of the page area content.
Area Template > Margin Bottom
Sets an offset from the left side of the page area content.
Area Template > Background Color
Select a background color for the Page Area.
Area Template > Background Picture
Select a background picture for the Page Area. With "Repeat", you can choose how the picture
will be displayed.
Area Template > Border Left Width
Displays a border on the left side of the Page Area in the choosen width (pixels).
Area Template > Border Left Color
Select a color for the left border.
Area Template > Border Right Width
Displays a border on the right side of the Page Area in the choosen width (pixels).
Area Template > Border Right Color
Select a color for the right border.
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Area Template > Border Top Width
Displays a border on the top side of the Page Area in the choosen width (pixels).
Area Template > Border Top Color
Select a color for the top border.
Area Template > Border Bottom Width
Displays a border on the bottom side of the Page Area in the choosen width (pixels).
Area Template > Border Bottom Color
Select a color for the bottom border.
Area Template > Add HTML Code PRO
Add custom html code to the Page Area to extend Goldfish's functionality.
Area Template > Add CSS Code PRO
Add custom css code to the Page Area. The code will be stored in the css section of your
website. You can't change the css code of internal items, but you can use the css code in your
custom html code.
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8. Text
Fill your website with content and add text.
You can add a text box to every page area or area template. To add a text box, edit the content of
a page area or area template and drag the text box from the elements panel to the editor.

A text box displays text. Double click on it and you can edit the text. in the text edit mode, the
properties on the properties panel change. Select text and click on Edit Text > Font Style >
Choose... to change the font style, alignment and size.

The font style is set by the selected font template. Activate a checkbox to overwrite the style
property with your own values.
INFO: If you use a main style on every page and in every text box, it's better to change the
default text template instead of overwriting the style in every text box. Choose nothing (the
project properties appear) and click on Project > Font Templates > Choose....
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Another important feature on websites is to add links. Select text and activate Edit text > Use as
link on the properties panel. Click on Choose... to set the link destination.

It's important to set the semantical meaning of your text. Search engines like google handle
headlines different than normal text. Select the text type at Edit Text > Text Type
- Healine 1 - Headline 6: The selected text is a headline. This changes not the style. This is
important for search engines.
- List: The selected text is list. Every new line is a seperate list item. A bullet can displayed
before every list item.
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Maybe you want to use uncommon fonts for headlines and other text. Usually you can't do this at
websites, because a font must be installed on the visitor's computer. If you use uncommon fonts it
probably won't.

If you use uncommon fonts, activate Text > Render As Picture on the properties panel. Then
Goldfish creates a picture with the text in the choosen font. It will be displayed on all computers.
Even if the font is missing there.
INFO: It's not recommended to use this option for long text. Use this only for head lines.
Otherwise the size of your website will grow rapidly.

Properties for Text
These properties can be set for a text box. Select a text box to show its properties.
Item > Left
Sets the distance from the left side of the parent element in pixels.
Item > Top
Sets the distance from the top side of the parent element in pixels.
Item > Width
Sets the width of the item in pixels.
Item > Height
Sets the width of the item in pixels.
Item > Padding Left
Sets the distance from the left side of the item to the content in pixels.
Item > Padding Right
Sets the distance from the right side of the item to the content in pixels.

- 36 -

8: Text
Item > Padding Top
Sets the distance from the top side of the item to the content in pixels.
Item > Padding Bottom
Sets the distance from the bottom side of the item to the content in pixels.
Item > Background Color
Select a background color for the item.
Item > Background Picture
Select a background picture for the item. With "Repeat", you can choose how the picture will be
displayed.
Item > Border Left Width
Displays a border on the left side of the item in the choosen width (pixels).
Item > Border Left Color
Select a color for the left border.
Item > Border Right Width
Displays a border on the right side of the item in the choosen width (pixels).
Item > Border Right Color
Select a color for the right border.
Item > Border Top Width
Displays a border on the top side of the item in the choosen width (pixels).
Item > Border Top Color
Select a color for the top border.
Item > Border Bottom Width
Displays a border on the bottom side of the item in the choosen width (pixels).
Item > Border Bottom Color
Select a color for the bottom border.
Item > Add HTML Code PRO
Add custom html code to the item to extend Goldfish's functionality.
Item > Add CSS Code PRO
Add custom css code to the item. The code will be stored in the css section of your website. You
can't change the css code of internal items, but you can use the css code in your custom html
code.
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Item > Identifer (Id) PRO
Sets the value for the "id" property. You can use this id to access the item with JavaScript.
Text > Render as picture
Renders the text as a picture, so that you can use uncommon fonts.
Text > Edit Content
Starts the edit mode of a text box.
Link style > Font style
Sets the font style for links.

Visual Effects
You can specify a visual effect, if the visitor interacts with a link (e.g. change the color if the visitor
moves his mouse over the link). The following properties are the same for Moving mouse over link
effect, Clicking on link effect and Already visited link effect.
Effect > Change font
Changes the font style of a menu item.
Effect > Font style
Sets the font style, to which will be changed.

RSS
The following properties are only visible if the page has a rss news feed.
RSS > Add text to feed
Adds the text box to the news feed of a page.
RSS > Title of the entry
The title of the news feed entry.
RSS > Date
The date, where the entry of the feed is published.

Properties for Edit Text
These properties can be set in the edit mode of a text box. Select a text box and double click on it
to start the edit mode.
Edit text > Text type
Sets the semantic meaning for selected text (normal text, headlines or list).
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Edit text > Padding left
The the selected text belongs to a list it sets the space between the list bullet and the text.
Edit text > Bullet picture
Choose a bullet picture for your list (only at Text type: List with bullet picture).
Edit text > Font style
Sets the font style for selected text.
Edit text > Use as link
Use the selected text as link e.g. to another website.
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9. Picture
Pictures are very important for the design of your website. The picture item in Goldfish has
smart functions for processing and showing pictures.
You can add a picture item to every page area or area template. To add a picture item, edit the
content of a page area or area template and drag the picture item from the elements panel to the
editor.

A picture item displays a picture on your website. The picture item which you have added before
is still empty. A question mark icon is displayed. To fill the item with a picture, enabled Picture >
Picture on the properties pane and click on the question mark icon besides.

Choose a picture from your hard disk. The media import window is displayed. Here you can enter
a description (the description is used as alt text in the html code). You can also resize the picture
(recommended for big pictures, which come directly from a digital camera).
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In Goldfish you can change the clipping of the picture. Start the edit mode with a double click on
the picture. Now you can zoom with the slider into the picture and drag the displayed clipping.
INFO: This is only possible if Picture > Calculate New On Export on the properties panel is
activated.

Attention if you add transparent gif images or gif animations: Deactivate always Picture >
Calculate New On Export. Otherwise the picture won't be exported correctly and the animation
will be destroyed.

Properties for Picture
These properties can be set for a picture item. Select a picture item to show its properties.
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Item > Left
Sets the distance from the left side of the parent element in pixels.
Item > Top
Sets the distance from the top side of the parent element in pixels.
Item > Width
Sets the width of the item in pixels.
Item > Height
Sets the width of the item in pixels.
Item > Padding Left
Sets the distance from the left side of the item to the content in pixels.
Item > Padding Right
Sets the distance from the right side of the item to the content in pixels.
Item > Padding Top
Sets the distance from the top side of the item to the content in pixels.
Item > Padding Bottom
Sets the distance from the bottom side of the item to the content in pixels.
Item > Background Color
Select a background color for the item.
Item > Background Picture
Select a background picture for the item. With "Repeat", you can choose how the picture will be
displayed.
Item > Border Left Width
Displays a border on the left side of the item in the choosen width (pixels).
Item > Border Left Color
Select a color for the left border.
Item > Border Right Width
Displays a border on the right side of the item in the choosen width (pixels).
Item > Border Right Color
Select a color for the right border.
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Item > Border Top Width
Displays a border on the top side of the item in the choosen width (pixels).
Item > Border Top Color
Select a color for the top border.
Item > Border Bottom Width
Displays a border on the bottom side of the item in the choosen width (pixels).
Item > Border Bottom Color
Select a color for the bottom border.
Item > Add HTML Code PRO
Add custom html code to the item to extend Goldfish's functionality.
Item > Add CSS Code PRO
Add custom css code to the item. The code will be stored in the css section of your website. You
can't change the css code of internal items, but you can use the css code in your custom html
code.
Item > Identifer (Id) PRO
Sets the value for the "id" property. You can use this id to access the item with JavaScript.
Picture > Picture
Select the picture, which you want to display.
Picture > Calculate New On Export
Calculates an optimized version of the picture in the correct size and quality for your website.
Deactivate this for transparent gif images and gif animations.
Picture > Edit Content
Click here to change the clipping for the picture. This is only available if Picture > Calculate New
On Export is enabled.
Link > Use as Link
Uses the picture as link. Select a page where the link should lead to.

Visual Effects
You can specify a visual effect, if your site visitor interacts with the picture link (e.g. change the
color if your site visitor moves his mouse over the menu item). The following properties are the
same for Moving mouse over link effect and Clicking on link effect.
Effect > Change Picture
Changes the picture. Select the picture to which should be changed.
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10. Media
Add QuickTime, Flash, RealMedia and Windows Media files to your website.
You can add a media player to every page area or area template. To add a media player, edit the
content of a page area or area template and drag the media player from the elements panel to the
editor.

A media player displays media content in many different formats. Add Quicktime compatible
video, Windows Media compatible video and audio, Flash movies or RealMedia compatible video
and audio.

INFO: Flash video (.flv files) are not supported. It is required to embed these files into a
normal flash movie (.swf file). You can display the .swf file in a Flash player then.
Select the player, which you want to use on the properties panel at Player and select a media file
from your harddisk at media. Every player type has a number of player specific properties.
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Properties for Media
These properties can be set for a media player. Select a media player to show its properties.
Item > Left
Sets the distance from the left side of the parent element in pixels.
Item > Top
Sets the distance from the top side of the parent element in pixels.
Item > Width
Sets the width of the item in pixels.
Item > Height
Sets the width of the item in pixels.
Item > Padding Left
Sets the distance from the left side of the item to the content in pixels.
Item > Padding Right
Sets the distance from the right side of the item to the content in pixels.
Item > Padding Top
Sets the distance from the top side of the item to the content in pixels.
Item > Padding Bottom
Sets the distance from the bottom side of the item to the content in pixels.
Item > Background Color
Select a background color for the item.
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Item > Background Picture
Select a background picture for the item. With "Repeat", you can choose how the picture will be
displayed.
Item > Border Left Width
Displays a border on the left side of the item in the choosen width (pixels).
Item > Border Left Color
Select a color for the left border.
Item > Border Right Width
Displays a border on the right side of the item in the choosen width (pixels).
Item > Border Right Color
Select a color for the right border.
Item > Border Top Width
Displays a border on the top side of the item in the choosen width (pixels).
Item > Border Top Color
Select a color for the top border.
Item > Border Bottom Width
Displays a border on the bottom side of the item in the choosen width (pixels).
Item > Border Bottom Color
Select a color for the bottom border.
Item > Add HTML Code PRO
Add custom html code to the item to extend Goldfish's functionality.
Item > Add CSS Code PRO
Add custom css code to the item. The code will be stored in the css section of your website. You
can't change the css code of internal items, but you can use the css code in your custom html
code.
Item > Identifer (Id) PRO
Sets the value for the "id" property. You can use this id to access the item with JavaScript.
Media > Media
Select the media file from your harddisk, which you want to display.
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Media > Player
Select the player type, which can play the media file.
Media > Start playback automatically
Starts playing automatically after the page is loaded.
Media > Looping
Plays the media file in an endless looping.
Media > Show controller
Shows playback controls like play, stop and pause (QuickTime, RealPlayer, Windows Media
Player only).
Media > Hide menu for saving media file
Hides the menu for saving the media file (QuickTime only).
Media > Transparent background
Displays flash movies with alpha and transparency in front of the page content (Flash only).
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11. Navigation Menu
Add a navigation menu to your website. A navigation menu is the most important element
what visitors can use to navigate at your website.
You can add a navigation menu to every page area or area template. To add a navigation menu,
edit the content of a page area or area template and drag the navigation menu from the elements
panel to the editor.

Usually you should add a navigation menu to an area template and use this area template on
every page of your website. So the navigation menu is displayed on every page of your website at
the same place.

The navigation menu shows automatically the pages of your website as menu entries. Usually
there is one entry for every page of your website. The shown text is always the Menu Title
property of a page.

To change the text, select the corresponding page and edit the Menu title property of the page in
the properties pane. If you deselect Menu Title, the page does not appear in the navigation menu.
INFO: It is not possible to add a link manually to a navigation menu. The navigation menu
- 48 -

11: Navigation Menu
shows always automatically the pages of your website.

There are several types of navigation menus. You can set the menu type on the propertys pane
at Menu > Menu Type.
- Simple Menu (1): Shows only one hierarchy level of the pages. It displays no submenus. If
your website has pages with sub pages, you need a second navigation menu for them.
- Menu with Submenu (2): Sows only two hierarchy levels of the pages. it displays one
submenu. If you click on a page with sub pages, the submenu appears directly under the main
menu entry of the page.
- Dropdown Menu right (3): Shows all hierarchy levels of the pages in a menu structure. If your
site visitors move their mouse over a menu entry of a page with subpages, a submenu will pop
up.
- Dropdown Menu bottom (4): Shows all hierarchy levels of the pages in a menu structure. If
your site visitors move their mouse over a menu entry of a page with subpages, a submenu
will pop up.
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By default, the main menu shows the first hierarchy level of pages (the start page and their sub
pages are shown). If you want to create a navigation menu that shows pages from another level,
you can change the property Menu > Base Folder. Here are all pages listed, that have sub pages.
E.g. if you select "products" in our example, "products" and all it's sub pages are shown.
INFO: If you change the size of the menu item, so that there is enough space, the menu
entries are displayed side by side.

Properties for Navigation Menu
These properties can be set for a navigation menu. Select a navigation menu to show its
properties.
Item > Left
Sets the distance from the left side of the parent element in pixels.
Item > Top
Sets the distance from the top side of the parent element in pixels.
Item > Width
Sets the width of the item in pixels.
Item > Height
Sets the width of the item in pixels.
Item > Padding Left
Sets the distance from the left side of the item to the content in pixels.
Item > Padding Right
Sets the distance from the right side of the item to the content in pixels.
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Item > Padding Top
Sets the distance from the top side of the item to the content in pixels.
Item > Padding Bottom
Sets the distance from the bottom side of the item to the content in pixels.
Item > Background Color
Select a background color for the item.
Item > Background Picture
Select a background picture for the item. With "Repeat", you can choose how the picture will be
displayed.
Item > Border Left Width
Displays a border on the left side of the item in the choosen width (pixels).
Item > Border Left Color
Select a color for the left border.
Item > Border Right Width
Displays a border on the right side of the item in the choosen width (pixels).
Item > Border Right Color
Select a color for the right border.
Item > Border Top Width
Displays a border on the top side of the item in the choosen width (pixels).
Item > Border Top Color
Select a color for the top border.
Item > Border Bottom Width
Displays a border on the bottom side of the item in the choosen width (pixels).
Item > Border Bottom Color
Select a color for the bottom border.
Item > Add HTML Code PRO
Add custom html code to the item to extend Goldfish's functionality.
Item > Add CSS Code PRO
Add custom css code to the item. The code will be stored in the css section of your website. You
can't change the css code of internal items, but you can use the css code in your custom html
code.
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Item > Identifer (Id) PRO
Sets the value for the "id" property. You can use this id to access the item with JavaScript.
Menu > Base Folder
Select a page with subpages that will be shown as main menu entries. By default the start page is
displayed but you can change this property to create submenus.
Menu > Show Base Folder as Menu Entry
Shows the selected page from Base Folder in the main menu. If you disable this, only their sub
pages will be shown.
Menu > Highlight Parent Entry
If you are on a page from the sub menu, the menu entry of their parent page will be highlighted,
too. If you deactivate this, only the entry of the current page will be highlited.
Menu > Menu Type
Sets the menu type for a page. You can choose between:
- Simple Menu
- Menu with Submenu
- Dropdown Menu right
- Dropdown Menu bottom
Menu > Margin Horizontal
Sets the space between the bottom of a menu entry and the top of the next entry.
Menu > Margin Vertical
Sets the space between the right of a menu entry and the left of the next entry.

Main Menu Entry and Submenu Entry
The following properties are the same for Main Menu Entry and Submenu entry. Note that
Submenu Entry will be only showed, if you don't choose "Simple Menu" as Menu Type. Because
a simple menu has no sub menu.
Menu Entry > Width
Sets the width of a menu entry in pixels.
Menu Entry > Height
Sets the height of a menu entry in pixels.
Menu Entry > Alignment
Sets the alignment of the text in a menu entry.
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Menu Entry > Font Style
Sets the font style of the text in a menu entry.
Menu Entry > Padding Left
Sets the distance from the left side of a menu entry to the content in pixels.
Menu Entry > Padding Right
Sets the distance from the right side of a menu entry to the content in pixels.
Menu Entry > Padding Top
Sets the distance from the top side of a menu entry to the content in pixels.
Menu Entry > Padding Bottom
Sets the distance from the bottom side of a menu entry to the content in pixels.
Menu Entry > Background Color
Select a background color for a menu entry.
Menu Entry > Background Picture
Select a background picture for a menu entry. With "Repeat", you can choose how the picture will
be displayed.
Menu Entry > Border Left Width
Displays a border on the left side of a menu entry in the choosen width (pixels).
Menu Entry > Border Left Color
Select a color for the left border.
Menu Entry > Border Right Width
Displays a border on the right side of a menu entry in the choosen width (pixels).
Menu Entry > Border Right Color
Select a color for the right border.
Menu Entry > Border Top Width
Displays a border on the top side of a menu entry in the choosen width (pixels).
Menu Entry > Border Top Color
Select a color for the top border.
Menu Entry > Border Bottom Width
Displays a border on the bottom side of a menu entry in the choosen width (pixels).
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Menu Entry > Border Bottom Color
Select a color for the bottom border.

Visual Effects
You can specify a visual effect, if your site visitor interacts with the navigation menu (e.g. change
the color if your site visitor moves his mouse over the menu item). The following properties are
the same for Moving mouse over link effect, Clicking on link effect and Already visited link effect.
Effect > Change Font
Changes the font style of a menu item.
Effect > Font Style
Sets the font style, to which will be changed.
Effect > Change Background
Changes the background of a menu item.
Effect > Background Color
Select a background color for a menu entry.
Effect > Background Picture
Select a background picture for a menu entry. With "Repeat", you can choose how the picture will
be displayed.
Effect > Change Border
Changes the border of a menu item.
Effect > Border Left Width
Displays a border on the left side of a menu entry in the choosen width (pixels).
Effect > Border Left Color
Select a color for the left border.
Effect > Border Right Width
Displays a border on the right side of a menu entry in the choosen width (pixels).
Effect > Border Right Color
Select a color for the right border.
Effect > Border Top Width
Displays a border on the top side of a menu entry in the choosen width (pixels).
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Effect > Border Top Color
Select a color for the top border.
Effect > Border Bottom Width
Displays a border on the bottom side of a menu entry in the choosen width (pixels).
Effect > Border Bottom Color
Select a color for the bottom border.
Effect > Change Padding
Changes the padding of a menu item.
Effect > Padding Left
Sets the distance from the left side of a menu entry to the content in pixels.
Effect > Padding Right
Sets the distance from the right side of a menu entry to the content in pixels.
Effect > Padding Top
Sets the distance from the top side of a menu entry to the content in pixels.
Effect > Padding Bottom
Sets the distance from the bottom side of a menu entry to the content in pixels.
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12. Shape
With shapes you can draw, rectangles, rounded rectangles, ovals and lines directly on
your website.
You can add a shape to every page area or area template. To add a shape, edit the content of a
page area or area template and drag the shape from the elements panel to the editor.

Shapes are a good choise if you want to create the layout of your website. Shapes can contain
rectangles, rounded rectangles, ovals or lines. Or nothing, if you just want the shape to show the
item's background.

The property Shape > Has Shape defines if a shape is shown in the item and what kind of shape
is used. Choose between rectangle, rounded rectangle, oval or line. It depends on the selection
there which other options are available.

Every shape has a fill color and a border. If you only want to have a rectangle with a background
or one color, deactivate Has Shape and use the background of the item instead.
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Properties for Shape
These properties can be set for a shape. Select a shape to show its properties.
Item > Left
Sets the distance from the left side of the parent element in pixels.
Item > Top
Sets the distance from the top side of the parent element in pixels.
Item > Width
Sets the width of the item in pixels.
Item > Height
Sets the width of the item in pixels.
Item > Padding Left
Sets the distance from the left side of the item to the content in pixels.
Item > Padding Right
Sets the distance from the right side of the item to the content in pixels.
Item > Padding Top
Sets the distance from the top side of the item to the content in pixels.
Item > Padding Bottom
Sets the distance from the bottom side of the item to the content in pixels.
Item > Background Color
Select a background color for the item.
Item > Background Picture
Select a background picture for the item. With "Repeat", you can choose how the picture will be
displayed.
Item > Border Left Width
Displays a border on the left side of the item in the choosen width (pixels).
Item > Border Left Color
Select a color for the left border.
Item > Border Right Width
Displays a border on the right side of the item in the choosen width (pixels).
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Item > Border Right Color
Select a color for the right border.
Item > Border Top Width
Displays a border on the top side of the item in the choosen width (pixels).
Item > Border Top Color
Select a color for the top border.
Item > Border Bottom Width
Displays a border on the bottom side of the item in the choosen width (pixels).
Item > Border Bottom Color
Select a color for the bottom border.
Item > Add HTML Code PRO
Add custom html code to the item to extend Goldfish's functionality.
Item > Add CSS Code PRO
Add custom css code to the item. The code will be stored in the css section of your website. You
can't change the css code of internal items, but you can use the css code in your custom html
code.
Item > Identifer (Id) PRO
Sets the value for the "id" property. You can use this id to access the item with JavaScript.
Shape > Has Shape
Select the shape, which should be shown. Deactivate this, if you don't want a shape.
Shape > Arc
Sets the arc for the round edges of a rounded rectangle.
Shape > Fill Color
Choose a fill color for the shape or the color of a line shape.
Shape > Size
Sets the size of a line shape in pixels.
Shape > Border Width
Sets the width of the border of the shape in pixels.
Shape > Border Color
Choose a color for the border of the shape.
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13. Gallery
With a gallery you can present dozens of photos to the visitors of your website in a slide
show.
You can add a gallery to every page area or area template. To add a gallery, edit the content of a
page area or area template and drag the gallery from the elements panel to the editor.

A gallery shows a range of pictures as thumbnails. The visitor of your website can click on each
thumbnail to see a larger version. Optional you can add a slideshow, so that the next picture will
loaded automatically.

To add pictures to your gallery, click on Gallery > Read from folder > Choose... and open the
folder with the pictures from your harddisk. The media import window apprears for each picture.
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13: Gallery
If you have large pictures (e.g. from a digital camera), you should reduce the size to max. 700 x
700 pixels. You can enter a description for every picture if you want. Check For All if you don't
want to pop up the media import window for every picture again.

If a visitor of your website clicks on a thumbnail, the larger version of the picture will be loaded on
the presentation page. Let's edit the style for this page. Enter a title for your gallery: Edit the text
at Gallery > Title in the properties pane. The title is shown in the titlebar of the presentation page.

If you want to load pictures automatically in a slide show, you can enable Presentation Page >
Slide Pause (Sec.) on the properties pane and enter a time in seconds. Otherwise deactivate this
option. If you want to show the comments, which you have entered in the media import window,
below every picture, check Presentation Page > Show Description.
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To change a comment for a picture, click in the white space of the project list (nothing will be
selected) and click on Project > Embedded Media in the properties pane. Here you can edit the
comments of all media files of your website.

Properties for Gallery
These properties can be set for a gallery. Select a gallery to show its properties.
Item > Left
Sets the distance from the left side of the parent element in pixels.
Item > Top
Sets the distance from the top side of the parent element in pixels.
Item > Width
Sets the width of the item in pixels.
Item > Height
Sets the width of the item in pixels.
Item > Padding Left
Sets the distance from the left side of the item to the content in pixels.
Item > Padding Right
Sets the distance from the right side of the item to the content in pixels.
Item > Padding Top
Sets the distance from the top side of the item to the content in pixels.
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Item > Padding Bottom
Sets the distance from the bottom side of the item to the content in pixels.
Item > Background Color
Select a background color for the item.
Item > Background Picture
Select a background picture for the item. With "Repeat", you can choose how the picture will be
displayed.
Item > Border Left Width
Displays a border on the left side of the item in the choosen width (pixels).
Item > Border Left Color
Select a color for the left border.
Item > Border Right Width
Displays a border on the right side of the item in the choosen width (pixels).
Item > Border Right Color
Select a color for the right border.
Item > Border Top Width
Displays a border on the top side of the item in the choosen width (pixels).
Item > Border Top Color
Select a color for the top border.
Item > Border Bottom Width
Displays a border on the bottom side of the item in the choosen width (pixels).
Item > Border Bottom Color
Select a color for the bottom border.
Item > Add HTML Code PRO
Add custom html code to the item to extend Goldfish's functionality.
Item > Add CSS Code PRO
Add custom css code to the item. The code will be stored in the css section of your website. You
can't change the css code of internal items, but you can use the css code in your custom html
code.
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Item > Identifer (Id) PRO
Sets the value for the "id" property. You can use this id to access the item with JavaScript.
Gallery > Read From Folder
Select a folder with pictures from your harddisk.
Gallery > Title
The title of your gallery. It is shown on the presentation page in the title bar of the web browser.
Preview Icon > Icon width (max)
Sets the maximal with of a thumbnail. Maximal because the picture is resized in aspect ratio.
Preview Icon > Icon height (max)
Sets the maximal height of a thumbnail. Maximal because the picture is resized in aspect ratio.
Preview Icon > Margin horizontal
Sets the space between the bottom of a thumbnail and the top of the next thumbnail.
Preview Icon > Margin vertical
Sets the space between the right of a thumbnail and the left of the next thumbnail.
Preview Icon > Padding Left
Sets the distance from the left side of a thumbnail to the content in pixels.
Preview Icon > Padding Right
Sets the distance from the right side of a thumbnail to the content in pixels.
Preview Icon > Padding Top
Sets the distance from the top side of a thumbnail to the content in pixels.
Preview Icon > Padding Bottom
Sets the distance from the bottom side of a thumbnail to the content in pixels.
Preview Icon > Background Color
Select a background color for a thumbnail.
Preview Icon > Background Picture
Select a background picture for a thumbnail. With "Repeat", you can choose how the picture will
be displayed.
Preview Icon > Border Left Width
Displays a border on the left side of a thumbnail in the choosen width (pixels).
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Preview Icon > Border Left Color
Select a color for the left border.
Preview Icon > Border Right Width
Displays a border on the right side of a thumbnail in the choosen width (pixels).
Preview Icon > Border Right Color
Select a color for the right border.
Preview Icon > Border Top Width
Displays a border on the top side of a thumbnail in the choosen width (pixels).
Preview Icon > Border Top Color
Select a color for the top border.
Preview Icon > Border Bottom Width
Displays a border on the bottom side of a thumbnail in the choosen width (pixels).
Preview Icon > Border Bottom Color
Select a color for the bottom border.
Presentation Page > Slide Pause (Sec)
Sets how long a pictures is shown in the slideshow. Deactivate this to have no slideshow.
Presentation Page > Show Description
Shows the comment of a picture below the large version picture on the presentation page.
Presentation Page > Font Style
Sets the font style for the presentation page.
Presentation Page > Background Color
Select a background color for the presentation page.
Presentation Page > Background Picture
Select a background picture for the presentation page. With "Repeat", you can choose how the
picture will be displayed.
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14. Visitor Counter
Add a visitor counter to your website. With a visitor counter you can show how many
visitors where on your website.
You can add a visitor counter to every page area or area template. To add a visitor counter, edit
the content of a page area or area template and drag the visitor counter from the elements panel
to the editor.

A visitor counter counts every visitor of your website and displays the number of visitors on an
image. Returning visiors are counted once in 24 hours. Change the properties in the section
Visitor Counter on the properties pane to change the style of the counter.

The property Style sets the style of the counter. You can choose from a couple of styles in
different colors. Digits sets the size of the counter. If the counter reding is too big for the number
of digits, the last digits will be cut off.

If you don't like the built in styles, you can create a custom counter picture. The counter picture is
a small image with the digits 0 to 9. The counter script cuts out every digit which is needed, and
puts them together to the displayed counter reading.

Choose Custom Style at Visitor Counter > Style on the properties pane and select your created
counter picture.
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14: Visitor Counter
INFO: This item uses PHP. Your webserver must support PHP to use it.

Properties for Visitor Counter
These properties can be set for a visitor counter. Select a visitor counter to show its properties.
Item > Left
Sets the distance from the left side of the parent element in pixels.
Item > Top
Sets the distance from the top side of the parent element in pixels.
Item > Width
Sets the width of the item in pixels.
Item > Height
Sets the width of the item in pixels.
Item > Padding Left
Sets the distance from the left side of the item to the content in pixels.
Item > Padding Right
Sets the distance from the right side of the item to the content in pixels.
Item > Padding Top
Sets the distance from the top side of the item to the content in pixels.
Item > Padding Bottom
Sets the distance from the bottom side of the item to the content in pixels.
Item > Background Color
Select a background color for the item.
Item > Background Picture
Select a background picture for the item. With "Repeat", you can choose how the picture will be
displayed.
Item > Border Left Width
Displays a border on the left side of the item in the choosen width (pixels).
Item > Border Left Color
Select a color for the left border.
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14: Visitor Counter
Item > Border Right Width
Displays a border on the right side of the item in the choosen width (pixels).
Item > Border Right Color
Select a color for the right border.
Item > Border Top Width
Displays a border on the top side of the item in the choosen width (pixels).
Item > Border Top Color
Select a color for the top border.
Item > Border Bottom Width
Displays a border on the bottom side of the item in the choosen width (pixels).
Item > Border Bottom Color
Select a color for the bottom border.
Item > Add HTML Code PRO
Add custom html code to the item to extend Goldfish's functionality.
Item > Add CSS Code PRO
Add custom css code to the item. The code will be stored in the css section of your website. You
can't change the css code of internal items, but you can use the css code in your custom html
code.
Item > Identifer (Id) PRO
Sets the value for the "id" property. You can use this id to access the item with JavaScript.
Visitor Counter > Style
Select style for your counter.
Visitor Counter > Counter Picture
Select a custom counter picture if you want to use a custom style for your counter.
Visitor Counter > Digits
Sets the number of digits, which the counter displays.
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15. Form
Add a contact form to yor website. With this form the visitor can send you messages.
You can add a form to every page area or area template. To add a form, edit the content of a
page area or area template and drag the form from the elements panel to the editor.

A form lets the visitor get in touch with you. Usually he fills out the form, sends it and you receive
an e-mail with the form content. But you can also create custom forms, that communicate with
your own web applications and scripts.

Double click on the form to edit it's content. You can reorder the form elements by dragging them
around. A click in the close widget of every element removes it from the form. Drag new form
elements from the elements panel to the form. The following elements are available:
- Text field: Displays an one line text field in the form. This is used for enering short information
like names, e-mail address or passwords.
- Multiline text field: Displays a large text field in the form. This is used for long text with
multiple lines.
- Selection element: Displays a list box, a popup menu or a set of radio boxes. This is used to
let the visitor descide between multiple options.
- Checkbox: Displays a checkbox in the form. This is used to accept or don't accept an option.
Double click on the form to edit it's content. You can reorder the form elements by dragging them
around. A click in the close widget of every element removes it from the form. Drag new form
elements from the elements panel to the form. The following elements are available:
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15: Form

Double click on a form element to see its options. The options which are available depend on the
form element on which you have clicked.

Options for Text Field
Name
Enter name of the form element. This is important for custom forms. The name must be unique in
a form and can only contain letters, digits, _, and -.
Display name
The name, which is displayed in the form and the e-mail with the form content.
Form element required
Enable this and the visitor must enter a value in this element. Otherwise the form can't be sent.
Default text
The text field is filled with this text by default.
Password Field
The text field shows only ******* if the visitor enters text. This is used for passwords.
Allow only e-mail addresses
Only an e-mail address can be entered. You can select the form element as reply address for
e-mail forms.
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15: Form

Options for Multiline Text Field
Name
Enter name of the form element. This is important for custom forms. The name must be unique in
a form and can only contain letters, digits, _, and -.
Display name
The name, which is displayed in the form and the e-mail with the form content.
Form element required
Enable this and the visitor must enter a value in this element. Otherwise the form can't be sent.
Default text
The text field is filled with this text by default.
Height (pixels)
The height of the text filed. If the visitor enters more text scrollbars will be shown.

Options for Selection Element
Name
Enter name of the form element. This is important for custom forms. The name must be unique in
a form and can only contain letters, digits, _, and -.
Display name
The name, which is displayed in the form and the e-mail with the form content.
Form element required
Enable this and the visitor must enter a value in this element. Otherwise the form can't be sent.
Selection kind
Sets the type of the selection element: List, Popup menu or Radio boxes
Options
Add or remove options from which the visitor can choose. Every option has a value for internal
use and a display name which is displayed in e-mails and in the form. If you enable Selected, the
option will be selected by default.
Height (pixels)
The height of the list box (list box only).
Multiple selection
The user can select multiple option in the lsit box (list box only).
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Options for Selection Element
Name
Enter name of the form element. This is important for custom forms. The name must be unique in
a form and can only contain letters, digits, _, and -.
Display name
The name, which is displayed in the form and the e-mail with the form content.
Form element required
Enable this and the visitor must enter a value in this element. Otherwise the form can't be sent.
Checked
The checkbox is checked by default.

To deliver the form to your e-mail account is's required that you enter your e-mail address at Send
page > E-mail address on the properties panel.

It's possible that Goldfish sets the entered e-mail address of the visitor as reply address for the
e-mail, which you receive. Therefore it's required that you mark at least one text field as e-mail
address field. Double click on a text field and enable Allow only e-mail addresses.
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15: Form

Leave the edit mode of the form. At Send page > Reply e-mail on the properties panel, there is a
list of all e-mail text fields. Select an e-mail text field as reply address for your e-mails.
INFO: This item uses PHP. Your webserver must support PHP to use it.

Properties for Form
These properties can be set for a form. Select a form to show its properties.
Item > Left
Sets the distance from the left side of the parent element in pixels.
Item > Top
Sets the distance from the top side of the parent element in pixels.
Item > Width
Sets the width of the item in pixels.
Item > Height
Sets the width of the item in pixels.
Item > Padding Left
Sets the distance from the left side of the item to the content in pixels.
Item > Padding Right
Sets the distance from the right side of the item to the content in pixels.
Item > Padding Top
Sets the distance from the top side of the item to the content in pixels.
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Item > Padding Bottom
Sets the distance from the bottom side of the item to the content in pixels.
Item > Background Color
Select a background color for the item.
Item > Background Picture
Select a background picture for the item. With "Repeat", you can choose how the picture will be
displayed.
Item > Border Left Width
Displays a border on the left side of the item in the choosen width (pixels).
Item > Border Left Color
Select a color for the left border.
Item > Border Right Width
Displays a border on the right side of the item in the choosen width (pixels).
Item > Border Right Color
Select a color for the right border.
Item > Border Top Width
Displays a border on the top side of the item in the choosen width (pixels).
Item > Border Top Color
Select a color for the top border.
Item > Border Bottom Width
Displays a border on the bottom side of the item in the choosen width (pixels).
Item > Border Bottom Color
Select a color for the bottom border.
Item > Add HTML Code PRO
Add custom html code to the item to extend Goldfish's functionality.
Item > Add CSS Code PRO
Add custom css code to the item. The code will be stored in the css section of your website. You
can't change the css code of internal items, but you can use the css code in your custom html
code.
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Item > Identifer (Id) PRO
Sets the value for the "id" property. You can use this id to access the item with JavaScript.
Form > Form type
Sets the type of the form: E-mail form or Custom form.
Form > Internet address
The internet address to which the form will be sent (custom forms only). At this address there
must be a script which handles the form data.
Form > Send method
Sets the send method Get or Post (custom forms only)
Form > Margin horizontal
Sets the space between two form elements
Form > Font style
Sets the font style for the form
Form > Send button
Enable this and the form has a send button. Enter the caption of the button.
Form > Reset button
Enable this and the form has a reset button. Enter the caption of the button.
Form > Edit content
Starts the edit mode of the form.
Send page > E-mail address
Sets the e-mail address to which the form should be sent.
Send page > E-mail subject
Sets the subject of the form e-mail.
Send page > Sent message
Sets the message, which is displayed to the visitor if the form is sent successfully.
Send page > Error message
Sets the message, which is displayed to the visitor if an error occured.
Send page > Reply e-mail
Sets the e-mail text field which contains the visitors e-mail addess.
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Send page > Font style
Sets the font style for the send page.
Send page > Button caption
Sets the button caption of the send page. The button lets the visitor retutn to yor website.
Send page > Background Color
Select a background color for the send page.
Send page > Background Picture
Select a background picture for the send page. With "Repeat", you can choose how the picture
will be displayed.
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16. Website Frame
With a website frame, you can show an external page directly within your website.
You can add a website frame to every page area or area template. To add a website frame, edit
the content of a page area or area template and drag the website frame from the elements panel
to the editor.

A website frame shows an external website directly on your page. For example you can include a
forum or other web application, which Goldfish does not support directly. Enter the url of the
external website at Website Frame > Url Of Frame Content.

Properties for Website Frame
These properties can be set for a website frame. Select a website frame to show its properties.
Item > Left
Sets the distance from the left side of the parent element in pixels.
Item > Top
Sets the distance from the top side of the parent element in pixels.
Item > Width
Sets the width of the item in pixels.
Item > Height
Sets the width of the item in pixels.
Item > Padding Left
Sets the distance from the left side of the item to the content in pixels.
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Item > Padding Right
Sets the distance from the right side of the item to the content in pixels.
Item > Padding Top
Sets the distance from the top side of the item to the content in pixels.
Item > Padding Bottom
Sets the distance from the bottom side of the item to the content in pixels.
Item > Background Color
Select a background color for the item.
Item > Background Picture
Select a background picture for the item. With "Repeat", you can choose how the picture will be
displayed.
Item > Border Left Width
Displays a border on the left side of the item in the choosen width (pixels).
Item > Border Left Color
Select a color for the left border.
Item > Border Right Width
Displays a border on the right side of the item in the choosen width (pixels).
Item > Border Right Color
Select a color for the right border.
Item > Border Top Width
Displays a border on the top side of the item in the choosen width (pixels).
Item > Border Top Color
Select a color for the top border.
Item > Border Bottom Width
Displays a border on the bottom side of the item in the choosen width (pixels).
Item > Border Bottom Color
Select a color for the bottom border.
Item > Add HTML Code PRO
Add custom html code to the item to extend Goldfish's functionality.
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16: Website Frame
Item > Add CSS Code PRO
Add custom css code to the item. The code will be stored in the css section of your website. You
can't change the css code of internal items, but you can use the css code in your custom html
code.
Item > Identifer (Id) PRO
Sets the value for the "id" property. You can use this id to access the item with JavaScript.
Website Frame > Url of frame content
Enter the url of the external website, which you want to display.
Website Frame > Show scrollbars if required
Enable this option and scrollbars will be shown if the external website is bigger than the frame.
Otherwise the content will be cut off.
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17. HTML Code
Use a html code container to add your own html code to a page and extend Goldfish's
functionality.
You can add a html code container to every page area or area template. To add a html code
container, edit the content of a page area or area template and drag the html code container from
the elements panel to the editor.

A html code container displays every pice of html code, what you want. For example you can
display a Google Maps (http://www.google.com/maps) map on your website and show your page
visitors where you are.

Enter the html code in the code editor. To open the code editor click on HTML Code > HTML
Code on the properties pane. The html code container is the only place where you can store html
code in Goldfish Standard. If you need more possibilities to enter html or css code, please
upgrade to Goldfish Professional.
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17: HTML Code

Properties for HTML Code
These properties can be set for a html code container. Select a html code container to show its
properties.
Item > Left
Sets the distance from the left side of the parent element in pixels.
Item > Top
Sets the distance from the top side of the parent element in pixels.
Item > Width
Sets the width of the item in pixels.
Item > Height
Sets the width of the item in pixels.
Item > Padding Left
Sets the distance from the left side of the item to the content in pixels.
Item > Padding Right
Sets the distance from the right side of the item to the content in pixels.
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Item > Padding Top
Sets the distance from the top side of the item to the content in pixels.
Item > Padding Bottom
Sets the distance from the bottom side of the item to the content in pixels.
Item > Background Color
Select a background color for the item.
Item > Background Picture
Select a background picture for the item. With "Repeat", you can choose how the picture will be
displayed.
Item > Border Left Width
Displays a border on the left side of the item in the choosen width (pixels).
Item > Border Left Color
Select a color for the left border.
Item > Border Right Width
Displays a border on the right side of the item in the choosen width (pixels).
Item > Border Right Color
Select a color for the right border.
Item > Border Top Width
Displays a border on the top side of the item in the choosen width (pixels).
Item > Border Top Color
Select a color for the top border.
Item > Border Bottom Width
Displays a border on the bottom side of the item in the choosen width (pixels).
Item > Border Bottom Color
Select a color for the bottom border.
Item > Add HTML Code PRO
Add custom html code to the item to extend Goldfish's functionality.
Item > Add CSS Code PRO
Add custom css code to the item. The code will be stored in the css section of your website. You
can't change the css code of internal items, but you can use the css code in your custom html
code.
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17: HTML Code
Item > Identifer (Id) PRO
Sets the value for the "id" property. You can use this id to access the item with JavaScript.
HTML Code > HTML Code
Enter the html code which should be included.
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18. Import Media
Learn how you can import and process media files like images, movies and documents in
Goldfish.
Every time if you import media files (images, movies, pdf and other media), the media import
window appears. An imported media file gets included into the .gfp file. So if you pass the .gfd file
to others, it's not neccessary to pass the media files as well.

There is a preview, if you import pictures (.jpg, .png, .gif). You can also resize the pictures, so that
your .gfp file gets not too big. This is recommended if you import large images directly from a
digital camera. 700 x 700 px are adequate in most cases. The resize function resizes the picture
only if it's bigger than the entered values. It resizes in aspect ratio.
INFO: The resize function is only available for .jpg and .png images. Not for .gif images.

You may enter a description for every imported media file. This description is used in many ways:
- As alt text in html code for images.
- As tooltip for links to the file (e.g. to a .pfd file).
- As description for images in a gallery.
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To edit the description or a file name, select nothing so that the properties for the project are
shown. Click on Project > Embedded Media > Choose... and the embedded media window
appears. Double click on a description to edit it
Double click on a name to edit it. Note that you can only use letters, numbers and _ for the name.
Don't remove the suffix. There is also a length restriction. If you have entered a bad name, it won't
be accepted.
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19. Working with Fonts
There are several things you should know if you work with fonts and font styles on
websites.
Fonts and font styles are handled in font templates. Select nothing (the project properties appear)
and click on Project > Font Templates > Choose... on the properties panel. A list of all font
templates appears.

The first template on the list is the Master Template. Here you can store the default font style for
your website. If you don't set a special font for all other font templates, or components, the style of
the master template is used. Double click on a font template to rename it.
Add a font template.
Duplicate a selected font template.
Delete a selected font template.
Opens the font editor and you can edit the font template.
Click on the Edit Font Template button. The font editor will be opend.
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The following option can be set in the font editor. Note that there are sometimes not all options
avaiable. It depends on the item from which you edit the font style.
Font template
Choose the font template, on which the font style is based. The style is taken from the font
template.
Font
Activate this to overwrite the font from the font template.
Style
Activate this to overwrite the font style of the font template.
Size
Activate this to overwrite the font size of the font template.
Color
Activate this to overwrite the color from the font template.
Line space
Activate this to overwrite the line space from the font template.
Alignment
Activate this to overwrite the alignment of the font template.
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19: Working with Fonts
INFO: If you change the style in a font template, this changes apply to all font styles which
use this font template and where the changed style property isn't overwritten.

A font can only be displayed if the visitor has it installed on his computer. So it's better to declare
a list of fonts, where the first font which is found will be used. Click on the button Alternative font
family next to the font selector.
Add an alternative font family.
Delete a selected alternative font family.
The list is processed from the top to the bottom. The first font which is found on the visitor's
computer is used.
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20. Build your Website
Build your website on the desktop and get all neccessary files, which you can upload to a
webserver.
You need a web server to publish your website on the internet. Usually a website hosting service
will provide you access to a web server, but you can also operate a web server by yourself.
INFO: Goldfish will not help you to find a hosting service or register a domain like
www.mywebsite.com. But you can find many hosting services with Google (http:/
/www.google.com).

The code files which Goldfish creates must be uploaded to your web server (blue cloud). The
visitors of your website get in touch with your webserver and receive your website from there.
If your website is complete you have to build all neccessary code files and media for the
webserver. Choose File > Build Website... in the menu and choose a destination on your hard
disk where Goldfish can save the files.
INFO: Don't upload the .gfp file to your webserver. This file contains your website project
and can't be read from a webserver. Always upload the files which you get from File >
Build Website....
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During the build process, there may occure build errors. There are several types of build errors.
- Missing e-mail address: You have an e-mail form on your website, but there is no e-mail
adress to which the form will be sent. Select the form and enter an e-mail address at Send
Page > E-Mail Address on the properties panel.
- Missing internet address: You have an rss newsfeed on your website, but the internet adress
is missing. The internet address is needed, by rss feeds. Select nothing (the project) and enter
the internet adress on which your website will be available at Project > Page Address (Url) on
the properties panel.
INFO: If you want to publish your website immediately on the internet, choose File >
Publish Website... instead of File > Build Website....
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21. Publish Website
Publish your website immedialtely on the internet with the built in ftp client.
You need a web server to publish your website on the internet. Usually a website hosting service
will provide you access to a web server, but you can also operate a web server by yourself.
INFO: Goldfish will not help you to find a hosting service or register a domain like
www.mywebsite.com. But you can find many hosting services with Google (http:/
/www.google.com).

The code files which Goldfish creates must be uploaded to your web server (blue cloud). The
visitors of your website get in touch with your webserver and receive your website from there.
If your website is complete you can publish it directly from Goldfish with the built in ftp client. You
need ftp access to your web server to publish your website. Choose File > Publish Website... from
the menu.
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21: Publish Website

Enter the address of the ftp server, the user name and password. And click on OK. The
webserver will be connected. A list of folders from your web server is shown. You can publish
your website here or navigate to a sub folder with doubleclick. Click on Publish to publish your
website.
INFO: Goldfish remembers all ftp logins which you have entered. You can choose a recent
login with the pulldown menu at the server field. If you activate Remember Password, the
password will be remembered as well.
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If there is an older version of your website on the web server, the button Publish changes to
Update. Click on Update and Goldfish updates your website. Only the new and changed files are
uploaded.

During the build process, there may occure build errors. There are several types of build errors.
- Missing e-mail address: You have an e-mail form on your website, but there is no e-mail
adress to which the form will be sent. Select the form and enter an e-mail address at Send
Page > E-Mail Address on the properties panel.
- Missing internet address: You have an rss newsfeed on your website, but the internet adress
is missing. The internet address is needed, by rss feeds. Select nothing (the project) and enter
the internet adress on which your website will be available at Project > Page Address (Url) on
the properties panel.
INFO: If you want to build your website on the desktop, choose File > Build Website...
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21: Publish Website
instead of File > Publish Website....
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22. Export a Design
Export your work as Goldfish design. Build websites from your design or deliver it to your
clients.
A Goldfish design is a design template for Goldfish websites. Choose File > Designs... from the
menu to see all installed designs. Technically a design is a Goldfish project which contains the
complet layout of a website but no content.

To export a design, choose File > Export > Design... from the menu. Click on the Goldfish icon
and paste a screenshot from your design. This is used in the designs window as preview. You
can also enter a description or copyright text.
Click on OK to save your design. Goldfish Design files have the extension .gfd instead of .gfp.
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23. Preferences
In the preferences, you can change the behavior of Goldfish.
Choose Goldfish > Preferences... (Edit > Preferences... on Windows) and the preferences
window appears. The perefernces are seperated in two areas. General and Craete Website.

General
The follwoning perferences can be set on the General tab.
Search for updates at Startup
Searches at every startup of Goldfish for updates on our website. You will be notified if there is an
update available.
Show designs at startup
Shows the designs window after the startup of Goldfish.
Use alignment guides
Use alignment guides to guide you with the layout of your website. You can drag an alignment
guide from the rulers.
Show area alignment guides on pages
If you have alignment guides on template areas, they will be shown on the page area that uses
the template area.
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23: Preferences
Snap alignment guides to object positions
if you drag an item, it will snap to an alignment guide near by.
Use sound effects
Plays sounds if there is an update available.
Close areas in the properties automatically
If you activate this, there is kept only one area open in the properties.

Create Websites
The follwoning perferences can be set on the Create Websites tab.
Name of index file
Usually, the file, which is loaded at first if the visitor enters your website is named index.htm.
Rename this if your website hosting service requires a differnent name.
Name of media folder
Here you can rename the folder for media files of your website. This is required if you create a
page with subpages which is called media, too.
name of support folder
Here you can rename the folder for support files of your website. This is required if you create a
page with subpages which is called support, too.
Suffix of code files
Here you can change the suffix for code files. Usually the extension is .htm. Some website
hosting services require .html instead.
Text encoding
Change the encoding if special characters (ä, ©, ß...) are displayed wrong on your website
JPEG export quality
Sets the quality for new calculated jpeg images. A lower quality makes smaller file sizes.
Save stylesheets externally
Usually the css style information is stored in one file for the whole website. Deactivate this if you
want to include the css information seperately in every code file.
Rename stylesheets during website updates
This prevents that an old style file is used, which was fould in the browser's cache on updated
websites.
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23: Preferences
Compatible with Internet Explorer 6
Includes javascript code for displaying transparent png images with Internet Explorer 6.
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24. Trouble and Errors
Learn what you can do if errors occure, if you find bugs or if you have trouble using
Goldfish.

Letters like ©, ä and ß are not displayed correctly on your website: Choose Goldfish >
Preferences... (Edit > Preferences... on Windows). Change Text Encoding on the tab Create
Website. If you export the website again, the characters will be displayed correctly.

When the visitor sends the form on your website, php code is shown and the visitor counter is not
displayed: Your website hosting service doesn't support php. Upgrade your websosting package
so that php is supported or remove all items which use php (visitor counter and form) from your
website.
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24: Trouble and Errors
Please contact the support if you see the message An exception was not handled. This is a bug
of Goldfish. You can contact the support at our support page (../support/contact.php).
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25. Goldfish Short Keys
Learn how to use Short Keys in Goldfish. This article contains a full list of all short keys
for Goldfish.

Application Start
- Reset preferences

Preferences
- Show advanced preferences

Edit Page
- Delete selected Page Area
- Leave edit mode

Edit Page Area
+ Click - Add or remove to selection
- 1 px. left
- 1 px. right
- 1 px. up
- 1 px. Down
- Delete selected items
+ Resize item - Resizes in aspect ratio
- Leave edit mode

Edit Page Item
- Leave edit mode

Edit Text
- Go right *
+
or
+

- Line end *

- Next word *

- Go left *
+
or
+

+

+

- Line start *

- Last word *
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25: Goldfish Short Keys
- Go up*
+

- Text start *

- Go down *
+

- Text end *

- Delete text left
- Delete text right
* If you press also

, the text will be selected.
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