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1. New in Goldfish 4

Goldfish 4 is the biggest update in the history of Goldfish. Innovations and improvements are

everywhere. In addition, Goldfish 4 is completely redesigned.

2. Quick Start Tutorial

Get to know Goldfish and create a sample website with blog, contact form and an animation on

the start page. Create a mobile view for smart phones.

3. Upgrade Guide

Read how to switch to Goldfish 4. Transfer all old projects and websites. Learn what works

automatically and where you need to adjust things manually.

4. Register and Unlock

When you purchase goldfish, you will receive a license key. Learn how to register and unlock all

the features, so that Goldfish works without limitations.

5. Project

Start a new Goldfish project and learn about everything that you can set in the project. This is the

first step when designing your website with Goldfish.

6. Pages and Page Templates

Separate your website into pages and subpages for better readability. Use page templates for the

layout of your website.

7. Areas and Area Templates

Create area templates for header, navigation, main content and footer and put them together on

the pages.

8. Slider

Several areas for sliding through. This works with a slider area that you can drag from the items

to the website.

9. Blog

A blog or CMS, allowing you to publish content without using Goldfish. This works with a blog

area, that you can drag from the items to the website.

10. Guestbook

A guestbook in which your site visitors can write comments. This works with a guestbook area,

that you can drag from the items to the website.
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11. Text

Fill your website with content and add text. This works with a text item that you can drag from the

items to the website.

12. Picture

Fill your website with content and add pictures. This works with an picture item that you can

drawn from the items to the website.

13. Audio & Video

Play sound files and videos on your website. This works with an Audio & Video item that you can

drag from the items to the website.

14. Shape

Draw rectangles, rounded rectangles, ovals, lines and other shapes directly on your website. This

works with a shape item that you can drag from the items to the website.

15. Menu

Essential for your website is the navigation between different pages. This works with a menu item

that you can drag from the items to the website.

16. Link Shape

Make any places of a website clickable. This works with a link shape that you can drag from the

items to the website.

17. Follow & Share

Connect your website to social networks. This works with a Follow & Share item that you can

drag from the items to the website.

18. Gallery

Present a selection of images on your website. This works with a gallery item that you can drag

from the items to the website.

19. Form

Stay in touch with the website visitors and add a contact form. This works with a form item that

you can drag from the items to the website.

20. Visitor Counter

Add a visitor counter to your website. With a visitor counter you can show the number of visitors

of your website.

21. Path & Sitemap

Show a sitemap or the path back to the start page. This works with a path & sitemap item that you

can drag from the items to the website.
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22. Website Frame

Show an external website, embedded directly on your website. This works with a website frame

item that you can drag from the items to the website.

23. HTML Code

Add code snippets and expand the functionality of Goldfish. This works with a HTML code item

that you can drag from the items to the website.

24. Search Field

Offer a full text search on your website. This works with a search field item that you can drag from

the items to the website.

25. Animation

Enhance your website with animations. Every item on a page can be animated. This works with

an animation item that you can drag from the items to the website.

26. Online Shop (Product & Shopping Cart)

Set up an online shop on your website. This works with a shopping cart item and some product

items, which you can drag from the items to the website.

27. Goldfish Link

Support Goldfish with a link to our website. This works with a Goldfish Link item that you can drag

from the components to the website.

28. Typography & Font Styles

Typography is very important on websites. Goldfish supports the font system of HTML, rendering

of text and Adobe Typekit. Because of this, all texts will be displayed similar on all devices.

29. Mobile Websites

More and more site visitors use mobile devices such as tablets and smartphones to visit your

website. That is why Goldfish supports mobile websites.

30. HTML, CSS, PHP and More

Extend the functionality of Goldfish with HTML, CSS, PHP and more. Goldfish is very flexible for

web developers.

31. Preview

Before you publish your finished website, you can generate a preview in Goldfish.

32. Publish Website

If your website is complete, you should publish it on the Internet. So visitors can find and see your

website.
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33. Export Project as a Design

Export your project as Goldfish design template. Create new projects from your design or hand

the design over to your customers.

34. Preferences

In the preferences, you can change the basic behavior of Goldfish.

35. Troubleshooting

Read what errors may occur with Goldfish and how to fix them.

36. Goldfish Short Keys

In this chapter you will find a list of keyboard shortcuts that make it easier to work with Goldfish or

gain access to hidden features.

- 5 -



1. New in Goldfish 4
Goldfish 4 is the biggest update in the history of Goldfish. Innovations and improvements

are everywhere. In addition, Goldfish 4 is completely redesigned.

Goldfish is the easy to use solution to design stunning, custom websites with the latest HTML5

technologies, in little time. We come from the creative business and understand how you think as

an illustrator, creative and designer. All our knowledge and our experience in developing websites

and the feedback from the Goldfish community are now in Goldfish 4.

Overview of New Features in Version 4.0

 - New designs for the creation of your website in only minutes

 - Customized website for smartphones and tablets

 - Automatic forwarding to a customized page, depending on the device, operating system or

language

 - Same typography on all devices by rendering fonts and support for Adobe Typekit

 - Retina graphics and support for resolution independent SVG vector graphics

 - HTML5 audio and video, as well as integration of YouTube videos

 - Special dynamic menus for mobile websites

 - Buttons for like and share for all major communities

 - New design of the image gallery and slideshow

 - Forms with support of multiple keybords on mobile devices

 - Automatically generated sitemap for finding a page quickly

 - New guestbook where your website visitors can post comments and annotations

 - Blog and CMS for posting content without Goldfish, directly on your website with comments

and RSS Feed

 - Integration of Google Analytics with data protection rules
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1: New in Goldfish 4

 - Pinning of backgrounds and page areas when scrolling (the background or area is fixed)

 - Publish your website directly via FTP with SSL encryption

 - Goldfish generates modern HTML5 and CSS code complying with official standards

 - Animations for any item on the page with many effects and possibilities

 - Show or hide any item by a click or hover with the mouse

 - Search box on the website to browse and find specific passages

 - Slider to scroll through different areas on a page

 - Online shop with PayPal Integration, which can be configurated in minutes

 - Write your own HTML and CSS code to any position of your website

 - The Mac version is a Cocoa instead of Carbon app for a better integration with macOS

More New Features in Version 4.1, 4.2, 4.3 and 4.4

 - Goldfish is now a modern 64-bit app, which makes it much more stable 

 - Upon request, Goldfish will generate the sitemap.xml and robots.txt files to let users find your

website better

 - New button object, especially suitable for mobile websites

 - Same typography on all devices by supporting Google Fonts

 - Web sites now show the standard warning for the usage of cookies, that is required in the EU

 - The Onlineshop now supports complex tax calculations for private and business customers

national and from abroad

 - Integration of payments with direct debit, credit card or on account in the online shop via

PayPal-Plus (only available in Germany

 - Password protection is now possible with several user names and passwords

 - Goldfish automatically generates the right icons for many different systems (iOS app icon,

favicon, Microsoft Tile icon, Android icon...)

 - Support for the Open Graph Protocol: Set the page preview when users share, post, and send

links of your website.

 - Video backgrounds for pages, page areas, and items

In addition there are improvements at almost all other parts. Goldfish 4 is completely revised and

redesigned.
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2. Quick Start Tutorial
Get to know Goldfish and create a sample website with blog, contact form and an

animation on the start page. Create a mobile view for smart phones.

In this tutorial, we are developing an unique layout. If you don't want that, you can select a

pre-built design in the Design window and fill it with content. This shortens the development time.

But in Goldfish you can unleash your creativity and develop the complete design of the website by

yourself. We suggest to create a sample website with the help of this guide and you will get an

introduction to Goldfish.

The Page Model of Goldfish
Goldfish creates websites in an innovative and unique way. There are flexible components

available such as pages, page areas, text boxes, or image items.

A page is made up of 3 different levels. A page (gray) is the base. There are page areas (yellow)

on a page, that represent different areas of your website (header, footer, navigation, main area,

etc.). A page area contains items (green). Items represent the content of your website such as

images, films or text.
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2: Quick Start Tutorial

In order to build a planned layout, you must divide (cut) it into different page areas at first. In the

example above we have a header area (on the top), an area for the content of the page (in the

middle left), an area for the navigation (in the middle right) and a footer (on the bottom). For a

different layout you will need a different breakdown of the areas. Divide the layout always so in

areas that the main area with the main content stands as a single area for itself.

The Layout for the Sample Website
For sample website, you will need 4 different photos, one of them should be suitable as a

background image. The layout will be completely created in Goldfish. You do not need any

additional software for this example.
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2: Quick Start Tutorial

As described earlier in The Page Model of Goldfish, the layout will be divided into areas. The 

Navigation (blue stripe) and the Header (directly below) are the same on each page. Below this

there is the main area, on that is displayed different content on all sub pages. The Footer at the

bottom is again the  same on every page. There will be copyright information on it.

Creating the Layout for Computers and Tablets
Start a new project and click on New Goldfish Project or select File > New ... from the menu. A

project window and the Design window will be opened.

Make sure that Add page for mobile devices is checked and double click on Blank because we

want to create a unique design. You will see the project list on the left. All the pages and

components for your website are listed here. First, click on Master Page, to change basic settings

such as the background color.
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2: Quick Start Tutorial

The properties for the Master Page appear on the right. Change Margin Left, Margin Right, 

Margin Top and Margin Bottom to 0 because the website does not require a page margin.

Change the color from Background Color to white. To do this, click in the gray box to bring up a

color picker.

We will need an Area Template for each area, that we get by cutting up the layout. An area

template represents a section of the website and can be used on any sub page, so that you have

to create everything only once.

We will need four area templates for Navigation, Header, Main and Footer, and the area template 

Main for the content already exists. Click on + at the bottom left and select Add Area Template.

Repeat this step two more times so that you have created a total of three new area templates.
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2: Quick Start Tutorial

Double click on the new templates in the project list, and change the name to Navigation, Header

and Footer. In the next step we will choose the correct settings for the area templates. First, click

on Navigation.

The properties of the area template Navigation are visible. Change the property Height (min) to 

60, because the navigation should be only 60 pixels high. Change the Background Color to blue,

and select the check box before Stretch background to border. So the background will be drawed

to the edges of browser windows, that are larger than the 1000 pixel wich are set as the Width.

Next, click on the page template Header. Change the Height (min) to 200 here. The header

should contain a photo as background. Because of this, turn off the Background Color by

removing the selection from the check box and click ? after Background Picture. Select a picture

from your computer for the background. Enter the value 1300 in both boxes at Reduce image size

to max. in the Import Media window. Thus, the image will be automatically scaled down during the

import. Click on OK to import the picture.

Choose the option Cut to Fill at Repeat, so that the background is displayed over the whole area.
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2: Quick Start Tutorial

At last, enable the checkbox Stretch background to border.

Next, click on the page template Main. Change only the Height (min) to 300 here.

Click on the page template Footer. Change the property Border Top Width to 3 and a three pixel

wide, black border appears on the top of the footer. Now, change the Height (min) to 50.

The next step is to build the layout on the start page from the area templates. Click on the Start

Page in the project list. Drag the Navigation, then the Header and the Footer from the

components at the bottom to the page. You can move the areas around with the mouse and can

drag them into the correct order. At the top the Navigation, below that the Header, Main and the 

Footer.

Choose Preview from the toolbar on the top and see the result. The basic layout is already done.

In the next step the menu, headlines and copyright text will be added.
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2: Quick Start Tutorial

We start on the area template Footer. Click on it and drag a Text item from the components to the

area template. Double click on the item, delete the text Lorem ipsum... and write © My Cool

Website, instead. Reduce size of the item by dragging the corners and move it to the position Left

of 0, and Top of 15. For this you can use alignment guides by dragging them from the rulers to

the Editor.

Go to the area template Header, and use again a text item for the headline and the sub headline.

You can choose the font size and color by selecting some text and clicking on Edit Text > Font

Style > Choose ... in the properties.

Go to the area template Navigation. A navigation menu should be there. Drag a Menu from the

components to the template and increase its length but decrease its height by dragging the

corners until it looks like in the picture above.
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2: Quick Start Tutorial

Change the property Menu > Menu Type to Simple Menu (displays no subfolders) in the

properties. Then add a 3 pixel and white border with Item > Border Left Width.

Go to the category Main Menu Entry. Add a 3 pixel and white border at Main Menu Entry > Border

Right Width. After that, turn off the Background Color.

When you move the mouse over a menu entry the the font color and style should change. Disable

the property Change Background at  Moving Mouse Over Link Effect,  enable Change Font  and

click on Choose... behind that. Select white as the font color and Bold as the font style.

Choose exactly the same at Clicking On Link Effect.

The menu shows still Untitled as the only entry for the start page. Go to the start page and

change the property Page > Title to My Website - Welcome. This text will be displayed in the title

bar of the browser window. Change Page > Menu Title to Welcome. This will change the text in

the menu.

INFO: If the properties of the page are not visible after a single click on Start Page, you

have to click a second time on it.
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2: Quick Start Tutorial

Choose Preview from the toolbar on the top and see the result. The layout for computers and

tablets is done.

Creating Sub Pages
In the next step, the website has to be filled with content. In addition, we need a total of 3 sub

pages (including the start page).

Add a new sub page. Click on + on the bottom left and select Add page. A new page below the

start page will be created.

- 16 -



2: Quick Start Tutorial

Double click on the page name and rename the new page to blog. Again, the page must be filled

with the layout. Click on the new page.

Select the template Master Page in the properties at Page > Page Template. The background

color and page margins change  Immediately, to that you have chosen on the Master Page.

Now drag again template by template from the components to the page. At first the Navigation,

then Header, Main and the last one Footer. Change the Title in the properties to My Website -

Blog and the Menu Title to Blog.

It is simple to create the next new page. Select the page blog.htm and click on Duplicate on the

bottom. Change Title to My Website - Contact and Menu Title to Contact in the properties of the

new page.

An Animation on the Start Page
For the start page, we will build an animation. Click the start page and double click on the empty

main area on the page.

Drag three Picture items to the start page and select a picture from your computer at Picture >

Picture in the properties for each of the three items. Activate Picture > Shadow for all three

images to create a shadow effect. Drag the images smaller and arrange them side by side. With 

Item > Rotation, you can rotate the pictures a bit.
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2: Quick Start Tutorial

Place a Text item below the pictures for a link to the sub page with the blog. Change the text to 

Blog and choose center as the text format.

Select the complete text and enable Use as link. Click on Choose ... behind that the Link window

will be opened. Select at /blog.html at Internal Link to Page.

The three images should be swirled in when the page is loaded. Each of the images must be

named for that. Click on each image and change the name at Item > Identifier (Id) to Picture1, 

Picture2 and Picture3. Then drag an Animation item to the editor. Place it below the images. The 

Animation item itself is invisible on the finished website.
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2: Quick Start Tutorial

Click on Animation > Animation > Choose... in the properties and the window Animation will be

opened. Click on + in this window and add Picture1, Picture2 and Picture3 to the animation.

Change the animations to Drive in in the list. Change the Direction for the first image to Left, for

the second image to Right and for the third image to Top in the options on the right. Then, enable

clockwise or counterclockwise rotation for each animation.

The images should drive in with a delay. Because of this, enter 2, 3 and 4 seconds in the column

at Delay (Sec.). Click on OK when you are done and have a look the preview if you want.

Setting Up a Blog
A blog should be installed on the page blog.html, that you can fill with content from a login area in

the browser while on the move. Click on the page blog.html and click a second time on it, so that

only the page is selected.

Select the main area on the page (click it once in the editor) and delete it with the delete key.

Instead, drag a Blog area to the place where the main area has been deleted.
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2: Quick Start Tutorial

Choose Main as the Area Template In the properties of the Blog area. Change Padding Top to 40

and Padding Bottom to 20. So the blog entries have some space.

Contact Form and Terms & Conditions
There should be a contact form and the Terms & Conditions on the contact page. Go to the

Contact page and double click on the main area there.

Drag a Text item to the editor and fill it with a Terms & Conditions text. Then drag Form item to

the editor and place it next to the Terms & Conditions.

If your site visitors fill out the form and send it, the data will be sent via email to you. For this

purpose you have to enter your e-mail address in the form properties. Do this in the properties of

the form at E-Mail > E-Mail Address.
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2: Quick Start Tutorial

Creating the Layout for Smartphones
The website for computers and tablets is now done. But the view for smart phones is still missing.

Goldfish has already automatically created a start page for smartphones and a redirection. All

visitors with a smartphone will be automatically redirected to mobile/. The layout for Smartphones

has to be separated in sections too. When doing this similar areas as for the large website can be

used.

Create three new area templates for the layout for smartphones. To do this, duplicate the already

existing area template Mobile Area with Duplicate on the bottom left. You now have a total of four

area templates together with the template Mobile Area.

Rename each area template to Mobile Main, Mobile Navigation, Mobile Header and Mobile

Footer. In the next step you have to choose the correct settings for each area template.

Set the Height (min) to 50 and choose blue as the Background Color for the area template Mobile

Navigation. Choose the header background picture also for Mobile Header and set Repeat to Cut

to Fill. For this template the Height (min) should be 150. Set the Height (min) to 300 for the Mobile

Main template. For Mobile Footer, add a 3 pixel wide black border and set the Height (min) to 50.
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2: Quick Start Tutorial

Go to the page mobile (the start page for smartphones). Build layout  here by dragging the

missing area templates from the components to the page. That are from top to bottom Mobile

Navigation, Mobile Header, Mobile Main and Mobile Footer. Explore the result in the preview. The

basic layout is done. Now you have to create the menu,  headlines and copyright text.

Click on the area template Mobile Navigation and drag a Menu item to it. In its properties, select 

Drawer Menu (displays no subfolders) as Menu > Type. A drawer menu is compact and perfectly

suited for smartphones.
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2: Quick Start Tutorial

To display all sub pages below mobile/ in the drawer menu and not the normal website, you need

to select /mobile as Base Folder in the properties.

Now you have to adjust the look of the menu items. Choose again blue in the properties as the

background color at Main Menu Entry > Background Color. Choose exactly the same setting as in

the menu for the normal website for Moving Mouse Over Link Effekt and Clicking on Link Effect

(disable Change Background, Change Font to a white font color and bold).

Switch to the area template Header and choose Edit > Select All from the menu. The Text item

with the title and the subtitle will be selected. Now choose Edit > Copy from the menu and copy

both to the clipboard. Switch to the area template Mobile Header and paste both with Edit > Paste

. Arrange the text items so that they fit into the template.

Also copy the copyright information from the area template Footer to the area template Mobile

Footer. Click on to the page mobile and change the title to My Website - Welcome.
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2: Quick Start Tutorial

You can not change the menu title here, because it is disabled for mobile so that it does not

appear in the normal website menu. Select the next entry in the project list instead, the navigation

menu link mobile, and change the property Menu Title to Welcome there.

Go back to the page mobile and choose Preview from the toolbar at the top and see the result.

The layout for smartphones is complete.

Creating Sub Pages
You have to fill the website with content. In addition, we need a total of 3 sub pages (including 

mobile).

Select + on the bottom left, and choose Add Page. Drag the new page on mobile if it is not

already inside it. Select Mobile Page as Page Template and drag again the four area templates 

Mobile Navigation, Mobile Header, Mobile Main and Mobile Footer to it.

Duplicate this newly added page two times. Rename the two new pages to blog.html and 

contact.html, and change the properties Title and Menu Title according to the page names.
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2: Quick Start Tutorial

Copying the Contents
Go to the start page, double click on the main area and select all (Edit > Select All from the

menu). Copy the selection and paste it on the page mobile into the main area there. Now you

have to rearrange and resize the items there. Don't forget to change the link destination of the link

Blog to blog.html below mobile.

Copy all items from the main area of the page contact.html to the main area of contact.html of the

mobile website. Rearrange the Terms and Conditions and the contact form one below the other

instead of side by side.

Replace the main area on the page blog.html with a Blog area. Choose Main as the Area

Templatein the properties of the blog area.
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2: Quick Start Tutorial

Explore the finished mobile website in the preview. By clicking on the drawer menu, it will be

opened and you can move to a different page.

Publish the Website on the Internet
The finished website can be published on the Internet now. Choose Publish from the toolbar.

An error message will appear, because the admin password has not been set yet. Enter a

password, which is required for adding and editing blog entries on the go.
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2: Quick Start Tutorial

In the second error message, Goldfish asks for the internet address (URL) of the Web server,

under which the website will be accessible. You must enter the complete address, including http://

.

In the next window, the FTP login from your web server is required. Enter your login data

consisting of server, user name and password and click on OK.
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2: Quick Start Tutorial

Goldfish connects to the server and displays a folder list from the web server. Double click on a

folder to get in there. On many web servers, you have to navigate into the correct subfolder at

first, on other servers there are no sub folders or that is not necessary. Ask your web hosting

service for the correct sub folder.

Click on Publish if you are in the correct folder. Goldfish uploads your website to your web server

now. When the process is finished, you can visit the website immediately with a computer, tablet

or smartphone and test it.
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3. Upgrade Guide
Read how to switch to Goldfish 4. Transfer all old projects and websites. Learn what works

automatically and where you need to adjust things manually.

Each project created in Goldfish since version 1.0 and therefore every website created by

Goldfish, can be opened and be edited with Goldfish 4. When you publish the website, all items

such as galleries and forms will be automatically updated. An adjustment by hand is necessary

only in some cases.

INFO: Once in Goldfish 4 opened and then saved projects are not backward compatible.

This means, that you can no longer open and edit them in versions older than Goldfish 4.

So after importing the project, save it under a new name.

If you are using one of the following functions in your Goldfish site, you need to adjust the project

manually before you publish your website in Goldfish. 4

Audio & Video
Videos and audio files are exported now as HTML5 video and HTML5 audio. Plugins are no

longer supported. Therefore, select every multimedia object which you have created with Goldfish

1, 2 or 3. Audio & Video will be displayed in the properties now.

Embedded Video Files

From now, videos have to be in .mp4 (H.264) format. In addition, .ogv (Theora) and .webm are

also supported. Please note: the last two formats do not work in all browsers. Formats such as 

.mov (Quicktime) or .wmv (Windows Media) can not be used anymore. Convert all videos, that

are no longer compatible, into .mp4 or embed other videos with the object HTML Code.

Embedded Audio Files

Change in the properties Audio & Video > Type to HTML5 Audio. From now, audio files have to

be in .mp3, .aac or .wav format. In addition, .oga (Ogg Vorbis) and .webm are also supported.

Please note: the last two formats do not work in all browsers. Formats such as .wma (Windows
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3: Upgrade Guide

Media) can not be used anymore. Convert audio files, that are no longer compatible, into .mp3 or

embed other audio files with the item HTML Code.

Adobe Flash

Flash is no longer supported and should not used any more, because it can not be displayed on

smartphones and tablets. If you still want to embed flash objects, use the item HTML Code.

In many cases, you also need to adjust the size of the Audio & Video objects. Controls are now

displayed within the video area itself and do not require extra space. When you select a media file

in the properties under Audio & Video > Media File, the new required size is calculated

automatically.

Custom HTML Code
If you have embedded your own HTML code with the HTML Code item, you don't need to change

something. If you have added code snippets in Goldfish 3 Professional at Add code before

document, Add header HTML code, Add HTML code, Add stylesheets or Add CSS code you will

find these snippets in the new code view.

Select a page in which you have inserted custom HTML code. Then, click on Code in the toolbar

to open the code view.

If the red error message appears (see previous image), you will need to paste the HTML code

new at the correct position of the document. Click on the button Not automatically inserted HTML

code and copy the code snippets to the correct position of the HTML document. The newly

pasted code will be shown in red.

 Not automatically inserted HTML code
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3: Upgrade Guide

Comments and Guestbook
The item Comments is no longer available in Goldfish 4. Use the new area Guestbook instead.

Reserve a complete page for the new guestbook and replace there the main area with a 

Guestbook. Choose the main area of your project in the properties at Page Area > Area Template

.

INFO: All entries of the old item Comments will be automatically imported into the new

guestbook.

Pages and Textfields with RSS-Feeds
RSS feeds in pages and textfields are not supported by Goldfish 4 any more. Use instead the

new area Blog for distributing news.

You can edit the entries on your blog online in your browser. The website must not be updated

with Goldfish for that anymore. All entries of a blog are automatically published as RSS feed.

Reserve a complete page for the new Blog and replace the main area with a Blog. Select the

main area of your project in the properties at Page Area> Area Template.

Online Shop
Because of new e-commerce rules in the European Union the texts of the item Shopping Cart

have been updated and expanded. Drag an new Shopping Cart in your project to avoid changing

the texts  in your old Shopping Cart manually.

Replace with the new Shopping Cart the old one and configure it. Read in chapter Online Shop

about the new features of the Shopping Cart. It has changed a lot.

Retina Websites
Your imported website is not automatically published as Retina website. In Retina websites all

images are displayed in double resolution and appear extra sharp on Retina-Macs, smartphones

and tablets.
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3: Upgrade Guide

In the project's properties you can enable the delivery as Retina website. Click on the top left on

the tab Design. Then click on PROJECT and activate in the properties Create Retina Website

with High Resolution images.

INFO: All background images appear in half size on a retina website because they are

displayed in double resolition. The same applies to newly added pictures. All previously

added pictures remain as they are (except background images).

Mobile Websites
Goldfish 4 will not automatically add a view for smartphones to your imported website. If you want

to add a view for smartphones, create a new page and name it mobile. Enter 500 in the properties

as Page Width (min) and activate Create as Folder. In the next step, you have to redirect all site

visitors with a smartphone to the new page.

Click on the start page. Maybe also a second time so that the properties of the page are

displayed. Activate Redirection > Redirection and then click on Choose.... In the Link-Window

choose the page /mobile as link destination. Click on OK and choose at Redirection > Condition

the entry Device is Smartphone from the list.

Now all website visitors using a smart phone are redirected to the page /mobile. All visitors with a

tablet or a computer remain on the Start Page.
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With Other Apps than Goldfish Created Websites
Unfortunately, websites which are not created with Goldfish and Websites where the .gfp project

file is no longer available, can not be imported and edited further. Instead, create a new project

and paste the text and images of your old website into Goldfish, using drag and drop or copy and

paste.
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When you purchase goldfish, you will receive a license key. Learn how to register and

unlock all the features, so that Goldfish works without limitations.

If you work with the test version of Goldfish, you will see the following window on startup. Building

websites and publishing websites is deactivated. Please purchase the full version if you want to

build your website with Goldfish.

Click on Purchase License. This will lead you to our website where you can purchase Goldfish.

You can choose between Goldfish Standard and Goldfish Professional.

If you have purchased Goldfish, you will receive your serial via e-mail. Copy both, the name at 

Registered to and the serial, and paste it into the corresponding fields. Then click on Unlock.
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Goldfish works without limitations now. If you have entered a serial for an upgrade, Goldfish will

ask you for the serial of an earlier version, which you have purchased. Enter the old serial (if the

fields are not already filled) and click on OK.

If you have purchased Goldfish Standard, you can always upgrade to Goldfish Professional. Click

on Upgrade Goldfish 4 in the toolbar.

Click on Purchase License and buy a license for the upgrade to Goldfish Professional. The

unlocking process is exactly the same as for an upgrade from an earlier version.

INFO: If you bought Goldfish from the Mac App Store, these dialogs do not appear. You
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must reload the app from our website in order to perform an upgrade from a previous

version. Goldfish will automatically detect your license from the Mac App Store. An

upgrade from Goldfish 4 Standard to Goldfish 4 Professional is also possible via the App

Store.
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5. Project
Start a new Goldfish project and learn about everything that you can set in the project.

This is the first step when designing your website with Goldfish.

Click on New Goldfish Project or choose File > New... from the menu, to begin a new project and

with that a new website.

If you start a new project, you have to decide whether you want to use a pre-built design or if you

want to start with a blank layout. If you start with a pre-built design, you don't have to create the

layout of your website itself. With an empty layout, it will be a bit more to work, but the result is a

website with your own personal design ideas.

If you don't like the included pre-built designs, you can download more pre-built designs for free

from our website by clicking on More Designs. If you want to add a customized view for
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smartphones, enable Add page for mobile devices. For more information, read the chapter Mobile

Websites. Click on OK if you have made a selection.

The project window is divided into several different areas. The project list (left) contains all the

elements of your website such as pages (with the start page as the first page), page templates

and area templates (more on that later). In Editor (center), you can enter text and edit the content

of your website.

Below the editor there all available items, that you can drag to the editor. In the Properties (right)

you can view and edit all the properties of the current selection. Right now, the properties of the

start page are visible, because it is currently selected in the project list.

In the toolbar on the top you can switch between the Design view (currently selected), HTML

code view and a page preview view. Here, you can also publish the website on the Internet and

visit the published website. On the right side of the toolbar you will find several links to Fishbeam

Software and the help and documentation.

The Page Model of Goldfish
Goldfish creates websites in an innovative and unique way. There are flexible components

available such as pages, page areas, text boxes, or image items.
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A page is made up of 3 different levels. A page (gray) is the base. There are page areas (yellow)

on a page, that represent different areas of your website (header, footer, navigation, main area,

etc.). A page area contains items (green). Items represent the content of your website such as

images, films or text.

In order to build a planned layout, you must divide (cut) it into different page areas at first. In the

example above we have a header area (on the top), an area for the content of the page (in the

middle left), an area for the navigation (in the middle right) and a footer (on the bottom). For a

different layout you will need a different breakdown of the areas. Divide the layout always so in

areas that the main area with the main content stands as a single area for itself.

Page Templates and Area Templates
Usually the layout will be the same on every single page of your website. Titles, menus,

backgrounds or headers and footers will look consistently. Because of this, there are Page

templates and Area Templates in Goldfish. These contain all the elements that are consistently
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on all or several pages of your website.

Set up the width of your layout and the main background in page template Master Page. After

that, create for each single area an area template with desired size and with the desired

background. To create a new area template, click on + below the project list on the left and select 

Add Area Template.

INFO: For more information about how to create pages templates and how to fill the area

templates with content like menus and headlines, read the chapter Pages and Page

Templates.

Pages
If you have created the layout from page templates and area templates, you can create the pages

of your website.

The start page is the first page of your website and already exists. It will be displayed at first when

your website will be visited. Create more pages with + and Add Page on the bottom left. You can

reorder the pages in the list, or drag one into another to create subpages.

INFO: For more information about how to fill the new pages with your layout and content,
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read the chapter Pages and Page Templates.

The Project List
All area templates, page templates, pages, and other components will appear in the project list on

the left. Below the project list are several icons with that you can edit the components.

 Adds new components to the project.

 - Add Page adds a page to the website.

 - Add Page Template adds a page template to the website.

 - Add Area Template adds an area template to the website.

 - Add Navigation Menu Link adds a link that will appear in the menus. Place the link like a page

into the page structure of your website. A menu that displays the page structure, will display

the link to the location of your choice then.

 - Add External File... adds an alias (shortcut) of any file to your website. For example, this will be

needed for embedding script files that are required by custom HTML code.

 - Add External Folder... adds an alias (shortcut) of any folder to your website. For example, this

will be needed for embedding script files that are required by custom HTML code.

 Duplicates the selection of the project list.

Depending on the selection, a page (with subpages), a page template, a area template, a alias or

a navigation menu link.

 Deletes the selection of the project list.

Depending on the selection, a page (with subpages), a page template, a area template, a alias or

a navigation menu link.

 Disables the selected page (with subpages) of the project list.

Disabled pages will not be not published if you publish the website. You should use this feature if

you have added a page that is not yet ready for being published or if you want to take a page

temporary offline.

All elements of the project list (except of the start page) can and should be renamed. Do this, with

a double click in the name and you can enter a new name. Names of pages should describe the

content and can not contain spaces or special characters.
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Properties for the Project
These properties can be set for the project. Click on PROJECT on the top left (the Goldfish icon

will be displayed in the editor), to see the properties of the project.

Project > Page Info (Meta Tags)

Meta tags are used by older search engines to find your website. Here you can enter project-wide

meta tags. Project-wide meta tags appear on every page of your website. If you want to enter

Meta Tags for only a single page, you can use the property Page > Page Information (Meta Tags)

of a page.

Enter information about your website for search engines in the Page Info (Meta Tags) window.

 - Language specifies the language into which the application side on.

 - Author specifies the author of the page.

 - Publisher specifies the publisher of the page, usually the author himself.

 - Copyright specifies information about the copyright.
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 - Keywords specifies key words for search engines, from which the page can be found. Only a

few older search engines use this.

 - Title specifies the page title.

 - Description specifies a description of the page.

 - Audience specifies the target audience of the page.

 - Page Topic specifies the pages category of the page.

 - Add Page to Search Index instructs search engines to include the page into the search index. 

Default leaves the decision to the search engine.

 - Add Linked Pagesnstructs search engines to include the subpages and links into the search

index. Default leaves the decision to the search engine.

 - Update Entry in Search Index Every specifies how often the entry should be updated in the

search index.Default leaves the decision to the search engine.

 - Other Meta Tags is a field for other meta tags that are not directly supported by Goldfish. Enter

the HTML code of a meta tag here.

INFO: Page infos, that are specified in the project, will apply to all pages of the project. If

the info is specified in the Page Info window of a page, it will overwrite the page info of the

project.

Project > Page Address (URL)

Enter the absolute page URL of your website here. E.g. http://mydomain.com. This is required if

you are using a blog on your website and for the Visit button from the toolbar at the top.

Project > Favorite Icon

Here you can choose a Favicon for your website. A Favicon is a small graphic in the adressbar

(the Fishbeam website uses a small fish as Favicon). FavIcons must be windows .ico files to

show up in Internet Explorer. Firefox, Safari and the others accept .gif and .png as well.

Project > Homescreen-Icon (iOS)

Select a .png file, that will appear as an icon on the home screen, when the user saves your

website there. Ideally, the size should be 144 x 144 pixels (for Retina iPads). On all other devices,

the icon will automatically appear with a smaller size.

Project > Admin Password

The password is required if you want to edit a guestbook or a blog on your website.

Project > Embedded Media

Click on Choose... to see a list of all embedded media files of your project. All images, movies

and other files, that you use on your website are embedded in the project.
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In the list of this window you can change the name or description of a media file. Please note that

names can't be too long and can not contain spaces or special characters. The description will be

used by images as the text description for people with visual impairment and will be displayed in a

gallery. Because of this, choose a description that describes the content of the media file.

Project > Font Templates

You can use font templates to store font styles that you want to use regularly on your website.

Usually a website has only a few different font styles. Click on Choose... to open the font

templates window.

Here you can define the default font styles that will be used on your website. If you do not

explicitly set the font style for items, the default font styles are used.

 - Master Template sets the default style for normal text.
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 - Headline 1. Order sets the default style for headlines of 1. order.

 - Headline 2. Order sets the default style for headlines of 2. order.

 - Headline 3. Order sets the default style for headlines of 3. order.

 - Headline 4. Order sets the default style for headlines of 4. order.

 - Headline 5. Order sets the default style for headlines of 5. order.

 - Headline 6. Order sets the default style for headlines of 6. order.

 - Link Template sets the default style for links.

 - Moving Mouse over Links sets the default style for links while the user moves the mouse over

the link.

 - Clicking on Link sets the default style for links while the user clicks the link.

 - Already visited Links sets the default style for links that lead to already visited pages.

You can also create additional fonts templates if you use certain styles often. A template can be

selected in a Font Style window of an item. So you don't need to change the font style each time

there.

 Adds a new font template.

 Duplicates a selected font template.

 Delete a selected font template (not for default templates).

 Opens the editor for font styles and you can edit the selected font template.

Double click on a font template to rename it. For more information about how the font system in

Goldfish works, read the chapter Typography & Font Styles.

Project > Name of Index File

Usually the name of the file that will be loaded when site visitors view your website is index (+ file

extension). Change the name, if your web hosting service requires this.

Project > Name of Media Folder

Here you can change the name of the media folder for images, movies and other media. This is

necessary if you want to create a page with subpages in the site structure called media.

Project > Name of Support Folder

Here you can change the name of the support folder for scripts, and stylesheets. This is

necessary if you want to create a page with subpages in the site structure called support.

Project > Suffix of Code Files

Here you can change the file extension for code files. Usually the file extension .html. Some web

hosting services require a different file extension. Change the file extension also if you are using

Goldfish for developing web applications with PHP.
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Project > Text Encoding

Change the text encoding when special characters (ä, ©, ß...) are displayed incorrectly on your

website.

Project > JPEG Export Quality

Determines the quality of newly generated JPEG images. Lower quality ensures a smaller file

size.

Project > Create Retina Website with High Resolution Images

Enable this option to publish the Web site as a retina website. Please note that backgrounds and

newly inserted images are displayed in double resolution, but half the size.

Project > Use Short File Paths

Deletes the name of the index file from paths and links to pages with sub-pages. The path 

/products/index.html will become /products/. This looks better in the browser address bar, but

destroyed links when you open the page locally on your computer and don't visit on the Internet.

Stats > Include Stats Web App PRO

Adds a web app, that displays visitor stats from your website right on your smartphone, tablet or

computer.

To access the stats app, open a web browser and enter http://www.mywebsite.com/support/stats.

Use the address of your website, instead of http://www.mywebsite.com. If you have changed the

value at Name of Support Folder in the properties, use the new name instead of support. Add the

web app to your home screen for easier access.

Stats > Today

Text in the user interface for Today.
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Stats > This Month

Text in the user interface for This Month.

Stats > This Year

Text in the user interface for This Year.

Stats > Total

Text in the user interface for Total.

Stats > Total Format

Format in the user interface for totals. Use %1 as a placeholder for the value.

Stats > Time Format

Format in the user interface for the hour of the day. Use %1 as a placeholder for the value.

Stats > Day Format

Format in the user interface for the day of the month. Use %1 as a placeholder for the value.

Stats > Month Format

Format in the user interface for the month. Use %1 as a placeholder for the value.

Stats > Open Website

Text in the user interface for Open Website.

Google > Google Analytics

Google Analytics is a free service from Google. With Google Analytics you can obtain complete

and detailed usage statistics for your website. Google provides you with a Google Analytics

Tracker ID to identify your website. Paste this ID here in Goldfish. The ID will be provided in this

form: UA-XXXXXX-X. Click on the arrow behind the field, to go to the Google Analytics website

and sign up.

Google > Webmaster Tools

Google Webmaster Tools is a free service from Google. With Google Webmaster Tools you can

optimize your website for the Google search engine. Google provides you with a meta tag in this

form: meta name="verify-v1" content="xxxxxxxxxxxxxxxxxxxxxxx". Paste it here. Goldfish will

automatically cut out the Tracker ID. Click on the arrow behind the field, to go to the Google

Webmaster Tools website and sign up.

Typekit > Typekit Kit ID

Typekit is a service from Adobe that allows you to display fonts on the website that are not

installed on the computer of the site visitor. After registration you will receive a HTML code

snippet with your Typkit ID. Paste this code here. Goldfish will automatically cut out the Typekit

ID. Click on the arrow behind the field, to go to the Typekit website and sign up. Please read the
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chapter Typography & Font Styles to learn how to use Adobe Typekit.
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Separate your website into pages and subpages for better readability. Use page templates

for the layout of your website.

Every website is made of several pages, which are ordered hierarchically. All pages of your

project are listed in the project list on the left side of a project window.

The first page is the start page of your project (the world icon). This is the page which will be

loaded if the user enters your page address (e.g. http://www.fishbeam.com). All other pages are

sub pages of the start page.

INFO: For more information about how to create pages and subpages, read the chapter 

Project.

The Page Model of Goldfish
Goldfish creates websites in an innovative and unique way. There are flexible components

available such as pages, page areas, text boxes, or image items.
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A page is made up of 3 different levels. A page (gray) is the base. There are page areas (yellow)

on a page, that represent different areas of your website (header, footer, navigation, main area,

etc.). A page area contains items (green). Items represent the content of your website such as

images, films or text.

In order to build a planned layout, you must divide (cut) it into different page areas at first. In the

example above we have a header area (on the top), an area for the content of the page (in the

middle left), an area for the navigation (in the middle right) and a footer (on the bottom). For a

different layout you will need a different breakdown of the areas. Divide the layout always so in

areas that the main area with the main content stands as a single area for itself.

Page Templates
Typically, there is used an identical layout on each page. To avoid setting up page width, borders

and backgrounds for every single page again, use a Page Template instead.
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All pages templates are listed under the section PAGE TEMPLATES in the project list. By default,

Goldfish create one page template named Master Page. If you create a mobile website too,

Goldfish creates a second page template, named Mobile Page. Use these templates and create

new ones if needed.

INFO: For more information about how to create pages templates, read the chapter Project.

Set the background, the margins, the width and the alignment for your website in the page

template. If you create a new page, go to the properties and select a suitable template at Page >

Page Template. The layout of the page is now inherited from the page template.

Filling the Page with Page Areas
At first, a new page is blank. If you assign a page template, it will have already a background and

the correct dimensions.

In the next step, you have to fill the page with page areas and create the intended layout with

them, wich was cut into several areas. For this, drag the needed area templates, such as Header,

Main, Navigation or Footer, from the items to the page. You can reorder the areas on the page by

dragging them around.

INFO: For more information about how to create area templates and how to fill areas with

content, read the chapters Project and Areas and Area Templates.
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Properties for Pages and Page Templates
These properties can be set for a page or a page template. Select a page or a page template to

see its properties.

Page > Title

The title of the page. The title will be shown as caption of the browser window.

Page > Menu Title

The menu title will be displayed in all navigation menus, who contain a link to this page. Disable it

and the page is not shown at the menu.

Page > Menu Picture

The menu picture will be displayed in all navigation menus in addition to the title. Possible are 

JPEG, PNG, SVG and GIF images.

Page > Page Info (Meta Tags)

Meta tags are used by older search engines to find your website. You can enter for this page

specific Meta Tags. Page-specific meta tags only appear on the current page. If you want to set

project wide meta tags for all pages of your website, you can use the property Project > Page Info

(Meta Tags) of the project.
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Enter information about your website for search engines in the Page Info (Meta Tags) window.

 - Language specifies the language into which the application side on.

 - Author specifies the author of the page.

 - Publisher specifies the publisher of the page, usually the author himself.

 - Copyright specifies information about the copyright.

 - Keywords specifies key words for search engines, from which the page can be found. Only a

few older search engines use this.

 - Title specifies the page title.

 - Description specifies a description of the page.

 - Audience specifies the target audience of the page.

 - Page Topic specifies the pages category of the page.

 - Add Page to Search Index instructs search engines to include the page into the search index. 

Default leaves the decision to the search engine.

 - Add Linked Pagesnstructs search engines to include the subpages and links into the search

index. Default leaves the decision to the search engine.
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 - Update Entry in Search Index Every specifies how often the entry should be updated in the

search index.Default leaves the decision to the search engine.

 - Other Meta Tags is a field for other meta tags that are not directly supported by Goldfish. Enter

the HTML code of a meta tag here.

INFO: Page infos, that are specified in the project, will apply to all pages of the project. If

the info is specified in the Page Info window of a page, it will overwrite the page info of the

project.

Page > Page Template

Select a page template, if you want to overwrite the style of the page with a template. Note that all

style properties for this page are hidden, if a page template is selected, because the style will be

set in the template then.

Page > Page Width (min)

Sets the minimal width of the page (pixel). If the browser window is smaller, scrollbars will be

shown. The width of a page area must be smaller or the same like the page with. You can't set a

minimal heigt of the page, because the height will be calculated by the minimal height of all page

areas.

Page > Content Alignment

Choose the alignment of the content if the browser window is larger than Page Width (min).

Page > Margin Left

Sets an offset from the left side of the page content.

Page > Margin Right

Sets an offset from the right side of the page content.

Page > Margin Top

Sets an offset from the top side of the page content.

Page > Margin Bottom

Sets an offset from the bottom side of the page content.

Page > Background Color

Select a background color for the Page.

Page > Background Picture Clip

Select a background picture from the Fishbeam Clips (

http://www.fishbeam.com/en/goldfish/clips.php) library. This option is only available if you have

the Fishbeam Clips library installed.
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Page > Background Picture

Select a background picture for the Page. With Repeat, you can choose how the picture will be

displayed. On Retina websites the background picture will be displayed with double resolution,

but half the size (except SVG images).

Page > Repeat

Repeats the background picture.

 - Don't Repeat displays the picture only once.

 - Repeat tiles the picture over the entire space.

 - Repeat Horizontally tiles the image in a row.

 - Repeat Vertically tiles the image in a column.

 - Cut to Fill displays the image once over the entire space. Overlapping edges will be cropped.

Page > Position Horizontal

Sets the horizontal position of the background picture. If the picture will be repeated, it will be

placed once on the specified position and the remaining space on the left, on the right, above and

below will be filled.

Page > Position Vertical

Sets the vertical position of the background picture. If the picture will be repeated, it will be placed

once on the specified position and the remaining space on the left, on the right, above and below

will be filled.

Page > Fix relative to Browser window

The position of the background picture is calculated on the basis of the browser window. The

picture is pined to the window and will not move when scrolling. The picture can be hidden or only

parts are visible if it is outside of the visible space.

Page > Fix first row of Page Areas when scrolling

When scrolling, the first line of page areas will be pinned to the browser window and stays in the

visible range.

Page > Fix last row of Page Areas when scrolling

When scrolling, the last line of page areas will be pinned to the browser window and stays in the

visible range.

Page > Exclude page from search PRO

When searching the website with a Search Field item, the page will be ignored and does not

appear in the results. Read the chapter Search Field for more information.

Page > Disable HTML Output PRO

Creates a blank page without any content or html code. Use this option only if you want to write a

script that writes HTML code.
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Password Protection > Page has password protection PRO

Protects the page by a password. Only users who know the password and enter it correctly can

visit the page.

Enable Password Protection > Page has password protection to protect a single page and its

subpages with a password. After that, a box for entering the password appears, instead of the

page. Only if the page visitor enters the password, the page will be loaded.

INFO: The pictures and other data, which are used on a password protected page, are not

specifically protected and can be accessed with knowledge of the exact file name. The

password protection used PHP.

Password Protection > Passwort

Specify the password here, that will be required for accessing the page. A user management with

different passwords for individual users is not possible.

Password Protection > Font Style

Specifies the font style for the page to enter the password. Activate a checkbox to set a style

attribute and override the global Font Template of the project.

 - Font specifies the font. Please note that the font must be installed on the computer the website

visitor to get displayed.

 - Style sets the style. Choose between Bold, Italic, Underline and Strikethrough.

 - Size specifies the font size in pixels.

 - Color sets the font color.

Please read the chapter Typography & Font Styles for more information about Font Styles and

Font Templates.

Password Protection > Color for Errors

Choose the color for errors due to incorrect input.

Password Protection > Caption

Caption of the password field.
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Password Protection > OK Button

Caption of the OK button.

Password Protection > Back Button

Caption of the button to cancel the password input.

Redirection > Redirection

Enables automatic forwarding to another page if the specified conditions are complied.

With an automatic redirection, you can filter the site visitors according to predefined criteria and

redirect them to specific pages.

For example, redirect all site visitors with a smartphone to a special smartphone page while

visitors with a tablet or computer stay on the normal page. You can also set a redirection to a

localized website depending on the language of the site visitor.

Enable Redirection > Redirection in the properties of the page for a redirection and click on 

Choose... behind that. Choose a customized page like /mobile as the destination for the

redirection in the Link window.
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In the link window, you can determine where the link should lead to. There are several options to

choose from.

Internal Link to Page sets a link to one of the pages or sub pages in your project. Select the page

from the list. From the action list below, you can select an action on the page as the link target.

 - With No Action, the page loads quite normal and nothing special happens.

 - With Deactivate all Redirections the page will be loaded and all existing redirections will be

deactivated. For example, if the website visitor has a smartphone and the website has a

redirection to a mobile page, the redirection will not be executed.

 - With Start Animation "Animation Name" the page will be loaded and the selected animation will

be started.

 - With Jump to Item "Item Name" the page will be loaded and it will be scrolled to the selected

item as an anchor point. To let an item appear in the list, enter a name for the item at Item >

Identifier (Id) in the properties.

E-Mail-Address sets a link to an e-mail address. This opens the user's e-mail app, and a new

e-mail to the specified e-mail address will be opened.

File sets a link to a file that will displayed or download. For example, if you select a PDF

document, it will be displayed by clicking on the link. On the other hand, .zip files will be

downloaded into the user's Downloads folder.

Custom Link sets a link to another website or link target. For example, enter an external address,

such as http://www.fishbeam.com.

Enable Open link in new window and the link will be opened in a new window or a new tab. If the

link is a download link, the window or the tab remains empty because the file will be downloaded.

Click on OK if you have chosen the redirection link and the link window will be closed. Now you
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can specify the condition for that the redirection will be active.

Select the condition in the properties at Redirection > Condition, for that the redirection will be

active . There are many conditions to choose from regarding devices, systems or languages.

INFO: You can set up multiple redirections on one page. Then, the conditions are

sequentially tested from top to bottom and the first matching redirection will be used.

Redirection > Condition

Select the condition for which the redirection is active. If the condition matches, the visitor will be

redirected, otherwise not.

Mobilgeräte > Hide Browser controls

The browser navigation on iOS devices with forward and back buttons will not be displayed and

the website will look like an app. This will only work if the website has been stored on the home

screen previously.

Mobile Devices > Black Status Bar

The status bar (battery indicator, wifi, network, etc.) on iOS devices is black. This will only work if

the website has been stored on the home screen previously.

Mobile Devices > Deactivate Pinch and Zoom

The website can't be resized on mobile devices with the fingers.
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Create area templates for header, navigation, main content and footer and put them

together on the pages.

The Page Model of Goldfish
Goldfish creates websites in an innovative and unique way. There are flexible components

available such as pages, page areas, text boxes, or image items.

A page is made up of 3 different levels. A page (gray) is the base. There are page areas (yellow)

on a page, that represent different areas of your website (header, footer, navigation, main area,

etc.). A page area contains items (green). Items represent the content of your website such as

images, films or text.

In order to build a planned layout, you must divide (cut) it into different page areas at first. In the

example above we have a header area (on the top), an area for the content of the page (in the
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middle left), an area for the navigation (in the middle right) and a footer (on the bottom). For a

different layout you will need a different breakdown of the areas. Divide the layout always so in

areas that the main area with the main content stands as a single area for itself.

Area Templates
An area template is part of the layout of your website. All the area templates put together,

produce the entire layout. Goldfish creates by default already some area templates like Main or 

Mobile Area. Use this area templates or add new ones.

Create for each area an area template. To create a new area template, click on + on the bottom

left of the project list and select Add Area Template. After that, select the size and the background

for each area template so that it fits your layout.

INFO: For more information about how to create area templates, read the chapter Project.

Filling the Page with Page Areas
At first, a new page is blank. If you assign a page template, it will have already a background and

the correct dimensions.

In the next step, you have to fill the page with page areas and create the intended layout with

them, wich was cut into several areas. For this, drag the needed area templates, such as Header,

Main, Navigation or Footer, from the items to the page. You can reorder the areas on the page by

dragging them around.

 Deletes the selected page area.
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When you add page areas, the page will be filled line by line from top to bottom. There will fit so

many page areas in a row, as long as its width is smaller than the width of the page. If the row is

full, the page area will be shifted to the next row.

INFO: The height of all page areas is in a row will always be the same. The height of the

largest area of a row will be used for all areas in the row.

Adding Content like Text, Images or Menus
If you have created all the area templates, and you have filled all pages with them, the layout will

be complete, but it lacks the content. Content will be inserted as items that can be freely

positioned on the template areas, areas and slider areas.

Before adding items, think about where they should be inserted. All items that should be present

on multiple pages (logo, menu, text in the footer...) belong to the layout and should be placed on

the template areas. All items that are only present on one page (body text, contact form, gallery...)

should be placed directly on the page in the appropriate area.

 - Adding items to areas: Select a page and double click on the desired area in the editor.

 - Adding items to template areas: Select the desired area template from the project list.
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In both cases, a list of items, which you can drag to the area or to the area template, will be

shown below. Drag the desired item from the items to the editor.

INFO: If you have the Fishbeam Clip Collection (

http://www.fishbeam.com/en/goldfish/clips.php) installed, many more clip items are

available.

You can move items in front of and behind each other and you can place them with pixel

accuracy.

 - Resize: Drag an item larger or smaller. By holding down the Shift key, the aspect ratio will be

retained.

 - Forward or backward: Select Arrange > Bring Forward, Arrange > Bring to Front, Arrange >

Send Backward or Arrange > Send to Back from the menu to arrange the selected items while

overlapping to the foreground or to the background.

 - Group: Select several items and select Arrange > Groupfrom the menu to create a grouping.

 - Lock: Select Arrange >Lock and the selected items are pinned. This means they are protected

against accidental displacement.

 - Positioning: Select Arrange > Align Objects or Arrange > Distribute Objects from the menu to

reposition the selected items in the center or evenly.

INFO: Click on an item while pressing the Shift key, and it will be added to or removed

from the selection.

Properties for Areas and Area Templates
These properties can be set for a page area or an area template. Select a page area or an area

template to see its properties.

Page Area >  Identifier (Id)

Specifies the name of the area in order to address it in animations or as a link target. Use only
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letters and numbers for the name, no spaces or special characters.

Page Area > Area Template

Select an area template, if you want to overwrite the style of the page area with a template. Note

that all style properties for this page area are hidden, if an area template is selected, because the

style is controlled by the template.

Page Area > Width

Sets the width of the page area (pixel). The width of a page area must be smaller or the same like

the page with.

Page Area > Height (min)

Sets the minimal height of the page area (pixel). The real height is calculated by the height of the

content and the height of other page areas in the same row.

Page Area > Margin Left

Sets an offset from the left side of the page area content.

Page Area > Margin Right

Sets an offset from the left side of the page area content.

Page Area > Margin Top

Sets an offset from the top side of the page area content.

Page Area > Margin Bottom

Sets an offset from the left side of the page area content.

Page Area > Background Color

Select a background color for the page area.

Page Area > Background Picture Clip

Select a background picture from the Fishbeam Clips (

http://www.fishbeam.com/en/goldfish/clips.php) library. This option is only available if you have

the Fishbeam Clips library installed.

Page Area > Background Picture

Select a background picture for the page area. With Repeat, you can choose how the picture will

be displayed. On Retina websites the background picture will be displayed with double resolution,

but half the size (except SVG images).

Page Area > Repeat

Repeats the background picture.

 - Don't Repeat displays the picture only once.

 - Repeat tiles the picture over the entire space.
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 - Repeat Horizontally tiles the image in a row.

 - Repeat Vertically tiles the image in a column.

 - Cut to Fill displays the image once over the entire space. Overlapping edges will be cropped.

Page Area > Position Horizontal

Sets the horizontal position of the background picture. If the picture will be repeated, it will be

placed once on the specified position and the remaining space on the left, on the right, above and

below will be filled.

Page Area > Position Vertical

Sets the vertical position of the background picture. If the picture will be repeated, it will be placed

once on the specified position and the remaining space on the left, on the right, above and below

will be filled.

Page Area > Fix relative to Browser window

The position of the background picture is calculated on the basis of the browser window. The

picture is pined to the window and will not move when scrolling. The picture can be hidden or only

parts are visible if it is outside of the visible space.

Page Area > Stretch background to border

If there is free space on the left or on the right of the page, the background will be extended to the

edge of the browser window. This allows you to create a widescreen layout without visible

borders.

Page Area > Border Left Width

Displays a border on the left side of the page area in the choosen width (pixels).

Page Area > Border Left Color

Select a color for the left border.

Page Area > Border Right Width

Displays a border on the right side of the page area in the choosen width (pixels).

Page Area > Border Right Color

Select a color for the right border.

Page Area > Border Top Width

Displays a border on the top side of the page area in the choosen width (pixels).

Page Area > Border Top Color

Select a color for the top border.
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Page Area > Border Bottom Width

Displays a border on the bottom side of the page area in the choosen width (pixels).

Page Area > Border Bottom Color

Select a color for the bottom border.

Content > Edit Content

Edit the content of the page area and add images, text or other content.
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Several areas for sliding through. This works with a slider area that you can drag from the

items to the website.

You can add a slider area to every page. To add a slider area, edit the content of a page  and

drag the slider area from the items to the editor.

A slider area is like a normal page area, with the difference that you can store items on several

slides. Site visitors can switch between the slides by clicking the forward- oder back-arrow. You

can drag items to the editor for filling the slider area, like you can do for filling normal page areas.

You can move items in front of and behind each other and you can place them with pixel

accuracy.

 - Resize: Drag an item larger or smaller. By holding down the Shift key, the aspect ratio will be

retained.

 - Forward or backward: Select Arrange > Bring Forward, Arrange > Bring to Front, Arrange >

Send Backward or Arrange > Send to Back from the menu to arrange the selected items while

overlapping to the foreground or to the background.

 - Group: Select several items and select Arrange > Groupfrom the menu to create a grouping.

 - Lock: Select Arrange >Lock and the selected items are pinned. This means they are protected

against accidental displacement.

 - Positioning: Select Arrange > Align Objects or Arrange > Distribute Objects from the menu to

reposition the selected items in the center or evenly.

INFO: Click on an item while pressing the Shift key, and it will be added to or removed

from the selection.
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After you have filled a slide with items, click on the forward-arrow to move to the next slide. There

you can place other items.

Animation when Switching Between Slides
By default, the slides drive out to the left or to the right. But you can also set a different animation.

To do this, change Slider > Transition Animation in the properties.

 - Drive Out Left: The items are moved out left or right.

 - Drive Out Top: The items are moved out top or bottom.

 - Drive Out Right: The opposite of Drive Out Left. The objects are moved out right or left.

 - Drive Out Bottom: The opposite of Drive Out Top. The object are moved out bottom or top.

 - Fade: When changing the slides they are faded

Slideshow
The slides can also be automatically changed after a sheduled time. For this, activate Slider >

Next slide after ... Seconds in the properties and enter a time period in seconds.

If you disable also the controls you have a self-running slideshow, in which you can use items

instead of only pictures.

Properties for Slider Areas
These properties can be set for a slider area. Select a slider area to see its properties.

Page Area >  Identifier (Id)

Specifies the name of the area in order to address it in animations or as a link target. Use only

letters and numbers for the name, no spaces or special characters.

Page Area > Area Template

Select an area template, if you want to overwrite the style of the page area with a template. Note

that all style properties for this page area are hidden, if an area template is selected, because the

style is controlled by the template.
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Page Area > Width

Sets the width of the page area (pixel). The width of a page area must be smaller or the same like

the page with.

Page Area > Height (min)

Sets the minimal height of the page area (pixel). The real height is calculated by the height of the

content and the height of other page areas in the same row.

Page Area > Margin Left

Sets an offset from the left side of the page area content.

Page Area > Margin Right

Sets an offset from the left side of the page area content.

Page Area > Margin Top

Sets an offset from the top side of the page area content.

Page Area > Margin Bottom

Sets an offset from the left side of the page area content.

Page Area > Background Color

Select a background color for the page area.

Page Area > Background Picture Clip

Select a background picture from the Fishbeam Clips (

http://www.fishbeam.com/en/goldfish/clips.php) library. This option is only available if you have

the Fishbeam Clips library installed.

Page Area > Background Picture

Select a background picture for the page area. With Repeat, you can choose how the picture will

be displayed. On Retina websites the background picture will be displayed with double resolution,

but half the size (except SVG images).

Page Area > Repeat

Repeats the background picture.

 - Don't Repeat displays the picture only once.

 - Repeat tiles the picture over the entire space.

 - Repeat Horizontally tiles the image in a row.

 - Repeat Vertically tiles the image in a column.

 - Cut to Fill displays the image once over the entire space. Overlapping edges will be cropped.

Page Area > Position Horizontal

Sets the horizontal position of the background picture. If the picture will be repeated, it will be
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placed once on the specified position and the remaining space on the left, on the right, above and

below will be filled.

Page Area > Position Vertical

Sets the vertical position of the background picture. If the picture will be repeated, it will be placed

once on the specified position and the remaining space on the left, on the right, above and below

will be filled.

Page Area > Fix relative to Browser window

The position of the background picture is calculated on the basis of the browser window. The

picture is pined to the window and will not move when scrolling. The picture can be hidden or only

parts are visible if it is outside of the visible space.

Page Area > Stretch background to border

If there is free space on the left or on the right of the page, the background will be extended to the

edge of the browser window. This allows you to create a widescreen layout without visible

borders.

Page Area > Border Left Width

Displays a border on the left side of the page area in the choosen width (pixels).

Page Area > Border Left Color

Select a color for the left border.

Page Area > Border Right Width

Displays a border on the right side of the page area in the choosen width (pixels).

Page Area > Border Right Color

Select a color for the right border.

Page Area > Border Top Width

Displays a border on the top side of the page area in the choosen width (pixels).

Page Area > Border Top Color

Select a color for the top border.

Page Area > Border Bottom Width

Displays a border on the bottom side of the page area in the choosen width (pixels).

Page Area > Border Bottom Color

Select a color for the bottom border.
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Content > Edit Content

Edit the sidearea's content and add items like images, texts or menus.

Slider > Transition Animation

Choose the animation during the transition between two slides. Be available:

 - Drive Out Left The objects are moved out left or right.

 - Drive Out Top The object are moved out top or bottom.

 - Drive Out Right Conversely as Drive Out Left. The objects are moved out right or left.

 - Drive Out Bottom Conversely as Drive Out Top. The object are moved out bottom or top.

 - Fade When changing the slides they are faded.

Slider > Show Controls

Determines whether the buttons to switch between the slides are displayed. If not, slides can only

be displayed with an automatic change.

Slider > Hide Controls Automatically

Fades in the buttons to switch between slides only when the page visitor moves the mouse over

the area or tapping it with a finger.

Slider > Custom Button Picture Left

Choose your your own button picture, if you do not like the standard back-button.

Visual Effects
You can specify a visual effect, if the user interacts with the back-button (e.g., replace the picture

if the visitor moves the mouse over the button). The following properties are the same for Moving

Mouse Over Link Effect and Clicking On Link Effect.

Effect > Change Picture

Changes the picture. Select a picture to which you want to change.

Properties for Slider Areas

Slider > Custom Button Picture Right

Choose your your own button picture, if you do not like the standard forward-button.

Visual Effects
You can specify a visual effect, if the user interacts with the forward-button (e.g., replace the

picture if the visitor moves the mouse over the button). The following properties are the same for 

Moving Mouse Over Link Effect and Clicking On Link Effect.

Effect > Change Picture

Changes the picture. Select a picture to which you want to change.
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Properties for Slider Areas

Slider > Next slide after ... Seconds

The next slide is displayed automatically after the specified time in seconds.

Slider > Show pages as circles on the bottom

Shows the number of slides on the bottom as circles. By clicking on a circle the user can skip to

the corresponding slide.

Slider > Circle Color

Sets the color of the circles.
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A blog or CMS, allowing you to publish content without using Goldfish. This works with a

blog area, that you can drag from the items to the website.

You can add a blog area to every page. To add a blog area, edit the content of a page and drag a

blog area from the items to the editor.

You can log directly in a blog area on the website and you can publish new entries without taking

a detour via Goldfish. With this, you can easily publish news on the go.

First set the password to edit the blog entries. The password is defined in the project and applies

to all login areas of your website. Click on PROJECT on the top left and enter a password at 

Project >Admin Password in the properties.

By default, a blog area shows a big button to log in on the website. If you want to hide the login

button, disable Blog > Show login button to edit blog entries in the properties. After that, add the

term ?admin=1 to the page address for logging in.

INFO: Add the page address with the suffix ?admin=1 to your favorites. Then you have

easy access to the login.

Editing of Blog Entries on the Website
At first, login on your website, using the administrator password. Then the following features will

be available.

 Edit Blog shows a password field to log into your blog.

 New Entry adds a new blog entry.

 Logout log off from the blog. The entries can not be edited any longer.
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Click on + to add a new blog entry. Empty fields with a placeholder text, that you can fill, will

appear.

 - Headline sets the headline for the blog entry.

 - Teaser sets a short description for the blog entry.

 - Blog sets the text of the blog entry.

 - Category sets the category for the entry. Use the same category for more than one entry to

mark them as associated.

 - Date sets the date of the blog entry.

You can enter rich text with pictures and links into the Blog field. For this, the following features

appear if you edit the text:

 Bold makes the selected text bold.

 Italic makes the selected text italic.

 Underline mmakes the selected text underlined.

 Strike makes the selected text strike-through.

 Left sets the selected paragraph to the left.

 Center sets the selected paragraph centered.

 Right sets the selected paragraph to the right.

 Justify sets the marked paragraph justified.

 Unordered List generates a bulleted list.

 Ordered List creates a numbered list.

 Picture inserts a picture from your computer.

 Link inserts a link.

After editing the blog entry, you still need to save it so that it appears on the blog.
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 Save Entry

 Delete Entry

If you have logged into your blog, you can also delete user comments. Go to the page with a

comment that you want to delete.

Click on the small X icon behind the comment and confirm the following question with OK.

Using the Blog Area as a CMS
In addition, you can use the blog area as a small Content Management System. In this case, you

do not need the subpages, the categories, the date field, the comments, the RSS feed and the

teaser text.

Go to the properties of the blog area and disable Blog > Show subpages, category and date, Blog

> Allow comments, Blog > Provide entries as RSS-Feed and Blog > Use teaser text.

Properties for Blog Areas
These properties can be set for a blog area. Select a blog area to see its properties.

Page Area >  Identifier (Id)

Specifies the name of the area in order to address it in animations or as a link target. Use only

letters and numbers for the name, no spaces or special characters.

Page Area > Area Template

Select an area template, if you want to overwrite the style of the page area with a template. Note

that all style properties for this page area are hidden, if an area template is selected, because the

style is controlled by the template.

Page Area > Width

Sets the width of the page area (pixel). The width of a page area must be smaller or the same like

the page with.
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Page Area > Height (min)

Sets the minimal height of the page area (pixel). The real height is calculated by the height of the

content and the height of other page areas in the same row.

Page Area > Margin Left

Sets an offset from the left side of the page area content.

Page Area > Margin Right

Sets an offset from the left side of the page area content.

Page Area > Margin Top

Sets an offset from the top side of the page area content.

Page Area > Margin Bottom

Sets an offset from the left side of the page area content.

Page Area > Background Color

Select a background color for the page area.

Page Area > Background Picture Clip

Select a background picture from the Fishbeam Clips (

http://www.fishbeam.com/en/goldfish/clips.php) library. This option is only available if you have

the Fishbeam Clips library installed.

Page Area > Background Picture

Select a background picture for the page area. With Repeat, you can choose how the picture will

be displayed. On Retina websites the background picture will be displayed with double resolution,

but half the size (except SVG images).

Page Area > Repeat

Repeats the background picture.

 - Don't Repeat displays the picture only once.

 - Repeat tiles the picture over the entire space.

 - Repeat Horizontally tiles the image in a row.

 - Repeat Vertically tiles the image in a column.

 - Cut to Fill displays the image once over the entire space. Overlapping edges will be cropped.

Page Area > Position Horizontal

Sets the horizontal position of the background picture. If the picture will be repeated, it will be

placed once on the specified position and the remaining space on the left, on the right, above and

below will be filled.
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Page Area > Position Vertical

Sets the vertical position of the background picture. If the picture will be repeated, it will be placed

once on the specified position and the remaining space on the left, on the right, above and below

will be filled.

Page Area > Fix relative to Browser window

The position of the background picture is calculated on the basis of the browser window. The

picture is pined to the window and will not move when scrolling. The picture can be hidden or only

parts are visible if it is outside of the visible space.

Page Area > Stretch background to border

If there is free space on the left or on the right of the page, the background will be extended to the

edge of the browser window. This allows you to create a widescreen layout without visible

borders.

Page Area > Border Left Width

Displays a border on the left side of the page area in the choosen width (pixels).

Page Area > Border Left Color

Select a color for the left border.

Page Area > Border Right Width

Displays a border on the right side of the page area in the choosen width (pixels).

Page Area > Border Right Color

Select a color for the right border.

Page Area > Border Top Width

Displays a border on the top side of the page area in the choosen width (pixels).

Page Area > Border Top Color

Select a color for the top border.

Page Area > Border Bottom Width

Displays a border on the bottom side of the page area in the choosen width (pixels).

Page Area > Border Bottom Color

Select a color for the bottom border.

Blog > Padding Left

Sets the distance from the left side of of the blog to the content in pixels.
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Blog > Padding Right

Sets the distance from the right side of of the blog to the content in pixels.

Blog > Padding Top

Sets the distance from the top side of of the blog to the content in pixels.

Blog > Padding Bottom

Sets the distance from the bottom side of of the blog to the content in pixels.

Blog > Name

Name of the blog (used in the RSS feed)

Blog > Description

Description of the blog (used in the RSS feed)

Blog > Data Source

Sets the name of the storage location for data. All blog areas with the same data source show the

same content.

Blog > Number of shown entries

Number of shown entries. More entries appear after a click on Load More Entries.

Blog > Number of shown entries in the RSS Feed

Number of shown entries in the RSS Feed.

Blog > Max width of pictures

Maximum width of pictures in blog entries. Larger pictures will be scaled down.

Blog > Max height of pictures

Maximum height of pictures in blog entries. Larger pictures will be scaled down.

Blog > Show Login Button to edit blog entries

Shows a button to edit the blog entries. If disabled, you have to log in by adding the suffix 

?admin=1 to the page address.

Blog > Show subpages, categories and date

Uses subpages, a field for categories and a date field in the entries. Disable this feature and the

blog can be used as a CMS.

Blog > Allow comments

Allows readers to post comments below a blog entry.
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Blog > Allow answers for comments

Allows users to answer to comments.

Blog > Provide entries as RSS-Feed

Provides the entries of the blog in a RSS feed for newsreader apps.

Blog > Use teaser text

Shows a field for a quick summary of your blog entry. This is used by the RSS feed.

User Interface > Font Style

The font style for blog entries. Activate a checkbox to set a style attribute and override the global

Font Template of the project.

 - Font specifies the font. Please note that the font must be installed on the computer the website

visitor to get displayed.

 - Style sets the style. Choose between Bold, Italic, Underline and Strikethrough.

 - Size specifies the font size in pixels.

 - Color sets the font color.

Please read the chapter Typography & Font Styles for more information about Font Styles and

Font Templates.

User Interface > Teaser Font Style

The font style for teasers, that are also links to the subpage of a blog entry. Activate a checkbox

to set a style attribute and override the global Font Template of the project.

 - Font specifies the font. Please note that the font must be installed on the computer the website

visitor to get displayed.

 - Style sets the style. Choose between Bold, Italic, Underline and Strikethrough.

 - Size specifies the font size in pixels.

 - Color sets the font color.

Please read the chapter Typography & Font Styles for more information about Font Styles and

Font Templates.

User Interface > Published in ... on ....

Text in the user interface for Published in ... on ....

User Interface > Published on ....

Text in the user interface for Published on ....

User Interface > ... on ...

Text in the user interface for ... on ...

User Interface > New Entry

Text in the user interface for New Entry
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User Interface > Edit Entry

Text in the user interface for Edit Entry

User Interface > Delete Entry

Text in the user interface for Delete Entry

User Interface > Save Entry

Text in the user interface for Save Entry

User Interface > Edit Blog

Text in the user interface for Edit Blog

User Interface > Logout

Text in the user interface for Logout

User Interface > 1 Comment

Text in the user interface for 1 Comment

User Interface > ... Comments

Text in the user interface for ... Comments

User Interface > Post Comment

Text in the user interface for Post Comment

User Interface > Answer

Text in the user interface for Answer

User Interface > Delete Comment

Text in the user interface for Delete Comment

User Interface > Load More Entries

Text in the user interface for Load More Entries

User Interface > Name *

Text in the user interface for Name *

User Interface > E-Mail Address *

Text in the user interface for E-Mail Address *

User Interface > Comment *

Text in the user interface for Comment *
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User Interface > Error Message

Text in the user interface for An error occurred (...)

User Interface > Delete Question for Entries

Text in the user interface for Do you really want to delete this entry?

User Interface > Delete Question for Comments

Text in the user interface for Do you really want to delete this comment?

User Interface > Link Address

Text in the user interface for Please enter a link address.

User Interface > Bold

Text in the user interface for Bold

User Interface > Italic

Text in the user interface for Italic

User Interface > Underline

Text in the user interface for Underline

User Interface > Strike

Text in the user interface for Strike

User Interface > Left

Text in the user interface for Left

User Interface > Center

Text in the user interface for Center

User Interface > Right

Text in the user interface for Right

User Interface > Justify

Text in the user interface for Justify

User Interface > Unordered List

Text in the user interface for Unordered List

User Interface > Ordered List

Text in the user interface for Ordered List
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User Interface > Picture

Text in the user interface for Picture

User Interface > Link

Text in the user interface for Link

User Interface > Blog

Text in the user interface for Blog

User Interface > Headline

Text in the user interface for Headline

User Interface > Teaser

Text in the user interface for Teaser

User Interface > Category

Text in the user interface for Category

User Interface > Date

Text in the user interface for Date

User Interface > Date Format

Date format in the user interface (PHP formatted).

Link Style > Font Style

Specifies the font style for links. Activate a checkbox to set a style attribute and override the

global Font Template of the project.

 - Font specifies the font. Please note that the font must be installed on the computer the website

visitor to get displayed.

 - Style sets the style. Choose between Bold, Italic, Underline and Strikethrough.

 - Size specifies the font size in pixels.

 - Color sets the font color.

Please read the chapter Typography & Font Styles for more information about Font Styles and

Font Templates.

Visual Effects
You can specify a visual effect, if a website visitor interacts with a link (e.g. change the color if the

visitor moves the mouse over the link). The following properties are the same for Moving Mouse

Over Link Effect, Clicking on Link Effect and Already Visited Link Effect.

Effect > Change Font

Changes the font style of a link.
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Effect > Font Style

Specifies the font style, to which you want to change. Activate a checkbox to set a style attribute

and override the global Font Template of the project.

 - Font specifies the font. Please note that the font must be installed on the computer the website

visitor to get displayed.

 - Style sets the style. Choose between Bold, Italic, Underline and Strikethrough.

 - Size specifies the font size in pixels.

 - Color sets the font color.

Please read the chapter Typography & Font Styles for more information about Font Styles and

Font Templates.

Properties for Blog Areas

Headline Link Style > Font Style

Specifies the font style for the teaser, which also acts as a link to the subpage of a blog entry.

Activate a checkbox to set a style attribute and override the global Font Template of the project.

 - Font specifies the font. Please note that the font must be installed on the computer the website

visitor to get displayed.

 - Style sets the style. Choose between Bold, Italic, Underline and Strikethrough.

 - Size specifies the font size in pixels.

 - Color sets the font color.

Please read the chapter Typography & Font Styles for more information about Font Styles and

Font Templates.

Visual Effects
You can specify a visual effect, if a website visitor interacts with a link (e.g. change the color if the

visitor moves the mouse over the link). The following properties are the same for Moving Mouse

Over Link Effect, Clicking on Link Effect and Already Visited Link Effect.

Effect > Change Font

Changes the font style of a link.

Effect > Font Style

Specifies the font style, to which you want to change. Activate a checkbox to set a style attribute

and override the global Font Template of the project.

 - Font specifies the font. Please note that the font must be installed on the computer the website

visitor to get displayed.

 - Style sets the style. Choose between Bold, Italic, Underline and Strikethrough.

 - Size specifies the font size in pixels.

 - Color sets the font color.

Please read the chapter Typography & Font Styles for more information about Font Styles and

Font Templates.
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A guestbook in which your site visitors can write comments. This works with a guestbook

area, that you can drag from the items to the website.

You can add a guestbook area to every page. To add a guestbook area, edit the content of a

page and drag a guestbook area from the items to the editor.

Visitors of your website can write messages and post comments in a guestbook area on your

website.

First set the password to delete the guestbook entries. The password is defined in the project and

applies to all login areas of your website. Click on PROJECT on the top left and enter a password

at Project >Admin Password in the properties.

By default, a guestbook area shows a big button to log in on the website. If you want to hide the

login button, disable Guestbook > Show login button to edit guestbook entries in the properties.

After that, add the term ?admin=1 to the page address for logging in.

INFO: Add the page address with the suffix ?admin=1 to your favorites. Then you have

easy access to the login.

Deleting Guestbook Entries
If you have logged into your guestbook, you can delete particular entries, that you don't want to

have in your guestbook.
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Click on the small X icon behind the entry and confirm the following question with OK.

Properties for Guestbook Areas
These properties can be set for a guestbook area. Select a guestbook area to see its properties.

Page Area >  Identifier (Id)

Specifies the name of the area in order to address it in animations or as a link target. Use only

letters and numbers for the name, no spaces or special characters.

Page Area > Area Template

Select an area template, if you want to overwrite the style of the page area with a template. Note

that all style properties for this page area are hidden, if an area template is selected, because the

style is controlled by the template.

Page Area > Width

Sets the width of the page area (pixel). The width of a page area must be smaller or the same like

the page with.

Page Area > Height (min)

Sets the minimal height of the page area (pixel). The real height is calculated by the height of the

content and the height of other page areas in the same row.

Page Area > Margin Left

Sets an offset from the left side of the page area content.

Page Area > Margin Right

Sets an offset from the left side of the page area content.

Page Area > Margin Top

Sets an offset from the top side of the page area content.

Page Area > Margin Bottom

Sets an offset from the left side of the page area content.

Page Area > Background Color

Select a background color for the page area.

Page Area > Background Picture Clip

Select a background picture from the Fishbeam Clips (

http://www.fishbeam.com/en/goldfish/clips.php) library. This option is only available if you have

the Fishbeam Clips library installed.
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Page Area > Background Picture

Select a background picture for the page area. With Repeat, you can choose how the picture will

be displayed. On Retina websites the background picture will be displayed with double resolution,

but half the size (except SVG images).

Page Area > Repeat

Repeats the background picture.

 - Don't Repeat displays the picture only once.

 - Repeat tiles the picture over the entire space.

 - Repeat Horizontally tiles the image in a row.

 - Repeat Vertically tiles the image in a column.

 - Cut to Fill displays the image once over the entire space. Overlapping edges will be cropped.

Page Area > Position Horizontal

Sets the horizontal position of the background picture. If the picture will be repeated, it will be

placed once on the specified position and the remaining space on the left, on the right, above and

below will be filled.

Page Area > Position Vertical

Sets the vertical position of the background picture. If the picture will be repeated, it will be placed

once on the specified position and the remaining space on the left, on the right, above and below

will be filled.

Page Area > Fix relative to Browser window

The position of the background picture is calculated on the basis of the browser window. The

picture is pined to the window and will not move when scrolling. The picture can be hidden or only

parts are visible if it is outside of the visible space.

Page Area > Stretch background to border

If there is free space on the left or on the right of the page, the background will be extended to the

edge of the browser window. This allows you to create a widescreen layout without visible

borders.

Page Area > Border Left Width

Displays a border on the left side of the page area in the choosen width (pixels).

Page Area > Border Left Color

Select a color for the left border.

Page Area > Border Right Width

Displays a border on the right side of the page area in the choosen width (pixels).
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Page Area > Border Right Color

Select a color for the right border.

Page Area > Border Top Width

Displays a border on the top side of the page area in the choosen width (pixels).

Page Area > Border Top Color

Select a color for the top border.

Page Area > Border Bottom Width

Displays a border on the bottom side of the page area in the choosen width (pixels).

Page Area > Border Bottom Color

Select a color for the bottom border.

Guestbook > Padding Left

Sets the distance from the left side of of the Guestbook to the content in pixels.

Guestbook > Padding Right

Sets the distance from the right side of of the Guestbook to the content in pixels.

Guestbook > Padding Top

Sets the distance from the top side of of the Guestbook to the content in pixels.

Guestbook > Padding Bottom

Sets the distance from the bottom side of of the Guestbook to the content in pixels.

Guestbook > Data Source

Sets the name of the storage location for data. All guestbook areas with the same data source

show the same content.

Guestbook > Show Login Button to edit guestbook entries

Shows a button to edit the guestbook entries. If disabled, you have to log in by adding the suffix 

?admin=1 to the page address.

Guestbook > Allow answers for guestbook entries

Allows users to answer to guestbook entries.

User Interface > Font Style

The font style for guestbook entries. Activate a checkbox to set a style attribute and override the

global Font Template of the project.

 - Font specifies the font. Please note that the font must be installed on the computer the website

visitor to get displayed.

 - Style sets the style. Choose between Bold, Italic, Underline and Strikethrough.
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 - Size specifies the font size in pixels.

 - Color sets the font color.

Please read the chapter Typography & Font Styles for more information about Font Styles and

Font Templates.

User Interface > Edit Guestbook

Text in the user interface for Edit Guestbook

User Interface > Logout

Text in the user interface for Logout

User Interface > Send Guestbook Entry

Text in the user interface for Send Guestbook Entry

User Interface > Answer

Text in the user interface for Answer

User Interface > Delete Guestbook Entry

Text in the user interface for Delete Guestbook Entry

User Interface > Name *

Text in the user interface for Name *

User Interface > E-Mail Address *

Text in the user interface for E-Mail Address *

User Interface > Comment *

Text in the user interface for Comment *

User Interface > Error Message

Text in the user interface for An error occurred (...).

User Interface > Delete Question for Guestbook Entries

Text in the user interface for Do you really want to delete this guestbook entry?

User Interface > ... on ...

Text in the user interface for ... on ...

User Interface > Date Format

Date format in the user interface (PHP formatted).

Link Style > Font Style

Specifies the font style for links. Activate a checkbox to set a style attribute and override the

global Font Template of the project.
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 - Font specifies the font. Please note that the font must be installed on the computer the website

visitor to get displayed.

 - Style sets the style. Choose between Bold, Italic, Underline and Strikethrough.

 - Size specifies the font size in pixels.

 - Color sets the font color.

Please read the chapter Typography & Font Styles for more information about Font Styles and

Font Templates.

Visual Effects
You can specify a visual effect, if a website visitor interacts with a link (e.g. change the color if the

visitor moves the mouse over the link). The following properties are the same for Moving Mouse

Over Link Effect, Clicking on Link Effect and Already Visited Link Effect.

Effect > Change Font

Changes the font style of a link.

Effect > Font Style

Specifies the font style, to which you want to change. Activate a checkbox to set a style attribute

and override the global Font Template of the project.

 - Font specifies the font. Please note that the font must be installed on the computer the website

visitor to get displayed.

 - Style sets the style. Choose between Bold, Italic, Underline and Strikethrough.

 - Size specifies the font size in pixels.

 - Color sets the font color.

Please read the chapter Typography & Font Styles for more information about Font Styles and

Font Templates.
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Fill your website with content and add text. This works with a text item that you can drag

from the items to the website.

You can add a text item to each area, slider area and area template. To add a text item, edit the

content of an area, slider or area template and drag a text item from the items to the editor.

A text item displays text. Double click on it and you can edit the text. In the text edit mode, the

properties on the right will change. Select some text and click on Edit Text > Font Style >

Choose... to change the font style, alignment, and size.

The selected template at Font Template will set the basic font style. You can overwrite individual

style properties with other styles. You can select the Master Template and more templates, that

you have created.
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Activate a checkbox to override a style property of the selected Font Template with a different

style.

 - Font specifies the font. Please note that the font must be installed on the computer the website

visitor to get displayed.

 - Style sets the style. Choose between Bold, Italic, Underline and Strikethrough.

 - Size specifies the font size in pixels.

 - Color sets the font color.

 - Line Space sets the line spacing in pixels. The line height is calculated of the Font Size + Line

Space.

 - Alignment sets the alignment of the paragraph. Possible values are Left, Center, Right and 

Justified.

INFO: If you mainly use the same style on every page and in every text item, it is better to

change the master template, rather than set the style in each single text item.

Changing the Default Font Template
Click on PROJECT on the top left (this will show the project properties) and click in the Project >

Font Templates > Choose... and the the window for font templates will appears.

Here you can change the default font for text, links and headlines. Please read the chapter 

Typography & Font Styles for more information about font templates.

Headlines, Lists and Enumerations
It is important to mark the semantic meaning of your text. Search engines like Google are rating

headlines differently than normal text. Select the text type at Edit Text > Text Type.
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 - Headline 1. Order - Headline 6. Order marks the selected text as a headline. The font style can

be specified in the font templates  Headline 1. Order to Headline 6. Order.

 - List marks the selected text as part of a list. Each new line will be a separate list item. A bullet

may be displayed before each list item. In addition to the predefined bullets, you can also use

your own picture as a bullet. Select it at Edit Text > Bullet Picture. Since bullet pictures can not

be displayed in retina resolution, you should only select .svg images here.

Render Text as a Picture
You might want to use unusual fonts for headlines and other text. Usually this is not possible on a

website, because the font must be installed on the device of the site visitor.

If you use unusual fonts, they will probably not displayed correctly.

If you use unusual fonts, enable Text > Render as picture in the properties of a Text item. After

that, Goldfish will create an image with the text in the selected font. It can be shown on all
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devices, even if the font is missing there.

INFO: It is not recommended to use this option for long texts. Use this only for headlines.

Otherwise, the size of your website will rise rapidly.

Links
Another important feature of a website is to add links. Select some text and enable Edit Text >

Use as link in the properties. Click on Choose... to specify the link target.

In the link window, you can determine where the link should lead to. There are several options to

choose from.

Internal Link to Page sets a link to one of the pages or sub pages in your project. Select the page

from the list. From the action list below, you can select an action on the page as the link target.

 - With No Action, the page loads quite normal and nothing special happens.

 - With Deactivate all Redirections the page will be loaded and all existing redirections will be

deactivated. For example, if the website visitor has a smartphone and the website has a

redirection to a mobile page, the redirection will not be executed.

 - With Start Animation "Animation Name" the page will be loaded and the selected animation will

be started.

 - With Jump to Item "Item Name" the page will be loaded and it will be scrolled to the selected

item as an anchor point. To let an item appear in the list, enter a name for the item at Item >

Identifier (Id) in the properties.

E-Mail-Address sets a link to an e-mail address. This opens the user's e-mail app, and a new

e-mail to the specified e-mail address will be opened.

File sets a link to a file that will displayed or download. For example, if you select a PDF
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document, it will be displayed by clicking on the link. On the other hand, .zip files will be

downloaded into the user's Downloads folder.

Custom Link sets a link to another website or link target. For example, enter an external address,

such as http://www.fishbeam.com.

Enable Open link in new window and the link will be opened in a new window or a new tab. If the

link is a download link, the window or the tab remains empty because the file will be downloaded.

Properties for Text Items
These properties can be set for a text item. Select a text item to see its properties.

Item > Identifier (Id)

Specifies the name of the item in order to address it in animations or as a link target. Use only

letters and numbers for the name, no spaces or special characters.

Item > Left

Sets the distance in pixels from the left side of the item to the area where the item is located.

Item > Top

Sets the distance in pixels from the top side of the item to the area where the item is located.

Item > Width

Sets the width of the item in pixels.

Item > Height

Sets the height of the item in pixels.

Item > Padding Left

Sets the distance from the left side of the item to the content in pixels.

Item > Padding Right

Sets the distance from the right side of the item to the content in pixels.

Item > Padding Top

Sets the distance from the top side of the item to the content in pixels.

Item > Padding Bottom

Sets the distance from the bottom side of the item to the content in pixels.

Item > Background Color

Select a background color for the item.
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Item > Background Picture Clip

Select a background picture from the Fishbeam Clips (

http://www.fishbeam.com/en/goldfish/clips.php) library. This option is only available if you have

the Fishbeam Clips library installed.

Item > Background Picture

Select a background picture for the item. With Repeat, you can choose how the picture will be

displayed. On Retina websites the background picture will be displayed with double resolution,

but half the size (except SVG images).

Item > Repeat

Repeats the background picture.

 - Don't Repeat displays the picture only once.

 - Repeat tiles the picture over the entire space.

 - Repeat Horizontally tiles the image in a row.

 - Repeat Vertically tiles the image in a column.

 - Cut to Fill displays the image once over the entire space. Overlapping edges will be cropped.

Item > Position Horizontal

Sets the horizontal position of the background picture. If the picture will be repeated, it will be

placed once on the specified position and the remaining space on the left, on the right, above and

below will be filled.

Item > Position Vertical

Sets the vertical position of the background picture. If the picture will be repeated, it will be placed

once on the specified position and the remaining space on the left, on the right, above and below

will be filled.

Item > Fix relative to Browser window

The position of the background picture is calculated on the basis of the browser window. The

picture is pined to the window and will not move when scrolling. The picture can be hidden or only

parts are visible if it is outside of the visible space.

Item > Border Left Width

Displays a border on the left side of the item in the choosen width (pixels).

Item > Border Left Color

Select a color for the left border.

Item > Border Right Width

Displays a border on the right side of the item in the choosen width (pixels).
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Item > Border Right Color

Select a color for the right border.

Item > Border Top Width

Displays a border on the top side of the item in the choosen width (pixels).

Item > Border Top Color

Select a color for the top border.

Item > Border Bottom Width

Displays a border on the bottom side of the item in the choosen width (pixels).

Item > Border Bottom Color

Select a color for the bottom border.

Item > Opacity (%) 

Makes the item transparent. From 0% (fully transparent) to 100% (completely visible).

Item > Rotation

Rotation of the object in a clockwise direction from 0° to 360°.

Item > Moving Mouse Over Animation PRO

Select an animation that you have previously created with an Animation item. The animation will

be started as soon as the website visitor moves the mouse over the item.

Item > Moving Mouse Out Animation PRO

Select an animation that you have previously created with an Animation item. The animation will

be started as soon as the website visitor moves the mouse from the item.

Text > Render as picture

Renders the text as a picture, so that you can use uncommon fonts.

Text > Edit Content

Click here to edit the content of a text item or double click on it.

Link Style > Font Style

Specifies the font style for links. Activate a checkbox to set a style attribute and override the

global Font Template of the project.

 - Font specifies the font. Please note that the font must be installed on the computer the website

visitor to get displayed.

 - Style sets the style. Choose between Bold, Italic, Underline and Strikethrough.

 - Size specifies the font size in pixels.

 - Color sets the font color.

Please read the chapter Typography & Font Styles for more information about Font Styles and
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Font Templates.

Visual Effects
You can specify a visual effect, if a website visitor interacts with a link (e.g. change the color if the

visitor moves the mouse over the link). The following properties are the same for Moving Mouse

Over Link Effect, Clicking on Link Effect and Already Visited Link Effect.

Effect > Change Font

Changes the font style of a link.

Effect > Font Style

Specifies the font style, to which you want to change. Activate a checkbox to set a style attribute

and override the global Font Template of the project.

 - Font specifies the font. Please note that the font must be installed on the computer the website

visitor to get displayed.

 - Style sets the style. Choose between Bold, Italic, Underline and Strikethrough.

 - Size specifies the font size in pixels.

 - Color sets the font color.

Please read the chapter Typography & Font Styles for more information about Font Styles and

Font Templates.

Properties for Text when Editing
These properties can be set in the edit mode of a text item. Select a text object and double click

on it to edit the text.

Edit Text > Text Type

Sets the semantic meaning for selected text (normal text, headlines or list). Headlines will be

displayed in a font style, that can be changed in the Font Templates of the project.

Edit Text > Padding Left

The selected text belongs to a list it sets the space between the list bullet and the text.

Edit Text > Bullet Picture

Choose a bullet picture for the list (only at Text Type: List with Bullet Picture.

Edit Text > Font Style

Specifies the font style for selected text.  Activate a checkbox to set a style attribute and override

the global Font Template of the project.

 - Font specifies the font. Please note that the font must be installed on the computer the website

visitor to get displayed.

 - Style sets the style. Choose between Bold, Italic, Underline and Strikethrough.

 - Size specifies the font size in pixels.

 - Color sets the font color.
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 - Line Space sets the line spacing in pixels. The line height is calculated of the Font Size + Line

Space.

 - Alignment sets the alignment of the paragraph. Possible values are Left, Center, Right and 

Justified.

Please read the chapter Typography & Font Styles for more information about Font Styles and

Font Templates.

Edit Text > Use as link

Defines the selected text as a link. In the link window, you can determine where the link should

lead to.

 - Internal Link to Page sets a link to one of the pages or sub pages in your project. Select the

page from the list. From the action list below, you can select an action on the page as the link

target.

 - E-Mail Address sets a link to an e-mail address. This opens the user's e-mail app, and a new

e-mail to the specified e-mail address will be opened.

 - File sets a link to a file that will displayed or download. For example, if you select a PDF

document, it will be displayed by clicking on the link.

 - Custom Link sets a link to another website or link target. For example, enter an external

address, such as http://www.fishbeam.com.
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Fill your website with content and add pictures. This works with an picture item that you

can drawn from the items to the website.

You can add a picture item to each area, slider area and area template. To add a picture item,

edit the content of an area, slider or area template and drag a picture item from the items to the

editor.

A picture item displays a single image on your website. The new picture item is empty by default.

To fill the item with a picture, click on the question mark behind Picture > Picture in the properties

and select an image from your hard drive. The Media Import window will be opened.

In the Import Media window, there are the following settings:

 - Name specifies the filename. Special characters or spaces should not be used for the file

name on websites. In addition, the name should not be too long. Because of this, Goldfish

shortens filenames, that are too long, to the correct length and removes all special characters

or spaces. If you do not like the filename, created by Goldfish, you can change it here.

 - Description specifies a comment for the file. For images, you should always enter a description

here. This will act as a description for visually impaired people or will displayed as the

description in a gallery.

 - Reduce image size to max. resizes the image during import. The aspect ratio will be retained.

On websites you should resize all large images (for example, from a digital camera) to reduce
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the file size and loading time. As a guideline we recommend approximately 1000 x 1000 pixels.

Please note that on retina websites the image will be actually resized to twice the entered size,

so it can be displayed in double resolution.

 - Rotate rotates images 90° to the left, 180° or 90° to the right. This allows you to correct the

orientation of images from digital cameras.

 - Flip horizontal flips the picture horizontally.

 - Flip vertical flips the picture vertically.

 - Apply to all applies all settings, made in the Media Import window, to all following files (only

available when importing multiple files from a folder).

INFO: On Retina websites, all images will be displayed in double resolution, but with half

the size (except SVG images). The settings Reduce image size to max., Rotate, Flip

horizontal and Flip vertical are only available for images in the .jpg and .png format.

The following image formats are supported by Goldfish. If you want to include pictures, that are in

a different format, you have to convert them with an image manipulating app to one of the

supported formats at first.

JPEG
The JPEG format (file extension .jpg or .jpeg) is suitable for photos and is also used by most

digital cameras. Goldfish can edit and save images in JPEG format. Because of this, there are

extended pictures processing options available for JPEG pictures.

PNG
The PNG format (file extension .png) is especially suited for graphics and controls and supports,

unlike JPEG, transparency. Goldfish can edit and save images in PNG format. Because of this,

there are extended pictures processing options available for PNG pictures.

SVG
We advise you to create all icons and design elements for your layout as SVG files (file extension 

.svg). The format SVG stores Illustrations that contain lines and surfaces instead pixels. This has

the advantage that you can zoom in and out SVG pictures without loss of quality. In addition, they

are sharp in every zoom level on Retina Macs, smartphones and tablets. Goldfish can not edit or

save images in the SVG format. Because of this, some editing options for pictures are not

available.

INFO: You can only resize SVG images in aspect ratio. Because of this, you can not not

stretch the width or height of SVG.

GIF
The out-dated GIF format (file extension .gif) is now largely replaced by PNG and has, in contrast

to this, some disadvantages. E.g. the color palette is limited to 256 colors.
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However, GIF, is the only image format that supports animations. When inserting an GIF

animation, Goldfish shows only a still image  in the editor. On the published website, or preview

the animation will be played. Goldfish can not edit or save images in the GIF format. Because of

this, some editing options for pictures are not available.

INFO: Disable always Picture > Calculate new on export for a GIF animation. Otherwise it

will be destroyed when publishing.

Specify the Clipping
You can specify the clipping in Goldfish. Start the edit mode by a double-click on the image.

Now you can zoom into the image with the slider and drag around the visible clipping. In addition,

the clipping can be dragged smaller and larger at the edges.

INFO: This is only possible if Picture > Calculate new on export is enabled in the

properties.

Image Effects
You can add image effects such as Reflection, Flip horizontal, Flip vertical and Shadow In the

properties at Picture.

INFO: The image effects Flip horizontal and Flip vertical are only available if Picture >

Calculate new on export is enabled in the properties.

Image Zoom
If you resize the picture to icon size, you can specify that a click on it, will show a larger version

(similar to the Gallery item).
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Drag the image small and enable Image Zoom > Activate Image Zoom.

Use Picture as a Link
An image can be used as a link so that another page will be loaded or effects will be triggered

with a click on the image. For this, enable Link > Use as link in the properties and click on 

Choose... behind that. The Link window will appear.

In the link window, you can determine where the link should lead to. There are several options to

choose from.

Internal Link to Page sets a link to one of the pages or sub pages in your project. Select the page
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from the list. From the action list below, you can select an action on the page as the link target.

 - With No Action, the page loads quite normal and nothing special happens.

 - With Deactivate all Redirections the page will be loaded and all existing redirections will be

deactivated. For example, if the website visitor has a smartphone and the website has a

redirection to a mobile page, the redirection will not be executed.

 - With Start Animation "Animation Name" the page will be loaded and the selected animation will

be started.

 - With Jump to Item "Item Name" the page will be loaded and it will be scrolled to the selected

item as an anchor point. To let an item appear in the list, enter a name for the item at Item >

Identifier (Id) in the properties.

E-Mail-Address sets a link to an e-mail address. This opens the user's e-mail app, and a new

e-mail to the specified e-mail address will be opened.

File sets a link to a file that will displayed or download. For example, if you select a PDF

document, it will be displayed by clicking on the link. On the other hand, .zip files will be

downloaded into the user's Downloads folder.

Custom Link sets a link to another website or link target. For example, enter an external address,

such as http://www.fishbeam.com.

Enable Open link in new window and the link will be opened in a new window or a new tab. If the

link is a download link, the window or the tab remains empty because the file will be downloaded.

Properties for Picture Items
These properties can be set for a picture item. Select a picture item to see its properties.

Item > Identifier (Id)

Specifies the name of the item in order to address it in animations or as a link target. Use only

letters and numbers for the name, no spaces or special characters.

Item > Left

Sets the distance in pixels from the left side of the item to the area where the item is located.

Item > Top

Sets the distance in pixels from the top side of the item to the area where the item is located.

Item > Width

Sets the width of the item in pixels.

Item > Height

Sets the height of the item in pixels.
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Item > Padding Left

Sets the distance from the left side of the item to the content in pixels.

Item > Padding Right

Sets the distance from the right side of the item to the content in pixels.

Item > Padding Top

Sets the distance from the top side of the item to the content in pixels.

Item > Padding Bottom

Sets the distance from the bottom side of the item to the content in pixels.

Item > Background Color

Select a background color for the item.

Item > Background Picture Clip

Select a background picture from the Fishbeam Clips (

http://www.fishbeam.com/en/goldfish/clips.php) library. This option is only available if you have

the Fishbeam Clips library installed.

Item > Background Picture

Select a background picture for the item. With Repeat, you can choose how the picture will be

displayed. On Retina websites the background picture will be displayed with double resolution,

but half the size (except SVG images).

Item > Repeat

Repeats the background picture.

 - Don't Repeat displays the picture only once.

 - Repeat tiles the picture over the entire space.

 - Repeat Horizontally tiles the image in a row.

 - Repeat Vertically tiles the image in a column.

 - Cut to Fill displays the image once over the entire space. Overlapping edges will be cropped.

Item > Position Horizontal

Sets the horizontal position of the background picture. If the picture will be repeated, it will be

placed once on the specified position and the remaining space on the left, on the right, above and

below will be filled.

Item > Position Vertical

Sets the vertical position of the background picture. If the picture will be repeated, it will be placed

once on the specified position and the remaining space on the left, on the right, above and below

will be filled.
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Item > Fix relative to Browser window

The position of the background picture is calculated on the basis of the browser window. The

picture is pined to the window and will not move when scrolling. The picture can be hidden or only

parts are visible if it is outside of the visible space.

Item > Border Left Width

Displays a border on the left side of the item in the choosen width (pixels).

Item > Border Left Color

Select a color for the left border.

Item > Border Right Width

Displays a border on the right side of the item in the choosen width (pixels).

Item > Border Right Color

Select a color for the right border.

Item > Border Top Width

Displays a border on the top side of the item in the choosen width (pixels).

Item > Border Top Color

Select a color for the top border.

Item > Border Bottom Width

Displays a border on the bottom side of the item in the choosen width (pixels).

Item > Border Bottom Color

Select a color for the bottom border.

Item > Opacity (%) 

Makes the item transparent. From 0% (fully transparent) to 100% (completely visible).

Item > Rotation

Rotation of the object in a clockwise direction from 0° to 360°.

Item > Moving Mouse Over Animation PRO

Select an animation that you have previously created with an Animation item. The animation will

be started as soon as the website visitor moves the mouse over the item.

Item > Moving Mouse Out Animation PRO

Select an animation that you have previously created with an Animation item. The animation will

be started as soon as the website visitor moves the mouse from the item.
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Picture > Picture

Select the picture, that you want to display. Possible are JPG, PNG, SVG and GIF images.

Picture > Calculate new on export

Calculates an optimized version of the picture in the correct size and quality for your website.

Deactivate this for svg images, transparent gif images and gif animations.

Picture > Edit Content

Click here to change the clipping for the picture. Note: This option is only available if Picture >

Calculate new on export is enabled.

Picture > Reflection

Adds a reflection to the image. Use the slider to adjust the size.

Picture > Flip horizontal

Flips the picture horizontally. Note: This option is only available if Picture > Calculate new on

export is enabled.

Picture > Flip vertical

Flips the picture vertically. Note: This option is only available if Picture > Calculate new on export

is enabled.

Picture > Shadow

Adds a shadow effect to the picture. Select a color for the shadow.

Picture > Angel

The angle in degrees, in which the shadow will show.

Picture > Offset

The offset beween the picture and the shaddow. An offset of 0 means that the shadow will be

located exactly among the picture.

Picture > Blur

Enter a value to blur the shaddow. A higher value blurs the shaddow more.

Picture > Opacity

The opacity of the shaddow. 100 means the shaddow has no transparency.

Image Zoom > Activate Image Zoom

Displays the picture in a full view when clicking on it.

Bildzoom > Show description

Shows comment of the picture in the full view below the picture.

- 106 -



12: Picture

Image Zoom > Font Style

Specifies the font style for the image description. Activate a checkbox to set a style attribute and

override the global Font Template of the project.

 - Font specifies the font. Please note that the font must be installed on the computer the website

visitor to get displayed.

 - Style sets the style. Choose between Bold, Italic, Underline and Strikethrough.

 - Size specifies the font size in pixels.

 - Color sets the font color.

Please read the chapter Typography & Font Styles for more information about Font Styles and

Font Templates.

Image Zoom > Background Color

Background color for the image description.

Image Zoom > Page Overlay > Background Color

Select a background color for the full view.

Image Zoom > Page Overlay > Background Picture Clip

Select a background picture from the Fishbeam Clips (

http://www.fishbeam.com/en/goldfish/clips.php) library. This option is only available if you have

the Fishbeam Clips library installed.

Image Zoom > Page Overlay > Background Picture

Select a background picture for the full view. With Repeat, you can choose how the picture will be

displayed. On Retina websites the background picture will be displayed with double resolution,

but half the size (except SVG images).

Image Zoom > Page Overlay > Repeat

Repeats the background picture.

 - Don't Repeat displays the picture only once.

 - Repeat tiles the picture over the entire space.

 - Repeat Horizontally tiles the image in a row.

 - Repeat Vertically tiles the image in a column.

 - Cut to Fill displays the image once over the entire space. Overlapping edges will be cropped.

Image Zoom > Page Overlay > Position Horizontal

Sets the horizontal position of the background picture. If the picture will be repeated, it will be

placed once on the specified position and the remaining space on the left, on the right, above and

below will be filled.

Image Zoom > Page Overlay > Position Vertical

Sets the vertical position of the background picture. If the picture will be repeated, it will be placed

once on the specified position and the remaining space on the left, on the right, above and below
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will be filled.

Image Zoom > Page Overlay > Fix relative to Browser window

The position of the background picture is calculated on the basis of the browser window. The

picture is pined to the window and will not move when scrolling. The picture can be hidden or only

parts are visible if it is outside of the visible space.

Image Zoom > Page Overlay > Opacity (%)

Sets the opacity of the background.

Link > Use as link

Uses the image as a link. In the link window, you can determine where the link should lead to.

 - Internal Link to Page sets a link to one of the pages or sub pages in your project. Select the

page from the list. From the action list below, you can select an action on the page as the link

target.

 - E-Mail Address sets a link to an e-mail address. This opens the user's e-mail app, and a new

e-mail to the specified e-mail address will be opened.

 - File sets a link to a file that will displayed or download. For example, if you select a PDF

document, it will be displayed by clicking on the link.

 - Custom Link sets a link to another website or link target. For example, enter an external

address, such as http://www.fishbeam.com.

Visual Effects
You can specify a visual effect, if the visitor of your website interacts with the picture link (e.g.

change the picture if the visitor moves the mouse over the picture). The following properties are

the same for Moving Mouse over Link Effect and Clicking on Link Effect.   

Effect > Change Picture

Changes the picture. Select the picture to which should be changed.

- 108 -



13. Audio & Video
Play sound files and videos on your website. This works with an Audio & Video item that

you can drag from the items to the website.

You can add an audio and video item to each area, slider area and area template. To add an

audio and video item, edit the content of an area, slider or area template and drag an audio and

video item from the items to the editor.

With an Audio & Video item, you can play HTML5 compatible audio and video files and YouTube

movies.

Depending on what type of audio or video you want to play, you have to select the correct type at 

Audio & Video > Type in the properties.

HTML5 Audio and HTML5 Video
Select the type HTML5 Audio for audio files and HTML5 Video for video files in the properties at 

Audio & Video > Type.

Compatible Audio Formats

 - MP3 (file extension .mp3)

Compatible with Safari, Chrome, Firefox, Internet Explorer and Opera

 - Wav (file extension .wav)

Compatible with Safari, Chrome, Firefox and Opera

 - Ogg (file extension .ogg, .oga)

Compatible with Chrome, Firefox and Opera

Compatible Video Formats

 - MP4 H.264 (file extension .mp4)

Compatible with Safari, Chrome, Firefox, Internet Explorer and Opera
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 - Ogg Theora (file extension .ogg, .ogv)

Compatible with Chrome, Firefox and Opera

 - WebM (file extension .webm)

Compatible with Chrome, Firefox and Opera

Select the desired file at Audio & Video > Media File. Because not every audio and video format

is compatible with all systems and browsers, you can embed the file in multiple formats. If you

want to embed the file in more than one format, select the additional files at Audio & Video >

Alternative Media File.

By default, controls with buttons like Play, Pause or Full Screen will appear. If you don't want that,

you can disable Audio & Video > Show controller in the properties.
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You can select a poster picture for videos. This picture will appear as a placeholder until the video

will be played. You can select an image in the properties at Audio & Video > Poster Picture before

Playback. We suggest you to select a still, taken from the video.

INFO: By default, a large play button will be displayed on the poster picture. You can

disable this in the properties or choose a custom artwork as the button picture.

YouTube
Select the type YouTube in the properties at Audio & Video > Type if you want to show a

YouTube video on the page.

Look in YouTube for the desired video and paste the URL from the browser address bar in the

field at Audio & Video > Video ID. Fter that, Goldfish will download a preview image and will

resize the Audio & Video item.

INFO: The field Audio & Video > ID will cut out the correct ID automatically. Just paste the

URL, the video ID or the embedding HTML code of a YouTube movie.
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By default, the YouTube player will be displayed with title and controls. But you can change that

in the properties at Audio & Video.

Properties for Audio & Video Items
These properties can be set for an audio & video item. Select an audio & video item to see its

properties.

Item > Identifier (Id)

Specifies the name of the item in order to address it in animations or as a link target. Use only

letters and numbers for the name, no spaces or special characters.

Item > Left

Sets the distance in pixels from the left side of the item to the area where the item is located.

Item > Top

Sets the distance in pixels from the top side of the item to the area where the item is located.

Item > Width

Sets the width of the item in pixels.

Item > Height

Sets the height of the item in pixels.

Item > Padding Left

Sets the distance from the left side of the item to the content in pixels.
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Item > Padding Right

Sets the distance from the right side of the item to the content in pixels.

Item > Padding Top

Sets the distance from the top side of the item to the content in pixels.

Item > Padding Bottom

Sets the distance from the bottom side of the item to the content in pixels.

Item > Background Color

Select a background color for the item.

Item > Background Picture Clip

Select a background picture from the Fishbeam Clips (

http://www.fishbeam.com/en/goldfish/clips.php) library. This option is only available if you have

the Fishbeam Clips library installed.

Item > Background Picture

Select a background picture for the item. With Repeat, you can choose how the picture will be

displayed. On Retina websites the background picture will be displayed with double resolution,

but half the size (except SVG images).

Item > Repeat

Repeats the background picture.

 - Don't Repeat displays the picture only once.

 - Repeat tiles the picture over the entire space.

 - Repeat Horizontally tiles the image in a row.

 - Repeat Vertically tiles the image in a column.

 - Cut to Fill displays the image once over the entire space. Overlapping edges will be cropped.

Item > Position Horizontal

Sets the horizontal position of the background picture. If the picture will be repeated, it will be

placed once on the specified position and the remaining space on the left, on the right, above and

below will be filled.

Item > Position Vertical

Sets the vertical position of the background picture. If the picture will be repeated, it will be placed

once on the specified position and the remaining space on the left, on the right, above and below

will be filled.

Item > Fix relative to Browser window

The position of the background picture is calculated on the basis of the browser window. The

picture is pined to the window and will not move when scrolling. The picture can be hidden or only
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parts are visible if it is outside of the visible space.

Item > Border Left Width

Displays a border on the left side of the item in the choosen width (pixels).

Item > Border Left Color

Select a color for the left border.

Item > Border Right Width

Displays a border on the right side of the item in the choosen width (pixels).

Item > Border Right Color

Select a color for the right border.

Item > Border Top Width

Displays a border on the top side of the item in the choosen width (pixels).

Item > Border Top Color

Select a color for the top border.

Item > Border Bottom Width

Displays a border on the bottom side of the item in the choosen width (pixels).

Item > Border Bottom Color

Select a color for the bottom border.

Item > Opacity (%) 

Makes the item transparent. From 0% (fully transparent) to 100% (completely visible).

Item > Rotation

Rotation of the object in a clockwise direction from 0° to 360°.

Item > Moving Mouse Over Animation PRO

Select an animation that you have previously created with an Animation item. The animation will

be started as soon as the website visitor moves the mouse over the item.

Item > Moving Mouse Out Animation PRO

Select an animation that you have previously created with an Animation item. The animation will

be started as soon as the website visitor moves the mouse from the item.

Audio & Video > Type

Select the type, depending on what you want to play.
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Audio & Video > Media File

Select the media file from your computer, that you want to play (not available if you have selected

YouTube at Audio & Video > Type).

Audio & Video > Alternative Media File

Select an alternative media file from your computer, that is in a different format. The browser will

automatically select the appropriate format (not available if you have selected YouTube at Audio

& Video > Type).

Audio & Video > Video ID

Enter the ID, the URL or the embed HTML code of a YouTube movie (only available if you have

selected YouTube at Audio & Video > Type).

Audio & Video > Show controller

Displays controls like play, stop, pause and full screen.

Audio & Video > Start playback automatically

Will play the media file automatically when the page has been loaded.

Audio & Video > Looping

Will play the media file in a loop.

Audio & Video > Start & Stop with click in display area

A click in the area of the Audio & Video item will start the playback or will paused it. (not available

if you have selected YouTube at Audio & Video > Type).

Audio & Video > Show suggestions

Displays more movies as a suggestion after playing a YouTube movie.

Audio & Video > Show Video Title

Displays the title in the player of YouTube movies.

Audio & Video > Play Audio Track

Plays the soundtrack of a video file.

Audio & Video > Poster Picture before Playback

Select an image that can be seen in the video before playback begins.

Audio & Video > Show play button on poster picture

Shows a play button on the poster picture.

Audio & Video > Play Button Picture

Choose a custom button picture if you don't like the standard play button.
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Draw rectangles, rounded rectangles, ovals, lines and other shapes directly on your

website. This works with a shape item that you can drag from the items to the website.

You can add a shape to each area, slider area and area template. To add a shape, edit the

content of an area, slider or area template and drag a shape item from the items to the editor.

Shapes are a good choice if you want to create the layout of your website. Shapes can contain

rectangles, rounded rectangles, ovals, lines or other shapes. Or nothing, if you just want to show

a plain box with background picture or background color.

The property Shape > Has Shape defines if a shape will be shown in the item and what kind of

shape will be used. Choose between rectangle, rounded rectangle, oval, line or one of the

numerous other sahpes. It depends on your selection which of the other options are available.
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Every shape has a fill color and a border. If you only want to have a rectangle with a background

or one color, deactivate Shape > Has Shape and use the background of the item instead.

INFO: Shapes can also be rotated or look semi-transparent. To do this, change Item >

Rotation and Item > Opacity from the properties.

Properties for Shape Items
These properties can be set for a shape item. Select a shape item to see its properties.

Item > Identifier (Id)

Specifies the name of the item in order to address it in animations or as a link target. Use only

letters and numbers for the name, no spaces or special characters.

Item > Left

Sets the distance in pixels from the left side of the item to the area where the item is located.

Item > Top

Sets the distance in pixels from the top side of the item to the area where the item is located.

Item > Width

Sets the width of the item in pixels.

Item > Height

Sets the height of the item in pixels.

Item > Padding Left

Sets the distance from the left side of the item to the content in pixels.
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Item > Padding Right

Sets the distance from the right side of the item to the content in pixels.

Item > Padding Top

Sets the distance from the top side of the item to the content in pixels.

Item > Padding Bottom

Sets the distance from the bottom side of the item to the content in pixels.

Item > Background Color

Select a background color for the item.

Item > Background Picture Clip

Select a background picture from the Fishbeam Clips (

http://www.fishbeam.com/en/goldfish/clips.php) library. This option is only available if you have

the Fishbeam Clips library installed.

Item > Background Picture

Select a background picture for the item. With Repeat, you can choose how the picture will be

displayed. On Retina websites the background picture will be displayed with double resolution,

but half the size (except SVG images).

Item > Repeat

Repeats the background picture.

 - Don't Repeat displays the picture only once.

 - Repeat tiles the picture over the entire space.

 - Repeat Horizontally tiles the image in a row.

 - Repeat Vertically tiles the image in a column.

 - Cut to Fill displays the image once over the entire space. Overlapping edges will be cropped.

Item > Position Horizontal

Sets the horizontal position of the background picture. If the picture will be repeated, it will be

placed once on the specified position and the remaining space on the left, on the right, above and

below will be filled.

Item > Position Vertical

Sets the vertical position of the background picture. If the picture will be repeated, it will be placed

once on the specified position and the remaining space on the left, on the right, above and below

will be filled.

Item > Fix relative to Browser window

The position of the background picture is calculated on the basis of the browser window. The

picture is pined to the window and will not move when scrolling. The picture can be hidden or only
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parts are visible if it is outside of the visible space.

Item > Border Left Width

Displays a border on the left side of the item in the choosen width (pixels).

Item > Border Left Color

Select a color for the left border.

Item > Border Right Width

Displays a border on the right side of the item in the choosen width (pixels).

Item > Border Right Color

Select a color for the right border.

Item > Border Top Width

Displays a border on the top side of the item in the choosen width (pixels).

Item > Border Top Color

Select a color for the top border.

Item > Border Bottom Width

Displays a border on the bottom side of the item in the choosen width (pixels).

Item > Border Bottom Color

Select a color for the bottom border.

Item > Opacity (%) 

Makes the item transparent. From 0% (fully transparent) to 100% (completely visible).

Item > Rotation

Rotation of the object in a clockwise direction from 0° to 360°.

Item > Moving Mouse Over Animation PRO

Select an animation that you have previously created with an Animation item. The animation will

be started as soon as the website visitor moves the mouse over the item.

Item > Moving Mouse Out Animation PRO

Select an animation that you have previously created with an Animation item. The animation will

be started as soon as the website visitor moves the mouse from the item.

Shape > Has shape

Select the shape that should be shown. Deactivate this, if you only want to have a plain rectangle

with a background or a color.
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Shape > Arc

Sets the arc for the round edges of a rounded rectangle.

Shape > Fill Color

Choose a fill color for the shape.

Shape > Color

Choose a color for the line shape.

Shape > Size

Sets the size of a line shape in pixels.

Shape > Border Width

Sets the width for the border of the shape in pixels.

Shape > Border Color

Choose a color for the border of the shape.
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Essential for your website is the navigation between different pages. This works with a

menu item that you can drag from the items to the website.

You can add a menu item to each area, slider area and area template. To add a menu item, edit

the content of an area, slider or area template and drag a menu item from the items to the editor.

INFO: You should add the menu item to an area template "Navigation" and use this area

template on every page of your website. If you do this, the menu will be displayed on every

page of your website at the same position.

The Navigation menu automatically displays your website pages as menu items. Usually it

contains exactly one entry for each page of your website. The displayed text is always the Page >

Menu Title property of a page.

To change the text, select the respective page and edit the property Page > Menu Title. If you

disable Page > Menu Title, the page does not appear in the navigation menu. With Page > Menu

Picture you can choose an image that will be displayed in addition to the text in the menu.
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You can also add an additional link to the menu. Just click on + on the left bottom and select Add

Navigation Menu Link. This adds a link, where you can assign a custom link destination. Drag the

link like a page to the desired position of the project list, so that it will show up on the desired

position in the menu.

There are several types of navigation menus. You can set the type in the properties at Menu >

Menu Type.

Simple Menu (displays no subfolders)
The menu type Simple Menu only displays one hierarchy level of pages. It shows no submenus. If

your website contains pages with subpages, you will need a second navigation menu for them.

Menu with Submenu (displays one subfolder)
The menu type Menu with Submenu displays only two hierarchy levels of pages. If you click on a

page with subpages, a submenu will be shown. The submenu will appear directly below the main

menu of the page.
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Drawer Menu (displays no subfolders)
The menu type Drawer Menu is primarily intended for websites on mobile devices. If you click on

the menu icon a drawer is pulled up with the menu, which pushes the website aside.

Dropdown Menu Right (displays all subfolders)
The Menu type Dropdown Menu Right shows all hierarchy levels of pages in a menu structure. If

the website visitor moves the mouse over a menu item from a page with subpages, a submenu

will be opend.
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Dropdown Menu Bottom (displays all subfolders)
The Menu type Dropdown Menu Bottom shows all hierarchy levels of pages in a menu structure.

If the website visitor moves the mouse over a menu item from a page with subpages, a submenu

will be opend.

Picture Menu (displays no subfolders)
The menu type Pictures Menu shows a slider with images as a menu. By clicking on a picture or

description the corresponding page will be loaded. More entries can be displayed by clicking on

the navigation arrows.

By default, the menu begins in the top hierarchy level of the website with the Start Page. The 

Start Page with sub pages is displayed  in the menu.

If you want to display a different section of the page hierarchy in the menu, you can change the

base folder in the properties at Menu > Base Folder. So you can display only the mobile Start

Page with sub pages in the menu for example.

INFO: If you drag the menu and increase its width, the menu items are displayed side by

side instead of one below the other.

Properties for Menu Items
These properties can be set for a menu item. Select a menu item to see its properties.
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Item > Identifier (Id)

Specifies the name of the item in order to address it in animations or as a link target. Use only

letters and numbers for the name, no spaces or special characters.

Item > Left

Sets the distance in pixels from the left side of the item to the area where the item is located.

Item > Top

Sets the distance in pixels from the top side of the item to the area where the item is located.

Item > Width

Sets the width of the item in pixels.

Item > Height

Sets the height of the item in pixels.

Item > Padding Left

Sets the distance from the left side of the item to the content in pixels.

Item > Padding Right

Sets the distance from the right side of the item to the content in pixels.

Item > Padding Top

Sets the distance from the top side of the item to the content in pixels.

Item > Padding Bottom

Sets the distance from the bottom side of the item to the content in pixels.

Item > Background Color

Select a background color for the item.

Item > Background Picture Clip

Select a background picture from the Fishbeam Clips (

http://www.fishbeam.com/en/goldfish/clips.php) library. This option is only available if you have

the Fishbeam Clips library installed.

Item > Background Picture

Select a background picture for the item. With Repeat, you can choose how the picture will be

displayed. On Retina websites the background picture will be displayed with double resolution,

but half the size (except SVG images).

Item > Repeat

Repeats the background picture.

 - Don't Repeat displays the picture only once.
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 - Repeat tiles the picture over the entire space.

 - Repeat Horizontally tiles the image in a row.

 - Repeat Vertically tiles the image in a column.

 - Cut to Fill displays the image once over the entire space. Overlapping edges will be cropped.

Item > Position Horizontal

Sets the horizontal position of the background picture. If the picture will be repeated, it will be

placed once on the specified position and the remaining space on the left, on the right, above and

below will be filled.

Item > Position Vertical

Sets the vertical position of the background picture. If the picture will be repeated, it will be placed

once on the specified position and the remaining space on the left, on the right, above and below

will be filled.

Item > Fix relative to Browser window

The position of the background picture is calculated on the basis of the browser window. The

picture is pined to the window and will not move when scrolling. The picture can be hidden or only

parts are visible if it is outside of the visible space.

Item > Border Left Width

Displays a border on the left side of the item in the choosen width (pixels).

Item > Border Left Color

Select a color for the left border.

Item > Border Right Width

Displays a border on the right side of the item in the choosen width (pixels).

Item > Border Right Color

Select a color for the right border.

Item > Border Top Width

Displays a border on the top side of the item in the choosen width (pixels).

Item > Border Top Color

Select a color for the top border.

Item > Border Bottom Width

Displays a border on the bottom side of the item in the choosen width (pixels).

Item > Border Bottom Color

Select a color for the bottom border.
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Item > Opacity (%) 

Makes the item transparent. From 0% (fully transparent) to 100% (completely visible).

Item > Rotation

Rotation of the object in a clockwise direction from 0° to 360°.

Item > Moving Mouse Over Animation PRO

Select an animation that you have previously created with an Animation item. The animation will

be started as soon as the website visitor moves the mouse over the item.

Item > Moving Mouse Out Animation PRO

Select an animation that you have previously created with an Animation item. The animation will

be started as soon as the website visitor moves the mouse from the item.

Menu > Menu Type

Specifies the Menu Type for the menu.

 - Simple Menu displays a one-dimensional menu.

 - Menu with Submenu displays a two-dimensional menu with submenu.

 - Drawer Menu displays the menu as an icon. By clicking on it, a drawer opens with the entries.

 - Dropdown Menu Right displays a multidimensional drop-down menu. In that the entries will be

unfolded to the right.

 - Dropdown Menu Bottom displays a multidimensional drop-down menu. In that the entries will

be unfolded to the bottom.

 - Picture Menu displays a slider menu with pictures.

Menu > Base Folder

Choose a page with subpages that appear as main menu. The default is the Start Page, but you

can change this property to display submenus or to create a menu for the mobile website.

Menu > Show base folder as menu entry

Displays the selected page from Menu > Base Folder in the main menu. When you disable this

property, only is subpages will be displayed.

Menu > Highlight entry

Defines which entries should be highlighted. For highlighting the Clicking on Link Effectwill be

used.

 - None highlights nothing.

 - Current Page highlights the entry of the current page.

 - Current Page and Direct Parent Page highlights the entry of the current page and the entry of

the direct parent page.

 - Current Page and all Parent Pages highlights the entry of the current page and all entries of

parent pages.
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Menu > Margin Horizontal

Sets the distance between the bottom of a menu item and the top of the next menu item.

Menu > Margin Vertical

Sets the distance between the right of a menu item and the left of the next menu item.

Menu > Background Color

Select a background color for the Drawer from the Drawer Menu.

Menu > Background Picture Clip

Select a background picture from the Fishbeam Clips (

http://www.fishbeam.com/en/goldfish/clips.php) library. This option is only available if you have

the Fishbeam Clips library installed.

Menu > Background Picture

Select a background picture for the Drawer from the Drawer Menu. With Repeat, you can

choose how the picture will be displayed. On Retina websites the background picture will be

displayed with double resolution, but half the size (except SVG images).

Menu > Repeat

Repeats the background picture.

 - Don't Repeat displays the picture only once.

 - Repeat tiles the picture over the entire space.

 - Repeat Horizontally tiles the image in a row.

 - Repeat Vertically tiles the image in a column.

 - Cut to Fill displays the image once over the entire space. Overlapping edges will be

cropped.

Menu > Position Horizontal

Sets the horizontal position of the background picture. If the picture will be repeated, it will be

placed once on the specified position and the remaining space on the left, on the right, above

and below will be filled.

Menu > Position Vertical

Sets the vertical position of the background picture. If the picture will be repeated, it will be

placed once on the specified position and the remaining space on the left, on the right, above

and below will be filled.

Menu > Fix relative to Browser window

The position of the background picture is calculated on the basis of the browser window. The

picture is pined to the window and will not move when scrolling. The picture can be hidden or

only parts are visible if it is outside of the visible space.
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Menu > Custom Button Picture

Select a picture as an icon for the Drawer Menu.

Menu > Custom Button Picture Left

Select a picture as a button for scrolling to the left in a Picture Menu.

Menu > Custom Button Picture Right

Select a picture as a button for scrolling to the right in a Picture Menu.

Visual Effects
You can specify a visual effect, if a website visitor of interacts with the button (e.g. change the

picture if the visitor moves the mouse over the button). The following properties are the same

for Moving Mouse Over Link Effect and Clicking on Link Effect.

Effect > Change Picture

Changes the picture. Select an picture to which you want to change.

Properties for Main Menu Entry, Submenu Entry and Picture Menu
Entry
The following properties are the same for Main Menu Entry, Submenu Entry and Picture Menu

Entry. Note that depending on the Menu Type just some of the properties may be visible.

Menu Entry > Width

Specifies the width of a menu entry in pixels.

Menu Entry > Height

Specifies the height of a menu entry in pixels.

Menu Entry > Alignment

Sets the text alignment in a menu entry.

Menu Entry > Font Style

Specifies the font style of a menu entry. Activate a checkbox to set a style attribute and

override the global Font Template of the project.

 - Font specifies the font. Please note that the font must be installed on the computer the

website visitor to get displayed.

 - Style sets the style. Choose between Bold, Italic, Underline and Strikethrough.

 - Size specifies the font size in pixels.

 - Color sets the font color.

Please read the chapter Typography & Font Styles for more information about Font Styles and

Font Templates.
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Menu Entry > Padding Left

Sets the distance from the left side of a menu entry to the content in pixels.

Menu Entry > Padding Right

Sets the distance from the right side of a menu entry to the content in pixels.

Menu Entry > Padding Top

Sets the distance from the top side of a menu entry to the content in pixels.

Menu Entry > Padding Bottom

Sets the distance from the bottom side of a menu entry to the content in pixels.

Menu Entry > Background Color

Select a background color for a menu entry.

Menu Entry > Background Picture Clip

Select a background picture from the Fishbeam Clips (

http://www.fishbeam.com/en/goldfish/clips.php) library. This option is only available if you have

the Fishbeam Clips library installed.

Menu Entry > Background Picture

Select a background picture for a menu entry. With Repeat, you can choose how the picture

will be displayed. On Retina websites the background picture will be displayed with double

resolution, but half the size (except SVG images).

Menu Entry > Repeat

Repeats the background picture.

 - Don't Repeat displays the picture only once.

 - Repeat tiles the picture over the entire space.

 - Repeat Horizontally tiles the image in a row.

 - Repeat Vertically tiles the image in a column.

 - Cut to Fill displays the image once over the entire space. Overlapping edges will be

cropped.

Menu Entry > Position Horizontal

Sets the horizontal position of the background picture. If the picture will be repeated, it will be

placed once on the specified position and the remaining space on the left, on the right, above

and below will be filled.

Menu Entry > Position Vertical

Sets the vertical position of the background picture. If the picture will be repeated, it will be

placed once on the specified position and the remaining space on the left, on the right, above

and below will be filled.
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Menu Entry > Fix relative to Browser window

The position of the background picture is calculated on the basis of the browser window. The

picture is pined to the window and will not move when scrolling. The picture can be hidden or

only parts are visible if it is outside of the visible space.

Menu Entry > Border Left Width

Displays a border on the left side of a menu entry in the choosen width (pixels).

Menu Entry > Border Left Color

Select a color for the left border.

Menu Entry > Border Right Width

Displays a border on the right side of a menu entry in the choosen width (pixels).

Menu Entry > Border Right Color

Select a color for the right border.

Menu Entry > Border Top Width

Displays a border on the top side of a menu entry in the choosen width (pixels).

Menu Entry > Border Top Color

Select a color for the top border.

Menu Entry > Border Bottom Width

Displays a border on the bottom side of a menu entry in the choosen width (pixels).

Menu Entry > Border Bottom Color

Select a color for the bottom border.

Visual Effects
You can specify a visual effect, if a website visitor of interacts with the menu (e.g. change the

color if the visitor moves the mouse over an entry). The following properties are the same for 

Moving Mouse Over Link Effect, Clicking on Link Effect and Already Visited Link Effect.

Effect > Change Font

Change the font style of a menu entry.

Effect > Font Style

Specifies the font style, to that you want to change. Activate a checkbox to set a style attribute

and override the global Font Template of the project.

 - Font specifies the font. Please note that the font must be installed on the computer the

website visitor to get displayed.

 - Style sets the style. Choose between Bold, Italic, Underline and Strikethrough.
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 - Size specifies the font size in pixels.

 - Color sets the font color.

Please read the chapter Typography & Font Styles for more information about Font Styles and

Font Templates.

Effect > Change Background

Changes the background of a menu entry.

Effect > Background Color

Select a background color for a menu entry.

Effect > Background Picture Clip

Select a background picture from the Fishbeam Clips (

http://www.fishbeam.com/en/goldfish/clips.php) library. This option is only available if you have

the Fishbeam Clips library installed.

Effect > Background Picture

Select a background picture for a menu entry. With Repeat, you can choose how the picture

will be displayed. On Retina websites the background picture will be displayed with double

resolution, but half the size (except SVG images).

Effect > Repeat

Repeats the background picture.

 - Don't Repeat displays the picture only once.

 - Repeat tiles the picture over the entire space.

 - Repeat Horizontally tiles the image in a row.

 - Repeat Vertically tiles the image in a column.

 - Cut to Fill displays the image once over the entire space. Overlapping edges will be

cropped.

Effect > Position Horizontal

Sets the horizontal position of the background picture. If the picture will be repeated, it will be

placed once on the specified position and the remaining space on the left, on the right, above

and below will be filled.

Effect > Position Vertical

Sets the vertical position of the background picture. If the picture will be repeated, it will be

placed once on the specified position and the remaining space on the left, on the right, above

and below will be filled.

Effect > Fix relative to Browser window

The position of the background picture is calculated on the basis of the browser window. The

picture is pined to the window and will not move when scrolling. The picture can be hidden or
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only parts are visible if it is outside of the visible space.

Effect > Change Border

Changes the border of a menu entry.

Effect > Border Left Width

Displays a border on the left side of a menu entry in the choosen width (pixels).

Effect > Border Left Color

Select a color for the left border.

Effect > Border Right Width

Displays a border on the right side of a menu entry in the choosen width (pixels).

Effect > Border Right Color

Select a color for the right border.

Effect > Border Top Width

Displays a border on the top side of a menu entry in the choosen width (pixels).

Effect > Border Top Color

Select a color for the top border.

Effect > Border Bottom Width

Displays a border on the bottom side of a menu entry in the choosen width (pixels).

Effect > Border Bottom Color

Select a color for the bottom border.

Effekt > Change Padding

Changes the padding of a menu entry.

Effect > Padding Left

Sets the distance from the left side of a menu entry to the content in pixels.

Effect > Padding Right

Sets the distance from the right side of a menu entry to the content in pixels.

Effect > Padding Top

Sets the distance from the top side of a menu entry to the content in pixels.

Effect > Padding Bottom

Sets the distance from the bottom side of a menu entry to the content in pixels.
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Make any places of a website clickable. This works with a link shape that you can drag

from the items to the website.

You can add a link shape to each area, slider area and area template. To add a link shape,

edit the content of an area, slider or area template and drag a link shape item from the items to

the editor.

A link shape can be placed on any area on the page. This makes the area clickable.

For example, place several link shapes on the top of the people in a picture and create a link

for each single person.

You can select what kind of shape should should be used as the link at Link Shape > Shape in

the properties. The options are Circle, Triangle and Rectangle.
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Enable Link Shape > Use shape as link and click on Choose... to create a link. The Link

-window will be opened.

In the link window, you can determine where the link should lead to. There are several options

to choose from.

Internal Link to Page sets a link to one of the pages or sub pages in your project. Select the

page from the list. From the action list below, you can select an action on the page as the link

target.

 - With No Action, the page loads quite normal and nothing special happens.

 - With Deactivate all Redirections the page will be loaded and all existing redirections will be

deactivated. For example, if the website visitor has a smartphone and the website has a

redirection to a mobile page, the redirection will not be executed.

 - With Start Animation "Animation Name" the page will be loaded and the selected animation

will be started.

 - With Jump to Item "Item Name" the page will be loaded and it will be scrolled to the

selected item as an anchor point. To let an item appear in the list, enter a name for the item

at Item > Identifier (Id) in the properties.

E-Mail-Address sets a link to an e-mail address. This opens the user's e-mail app, and a new

e-mail to the specified e-mail address will be opened.

File sets a link to a file that will displayed or download. For example, if you select a PDF

document, it will be displayed by clicking on the link. On the other hand, .zip files will be

downloaded into the user's Downloads folder.

Custom Link sets a link to another website or link target. For example, enter an external

address, such as http://www.fishbeam.com.
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Enable Open link in new window and the link will be opened in a new window or a new tab. If

the link is a download link, the window or the tab remains empty because the file will be

downloaded.

Properties for Link Shape Items
These properties can be set for a link shape item. Select a link shape item to see its

properties.

Item > Identifier (Id)

Specifies the name of the item in order to address it in animations or as a link target. Use only

letters and numbers for the name, no spaces or special characters.

Item > Left

Sets the distance in pixels from the left side of the item to the area where the item is located.

Item > Top

Sets the distance in pixels from the top side of the item to the area where the item is located.

Item > Width

Sets the width of the item in pixels.

Item > Height

Sets the height of the item in pixels.

Item > Padding Left

Sets the distance from the left side of the item to the content in pixels.

Item > Padding Right

Sets the distance from the right side of the item to the content in pixels.

Item > Padding Top

Sets the distance from the top side of the item to the content in pixels.

Item > Padding Bottom

Sets the distance from the bottom side of the item to the content in pixels.

Item > Background Color

Select a background color for the item.

Item > Background Picture Clip

Select a background picture from the Fishbeam Clips (

http://www.fishbeam.com/en/goldfish/clips.php) library. This option is only available if you have

the Fishbeam Clips library installed.
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Item > Background Picture

Select a background picture for the item. With Repeat, you can choose how the picture will be

displayed. On Retina websites the background picture will be displayed with double resolution,

but half the size (except SVG images).

Item > Repeat

Repeats the background picture.

 - Don't Repeat displays the picture only once.

 - Repeat tiles the picture over the entire space.

 - Repeat Horizontally tiles the image in a row.

 - Repeat Vertically tiles the image in a column.

 - Cut to Fill displays the image once over the entire space. Overlapping edges will be

cropped.

Item > Position Horizontal

Sets the horizontal position of the background picture. If the picture will be repeated, it will be

placed once on the specified position and the remaining space on the left, on the right, above

and below will be filled.

Item > Position Vertical

Sets the vertical position of the background picture. If the picture will be repeated, it will be

placed once on the specified position and the remaining space on the left, on the right, above

and below will be filled.

Item > Fix relative to Browser window

The position of the background picture is calculated on the basis of the browser window. The

picture is pined to the window and will not move when scrolling. The picture can be hidden or

only parts are visible if it is outside of the visible space.

Item > Border Left Width

Displays a border on the left side of the item in the choosen width (pixels).

Item > Border Left Color

Select a color for the left border.

Item > Border Right Width

Displays a border on the right side of the item in the choosen width (pixels).

Item > Border Right Color

Select a color for the right border.
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Item > Border Top Width

Displays a border on the top side of the item in the choosen width (pixels).

Item > Border Top Color

Select a color for the top border.

Item > Border Bottom Width

Displays a border on the bottom side of the item in the choosen width (pixels).

Item > Border Bottom Color

Select a color for the bottom border.

Item > Opacity (%) 

Makes the item transparent. From 0% (fully transparent) to 100% (completely visible).

Item > Rotation

Rotation of the object in a clockwise direction from 0° to 360°.

Item > Moving Mouse Over Animation PRO

Select an animation that you have previously created with an Animation item. The animation

will be started as soon as the website visitor moves the mouse over the item.

Item > Moving Mouse Out Animation PRO

Select an animation that you have previously created with an Animation item. The animation

will be started as soon as the website visitor moves the mouse from the item.

Link Shape > Shape

Sets the shape to be used as a clickable area.

 - Circle shows a circle as a clickable area.

 - Triangle shows a triangle as a clickable area.

 - Rectangle shows a rectangle as a clickable area.

Link Shape > Use shape as link

Defines the link that will be executed by click on the shape. In the link window, you can

determine where the link should lead to.

 - Internal Link to Page sets a link to one of the pages or sub pages in your project. Select the

page from the list. From the action list below, you can select an action on the page as the

link target.

 - E-Mail Address sets a link to an e-mail address. This opens the user's e-mail app, and a

new e-mail to the specified e-mail address will be opened.

 - File sets a link to a file that will displayed or download. For example, if you select a PDF

document, it will be displayed by clicking on the link.

 - Custom Link sets a link to another website or link target. For example, enter an external
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address, such as http://www.fishbeam.com.
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Connect your website to social networks. This works with a Follow & Share item that

you can drag from the items to the website.

You can add a follow & share item to each area, slider area and area template. To add a follow

& share item, edit the content of an area, slider or area template and drag a follow & share

item from the items to the editor.

A Follow & Share item allows you to connect your website with your accounts of social

networks.

Select the type of buttons you want to add at Follow & Share > Type in the properties.

Share Buttons
Displays buttons for sharing and liking of the current page.

Supported are Facebook, Twitter, LinkedIn, Google+, Pinterest and Share More. Select the

desired button in the properties. Share More will show a range of other options, such as

printing, e-mail recommendation and lesser known social networks.

Follow Buttons
Displays buttons for following you in social networks.

Supported are Facebook, Twitter, YouTube, LinkedIn, Google+, Flickr, Vimeo, Pinterest, 

Instagram and Forsquare. Select the desired button in the properties and enter your profile
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name of the social network in the field behind.

Properties for Follow & Share Items
These properties can be set for a follow & share item. Select a follow & share item to see its

properties.

Item > Identifier (Id)

Specifies the name of the item in order to address it in animations or as a link target. Use only

letters and numbers for the name, no spaces or special characters.

Item > Left

Sets the distance in pixels from the left side of the item to the area where the item is located.

Item > Top

Sets the distance in pixels from the top side of the item to the area where the item is located.

Item > Width

Sets the width of the item in pixels.

Item > Height

Sets the height of the item in pixels.

Item > Padding Left

Sets the distance from the left side of the item to the content in pixels.

Item > Padding Right

Sets the distance from the right side of the item to the content in pixels.

Item > Padding Top

Sets the distance from the top side of the item to the content in pixels.

Item > Padding Bottom

Sets the distance from the bottom side of the item to the content in pixels.

Item > Background Color

Select a background color for the item.

Item > Background Picture Clip

Select a background picture from the Fishbeam Clips (

http://www.fishbeam.com/en/goldfish/clips.php) library. This option is only available if you have

the Fishbeam Clips library installed.
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Item > Background Picture

Select a background picture for the item. With Repeat, you can choose how the picture will be

displayed. On Retina websites the background picture will be displayed with double resolution,

but half the size (except SVG images).

Item > Repeat

Repeats the background picture.

 - Don't Repeat displays the picture only once.

 - Repeat tiles the picture over the entire space.

 - Repeat Horizontally tiles the image in a row.

 - Repeat Vertically tiles the image in a column.

 - Cut to Fill displays the image once over the entire space. Overlapping edges will be

cropped.

Item > Position Horizontal

Sets the horizontal position of the background picture. If the picture will be repeated, it will be

placed once on the specified position and the remaining space on the left, on the right, above

and below will be filled.

Item > Position Vertical

Sets the vertical position of the background picture. If the picture will be repeated, it will be

placed once on the specified position and the remaining space on the left, on the right, above

and below will be filled.

Item > Fix relative to Browser window

The position of the background picture is calculated on the basis of the browser window. The

picture is pined to the window and will not move when scrolling. The picture can be hidden or

only parts are visible if it is outside of the visible space.

Item > Border Left Width

Displays a border on the left side of the item in the choosen width (pixels).

Item > Border Left Color

Select a color for the left border.

Item > Border Right Width

Displays a border on the right side of the item in the choosen width (pixels).

Item > Border Right Color

Select a color for the right border.
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Item > Border Top Width

Displays a border on the top side of the item in the choosen width (pixels).

Item > Border Top Color

Select a color for the top border.

Item > Border Bottom Width

Displays a border on the bottom side of the item in the choosen width (pixels).

Item > Border Bottom Color

Select a color for the bottom border.

Item > Opacity (%) 

Makes the item transparent. From 0% (fully transparent) to 100% (completely visible).

Item > Rotation

Rotation of the object in a clockwise direction from 0° to 360°.

Item > Moving Mouse Over Animation PRO

Select an animation that you have previously created with an Animation item. The animation

will be started as soon as the website visitor moves the mouse over the item.

Item > Moving Mouse Out Animation PRO

Select an animation that you have previously created with an Animation item. The animation

will be started as soon as the website visitor moves the mouse from the item.

Follow & Share > Type

Choose what kind of buttons should be displayed.

 - Share Buttons shows buttons for sharing and liking of the current page.

 - Follow Buttons shows buttons for following you on social networks.

Follow & Share > Facebook

Displays a Facebook button. Enter your Facebook profile, if the type is Follow Buttons.

Follow & Share > Twitter

Displays a Twitter button. Enter your Twitter profile, if the type is Follow Buttons.

Follow & Share > YouTube

Available only for Type Follow Buttons. Displays a YouTube button. Enter your YouTube

profile.

Follow & Share > LinkedIn

Available only for Type Share Buttons. Displays a LinkedIn button.
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Follow & Share > LinkedIn (Personal)

Available only for Type Follow Buttons. Displays a LinkedIn button. Enter your personal

LinkedIn profile.

Follow & Share > LinkedIn (Company)

Available only for Type Follow Buttons. Displays a LinkedIn button. Enter the LinkedIn profile

of your company.

Follow & Share > Google+

Displays a Google+ button. Enter your Google+ profile, if the type is Follow Buttons.

Follow & Share > Flickr

Available only for Type Follow Buttons. Displays a Flickr button. Enter your Flickr profile.

Follow & Share > Vimeo

Available only for Type Follow Buttons. Displays a Vimeo button. Enter your Vimeo profile.

Follow & Share > Pinterest

Displays a Pinterest button. Enter your Pinterest profile, if the type is Follow Buttons.

Follow & Share > Instagram

Available only for Type Follow Buttons. Displays a Instagram button. Enter your Instagram

profile.

Follow & Share > Forsquare

Available only for Type Follow Buttons. Displays a Forsquare button. Enter your Forsquare

profile.

Follow & Share > Share More

Available only for Type Share Buttons. Displays a button for a selection of other options such

as printing, e-mail recommendation and lesser known social networks.
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Present a selection of images on your website. This works with a gallery item that you

can drag from the items to the website.

You can add a gallery to each area, slider area and area template. To add a gallery, edit the

content of an area, slider or area template and drag a gallery item from the items to the editor.

In a gallery you can present a selection of images to the site visitors. Usually a preview of the

images will be displayed on the page, that can be enlarged with a click.

But you can also run an automatic slide show on the page . Then all the pictures will be

displayed in sequence. As the transition between the pictures a fade effect will be used.

After adding a gallery item, this will be empty by default. Double click on it to add images. You

have several options to add images.

Edit Gallery > Add one picture

Select a picture from your hard disk to add it to the gallery.

Edit Gallery > Add from folder

Select a folder of pictures from your hard disk. Goldfish will add all these pictures to your

gallery.
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Edit Gallery > Delete all pictures

Deletes all pictures from your gallery.

Pictures in the formats .jpg, .png, .svg and .gif are supported. When you add one or more

pictures, the Import Media window will appear.

In the Import Media window, there are the following settings:

 - Name specifies the filename. Special characters or spaces should not be used for the file

name on websites. In addition, the name should not be too long. Because of this, Goldfish

shortens filenames, that are too long, to the correct length and removes all special

characters or spaces. If you do not like the filename, created by Goldfish, you can change it

here.

 - Description specifies a comment for the file. For images, you should always enter a

description here. This will act as a description for visually impaired people or will displayed

as the description in a gallery.

 - Reduce image size to max. resizes the image during import. The aspect ratio will be

retained. On websites you should resize all large images (for example, from a digital

camera) to reduce the file size and loading time. As a guideline we recommend

approximately 1000 x 1000 pixels. Please note that on retina websites the image will be

actually resized to twice the entered size, so it can be displayed in double resolution.

 - Rotate rotates images 90° to the left, 180° or 90° to the right. This allows you to correct the

orientation of images from digital cameras.

 - Flip horizontal flips the picture horizontally.

 - Flip vertical flips the picture vertically.

 - Apply to all applies all settings, made in the Media Import window, to all following files (only
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available when importing multiple files from a folder).

INFO: On Retina websites, all images will be displayed in double resolution, but with

half the size (except SVG images). The settings Reduce image size to max., Rotate, Flip

horizontal and Flip vertical are only available for images in the .jpg and .png format.

Once you have imported the pictures, they will be displayed as thumbnails in the gallery.

You can change the order of images by dragging them with the mouse. You can also delete an

image by clicking on the X icon next to it.

By right-clicking on a thumbnail and choosing Edit Comment... you can edit the description of a

picture after adding it. If you have finished editing of the gallery, click in the area next to the

gallery. This will quit the edit mode.
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Now you should look after the presentation of the pictures. There are several options are

available in the properties at Gallery > Type.

Classic
The type Classic will open a larger version on a separate page by clicking on a thumbnail. This

has the advantage that no Javascript is required and you are able to create a link to every

individual image of the gallery.

INFO: You can change the size and appearance of the thumbnails in the properties at 

Preview Icon and you can change the appearance of the pages for the full size pictures

at Gallery > Page Overlay. Gallery > Next picture after ... seconds will load the next

picture automatically after the specified time in the full size view.

Light Box
The type Light Box will open a larger version in the foreground of the page by clicking on a

thumbnail. The page will be overlaid with a semitransparent background.
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INFO: You can change the size and appearance of the thumbnails in the properties at 

Preview Icon and you can change the appearance of the background with that the page

will be overlaid at Gallery > Page Overlay. Gallery > Next picture after ... seconds will

load the next picture automatically after the specified time in the full size view.

Image Zoom
The type Image Zoom will open a larger version directly on the page by clicking on a

thumbnail.
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INFO: You can change the size and appearance of the thumbnails in the properties at 

Preview Icon and you can change the appearance of the background with that the page

will be overlaid optional at Gallery > Page Overlay.

Slide Show
The type Slide Show provides a full view of the current picture directly on the page.
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INFO: You can change the size and appearance of the thumbnails in the properties at 

Preview Icon and Gallery > Next picture after ... seconds will load the next picture

automatically after the specified time.

If you enter the value 0 in the properties at Gallery > Limit number of preview icons to and you

enable Gallery > Next picture after ... seconds, you will get a picture with automatically running

slide show.

Properties for Gallery Items
These properties can be set for a gallery item. Select a gallery item to see its properties.

Item > Identifier (Id)

Specifies the name of the item in order to address it in animations or as a link target. Use only

letters and numbers for the name, no spaces or special characters.

Item > Left

Sets the distance in pixels from the left side of the item to the area where the item is located.

Item > Top

Sets the distance in pixels from the top side of the item to the area where the item is located.

Item > Width

Sets the width of the item in pixels.

Item > Height

Sets the height of the item in pixels.
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Item > Padding Left

Sets the distance from the left side of the item to the content in pixels.

Item > Padding Right

Sets the distance from the right side of the item to the content in pixels.

Item > Padding Top

Sets the distance from the top side of the item to the content in pixels.

Item > Padding Bottom

Sets the distance from the bottom side of the item to the content in pixels.

Item > Background Color

Select a background color for the item.

Item > Background Picture Clip

Select a background picture from the Fishbeam Clips (

http://www.fishbeam.com/en/goldfish/clips.php) library. This option is only available if you have

the Fishbeam Clips library installed.

Item > Background Picture

Select a background picture for the item. With Repeat, you can choose how the picture will be

displayed. On Retina websites the background picture will be displayed with double resolution,

but half the size (except SVG images).

Item > Repeat

Repeats the background picture.

 - Don't Repeat displays the picture only once.

 - Repeat tiles the picture over the entire space.

 - Repeat Horizontally tiles the image in a row.

 - Repeat Vertically tiles the image in a column.

 - Cut to Fill displays the image once over the entire space. Overlapping edges will be

cropped.

Item > Position Horizontal

Sets the horizontal position of the background picture. If the picture will be repeated, it will be

placed once on the specified position and the remaining space on the left, on the right, above

and below will be filled.

Item > Position Vertical

Sets the vertical position of the background picture. If the picture will be repeated, it will be

placed once on the specified position and the remaining space on the left, on the right, above

and below will be filled.
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Item > Fix relative to Browser window

The position of the background picture is calculated on the basis of the browser window. The

picture is pined to the window and will not move when scrolling. The picture can be hidden or

only parts are visible if it is outside of the visible space.

Item > Border Left Width

Displays a border on the left side of the item in the choosen width (pixels).

Item > Border Left Color

Select a color for the left border.

Item > Border Right Width

Displays a border on the right side of the item in the choosen width (pixels).

Item > Border Right Color

Select a color for the right border.

Item > Border Top Width

Displays a border on the top side of the item in the choosen width (pixels).

Item > Border Top Color

Select a color for the top border.

Item > Border Bottom Width

Displays a border on the bottom side of the item in the choosen width (pixels).

Item > Border Bottom Color

Select a color for the bottom border.

Item > Opacity (%) 

Makes the item transparent. From 0% (fully transparent) to 100% (completely visible).

Item > Rotation

Rotation of the object in a clockwise direction from 0° to 360°.

Item > Moving Mouse Over Animation PRO

Select an animation that you have previously created with an Animation item. The animation

will be started as soon as the website visitor moves the mouse over the item.

Item > Moving Mouse Out Animation PRO

Select an animation that you have previously created with an Animation item. The animation

will be started as soon as the website visitor moves the mouse from the item.

- 153 -



18: Gallery

Gallery > Edit Content

Click here to edit the content of a gallery or double click on it.

Gallery > Type

Choose the type of the gallery. The type affects how the larger version of a thumbnail will be

presented.

 - Classic provides a gallery with subpages for the full view.

 - Light Box shows the large view of the pictures on a semitransparent background.

 - Image Zoom provides a gallery with thumbnails that can get enlarged.

 - Slide Show provides the full view of a picture directly on the page.

Gallery > Title

The title of your gallery. It will be shown on the presentation page in the title bar of the web

browser (only if you choose Classic as the Gallery > Type).

Gallery > Limit number of preview icons to

Limits the number of thumbnails. More pictures will be displayed while in full view, but not as a

thumbnail on the page (not available if you choose Image Zoom as the Gallery > Type).

Gallery >Next picture after ... seconds

Loads automatically the next picture after the specified time in full view (not available if you

choose Image Zoom as the Gallery > Type).

Gallery > Show description

Shows the comment of a picture in the full view below the picture.

Gallery > Font Style

Specifies the font style for the picture description. Activate a checkbox to set a style attribute

and override the global Font Template of the project.

 - Font specifies the font. Please note that the font must be installed on the computer the

website visitor to get displayed.

 - Style sets the style. Choose between Bold, Italic, Underline and Strikethrough.

 - Size specifies the font size in pixels.

 - Color sets the font color.

Please read the chapter Typography & Font Styles for more information about Font Styles and

Font Templates.

Gallery > Background Color

Background color for the picture description (only if you choose Image Zoom or Slideshow as

the Gallery > Type).
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Gallery > Page Overlay > Background Color

Select a background color for the full view.

Gallery > Page Overlay > Background Picture Clip

Select a background picture from the Fishbeam Clips (

http://www.fishbeam.com/en/goldfish/clips.php) library. This option is only available if you have

the Fishbeam Clips library installed.

Gallery > Page Overlay > Background Picture

Select a background picture for the full view. With Repeat, you can choose how the picture will

be displayed. On Retina websites the background picture will be displayed with double

resolution, but half the size (except SVG images).

Gallery > Page Overlay > Repeat

Repeats the background picture.

 - Don't Repeat displays the picture only once.

 - Repeat tiles the picture over the entire space.

 - Repeat Horizontally tiles the image in a row.

 - Repeat Vertically tiles the image in a column.

 - Cut to Fill displays the image once over the entire space. Overlapping edges will be

cropped.

Gallery > Page Overlay > Position Horizontal

Sets the horizontal position of the background picture. If the picture will be repeated, it will be

placed once on the specified position and the remaining space on the left, on the right, above

and below will be filled.

Gallery > Page Overlay > Position Vertical

Sets the vertical position of the background picture. If the picture will be repeated, it will be

placed once on the specified position and the remaining space on the left, on the right, above

and below will be filled.

Gallery > Page Overlay > Fix relative to Browser window

The position of the background picture is calculated on the basis of the browser window. The

picture is pined to the window and will not move when scrolling. The picture can be hidden or

only parts are visible if it is outside of the visible space.

Gallery > Page Overlay > Opacity (%)

Sets the opacity of the background (only if you choose Light Box or Image Zoom as the Gallery

> Type).
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Preview Icon > Icon Width (max)

Specifies the width of a thumbnail.

Preview Icon > Icon Height (max)

Specifies the height of a thumbnail.

Preview Icon > Image Matching

Specifies how a thumbnail will be displayed.

 - Keep Aspect Ratio resizes the thumbnail while maintaining the aspect ratio. The longest

side will be thumbnail with or height.

 - Cut to Fill resizes the thumbnail exactly to icon width and height. Overlapping edges will be

cut off.

 - Stretch to Fillresizes the thumbnail exactly to icon width and height. The picture will might

be distorted.

Preview Icon > Margin Horizontal

Sets the space between the bottom of a thumbnail and the top of the next thumbnail.

Preview Icon > Margin Vertical

Sets the space between the right of a thumbnail and the left of the next thumbnail.

Preview Icon > Padding Left

Sets the distance from the left side of of a thumbnail to the content in pixels.

Preview Icon > Padding Right

Sets the distance from the right side of of a thumbnail to the content in pixels.

Preview Icon > Padding Top

Sets the distance from the top side of of a thumbnail to the content in pixels.

Preview Icon > Padding Bottom

Sets the distance from the bottom side of of a thumbnail to the content in pixels.

Preview Icon > Background Color

Select a background color for a thumbnail.

Preview Icon > Background Picture Clip

Select a background picture from the Fishbeam Clips (

http://www.fishbeam.com/en/goldfish/clips.php) library. This option is only available if you have

the Fishbeam Clips library installed.

Preview Icon > Background Picture

Select a background picture for a thumbnail. With Repeat, you can choose how the picture will
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be displayed. On Retina websites the background picture will be displayed with double

resolution, but half the size (except SVG images).

Preview Icon > Repeat

Repeats the background picture.

 - Don't Repeat displays the picture only once.

 - Repeat tiles the picture over the entire space.

 - Repeat Horizontally tiles the image in a row.

 - Repeat Vertically tiles the image in a column.

 - Cut to Fill displays the image once over the entire space. Overlapping edges will be

cropped.

Preview Icon > Position Horizontal

Sets the horizontal position of the background picture. If the picture will be repeated, it will be

placed once on the specified position and the remaining space on the left, on the right, above

and below will be filled.

Preview Icon > Position Vertical

Sets the vertical position of the background picture. If the picture will be repeated, it will be

placed once on the specified position and the remaining space on the left, on the right, above

and below will be filled.

Preview Icon > Fix relative to Browser window

The position of the background picture is calculated on the basis of the browser window. The

picture is pined to the window and will not move when scrolling. The picture can be hidden or

only parts are visible if it is outside of the visible space.

Preview Icon > Border Left Width

Displays a border on the left side of of a thumbnail in the choosen width (pixels).

Preview Icon > Border Left Color

Select a color for the left border.

Preview Icon > Border Right Width

Displays a border on the right side of of a thumbnail in the choosen width (pixels).

Preview Icon > Border Right Color

Select a color for the right border.

Preview Icon > Border Top Width

Displays a border on the top side of of a thumbnail in the choosen width (pixels).
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Preview Icon > Border Top Color

Select a color for the top border.

Preview Icon > Border Bottom Width

Displays a border on the bottom side of of a thumbnail in the choosen width (pixels).

Preview Icon > Border Bottom Color

Select a color for the bottom border.
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Stay in touch with the website visitors and add a contact form. This works with a form

item that you can drag from the items to the website.

You can add a form item to each area, slider area and area template. To add a form item, edit

the content of an area, slider or area template and drag a form item from the items to the

editor.

A form let the visitors of your website get in touch with you. Usually he fills out the form, sends

it and you receive an e-mail with the form content. But you can also create custom forms, that

communicate with your own web applications and scripts.

Double click on the form to edit its content. You can reorder the form elements by dragging

them around. A click in the close widget of every element removes it from the form. Drag new

form elements from the items to the form. The following elements are available:

 - Text Field: Displays an one line text field in the form. This is used for entering short

information like names, e-mail addresses or passwords.

 - Multiline Text Field: Displays a large text field in the form. This is used for long text with

multiple lines.

 - Selection Element: Displays a list box, a popup menu or a set of radio boxes. This is used

to let the visitor choose from multiple options.

 - Checkbox:  Displays a checkbox in the form. This is used to accept or don't accept an

option.
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Double click on a form element to see its options. The options that are available depend on the

form element on that you have clicked.

Options for Text Fields

Name

Enter a name for the form element. This is important for custom forms. The name must be

unique in a form and can only contain letters, digits, _, and -.

Display Name

The name, which is displayed in the form and the e-mail with the form content.

Form element required

Enable this and the visitor must enter a value in this element. Otherwise the form can't be sent.

Default Text

The text field is filled with this text by default.

Field is destined for

Specify the data type, that can be entered here. Other input will be rejected as incorrect.

Mobile devices also display customized touch keyboards. For example, a keyboard appears

only with numbers for the data type Number. You can choose from the following data types.

 - Text allows input of any text.
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 - E-Mail Address allows only entering of e-mail addresses.

 - Password allows input of any text, but shows only "???" instead of the characters.

 - Phone Number lässt nur eine Eingabe von Telefonnummern zu.

 - Number allows only entering of phone numbers.

 - Internet Address (Url) allows only entering of an internet address.

 - Date only allows to enter a date. In iOS, a date chooser will be shown.

 - Time only allows to enter a time. In iOS, a time chooser will be shown.

Deactivate automatic spellcheck

Disables automatic spell checking and correction. For example, that is useful when entering

usernames.

Deactivate capitalizing of the first character

Disables automatic capitalization of the first character on mobile devices. For example, that is

useful when entering usernames.

Options for Multiline Text Fields

Name

Enter a name for the form element. This is important for custom forms. The name must be

unique in a form and can only contain letters, digits, _, and -.

Display Name

The name, which is displayed in the form and the e-mail with the form content.

Form element required

Enable this and the visitor must enter a value in this element. Otherwise the form can't be sent.

Default Text

The text field is filled with this text by default.

Height (Pixel)

The height of the text filed. If the visitor enters more text scrollbars will be shown.

Deactivate automatic spellcheck

Disables automatic spell checking and correction. For example, that is useful when entering

usernames.

Deactivate capitalizing of the first character

Disables automatic capitalization of the first character on mobile devices. For example, that is

useful when entering usernames.
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Options for Selection Elements

Name

Enter a name for the form element. This is important for custom forms. The name must be

unique in a form and can only contain letters, digits, _, and -.

Display Name

The name, which is displayed in the form and the e-mail with the form content.

Form element required

Enable this and the visitor must enter a value in this element. Otherwise the form can't be sent.

Selection Kind

Sets the type of the selection element: List, Popup Menu or Radio Boxes

Options

Add or remove options from which the visitor can choose. Every option has a value for internal

use and a display name which is displayed in e-mails and in the form. If you enable Selected,

the option will be selected by default.

Height (Pixel)

The height of the list box (list box only).

Multiple selection

The user can select multiple options in the list box (list box only).

Options for Checkboxes

Name

Enter a name for the form element. This is important for custom forms. The name must be

unique in a form and can only contain letters, digits, _, and -.

Display Name

The name, which is displayed in the form and the e-mail with the form content.

Form element required

Enable this and the visitor must enter a value in this element. Otherwise the form can't be sent.

Checked

The checkbox is checked by default.
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To send the form to your e-mail account, it is required that you enter your e-mail address at 

Send Page > E-Mail Address in the properties. Goldfish can use the entered email address of

the visitor as a response e-mail address. For this you have to choose E-Mail Address at Field

is destined for at least at one text field. Double click on a single-line text field and make this

setting.

Exit the editing of the form. There is a list of all the e-mail text fields at E-Mail > Reply E-Mail.

Select a text field as the response e-mail address.

ReCaptcha Spam Protection
To protect yourself from SPAM e-mails, you can enable the ReCAPTCHA spam protection.

Then, the site visitors will have to read and write letters from an image for sending send the

form. This is difficult for automated spam robots, so no, or only a little junk mail will be sent.

Enable the reCaptcha spam protection in the properties at Form > ReCAPTCHA Spam

Protection.

ReCAPTCHA is a free service from Google. You need to register with Google to use the

feature. To do this, click the on arrow behind the explanation in the properties to go to the

ReCAPTCHA website. After registration you will receive two 40-character keys. Enter them

into the fields  Form > ReCAPTCHA Public Key and Form > ReCaptcha Private Key.

E-Mail Sending Problems
If there are any problems, when sending emails (emails won't be delivered), check the

following:

Is the specified recipient e-mail address correct? This is the easiest and most common

mistake. Correct the address and try it again.

Are there requirements for sending e-mails via the PHP function mail() from your web

hosting service? Many web hosting services do have guidelines to protect against spam

emails. Sometimes a return e-mail address must be entered in the customer login area of the
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web hosting service. Or only email addresses, that belong to your Internet domain, are

allowed. Check that with your web hosting service support.

Use External SMTP Server
If all of that fails, you can still use an external SMTP server. For this, activate the

corresponding property at E-Mail > Use external SMTP server.

Enter the login data of an e-mail SMTP server in the properties at E-Mail > SMTP Server, 

E-Mail > SMTP User and E-Mail > SMTP Password. You will get this information from your

email service provider or from your email client.

INFO: If the PHP function mail() does not work, usually an external SMTP server does

and vice versa. However, there are a few web hosting services, where both options are

working.

INFO: This item uses PHP. Your webserver must support PHP to use it.

Properties for Form Items
These properties can be set for a form item. Select a form item to see its properties.

Item > Identifier (Id)

Specifies the name of the item in order to address it in animations or as a link target. Use only

letters and numbers for the name, no spaces or special characters.

Item > Left

Sets the distance in pixels from the left side of the item to the area where the item is located.

Item > Top

Sets the distance in pixels from the top side of the item to the area where the item is located.

Item > Width

Sets the width of the item in pixels.

Item > Height

Sets the height of the item in pixels.
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Item > Padding Left

Sets the distance from the left side of the item to the content in pixels.

Item > Padding Right

Sets the distance from the right side of the item to the content in pixels.

Item > Padding Top

Sets the distance from the top side of the item to the content in pixels.

Item > Padding Bottom

Sets the distance from the bottom side of the item to the content in pixels.

Item > Background Color

Select a background color for the item.

Item > Background Picture Clip

Select a background picture from the Fishbeam Clips (

http://www.fishbeam.com/en/goldfish/clips.php) library. This option is only available if you have

the Fishbeam Clips library installed.

Item > Background Picture

Select a background picture for the item. With Repeat, you can choose how the picture will be

displayed. On Retina websites the background picture will be displayed with double resolution,

but half the size (except SVG images).

Item > Repeat

Repeats the background picture.

 - Don't Repeat displays the picture only once.

 - Repeat tiles the picture over the entire space.

 - Repeat Horizontally tiles the image in a row.

 - Repeat Vertically tiles the image in a column.

 - Cut to Fill displays the image once over the entire space. Overlapping edges will be

cropped.

Item > Position Horizontal

Sets the horizontal position of the background picture. If the picture will be repeated, it will be

placed once on the specified position and the remaining space on the left, on the right, above

and below will be filled.

Item > Position Vertical

Sets the vertical position of the background picture. If the picture will be repeated, it will be

placed once on the specified position and the remaining space on the left, on the right, above

and below will be filled.
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Item > Fix relative to Browser window

The position of the background picture is calculated on the basis of the browser window. The

picture is pined to the window and will not move when scrolling. The picture can be hidden or

only parts are visible if it is outside of the visible space.

Item > Border Left Width

Displays a border on the left side of the item in the choosen width (pixels).

Item > Border Left Color

Select a color for the left border.

Item > Border Right Width

Displays a border on the right side of the item in the choosen width (pixels).

Item > Border Right Color

Select a color for the right border.

Item > Border Top Width

Displays a border on the top side of the item in the choosen width (pixels).

Item > Border Top Color

Select a color for the top border.

Item > Border Bottom Width

Displays a border on the bottom side of the item in the choosen width (pixels).

Item > Border Bottom Color

Select a color for the bottom border.

Item > Opacity (%) 

Makes the item transparent. From 0% (fully transparent) to 100% (completely visible).

Item > Rotation

Rotation of the object in a clockwise direction from 0° to 360°.

Item > Moving Mouse Over Animation PRO

Select an animation that you have previously created with an Animation item. The animation

will be started as soon as the website visitor moves the mouse over the item.

Item > Moving Mouse Out Animation PRO

Select an animation that you have previously created with an Animation item. The animation

will be started as soon as the website visitor moves the mouse from the item.

- 166 -



19: Form

Form > Form Type

Sets the type of the form: E-Mail Form or Custom Form.

Form > Internet Address

The internet address to which the form will be sent (custom forms only). At this address there

must be a script which handles the form data.

Form > Send Method

Sets the send method Get or Post (custom forms only).

Form > Margin Horizontal

Sets the space between two form elements.

Form > Font Style

Sets the font style for the form. Activate a checkbox to set a style attribute and override the

global Font Template of the project.

 - Font specifies the font. Please note that the font must be installed on the computer the

website visitor to get displayed.

 - Style sets the style. Choose between Bold, Italic, Underline and Strikethrough.

 - Size specifies the font size in pixels.

 - Color sets the font color.

Please read the chapter Typography & Font Styles for more information about Font Styles and

Font Templates.

Form > Color for Errors

Select the color in that submission errors will be displayed.

Form > Edit Content

Click here to edit the content of the form item or double click on it.

Form > ReCaptcha Spam Protection

Enables the ReCaptcha spam protection. You have to sign in at Google ReCaptcha to use this

service.

Form > ReCaptcha Public Key

Enter the received Google ReCaptcha website key here.

Form > ReCaptcha Private Key

Enter the received Google ReCaptcha private key here.

Form > Send Button

Enable this and the form has a send button. Enter the caption of the button.
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Form > Custom Button Picture

Choose your your own button picture, if you do not like the standard send-button.

Visual Effects
You can specify a visual effect, if the user interacts with the send-button (e.g., replace the

picture if the visitor moves the mouse over the button). The following properties are the same

for Moving Mouse Over Link Effect and Clicking On Link Effect.

Effect > Change Picture

Changes the picture. Select a picture to which you want to change.

Properties for Form Items

E-Mail > E-Mail Address

Sets the e-mail address to which the form should be sent.

E-Mail > Use external SMTP server

Allows you to send emails through an SMTP server. Enable this option if you encounter

problems when sending emails.

E-Mail > SMTP Server

Enter your SMTP server. You can get this information from your e-mail provider or your email

client.

E-Mail > SMTP User

Enter your SMTP user. You can get this information from your e-mail provider or your email

client.

E-Mail > SMTP Password

Enter your SMTP password. You can get this information from your e-mail provider or your

email client.

E-Mail > Show message with contact e-mail address if a mail error occures

If an error occurs when the form was submitted, the recipient's e-mail address will be visible

directly. So site visitors can then direct contact you via email.

E-Mail > Message

The message that appears to contact via email. Write. %s as a placeholder for the e-mail

address.

E-Maile > E-Mail Subject

Sets the subject of the form e-mail.
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E-Mail > Sent Message

Sets the message, that will be displayed to the visitor if the form was sent successfully.

E-Mail > Reply E-Mail

Select the e-mail text field that contains the email address of the website visitor.
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Add a visitor counter to your website. With a visitor counter you can show the number

of visitors of your website.

You can add a visitor counter to each area, slider area and area template. To add a visitor

counter, edit the content of an area, slider or area template and drag a visitor counter item

from the items to the editor.

A visitor counter counts every visitor of your website and displays the number of visitors as a

picture. Returning visiors are counted once in 24 hours. Change the properties from the

section Visitor Counter from the properties to change the style of the counter.

The property Visitor Counter > Style sets the style of the counter. You can choose from a

couple of styles in different colors. Visitor Counter > Digits sets the size of the counter. If the

counter reading is too big for the number of digits, the last digits will be cut off.
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INFO: If you have Goldfish Clips (http://www.fishbeam.com/en/goldfish/clips.php)

installed, there are many more counter styles available. If not, there are only seven built

in styles.

If you don't like the built in styles, you can create a custom counter picture. The counter picture

is a small image with the digits 0 to 9 on it. The counter script cuts out every digit which is

needed, and puts them together to the displayed counter reading.

Choose Custom Style at Visitor Counter > Style from the properties and select your created

counter picture. On Retina websites your counter picture will be displayed in double resolution,

but half the size.

INFO: This item uses PHP. Your webserver must support PHP to use it.

Properties for Visitor Counters
These properties can be set for a visitor counter. Select a visitor counter to see its properties.

Item > Identifier (Id)

Specifies the name of the item in order to address it in animations or as a link target. Use only

letters and numbers for the name, no spaces or special characters.

Item > Left

Sets the distance in pixels from the left side of the item to the area where the item is located.

Item > Top

Sets the distance in pixels from the top side of the item to the area where the item is located.

Item > Width

Sets the width of the item in pixels.

Item > Height

Sets the height of the item in pixels.

Item > Padding Left

Sets the distance from the left side of the item to the content in pixels.

Item > Padding Right

Sets the distance from the right side of the item to the content in pixels.
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Item > Padding Top

Sets the distance from the top side of the item to the content in pixels.

Item > Padding Bottom

Sets the distance from the bottom side of the item to the content in pixels.

Item > Background Color

Select a background color for the item.

Item > Background Picture Clip

Select a background picture from the Fishbeam Clips (

http://www.fishbeam.com/en/goldfish/clips.php) library. This option is only available if you have

the Fishbeam Clips library installed.

Item > Background Picture

Select a background picture for the item. With Repeat, you can choose how the picture will be

displayed. On Retina websites the background picture will be displayed with double resolution,

but half the size (except SVG images).

Item > Repeat

Repeats the background picture.

 - Don't Repeat displays the picture only once.

 - Repeat tiles the picture over the entire space.

 - Repeat Horizontally tiles the image in a row.

 - Repeat Vertically tiles the image in a column.

 - Cut to Fill displays the image once over the entire space. Overlapping edges will be

cropped.

Item > Position Horizontal

Sets the horizontal position of the background picture. If the picture will be repeated, it will be

placed once on the specified position and the remaining space on the left, on the right, above

and below will be filled.

Item > Position Vertical

Sets the vertical position of the background picture. If the picture will be repeated, it will be

placed once on the specified position and the remaining space on the left, on the right, above

and below will be filled.

Item > Fix relative to Browser window

The position of the background picture is calculated on the basis of the browser window. The

picture is pined to the window and will not move when scrolling. The picture can be hidden or

only parts are visible if it is outside of the visible space.
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Item > Border Left Width

Displays a border on the left side of the item in the choosen width (pixels).

Item > Border Left Color

Select a color for the left border.

Item > Border Right Width

Displays a border on the right side of the item in the choosen width (pixels).

Item > Border Right Color

Select a color for the right border.

Item > Border Top Width

Displays a border on the top side of the item in the choosen width (pixels).

Item > Border Top Color

Select a color for the top border.

Item > Border Bottom Width

Displays a border on the bottom side of the item in the choosen width (pixels).

Item > Border Bottom Color

Select a color for the bottom border.

Item > Opacity (%) 

Makes the item transparent. From 0% (fully transparent) to 100% (completely visible).

Item > Rotation

Rotation of the object in a clockwise direction from 0° to 360°.

Item > Moving Mouse Over Animation PRO

Select an animation that you have previously created with an Animation item. The animation

will be started as soon as the website visitor moves the mouse over the item.

Item > Moving Mouse Out Animation PRO

Select an animation that you have previously created with an Animation item. The animation

will be started as soon as the website visitor moves the mouse from the item.

Visitor Counter > Style

Select style for your counter.

Visitor Counter > Counter Picture

Select a custom counter picture if you want to use a custom style for your counter. On Retina

websites your counter picture will be displayed in double resolution, but half the size.
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Visitor Counter > Digits

Sets the number of digits that the counter displays.
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21. Path & Sitemap
Show a sitemap or the path back to the start page. This works with a path & sitemap

item that you can drag from the items to the website.

You can add a path & sitemap item to each area, slider area and area template. To add a path

& sitemap item, edit the content of an area, slider or area template and drag a path & sitemap

item from the items to the editor.

A path & sitemap item shows either the path back to the start page or an overview of all pages

and subpages of the website (sitemap).

Select which of the two options you want to be displayed on the page at Path & Sitemap >

Type in the properties.

Path
Path shows the path back to start page. Each entry can be clicked as a link to go to the

corresponding page.

Sitemap
Sitemap shows an overview of all pages and subpages of the website (sitemap). Each entry

can be clicked as a link to go to the corresponding page. Pages, with the deactivated property 
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Page > Menu Title, will not appear in the sitemap.

By default, the path & sitemap item begins in the top hierarchy level of the website with the

Start Page. The Start Page with sub pages will be displayed in the path & sitemap item.

If you want to display a different section of the page hierarchy as the path or sitemap, you can

change the base folder in the properties at Path & Sitemap > Base Folder. So you can display

only the mobile Start Page with sub pages as the path or sitemap for example.

Properties for Path & Sitemap Items
These properties can be set for a path & sitemap item. Select a path & sitemap item to see its

properties.

Item > Identifier (Id)

Specifies the name of the item in order to address it in animations or as a link target. Use only

letters and numbers for the name, no spaces or special characters.

Item > Left

Sets the distance in pixels from the left side of the item to the area where the item is located.

Item > Top

Sets the distance in pixels from the top side of the item to the area where the item is located.

Item > Width

Sets the width of the item in pixels.

Item > Height

Sets the height of the item in pixels.
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Item > Padding Left

Sets the distance from the left side of the item to the content in pixels.

Item > Padding Right

Sets the distance from the right side of the item to the content in pixels.

Item > Padding Top

Sets the distance from the top side of the item to the content in pixels.

Item > Padding Bottom

Sets the distance from the bottom side of the item to the content in pixels.

Item > Background Color

Select a background color for the item.

Item > Background Picture Clip

Select a background picture from the Fishbeam Clips (

http://www.fishbeam.com/en/goldfish/clips.php) library. This option is only available if you have

the Fishbeam Clips library installed.

Item > Background Picture

Select a background picture for the item. With Repeat, you can choose how the picture will be

displayed. On Retina websites the background picture will be displayed with double resolution,

but half the size (except SVG images).

Item > Repeat

Repeats the background picture.

 - Don't Repeat displays the picture only once.

 - Repeat tiles the picture over the entire space.

 - Repeat Horizontally tiles the image in a row.

 - Repeat Vertically tiles the image in a column.

 - Cut to Fill displays the image once over the entire space. Overlapping edges will be

cropped.

Item > Position Horizontal

Sets the horizontal position of the background picture. If the picture will be repeated, it will be

placed once on the specified position and the remaining space on the left, on the right, above

and below will be filled.

Item > Position Vertical

Sets the vertical position of the background picture. If the picture will be repeated, it will be

placed once on the specified position and the remaining space on the left, on the right, above

and below will be filled.
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Item > Fix relative to Browser window

The position of the background picture is calculated on the basis of the browser window. The

picture is pined to the window and will not move when scrolling. The picture can be hidden or

only parts are visible if it is outside of the visible space.

Item > Border Left Width

Displays a border on the left side of the item in the choosen width (pixels).

Item > Border Left Color

Select a color for the left border.

Item > Border Right Width

Displays a border on the right side of the item in the choosen width (pixels).

Item > Border Right Color

Select a color for the right border.

Item > Border Top Width

Displays a border on the top side of the item in the choosen width (pixels).

Item > Border Top Color

Select a color for the top border.

Item > Border Bottom Width

Displays a border on the bottom side of the item in the choosen width (pixels).

Item > Border Bottom Color

Select a color for the bottom border.

Item > Opacity (%) 

Makes the item transparent. From 0% (fully transparent) to 100% (completely visible).

Item > Rotation

Rotation of the object in a clockwise direction from 0° to 360°.

Item > Moving Mouse Over Animation PRO

Select an animation that you have previously created with an Animation item. The animation

will be started as soon as the website visitor moves the mouse over the item.

Item > Moving Mouse Out Animation PRO

Select an animation that you have previously created with an Animation item. The animation

will be started as soon as the website visitor moves the mouse from the item.
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Path & Sitemap > Type

Specify what will be displayed.

 - Path shows the path back to start page.

 - Sitemap shows an overview of all pages and subpages of the website (sitemap).

Path & Sitemap > Base Folder

Choose a page with subpages that appear as the path or sitemap. The default is the Start

Page, but you can change this property to display sections or the mobile website.

Path & Sitemap > Show base folder as entry

Displays the selected page from Path & Sitemap > Base Folder in the path or sitemap. When

you disable this property, only is subpages will be displayed.

Path & Sitemap > Entry Width

Sets the width of an entry in the sitemap.

Path & Sitemap > Margin Horizontal

Sets the space between two blocks in the Sitemap that are below each other.

Path & Sitemap > Font Style

The font style for the list item (sitemap) or the separator (path). Activate a checkbox to set a

style attribute and override the global Font Template of the project.

 - Font specifies the font. Please note that the font must be installed on the computer the

website visitor to get displayed.

 - Style sets the style. Choose between Bold, Italic, Underline and Strikethrough.

 - Size specifies the font size in pixels.

 - Color sets the font color.

Please read the chapter Typography & Font Styles for more information about Font Styles and

Font Templates.

Path & Sitemap > Bulletpoint

Select the bullet for the Sitemap.

Path & Sitemap > Padding Left

Sets the space between a list bullet and an entry.

Path & Sitemap > Bullet Picture

Choose a bullet picture for the list (only at Bulletpoint: Bullet Picture.

Path & Sitemap > Delemiter

Delemiter between two links from the path. The default value is >.
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Link Style > Font Style

Specifies the font style for links. Activate a checkbox to set a style attribute and override the

global Font Template of the project.

 - Font specifies the font. Please note that the font must be installed on the computer the

website visitor to get displayed.

 - Style sets the style. Choose between Bold, Italic, Underline and Strikethrough.

 - Size specifies the font size in pixels.

 - Color sets the font color.

Please read the chapter Typography & Font Styles for more information about Font Styles and

Font Templates.

Visual Effects
You can specify a visual effect, if a website visitor interacts with a link (e.g. change the color if

the visitor moves the mouse over the link). The following properties are the same for Moving

Mouse Over Link Effect, Clicking on Link Effect and Already Visited Link Effect.

Effect > Change Font

Changes the font style of a link.

Effect > Font Style

Specifies the font style, to which you want to change. Activate a checkbox to set a style

attribute and override the global Font Template of the project.

 - Font specifies the font. Please note that the font must be installed on the computer the

website visitor to get displayed.

 - Style sets the style. Choose between Bold, Italic, Underline and Strikethrough.

 - Size specifies the font size in pixels.

 - Color sets the font color.

Please read the chapter Typography & Font Styles for more information about Font Styles and

Font Templates.
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Show an external website, embedded directly on your website. This works with a

website frame item that you can drag from the items to the website.

You can add a website frame item to each area, slider area and area template. To add a

website frame item, edit the content of an area, slider or area template and drag a website

frame item from the items to the editor.

A website frame item shows an external website directly on your page. For example you can

include a forum or other web application, which Goldfish does not support directly. Enter the

website address (url) of the external website at Website Frame > Url of Frame Content.

Properties for Website Frame Items
These properties can be set for a website frame item. Select a website frame item to see its

properties.

Item > Identifier (Id)

Specifies the name of the item in order to address it in animations or as a link target. Use only

letters and numbers for the name, no spaces or special characters.

Item > Left

Sets the distance in pixels from the left side of the item to the area where the item is located.

Item > Top

Sets the distance in pixels from the top side of the item to the area where the item is located.

- 181 -



22: Website Frame

Item > Width

Sets the width of the item in pixels.

Item > Height

Sets the height of the item in pixels.

Item > Padding Left

Sets the distance from the left side of the item to the content in pixels.

Item > Padding Right

Sets the distance from the right side of the item to the content in pixels.

Item > Padding Top

Sets the distance from the top side of the item to the content in pixels.

Item > Padding Bottom

Sets the distance from the bottom side of the item to the content in pixels.

Item > Background Color

Select a background color for the item.

Item > Background Picture Clip

Select a background picture from the Fishbeam Clips (

http://www.fishbeam.com/en/goldfish/clips.php) library. This option is only available if you have

the Fishbeam Clips library installed.

Item > Background Picture

Select a background picture for the item. With Repeat, you can choose how the picture will be

displayed. On Retina websites the background picture will be displayed with double resolution,

but half the size (except SVG images).

Item > Repeat

Repeats the background picture.

 - Don't Repeat displays the picture only once.

 - Repeat tiles the picture over the entire space.

 - Repeat Horizontally tiles the image in a row.

 - Repeat Vertically tiles the image in a column.

 - Cut to Fill displays the image once over the entire space. Overlapping edges will be

cropped.

Item > Position Horizontal

Sets the horizontal position of the background picture. If the picture will be repeated, it will be

placed once on the specified position and the remaining space on the left, on the right, above
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and below will be filled.

Item > Position Vertical

Sets the vertical position of the background picture. If the picture will be repeated, it will be

placed once on the specified position and the remaining space on the left, on the right, above

and below will be filled.

Item > Fix relative to Browser window

The position of the background picture is calculated on the basis of the browser window. The

picture is pined to the window and will not move when scrolling. The picture can be hidden or

only parts are visible if it is outside of the visible space.

Item > Border Left Width

Displays a border on the left side of the item in the choosen width (pixels).

Item > Border Left Color

Select a color for the left border.

Item > Border Right Width

Displays a border on the right side of the item in the choosen width (pixels).

Item > Border Right Color

Select a color for the right border.

Item > Border Top Width

Displays a border on the top side of the item in the choosen width (pixels).

Item > Border Top Color

Select a color for the top border.

Item > Border Bottom Width

Displays a border on the bottom side of the item in the choosen width (pixels).

Item > Border Bottom Color

Select a color for the bottom border.

Item > Opacity (%) 

Makes the item transparent. From 0% (fully transparent) to 100% (completely visible).

Item > Rotation

Rotation of the object in a clockwise direction from 0° to 360°.
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Item > Moving Mouse Over Animation PRO

Select an animation that you have previously created with an Animation item. The animation

will be started as soon as the website visitor moves the mouse over the item.

Item > Moving Mouse Out Animation PRO

Select an animation that you have previously created with an Animation item. The animation

will be started as soon as the website visitor moves the mouse from the item.

Website Frame > Url of Frame Content

Enter the url of the external website, that you want to display.

Website Frame > Show scrollbars if required

Enable this option and scrollbars will be shown if the external website is bigger than the frame.

Otherwise the content will be cut off.

- 184 -



23. HTML Code
Add code snippets and expand the functionality of Goldfish. This works with a HTML

code item that you can drag from the items to the website.

You can add a HTML code item to each area, slider area and area template. To add a HTML

code item, edit the content of an area, slider or area template and drag a HTML code item from

the items to the editor.

An HTML code item displays every piece of HTML code, that you want. For example, you can

display a Google Maps (http://www.google.com/maps) map on your website and show your

page visitors where you are.

Paste the HTML code pice in the code editor. To open the code editor click on HTML Code >

HTML Code in the properties. A HTML code item is the only place where you can store HTML

code in Goldfish Standard. If you need more possibilities to enter HTML or CSS code, please

upgrade to Goldfish Professional and use the tab Code on the top left side of the toolbar.
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Properties for HTML Code items
These properties can be set for a HTML code item. Select a HTML code item to see its

properties.

Item > Identifier (Id)

Specifies the name of the item in order to address it in animations or as a link target. Use only

letters and numbers for the name, no spaces or special characters.

Item > Left

Sets the distance in pixels from the left side of the item to the area where the item is located.

Item > Top

Sets the distance in pixels from the top side of the item to the area where the item is located.

Item > Width

Sets the width of the item in pixels.

Item > Height

Sets the height of the item in pixels.

Item > Padding Left

Sets the distance from the left side of the item to the content in pixels.

- 186 -



23: HTML Code

Item > Padding Right

Sets the distance from the right side of the item to the content in pixels.

Item > Padding Top

Sets the distance from the top side of the item to the content in pixels.

Item > Padding Bottom

Sets the distance from the bottom side of the item to the content in pixels.

Item > Background Color

Select a background color for the item.

Item > Background Picture Clip

Select a background picture from the Fishbeam Clips (

http://www.fishbeam.com/en/goldfish/clips.php) library. This option is only available if you have

the Fishbeam Clips library installed.

Item > Background Picture

Select a background picture for the item. With Repeat, you can choose how the picture will be

displayed. On Retina websites the background picture will be displayed with double resolution,

but half the size (except SVG images).

Item > Repeat

Repeats the background picture.

 - Don't Repeat displays the picture only once.

 - Repeat tiles the picture over the entire space.

 - Repeat Horizontally tiles the image in a row.

 - Repeat Vertically tiles the image in a column.

 - Cut to Fill displays the image once over the entire space. Overlapping edges will be

cropped.

Item > Position Horizontal

Sets the horizontal position of the background picture. If the picture will be repeated, it will be

placed once on the specified position and the remaining space on the left, on the right, above

and below will be filled.

Item > Position Vertical

Sets the vertical position of the background picture. If the picture will be repeated, it will be

placed once on the specified position and the remaining space on the left, on the right, above

and below will be filled.
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Item > Fix relative to Browser window

The position of the background picture is calculated on the basis of the browser window. The

picture is pined to the window and will not move when scrolling. The picture can be hidden or

only parts are visible if it is outside of the visible space.

Item > Border Left Width

Displays a border on the left side of the item in the choosen width (pixels).

Item > Border Left Color

Select a color for the left border.

Item > Border Right Width

Displays a border on the right side of the item in the choosen width (pixels).

Item > Border Right Color

Select a color for the right border.

Item > Border Top Width

Displays a border on the top side of the item in the choosen width (pixels).

Item > Border Top Color

Select a color for the top border.

Item > Border Bottom Width

Displays a border on the bottom side of the item in the choosen width (pixels).

Item > Border Bottom Color

Select a color for the bottom border.

Item > Opacity (%) 

Makes the item transparent. From 0% (fully transparent) to 100% (completely visible).

Item > Rotation

Rotation of the object in a clockwise direction from 0° to 360°.

Item > Moving Mouse Over Animation PRO

Select an animation that you have previously created with an Animation item. The animation

will be started as soon as the website visitor moves the mouse over the item.

Item > Moving Mouse Out Animation PRO

Select an animation that you have previously created with an Animation item. The animation

will be started as soon as the website visitor moves the mouse from the item.
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HTML Code > HTML Code

Enter the html code which should be included.
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24. Search Field
Offer a full text search on your website. This works with a search field item that you can

drag from the items to the website.

You can add a search field to each area, slider area and area template. To add a search field,

edit the content of an area, slider or area template and drag a search field item from the items

to the editor.

A search field item provides a full text search for your website. All pages in that the searched

term can be found, will be displayed with the menu title. Clicking on a result leads to the

appropriate page.

The design of a search field and the results can be fully customized. Enter the text you want to

appear as a placeholder in the properties at Search Field > Placeholder Text. You can choose

colours, the background and the font style of the result list in the properties at Result Links.

The search field offers two different ways to present the search results. You can select that in

the properties at Search Field > Results.

 - Below When Typing displays the search results live when typing, directly below the search

field.

 - Overlay Page displays the search results on top of the website only after pressing the enter

key.
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Set the maximum number of search results in the properties at Search Field > Limited Search

Result to.

Individual pages can be excluded from the search. Enable Page> Exclude page from search in

the properties of a page.

Properties for Search Field Items
These properties can be set for a search field item. Select a search field item to see its

properties.

Item > Identifier (Id)

Specifies the name of the item in order to address it in animations or as a link target. Use only

letters and numbers for the name, no spaces or special characters.

Item > Left

Sets the distance in pixels from the left side of the item to the area where the item is located.

Item > Top

Sets the distance in pixels from the top side of the item to the area where the item is located.

Item > Width

Sets the width of the item in pixels.

Item > Height

Sets the height of the item in pixels.

Item > Padding Left

Sets the distance from the left side of the item to the content in pixels.

Item > Padding Right

Sets the distance from the right side of the item to the content in pixels.

Item > Padding Top

Sets the distance from the top side of the item to the content in pixels.

Item > Padding Bottom

Sets the distance from the bottom side of the item to the content in pixels.

Item > Background Color

Select a background color for the item.
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Item > Background Picture Clip

Select a background picture from the Fishbeam Clips (

http://www.fishbeam.com/en/goldfish/clips.php) library. This option is only available if you have

the Fishbeam Clips library installed.

Item > Background Picture

Select a background picture for the item. With Repeat, you can choose how the picture will be

displayed. On Retina websites the background picture will be displayed with double resolution,

but half the size (except SVG images).

Item > Repeat

Repeats the background picture.

 - Don't Repeat displays the picture only once.

 - Repeat tiles the picture over the entire space.

 - Repeat Horizontally tiles the image in a row.

 - Repeat Vertically tiles the image in a column.

 - Cut to Fill displays the image once over the entire space. Overlapping edges will be

cropped.

Item > Position Horizontal

Sets the horizontal position of the background picture. If the picture will be repeated, it will be

placed once on the specified position and the remaining space on the left, on the right, above

and below will be filled.

Item > Position Vertical

Sets the vertical position of the background picture. If the picture will be repeated, it will be

placed once on the specified position and the remaining space on the left, on the right, above

and below will be filled.

Item > Fix relative to Browser window

The position of the background picture is calculated on the basis of the browser window. The

picture is pined to the window and will not move when scrolling. The picture can be hidden or

only parts are visible if it is outside of the visible space.

Item > Border Left Width

Displays a border on the left side of the item in the choosen width (pixels).

Item > Border Left Color

Select a color for the left border.

Item > Border Right Width

Displays a border on the right side of the item in the choosen width (pixels).
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Item > Border Right Color

Select a color for the right border.

Item > Border Top Width

Displays a border on the top side of the item in the choosen width (pixels).

Item > Border Top Color

Select a color for the top border.

Item > Border Bottom Width

Displays a border on the bottom side of the item in the choosen width (pixels).

Item > Border Bottom Color

Select a color for the bottom border.

Item > Opacity (%) 

Makes the item transparent. From 0% (fully transparent) to 100% (completely visible).

Item > Rotation

Rotation of the object in a clockwise direction from 0° to 360°.

Item > Moving Mouse Over Animation PRO

Select an animation that you have previously created with an Animation item. The animation

will be started as soon as the website visitor moves the mouse over the item.

Item > Moving Mouse Out Animation PRO

Select an animation that you have previously created with an Animation item. The animation

will be started as soon as the website visitor moves the mouse from the item.

Search Field > Background Color

Sets the background color in the search field.

Search Field > Border Color

Sets the color of the border around the search field.

Search Field > Font Style

Specifies the font style entered text in the search field. Activate a checkbox to set a style

attribute and override the global Font Template of the project.

 - Font specifies the font. Please note that the font must be installed on the computer the

website visitor to get displayed.

 - Style sets the style. Choose between Bold, Italic, Underline and Strikethrough.

 - Size specifies the font size in pixels.

 - Color sets the font color.

Please read the chapter Typography & Font Styles for more information about Font Styles and
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Font Templates.

Search Field > Placeholder Text

This text will be displayed as a placeholder in the search field, as long as no text has been

entered.

Search Field > Font Color

Text color of the placeholder text.

Search Field > Results

Select how search results will be displayed.

 - Below When Typing displays the search results live when typing, directly below the search

field.

 - Overlay Page displays the search results on top of the website only after pressing the enter

key.

Search Field > Limit Search Result to

Maximum number of displayed search results.

Search Field > Page Overlay > Background Color

Select a background color for the search result.

Search Field > Page Overlay > Background Picture Clip

Select a background picture from the Fishbeam Clips (

http://www.fishbeam.com/en/goldfish/clips.php) library. This option is only available if you have

the Fishbeam Clips library installed.

Search Field > Page Overlay > Background Picture

Select a background picture for the search result. With Repeat, you can choose how the

picture will be displayed. On Retina websites the background picture will be displayed with

double resolution, but half the size (except SVG images).

Search Field > Page Overlay > Repeat

Repeats the background picture.

 - Don't Repeat displays the picture only once.

 - Repeat tiles the picture over the entire space.

 - Repeat Horizontally tiles the image in a row.

 - Repeat Vertically tiles the image in a column.

 - Cut to Fill displays the image once over the entire space. Overlapping edges will be

cropped.
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Search Field > Page Overlay > Position Horizontal

Sets the horizontal position of the background picture. If the picture will be repeated, it will be

placed once on the specified position and the remaining space on the left, on the right, above

and below will be filled.

Search Field > Page Overlay > Position Vertical

Sets the vertical position of the background picture. If the picture will be repeated, it will be

placed once on the specified position and the remaining space on the left, on the right, above

and below will be filled.

Search Field > Page Overlay > Fix relative to Browser window

The position of the background picture is calculated on the basis of the browser window. The

picture is pined to the window and will not move when scrolling. The picture can be hidden or

only parts are visible if it is outside of the visible space.

Search Field > Page Overlay > Opacity (%)

Sets the opacity of the background (only available if Overlay Page is selected at Search Field

> Results).

Result Links > Width

Width of a search result if you have chosen the value Overlay Page at Search Field > Results.

Otherwise, the results will be displayed in the width of the search field.

Result Links > Position

Specifies the position of a search result.

Result Links > Font Style

Specifies the font style for search results. Activate a checkbox to set a style attribute and

override the global Font Template of the project.

 - Font specifies the font. Please note that the font must be installed on the computer the

website visitor to get displayed.

 - Style sets the style. Choose between Bold, Italic, Underline and Strikethrough.

 - Size specifies the font size in pixels.

 - Color sets the font color.

Please read the chapter Typography & Font Styles for more information about Font Styles and

Font Templates.

Result Links > Padding Left

Sets the distance from the left side of the search results to the content in pixels.

Result Links > Padding Right

Sets the distance from the right side of the search results to the content in pixels.

- 195 -



24: Search Field

Result Links > Padding Top

Sets the distance from the top side of the search results to the content in pixels.

Result Links > Padding Bottom

Sets the distance from the bottom side of the search results to the content in pixels.

 Result Links > Background Color

Select a background color for the search results.

 Result Links > Background Picture Clip

Select a background picture from the Fishbeam Clips (

http://www.fishbeam.com/en/goldfish/clips.php) library. This option is only available if you have

the Fishbeam Clips library installed.

 Result Links > Background Picture

Select a background picture for the search results. With Repeat, you can choose how the

picture will be displayed. On Retina websites the background picture will be displayed with

double resolution, but half the size (except SVG images).

 Result Links > Repeat

Repeats the background picture.

 - Don't Repeat displays the picture only once.

 - Repeat tiles the picture over the entire space.

 - Repeat Horizontally tiles the image in a row.

 - Repeat Vertically tiles the image in a column.

 - Cut to Fill displays the image once over the entire space. Overlapping edges will be

cropped.

 Result Links > Position Horizontal

Sets the horizontal position of the background picture. If the picture will be repeated, it will be

placed once on the specified position and the remaining space on the left, on the right, above

and below will be filled.

 Result Links > Position Vertical

Sets the vertical position of the background picture. If the picture will be repeated, it will be

placed once on the specified position and the remaining space on the left, on the right, above

and below will be filled.

 Result Links > Fix relative to Browser window

The position of the background picture is calculated on the basis of the browser window. The

picture is pined to the window and will not move when scrolling. The picture can be hidden or

only parts are visible if it is outside of the visible space.
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 Result Links > Border Left Width

Displays a border on the left side of  the search results in the choosen width (pixels).

 Result Links > Border Left Color

Select a color for the left border.

 Result Links > Border Right Width

Displays a border on the right side of  the search results in the choosen width (pixels).

 Result Links > Border Right Color

Select a color for the right border.

 Result Links > Border Top Width

Displays a border on the top side of  the search results in the choosen width (pixels).

 Result Links > Border Top Color

Select a color for the top border.

 Result Links > Border Bottom Width

Displays a border on the bottom side of  the search results in the choosen width (pixels).

 Result Links > Border Bottom Color

Select a color for the bottom border.

Visual Effects
You can specify a visual effect, if a website visitor of interacts with a link from the search result

(e.g. change the color if the visitor moves the mouse over an link). The following properties are

the same for Moving Mouse Over Link Effect, Clicking on Link Effect and Already Visited Link

Effect.

Effect > Change Font

Change the font style of a link.

Effect > Font Style

Specifies the font style, to that you want to change. Activate a checkbox to set a style attribute

and override the global Font Template of the project.

 - Font specifies the font. Please note that the font must be installed on the computer the

website visitor to get displayed.

 - Style sets the style. Choose between Bold, Italic, Underline and Strikethrough.

 - Size specifies the font size in pixels.

 - Color sets the font color.

Please read the chapter Typography & Font Styles for more information about Font Styles and

Font Templates.
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Effect > Change Background

Changes the background of a link.

Effect > Background Color

Select a background color for a link.

Effect > Background Picture Clip

Select a background picture from the Fishbeam Clips (

http://www.fishbeam.com/en/goldfish/clips.php) library. This option is only available if you have

the Fishbeam Clips library installed.

Effect > Background Picture

Select a background picture for a link. With Repeat, you can choose how the picture will be

displayed. On Retina websites the background picture will be displayed with double resolution,

but half the size (except SVG images).

Effect > Repeat

Repeats the background picture.

 - Don't Repeat displays the picture only once.

 - Repeat tiles the picture over the entire space.

 - Repeat Horizontally tiles the image in a row.

 - Repeat Vertically tiles the image in a column.

 - Cut to Fill displays the image once over the entire space. Overlapping edges will be

cropped.

Effect > Position Horizontal

Sets the horizontal position of the background picture. If the picture will be repeated, it will be

placed once on the specified position and the remaining space on the left, on the right, above

and below will be filled.

Effect > Position Vertical

Sets the vertical position of the background picture. If the picture will be repeated, it will be

placed once on the specified position and the remaining space on the left, on the right, above

and below will be filled.

Effect > Fix relative to Browser window

The position of the background picture is calculated on the basis of the browser window. The

picture is pined to the window and will not move when scrolling. The picture can be hidden or

only parts are visible if it is outside of the visible space.

Effect > Change Border

Changes the border of a link.
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Effect > Border Left Width

Displays a border on the left side of a link in the choosen width (pixels).

Effect > Border Left Color

Select a color for the left border.

Effect > Border Right Width

Displays a border on the right side of a link in the choosen width (pixels).

Effect > Border Right Color

Select a color for the right border.

Effect > Border Top Width

Displays a border on the top side of a link in the choosen width (pixels).

Effect > Border Top Color

Select a color for the top border.

Effect > Border Bottom Width

Displays a border on the bottom side of a link in the choosen width (pixels).

Effect > Border Bottom Color

Select a color for the bottom border.

Effekt > Change Padding

Changes the padding of a link.

Effect > Padding Left

Sets the distance from the left side of a link to the content in pixels.

Effect > Padding Right

Sets the distance from the right side of a link to the content in pixels.

Effect > Padding Top

Sets the distance from the top side of a link to the content in pixels.

Effect > Padding Bottom

Sets the distance from the bottom side of a link to the content in pixels.
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Enhance your website with animations. Every item on a page can be animated. This

works with an animation item that you can drag from the items to the website.

You can add an animation item to each area, slider area and area template. To add an

animation item, edit the content of an area, slider or area template and drag an animation item

from the items to the editor.

An animation item contains the schedule for an animation. It will not be displayed on the page,

but only stores the schedule. Because of this, you can place it on the page where it does not

bother you. Enter a unique name in the properties at Animation > Name, so you do not mix the

animation items later.

The schedule can contain any items or page areas. You can show, hide and bounce these

items and areas with an animation - many other animation effects are also possible. For

adressing these items or areas in an animation, give them an unique name in the properties at 

Item > Identifier (ID) or at Page Area > Identifier (ID).

INFO: Please note that the property Page Area > Identifier (ID) is only visible, when you

are not in the edit mode of the area. Click once in the space outside of the area when

you are in edit mode.
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Open the Animation window. Therefore click on Animation > Animation > Choose... in the

properties of the animation. The animation schedule is listed there. Each step will executed

sequentially. So you can animate multiple items simultaneously or sequentially. At the

beginning the list is empty. On the right,there are options for the selected animation step of the

schedule.

 Adds an item, that you want to animate, as a step in the schedule.

 Deletes the selected step from the schedule.

 Looping: Repeats the schedule when the end is reached.

Click on + to add items, that you want to animate, to the schedule. You must have named the

items at Item > Identifier (ID) before that. With Open Link you can add a link. If the animation

arrives at this point, the link will be opened. With this, you can start another animation or switch

to another page.

After you have added items, choose an animation type at Animation in the schedule. The

following types are available:

 - Show shows the item immediately without an animation.
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 - Fade In fades the item in smoothly in with a fade effect.

 - Drive In drives the item in from the side.

 - Scale Up enlarges the item from one point until it reaches the original size.

 - Puff In reduces the size of the item from quite huge, until it reaches the original size.

 - Wipe In opens the content like a curtain.

 - Bounce let the item bounce for a few times.

 - Pulsate let the item pulse (the item is briefly hidden and displayed).

 - Shake shakes the item.

 - Move moves the item to another location.

 - Hide hides the item without animation immediately.

 - Fade Out fades the item out smoothly with a transition.

 - Drive Out drives the item out to the side.

 - Scale Down reduces the size of the item to one point until it's finally gone.

 - Puff Out enlarges the item and fades it out a the same time.

 - Wipe out closes the content like a curtain.

For each type of animation there are numerous options available. Please, note that not all

options are for all animation types available.

Sound Effect

Plays a sound effect during the animation. You can use a sound effect from the list or select

your own .mp3-file.

Duration

Duration of the Animation in seconds.

Motion

Sets the motion type.

 - Natural performs the animation with natural inertia. Items are a bit sluggish at the beginning

and at the end.
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 - Linear runs the animation absolutely straight.

 - Speed Up lets the animation get faster during the performance.

 - Speed Down lets the the animation get slower during the performance.

 - Bounce let the animation cushion at the end as in a collision or a rubber band.

Direction

Determines the direction from which the item should appear or into which the item should

disappear.

Rotation

The item rotates during the animation clockwise or anticlockwise.

Transition

The item will be displayed or hidden during the animation.

Origin

Only at Wipe In and Wipe Out.

 - Left wipes in the item from the left or wipes it out to the left.

 - Center wipes in the item from the center to the left and right or wipes it out from the left and

right to the center.

 - Right wipes in the item from the right or wipes it out to the right.

 - Top wipes in the item from the top or wipes it out to the top.

 - Middle wipes in the item from the middle to the top and bottom or wipes it out from the top

and bottom to the middle.

 - Bottom wipes in the item from the bottom or wipes it out to the bottom.

 - Absolut Center wipes the item out from the center in all directions or wipes it in to the

center.

Times

Specifies how many times the animation will be repeated.

Left +/-

Setsthe number of pixels to which the item is to be moved horizontally.

Top +/-

Sets the number of pixels to which the item is to be moved vertically.

Link

Only at Open Link. In the link window, you can determine where the link should lead to.

 - Internal Link to Page sets a link to one of the pages or sub pages in your project. Select the

page from the list. From the action list below, you can select an action on the page as the

link target.

 - E-Mail Address sets a link to an e-mail address. This opens the user's e-mail app, and a
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new e-mail to the specified e-mail address will be opened.

 - File sets a link to a file that will displayed or download. For example, if you select a PDF

document, it will be displayed by clicking on the link.

 - Custom Link sets a link to another website or link target. For example, enter an external

address, such as http://www.fishbeam.com.

Normally all steps and animations are executed one after the other or immediately in the

schedule. But, you can give a delay with Delay (Sec.) for that the execution of the step should

wait. Also, several steps can be executed in parallel. For this select the value Simutaneously

with #x at Start.

If you finished the schedule, close the window Animation with a click on OK. Now you have to

define when the animation should be executed.

You can set this in the properties of the animation with Animation > Start Animation.

 - No Autostart starts the animation not automatically. Then, you can play the animation via a

link or when interacting with an item.

 - Immediatelly start the animation as soon as the page is completely loaded.

 - When Come into View starts the animation as soon as the (invisible) animation item

appears into the field of view. For example, that is the case when the animation item comes

into view by scrolling.
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You can start an animation when the user moves the mouse over an item or moves it out of

the item. To do this, select the animation in the properties of the item at Item > Moving Mouse

Over Animation or at Item > Moving Mouse Out Animation.

INFO: You can also start an animation by clicking on a link. Choose Internal Link To

Page as the link target and Start Animation "xyz" as the action.

Properties for Animation Items
These properties can be set for an animation item. Select an animation item to see its

properties.

Item > Identifier (Id)

Specifies the name of the item in order to address it in animations or as a link target. Use only

letters and numbers for the name, no spaces or special characters.

Item > Left

Sets the distance in pixels from the left side of the item to the area where the item is located.

Item > Top

Sets the distance in pixels from the top side of the item to the area where the item is located.

Item > Width

Sets the width of the item in pixels.

Item > Height

Sets the height of the item in pixels.

Item > Padding Left

Sets the distance from the left side of the item to the content in pixels.

Item > Padding Right

Sets the distance from the right side of the item to the content in pixels.

Item > Padding Top

Sets the distance from the top side of the item to the content in pixels.
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Item > Padding Bottom

Sets the distance from the bottom side of the item to the content in pixels.

Item > Background Color

Select a background color for the item.

Item > Background Picture Clip

Select a background picture from the Fishbeam Clips (

http://www.fishbeam.com/en/goldfish/clips.php) library. This option is only available if you have

the Fishbeam Clips library installed.

Item > Background Picture

Select a background picture for the item. With Repeat, you can choose how the picture will be

displayed. On Retina websites the background picture will be displayed with double resolution,

but half the size (except SVG images).

Item > Repeat

Repeats the background picture.

 - Don't Repeat displays the picture only once.

 - Repeat tiles the picture over the entire space.

 - Repeat Horizontally tiles the image in a row.

 - Repeat Vertically tiles the image in a column.

 - Cut to Fill displays the image once over the entire space. Overlapping edges will be

cropped.

Item > Position Horizontal

Sets the horizontal position of the background picture. If the picture will be repeated, it will be

placed once on the specified position and the remaining space on the left, on the right, above

and below will be filled.

Item > Position Vertical

Sets the vertical position of the background picture. If the picture will be repeated, it will be

placed once on the specified position and the remaining space on the left, on the right, above

and below will be filled.

Item > Fix relative to Browser window

The position of the background picture is calculated on the basis of the browser window. The

picture is pined to the window and will not move when scrolling. The picture can be hidden or

only parts are visible if it is outside of the visible space.

Item > Border Left Width

Displays a border on the left side of the item in the choosen width (pixels).
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Item > Border Left Color

Select a color for the left border.

Item > Border Right Width

Displays a border on the right side of the item in the choosen width (pixels).

Item > Border Right Color

Select a color for the right border.

Item > Border Top Width

Displays a border on the top side of the item in the choosen width (pixels).

Item > Border Top Color

Select a color for the top border.

Item > Border Bottom Width

Displays a border on the bottom side of the item in the choosen width (pixels).

Item > Border Bottom Color

Select a color for the bottom border.

Item > Opacity (%) 

Makes the item transparent. From 0% (fully transparent) to 100% (completely visible).

Item > Rotation

Rotation of the object in a clockwise direction from 0° to 360°.

Item > Moving Mouse Over Animation PRO

Select an animation that you have previously created with an Animation item. The animation

will be started as soon as the website visitor moves the mouse over the item.

Item > Moving Mouse Out Animation PRO

Select an animation that you have previously created with an Animation item. The animation

will be started as soon as the website visitor moves the mouse from the item.

Animation > Name

Specify a unique name for the animation, to avoid confusion of multiple animations on a page.

Animation > Animation

Opens the Animation window in which you can set the schedule of the animation.

Animation > Start Animation

Sets the beginning of the animation.

 - No Autostart starts the animation not automatically. Then, you can play the animation via a
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link or when interacting with an item.

 - Immediatelly start the animation as soon as the page is completely loaded.

 - When Come into View starts the animation as soon as the (invisible) animation item

appears into the field of view. For example, that is the case when the animation item comes

into view by scrolling.

Examples
Get to know in the following examples what you can do with an animation everything. 

Example: Transition effect when the page loads
In this example, only the page background is displayed when the page loads. If all items are

finished loading, the page content fades with a transition effect.

Drag an animation on the page and place it where it does not interfere. Then rename all page

areas in the properties at Page Area> Identifier (ID) so that they are accessible in the

animation.

Call now in the properties of the animation at Animation > Animation> Choose... the window 

Animation. Add with + every side area of the side. Set the Animation on Fade In. Now you

have to set at Start the value Simultaneously with #1 anywhere(despite of the first animation,
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which starts always immediatelly).

You can check the result in the Preview view. If the transition effect should be delayed, set the

values in the window Animation at Delay (Sec.) anywhere.

Example: Pop-up Window
In this example, you will learn how to create a pop-up window which overlies the side and

disappears when clicking on an X-Button.

Built a new po-pup window, e.g. from a text box with background color and brinks. If you use

multiple items, group them so that you get a single item as a pop-up window. At last you place

on the popup a picture as a Close-Button which does not belong to the grouping.

Entitle the Close-Button and the popup in the properties Item > Identifer (Id) so that they are

accessible in the animation.

Drag an animation on the page where popup is situated and place it where it does not

interfere. Click the properties on Animation > Animation > Choose...  so that the Animation  will
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appear.

Add with + the Close-Button and set the animation on Fade Out. Then add also the pop-up and

select the animation Drive Out or another animation that allows the pop-up to disappear.

Now the animation needs to be connected to the Close-Button. The animation may not be

immediately executed when the page loads. So set in the qualities of the animation under 

Animation> Start Animation the value to No Autostart.

 Activate in the qualities of the Close-Button the option Link> Use as Link. Then click in 

Choose... behind it, for open so that the window Link.

Select at Internal Link To Page the page, on which the animation is situated. Below choose

then the action Start Animation "Animation 1".

You can see the result in the preview. The pop-up appears and would disappear with a click on

the Close-Button.

Example: Info-balloon
This example creates an info bubble containing additional information. This is displayed when

the user moves the mouse over an item, and disappears when the mouse pointer leaves the

item.
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First, determine the item to which the additional information should appear. This can be an

image, as in this example, or any other item of a page. Place the additional information in the

vicinity, for example, with a Form- and a Text-object. Group all items that belong to the

additional information. Rename the group in the properties with Item > Identifer (ID) to make

them accessible for an animation.

Two animations are required. One for fading in and one for fading out of the additional

information. Therefor drag two animations on the page and place them where they do not

interfere. Rename the animations in Animation > Name, so you will not confuse them later.

Open successively the window Animation from both animations. Therefor click in the properties

Animation > Animation > Choose.... Add the additional information item with + in both

animations and select for the first one Fade In and for the second one Fade Out.
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Finally the two animations need to be connected with the item, in which the additional

informations should appear. Choose in the properties of the object both animations with Item >

Moving Mouse Over Animation or Item > Moving Mouse Out Animation.

You can see the result in the preview. The additional information will be displayed when the

mouse is moved to the object and disappear again once the mouse is moved out of the object.
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Set up an online shop on your website. This works with a shopping cart item and some

product items, which you can drag from the items to the website.

The product and the shopping cart item is only available in Goldfish Professional. PRO

Goldfish allows you to set up an online shop in only minutes. The shop is based on a shopping

cart item and one or more product items. You can add an online shop to each area, slider area

and area template. To add an online shop, edit the content of an area, slider or page template

and drag one or more product items as well as a shopping cart item from the items in the

editor.

Make sure that you only use one single shopping cart in your online shop. Therefore, place the

cart item on an area template that you can use on all shopping pages. Use a product item for

each different product that you want to sell.

E-Commerce Regulations in the European Union
If you operate the Online Store from within the EU, you need to operate your online store

according to the e-commerce regulations of the EU. This guide can help you with that. If you

operate your online shop from outside the EU, other rules may apply.

INFO: Please note that we can not assume any liability for completeness and accuracy

of this manual and our shop software. Ask a lawyer to check your online shop if you

want to make sure that all regulations are respected correctly.

Preparations for the Online Shop on your Website 

 1. Create a new sub page with shipping costs. List your shipping costs there. Additional

costs for payment methods (cash on delivery) must also be listed. You have to offer at least

one widely-used payment method at no additional cost. Look for assistance on the Internet

or ask a lawyer to specify the shipping costs correctly.

 2. Create a new sub page for the terms and conditions. Place your terms and conditions

there. Look for assistance on the Internet or ask a lawyer to specify the terms and

conditions correctly.

 3. Consumers have the right to cancel orders. Create a new sub page for the cancellation

policy. Place your cancellation policy there. Look for assistance on the Internet or ask a

lawyer to specify the cancellation policy correctly.

Placing the Shopping Cart
Place a shopping cart on the page. Use exactly one cart for your online shop and not more.

You can put the cart on an area template if you are using multiple sub pages with products.
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Then use the area template with the shopping cart on each sub page.

The next step is to set the correct properties of the shopping cart.

 1. Enter your e-mail address at Shopping Cart > E-Mail Address. Then you will receive an

e-mail when a customer has ordered something.

 2. Click on Choose... behind Cart > Payment Options and delete all the payment methods that

you do not want to offer. You can write other payment methods, that you want to offer in a

new line on the list. All payment methods except PayPal can only be selected by the

customer, but there is no automatic payment processing. In the second column, you can

specify additional payment costs that are charged to the customer when the payment

method is selected. Enter the payment costs according to your specifications on the sub

page, that you have created previously.

 3. Click on Choose behind Shopping Cart > Countries and delete all the countries to which you

don't want to deliver. You can add other countries at the end of the list. There you can also

enter the the shipping costs per country and set an order value, from that the shipping is

free. Enter the shipping costs according to your specifications on the sub page, that you

have created previously.

 4. Disable Shopping Cart > State, if you do not sell to countries that need the state in the

address (eg. the USA).

 5. Activate Shopping Cart > Link to Terms and Conditions, and select the earlier created sub

page with the terms and conditions as the link target.
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 6. Activate Shopping Cart > Link to Cancellation Policy, and select the earlier created sub

page with the cancellation policy as the link target.

 7. Click on Choose... behind Shopping Cart > Text in Cart and enter the complete shipping

and payment costs for your online shop there too.

 8. Click on Choose... behind Shopping Cart > Text in Order Confirmation and paste your

cancellation policy at the marked point. The full text of the cancellation policy must be

pasted.

Setting up PayPal
Enable Shopping Cart > Use PayPal in the properties if you want to use PayPal as a payment

method. Then login on the PayPal website and look for the API keys of your PayPal account.

 1. Click after the login to Selling with PayPal > Seller preferences.

 2. Click on the next page at API Access on Request or Update.

 3. Select Option 2 - Request API credentials to create your own API username and password.

 4. Click on View API Signature.

Paste the stored data in the corresponding fields from the properties at Shopping Cart > Use

PayPal.

INFO: Make sure that you have stored the payment method PayPal in the properties at 

Shopping Cart > Payment Options. Otherwise, PayPal will not appear in your online

store.

Adding Products
Place a Product item on the page for every product that you want to sell.

 1. Enter a unique item number for the product in the properties at Product> Product ID . This

can not contain any spaces or special characters.

 2. Enter the name of your product and a very brief description of the essential features of your

product at Product > Product Name. This description must be displayed in the cart if you

operate your online shop from the EU.

 3. Enter the price of your product at Product > Price. The currency is already set in the

shopping cart.

 4. Change the price of the product to the price of your choice at Product > Label.
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 5. Place a text item next to each product item with the text Incl. VAT. excl. shipping costs. Be

sure to use the words shipping costs as a link to the page with the shipping shipping costs.

We suggest to activate Open link in a new window in the link window.

INFO: This item uses PHP. Your webserver must support PHP to use it.

Properties for the Shopping Cart Item
These properties can be set for the shopping cart item. Select the shopping cart item to see its

properties.

Item > Identifier (Id)

Specifies the name of the item in order to address it in animations or as a link target. Use only

letters and numbers for the name, no spaces or special characters.

Item > Left

Sets the distance in pixels from the left side of the item to the area where the item is located.

Item > Top

Sets the distance in pixels from the top side of the item to the area where the item is located.

Item > Width

Sets the width of the item in pixels.

Item > Height

Sets the height of the item in pixels.

Item > Padding Left

Sets the distance from the left side of the item to the content in pixels.

Item > Padding Right

Sets the distance from the right side of the item to the content in pixels.

Item > Padding Top

Sets the distance from the top side of the item to the content in pixels.

Item > Padding Bottom

Sets the distance from the bottom side of the item to the content in pixels.

Item > Background Color

Select a background color for the item.

Item > Background Picture Clip

Select a background picture from the Fishbeam Clips (

http://www.fishbeam.com/en/goldfish/clips.php) library. This option is only available if you have
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the Fishbeam Clips library installed.

Item > Background Picture

Select a background picture for the item. With Repeat, you can choose how the picture will be

displayed. On Retina websites the background picture will be displayed with double resolution,

but half the size (except SVG images).

Item > Repeat

Repeats the background picture.

 - Don't Repeat displays the picture only once.

 - Repeat tiles the picture over the entire space.

 - Repeat Horizontally tiles the image in a row.

 - Repeat Vertically tiles the image in a column.

 - Cut to Fill displays the image once over the entire space. Overlapping edges will be

cropped.

Item > Position Horizontal

Sets the horizontal position of the background picture. If the picture will be repeated, it will be

placed once on the specified position and the remaining space on the left, on the right, above

and below will be filled.

Item > Position Vertical

Sets the vertical position of the background picture. If the picture will be repeated, it will be

placed once on the specified position and the remaining space on the left, on the right, above

and below will be filled.

Item > Fix relative to Browser window

The position of the background picture is calculated on the basis of the browser window. The

picture is pined to the window and will not move when scrolling. The picture can be hidden or

only parts are visible if it is outside of the visible space.

Item > Border Left Width

Displays a border on the left side of the item in the choosen width (pixels).

Item > Border Left Color

Select a color for the left border.

Item > Border Right Width

Displays a border on the right side of the item in the choosen width (pixels).

Item > Border Right Color

Select a color for the right border.
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Item > Border Top Width

Displays a border on the top side of the item in the choosen width (pixels).

Item > Border Top Color

Select a color for the top border.

Item > Border Bottom Width

Displays a border on the bottom side of the item in the choosen width (pixels).

Item > Border Bottom Color

Select a color for the bottom border.

Item > Opacity (%) 

Makes the item transparent. From 0% (fully transparent) to 100% (completely visible).

Item > Rotation

Rotation of the object in a clockwise direction from 0° to 360°.

Item > Moving Mouse Over Animation PRO

Select an animation that you have previously created with an Animation item. The animation

will be started as soon as the website visitor moves the mouse over the item.

Item > Moving Mouse Out Animation PRO

Select an animation that you have previously created with an Animation item. The animation

will be started as soon as the website visitor moves the mouse from the item.

Shopping Cart > E-Mail Address

Enter the e-mail address to which the orders will be sent.

Shopping Cart > Use external SMTP server

Allows you to send emails through an SMTP server. Enable this option if you encounter

problems when sending emails.

Shopping Cart > SMTP Server

Enter your SMTP server. You can get this information from your e-mail provider or your email

client.

Shopping Cart > SMTP User

Enter your SMTP user. You can get this information from your e-mail provider or your email

client.

Shopping Cart > SMTP Password

Enter your SMTP password. You can get this information from your e-mail provider or your

email client.
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Shopping Cart > Show message with contact e-mail address if a mail error occures

If an error occurs while sending the order, the e-mail address for order will be shown. Then the

page visitor can order directly via e-mail.

Shopping Cart > Message

The message that appears to order by e-mail. Write % s as a placeholder for the email

address.

Shopping Cart > E-Mail Subject

Subject in order notification e-mails.

Shopping Cart > Currency

Currency for orders.

Shopping Cart > Decimal Point

Decimal point for currency formatted numbers.

Shopping Cart > Tax (%)

Tax ammount for all orders.

Shopping Cart > Tax Included

Enable this if the tax is included in the prices of the products. Otherwise the tax will be added

to Estimated Total.

Shopping Cart > Calculate Shipping Fee

Enable this option to calculate shipping fees. The amount of shipping fees is set in Shopping

Cart > Countries.

Shopping Cart > Use PayPal

Enable this option if you want to allow payments via PayPal. In addition, PayPal has to be

stored in Shopping Cart > Payment Options.

Shopping Cart > API User

Enter the API username, that you have received from PayPal.

Shopping Cart > API Password

Enter the API password, that you have received from PayPal.

Shopping Cart > API Signature

Enter the API signature, that you have received from PayPal.

Shopping Cart > PayPal Checkout Text

Text that appears in PayPal durinmg the payment.
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Shopping Cart > Payment Options

List of payment options, that are supported in the store.

Shopping Cart > Countries

A list of countries to that you want to deliver.

Shopping Cart > State

Adds a field for the state to the order process (needed for US and Canadian addresses).

property]Shopping Cart > Comment

Adds a field for comments to the order process.

Shopping Cart > Generate order number

Generates a unique order number for every order and displays it in all order e-mails.

Shopping Cart > Terms and Conditions Link

Displays a link to the Terms and Conditions during the order process. In the link window, you

can determine where the link should lead to.

 - Internal Link to Page sets a link to one of the pages or sub pages in your project. Select the

page from the list. From the action list below, you can select an action on the page as the

link target.

 - E-Mail Address sets a link to an e-mail address. This opens the user's e-mail app, and a

new e-mail to the specified e-mail address will be opened.

 - File sets a link to a file that will displayed or download. For example, if you select a PDF

document, it will be displayed by clicking on the link.

 - Custom Link sets a link to another website or link target. For example, enter an external

address, such as http://www.fishbeam.com.

Shopping Cart > Cancellation Policy Link

Displays a link to the Cancellation Policy during the order process. In the link window, you can

determine where the link should lead to.

 - Internal Link to Page sets a link to one of the pages or sub pages in your project. Select the

page from the list. From the action list below, you can select an action on the page as the

link target.

 - E-Mail Address sets a link to an e-mail address. This opens the user's e-mail app, and a

new e-mail to the specified e-mail address will be opened.

 - File sets a link to a file that will displayed or download. For example, if you select a PDF

document, it will be displayed by clicking on the link.

 - Custom Link sets a link to another website or link target. For example, enter an external

address, such as http://www.fishbeam.com.
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Shopping Cart > Text in cart

Text that appears in the shopping cart.

Shopping Cart > Text in Order Summary

Text that appears on the order summary page.

Shopping Cart > Text in Order confirmation

Text that is displayed in the order confirmation e-mail.

Button > Button Type

Specifies the appearance of the shopping cart.

 - Button shows the shopping cart as a button.

 - Text shows the shopping cart as text.

Button > Font Style

Specifies the font style for the shopping cart. Activate a checkbox to set a style attribute and

override the global Font Template of the project.

 - Font specifies the font. Please note that the font must be installed on the computer the

website visitor to get displayed.

 - Style sets the style. Choose between Bold, Italic, Underline and Strikethrough.

 - Size specifies the font size in pixels.

 - Color sets the font color.

 - Line Space sets the line spacing in pixels. The line height is calculated of the Font Size +

Line Space.

 - Alignment sets the alignment of the paragraph. Possible values are Left, Center, Right and 

Justified.

Please read the chapter Typography & Font Styles for more information about Font Styles and

Font Templates.

Button > ... Items

Text in the shopping cart for ... Items

Button > 1 Item

Text in the shopping cart for 1 Item

Button > Checkout

Text in the shopping cart for Checkout

Button > Use cart animation

Displays a star, flying from the product to your cart, when buying.
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Button > Color of Count Badge

Color for the counter display in the shopping cart.

Button > Font Color of Count Badge

Font color for the counter display in the cart.

Button > Custom Button Picture

Select a picture as an icon for the button, if you don't like the default shopping cart.

Visual Effects
You can specify a visual effect, if a website visitor interacts with the shopping cart (e.g. change

the picture if the visitor moves the mouse over the button). The following properties are the

same for Moving Mouse Over Link Effect and Clicking on Link Effect.

Effect > Change Picture

Changes the picture. Select an picture to which you want to change.

Properties for the Shopping Cart Item

Page Background > Background Color

Select a background color for the shopping cart page.

Page Background > Background Picture Clip

Select a background picture from the Fishbeam Clips (

http://www.fishbeam.com/en/goldfish/clips.php) library. This option is only available if you have

the Fishbeam Clips library installed.

Page Background > Background Picture

Select a background picture for the shopping cart page. With Repeat, you can choose how the

picture will be displayed. On Retina websites the background picture will be displayed with

double resolution, but half the size (except SVG images).

Page Background > Repeat

Repeats the background picture.

 - Don't Repeat displays the picture only once.

 - Repeat tiles the picture over the entire space.

 - Repeat Horizontally tiles the image in a row.

 - Repeat Vertically tiles the image in a column.

 - Cut to Fill displays the image once over the entire space. Overlapping edges will be

cropped.

Page Background > Position Horizontal

Sets the horizontal position of the background picture. If the picture will be repeated, it will be

placed once on the specified position and the remaining space on the left, on the right, above
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and below will be filled.

Page Background > Position Vertical

Sets the vertical position of the background picture. If the picture will be repeated, it will be

placed once on the specified position and the remaining space on the left, on the right, above

and below will be filled.

Page Background > Fix relative to Browser window

The position of the background picture is calculated on the basis of the browser window. The

picture is pined to the window and will not move when scrolling. The picture can be hidden or

only parts are visible if it is outside of the visible space.

Page Background > Opacity (%)

Sets the opacity for the background.

User Interface > Background Color

Select a background color for the shopping cart.

User Interface > Background Picture Clip

Select a background picture from the Fishbeam Clips (

http://www.fishbeam.com/en/goldfish/clips.php) library. This option is only available if you have

the Fishbeam Clips library installed.

User Interface > Background Picture

Select a background picture for the shopping cart. With Repeat, you can choose how the

picture will be displayed. On Retina websites the background picture will be displayed with

double resolution, but half the size (except SVG images).

User Interface > Repeat

Repeats the background picture.

 - Don't Repeat displays the picture only once.

 - Repeat tiles the picture over the entire space.

 - Repeat Horizontally tiles the image in a row.

 - Repeat Vertically tiles the image in a column.

 - Cut to Fill displays the image once over the entire space. Overlapping edges will be

cropped.

User Interface > Position Horizontal

Sets the horizontal position of the background picture. If the picture will be repeated, it will be

placed once on the specified position and the remaining space on the left, on the right, above

and below will be filled.
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User Interface > Position Vertical

Sets the vertical position of the background picture. If the picture will be repeated, it will be

placed once on the specified position and the remaining space on the left, on the right, above

and below will be filled.

User Interface > Fix relative to Browser window

The position of the background picture is calculated on the basis of the browser window. The

picture is pined to the window and will not move when scrolling. The picture can be hidden or

only parts are visible if it is outside of the visible space.

User Interface > Padding Left

Sets the distance from the left side of the shopping cart to the content in pixels.

User Interface > Padding Right

Sets the distance from the right side of the shopping cart to the content in pixels.

User Interface > Padding Top

Sets the distance from the top side of the shopping cart to the content in pixels.

User Interface > Padding Bottom

Sets the distance from the bottom side of the shopping cart to the content in pixels.

User Interface > Border Left Width

Displays a border on the left side of the shopping cart in the choosen width (pixels).

User Interface > Border Left Color

Select a color for the left border.

User Interface > Border Right Width

Displays a border on the right side of the shopping cart in the choosen width (pixels).

User Interface > Border Right Color

Select a color for the right border.

User Interface > Border Top Width

Displays a border on the top side of the shopping cart in the choosen width (pixels).

User Interface > Border Top Color

Select a color for the top border.

User Interface > Border Bottom Width

Displays a border on the bottom side of the shopping cart in the choosen width (pixels).
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User Interface > Border Bottom Color

Select a color for the bottom border.

User Interface > Font Style

Specifies the font style for the shopping cart. Activate a checkbox to set a style attribute and

override the global Font Template of the project.

 - Font specifies the font. Please note that the font must be installed on the computer the

website visitor to get displayed.

 - Style sets the style. Choose between Bold, Italic, Underline and Strikethrough.

 - Size specifies the font size in pixels.

 - Color sets the font color.

 - Line Space sets the line spacing in pixels. The line height is calculated of the Font Size +

Line Space.

 - Alignment sets the alignment of the paragraph. Possible values are Left, Center, Right and 

Justified.

Please read the chapter Typography & Font Styles for more information about Font Styles and

Font Templates.

User Interface > Items

Text in the user interface for Items.

User Interface > Item Price

Text in the user interface for Item Price.

User Interface > Quantity

Text in the user interface for Quantity.

User Interface > Item Total

Text in the user interface for Item Total.

User Interface > Shipping Fee

Text in the user interface for Shipping Fee.

User Interface > From ...

Text in the user interface for From ....

User Interface > Estimated Total

Text in the user interface for Estimated Total.

User Interface > Close

Text in the user interface for Close.
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User Interface > Checkout

Text in the user interface for Checkout.

User Interface > Back

Text in the user interface for Back.

User Interface > Next

Text in the user interface for Next.

User Interface > Submit Order

Text in the user interface for Submit Order.

User Interface > First Name

Text in the user interface for First Name.

User Interface > Last Name

Text in the user interface for Last Name.

User Interface > Street

Text in the user interface for Street.

User Interface > Zip/Postal Code

Text in the user interface for Zip/Postal Code.

User Interface > City

Text in the user interface for City.

User Interface > Country

Text in the user interface for Country.

User Interface > Phone

Text in the user interface for Phone.

User Interface > E-Mail Address

Text in the user interface for E-Mail Address.

User Interface > Reenter E-Mail Address

Text in the user interface for Reenter E-Mail Address.

User Interface > Payment

Text in the user interface for Payment.
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User Interface > Personal Information

Text in the user interface for Personal Information.

User Interface > Thank You Message

Text of thank you message after a successful order.

User Interface > Date Format

Date format in the user interface (PHP formatted).

User Interface > Info about Terms and Conditions

Information text about Terms and Conditions.

User Interface > Accept Terms & Conditions

Text in the user interface to accept the Terms and Conditions.

User Interface > Empty Cart

Text in the user interface for Empty Cart.

User Interface > VAT

Text in the user interface for VAT.

User Interface > Sub Total

Text in the user interface for Sub Total.

User Interface > ...% VAT on ...

Text in the user interface for ...% VAT on ....

User Interface > Background Color to Highlight the Order

Choose a background color to highlight the order.

User Interface > Terms and Conditions

Text in the user interface for Terms and Conditions.

User Interface > Cancellation Policy

Text in the user interface for Cancellation Policy.

User Interface > Continue with PayPal

Text in the user interface for Continue with PayPal.

Link Style > Font Style

Specifies the font style for links. Activate a checkbox to set a style attribute and override the

global Font Template of the project.

 - Font specifies the font. Please note that the font must be installed on the computer the

website visitor to get displayed.
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 - Style sets the style. Choose between Bold, Italic, Underline and Strikethrough.

 - Size specifies the font size in pixels.

 - Color sets the font color.

Please read the chapter Typography & Font Styles for more information about Font Styles and

Font Templates.

Visual Effects
You can specify a visual effect, if a website visitor interacts with a link (e.g. change the color if

the visitor moves the mouse over the link). The following properties are the same for Moving

Mouse Over Link Effect, Clicking on Link Effect and Already Visited Link Effect.

Effect > Change Font

Changes the font style of a link.

Effect > Font Style

Specifies the font style, to which you want to change. Activate a checkbox to set a style

attribute and override the global Font Template of the project.

 - Font specifies the font. Please note that the font must be installed on the computer the

website visitor to get displayed.

 - Style sets the style. Choose between Bold, Italic, Underline and Strikethrough.

 - Size specifies the font size in pixels.

 - Color sets the font color.

Please read the chapter Typography & Font Styles for more information about Font Styles and

Font Templates.

Properties for Product Items
These properties can be set for a product item. Select a product item to see its properties.

Item > Identifier (Id)

Specifies the name of the item in order to address it in animations or as a link target. Use only

letters and numbers for the name, no spaces or special characters.

Item > Left

Sets the distance in pixels from the left side of the item to the area where the item is located.

Item > Top

Sets the distance in pixels from the top side of the item to the area where the item is located.

Item > Width

Sets the width of the item in pixels.
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Item > Height

Sets the height of the item in pixels.

Item > Padding Left

Sets the distance from the left side of the item to the content in pixels.

Item > Padding Right

Sets the distance from the right side of the item to the content in pixels.

Item > Padding Top

Sets the distance from the top side of the item to the content in pixels.

Item > Padding Bottom

Sets the distance from the bottom side of the item to the content in pixels.

Item > Background Color

Select a background color for the item.

Item > Background Picture Clip

Select a background picture from the Fishbeam Clips (

http://www.fishbeam.com/en/goldfish/clips.php) library. This option is only available if you have

the Fishbeam Clips library installed.

Item > Background Picture

Select a background picture for the item. With Repeat, you can choose how the picture will be

displayed. On Retina websites the background picture will be displayed with double resolution,

but half the size (except SVG images).

Item > Repeat

Repeats the background picture.

 - Don't Repeat displays the picture only once.

 - Repeat tiles the picture over the entire space.

 - Repeat Horizontally tiles the image in a row.

 - Repeat Vertically tiles the image in a column.

 - Cut to Fill displays the image once over the entire space. Overlapping edges will be

cropped.

Item > Position Horizontal

Sets the horizontal position of the background picture. If the picture will be repeated, it will be

placed once on the specified position and the remaining space on the left, on the right, above

and below will be filled.
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Item > Position Vertical

Sets the vertical position of the background picture. If the picture will be repeated, it will be

placed once on the specified position and the remaining space on the left, on the right, above

and below will be filled.

Item > Fix relative to Browser window

The position of the background picture is calculated on the basis of the browser window. The

picture is pined to the window and will not move when scrolling. The picture can be hidden or

only parts are visible if it is outside of the visible space.

Item > Border Left Width

Displays a border on the left side of the item in the choosen width (pixels).

Item > Border Left Color

Select a color for the left border.

Item > Border Right Width

Displays a border on the right side of the item in the choosen width (pixels).

Item > Border Right Color

Select a color for the right border.

Item > Border Top Width

Displays a border on the top side of the item in the choosen width (pixels).

Item > Border Top Color

Select a color for the top border.

Item > Border Bottom Width

Displays a border on the bottom side of the item in the choosen width (pixels).

Item > Border Bottom Color

Select a color for the bottom border.

Item > Opacity (%) 

Makes the item transparent. From 0% (fully transparent) to 100% (completely visible).

Item > Rotation

Rotation of the object in a clockwise direction from 0° to 360°.

Item > Moving Mouse Over Animation PRO

Select an animation that you have previously created with an Animation item. The animation

will be started as soon as the website visitor moves the mouse over the item.

- 230 -



26: Online Shop (Product & Shopping Cart)

Item > Moving Mouse Out Animation PRO

Select an animation that you have previously created with an Animation item. The animation

will be started as soon as the website visitor moves the mouse from the item.

Product > Product ID

Enter a unique item number for the product. The item number can not contain spaces or

special characters.

Product > Produktname

Product Name. This will be displayed in the shopping cart.

Product > Price

Price of the product. The currency and tax is set in the shopping cart.

Product > Differing Tax (%)

Enable this if the tax for this product differs from the global tax which is set in the shopping

cart.

Product > Label

The text in the product button.

Product > Alignment

Sets the alignment of the text in the product button.

Product > Font Style

Specifies the font style of the product button. Activate a checkbox to set a style attribute and

override the global Font Template of the project.

 - Font specifies the font. Please note that the font must be installed on the computer the

website visitor to get displayed.

 - Style sets the style. Choose between Bold, Italic, Underline and Strikethrough.

 - Size specifies the font size in pixels.

 - Color sets the font color.

Please read the chapter Typography & Font Styles for more information about Font Styles and

Font Templates.

Product > Padding Left

Sets the distance from the left side of the product button to the content in pixels.

Product > Padding Right

Sets the distance from the right side of the product button to the content in pixels.

Product > Padding Top

Sets the distance from the top side of the product button to the content in pixels.
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Product > Padding Bottom

Sets the distance from the bottom side of the product button to the content in pixels.

Button > Custom Button Picture

Select a picture as an icon for the button, if you don't like the default product button.

Visual Effects
You can specify a visual effect, if a website visitor interacts with the product button (e.g.

change the picture if the visitor moves the mouse over the button). The following properties are

the same for Moving Mouse Over Link Effect and Clicking on Link Effect.

Effect > Change Picture

Changes the picture. Select an picture to which you want to change.
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27. Goldfish Link
Support Goldfish with a link to our website. This works with a Goldfish Link item that

you can drag from the components to the website.

You can add a Goldfish Link to each area, slider area and area template. To add a Goldfish

Link, edit the content of an area, slider or area template and drag a Goldfish Link item from the

items to the editor.

This creates a picture item that contains an .svg picture with a Goldfish button. This picture

acts as a link to our website http://www.fishbeam.com.

Read the chapter Picture to learn about its properties.
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28. Typography & Font Styles
Typography is very important on websites. Goldfish supports the font system of HTML,

rendering of text and Adobe Typekit. Because of this, all texts will be displayed similar

on all devices.

In an new project you should define the default font styles, with the primarily used styles on the

website, at first. These are the base for all texts on the website. Click on PROJECT on the top

left in the project list, so that the project properties are visible. Then click on Project > Font

Templates > Choose... and the Font Templates window will be opened.

Here you can define the default font styles that will be used on your website. If you do not

explicitly set the font style for items, the default font styles are used.

 - Master Template sets the default style for normal text.

 - Headline 1. Order sets the default style for headlines of 1. order.

 - Headline 2. Order sets the default style for headlines of 2. order.

 - Headline 3. Order sets the default style for headlines of 3. order.

 - Headline 4. Order sets the default style for headlines of 4. order.

 - Headline 5. Order sets the default style for headlines of 5. order.

 - Headline 6. Order sets the default style for headlines of 6. order.

 - Link Template sets the default style for links.

 - Moving Mouse over Links sets the default style for links while the user moves the mouse

over the link.

 - Clicking on Link sets the default style for links while the user clicks the link.

 - Already visited Links sets the default style for links that lead to already visited pages.

You can also create additional fonts templates if you use certain styles often. A template can

be selected in a Font Style window of an item. So you don't need to change the font style each
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time there.

 Adds a new font template.

 Duplicates a selected font template.

 Delete a selected font template (not for default templates).

 Opens the editor for font styles and you can edit the selected font template.

Double click on a font template to rename it. 

Edit Font Templates and Font Styles
When you edit a font template, or you set the font style anywhere on the website, the Font

Style window will appear.

The selected template at Font Template will set the basic font style. You can overwrite

individual style properties with other styles. You can select the Master Template and more

templates, that you have created.
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Activate a checkbox to override a style property of the selected Font Template with a different

style.

 - Font specifies the font. Please note that the font must be installed on the computer the

website visitor to get displayed.

 - Style sets the style. Choose between Bold, Italic, Underline and Strikethrough.

 - Size specifies the font size in pixels.

 - Color sets the font color.

 - Line Space sets the line spacing in pixels. The line height is calculated of the Font Size +

Line Space.

 - Alignment sets the alignment of the paragraph. Possible values are Left, Center, Right and 

Justified.

INFO: If you mainly use the same style on every page and in every text item, it is better

to change the master template, rather than set the style in each single text item.

In general, fonts will only be displayed if they are installed on the device of the website visitor.

Because of this, you can create lists of fonts in Goldfish, from that the first font, wich is

installed on the device of the visitor, is used to display texts.

To do this, click on the button Alternative Font Family next to the font chooser and the 

Alternative Font Family window will be opened.

 Add Alternative Font Family

 Remove Alternative Font Family

Add alternative fonts that will be used when the required font was not found on the device of

the website visitor. The list will be processed from top to bottom and the first font, that is

installed, will be used to display text.
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INFO: If none of the fonts can be found, a default system font will be used. You can set

the basic characteristics for the standard font at Base Font Family.

Render Text as a Picture
You might want to use unusual fonts for headlines and other text. Usually this is not possible

on a website, because the font must be installed on the device of the site visitor.

If you use unusual fonts, they will probably not displayed correctly.

If you use unusual fonts, enable Text > Render as picture in the properties of a Text item. After

that, Goldfish will create an image with the text in the selected font. It can be shown on all

devices, even if the font is missing there.

INFO: It is not recommended to use this option for long texts. Use this only for

headlines. Otherwise, the size of your website will rise rapidly.

Embedded fonts with Adobe Typekit
Similar to a PDF document, fonts can be embedded in a website. The font don't have to be

installed on the device the of the website visitor anymore then, but it will be loaded from the

Internet. Because of the necessary licenses and because the font has to be stored in multiple

formats, Goldfish supports the Service Adobe Typekit.

To use Typekit, you have to register at the service. Click on PROJECT on the top left and go to

the properties. Click in the arrow below Typekit > Typekit ID and sign in. Copy the Kit ID after

you have registered your website and paste it in Goldfish at Typekit > Typekit Kit ID.
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After that, simply pic a font from the Typekit website and enter it in a Font Style window.

Goldfish will displays the font in the editor and preview only if it is installed locally on your

computer. Otherwise, the correct font will only appear on the published website and in the Font

Style window, the message Goldfish can't show the font in the editor, because it is not installed

on your computer. appears.
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29. Mobile Websites
More and more site visitors use mobile devices such as tablets and smartphones to

visit your website. That is why Goldfish supports mobile websites.

On mobile devices, all websites are always scaled precisely to the specified Goldfish page

width. Normal pages are correctly shown on smartphones but the texts and images are usually

too small to be seen closer without zooming.

Goldfish does not support responsive layouts, because the exact placement of objects with a

fixed width and height it wouldn't be possible there. In Goldfish you as a designer do have full

control over the layout of the website. Instead of responsive pages a special mobile website is

created by Goldfish. This is much more flexible because you can choose which content will be

shown on the mobile website.

The easiest way to create a mobile website is to enable the checkbox Add page for mobile

devices when creating a new project. If you choose a pre-built design, a mobile website will be

usually included automatically.
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Now you will find the page mobile in the project, to that all website visitors with a smartphone

will be forwarded automatically. On the other hand, all website visitors using a tablet or

computer remain on the normal website.

Create a page for mobile devices manually
If you want to add a mobile website to an existing project, you will need to create it manually.

 1. Add a Page Template called Mobile Page and enter 500 as Page Width (min) in the

properties. After that, set all margins to 0.

 2. Add Area Templates like Mobile Header, Mobile Navigation, Mobile Main or Mobile Footer

and create the layout for the mobile website in the width of the 500.

 3. Create a new page below the start page named mobile.html. It acts as the start page for

smartphones.

 4. Select Mobile Page as Page Template and fill the new page with the created Area

Templates, to create the layout.

 5. Disable the Menu Title, so that the mobile page will not appear in the navigation menu of

the normal website.

 6. Create a Navigation Menu Link (+ on the bottom left) and then drag the new link on the

mobile start page.

 7. Select the page /mobile as link taget of the navigation menu link. This is needed to show the

mobile start page in a navigation menu for the mobile website.

 8. Now set up the redirection from the start page. Go to the start page.

 9. Activate Redirection> Redirection in the properties and select /mobile as the redirection

destination. Choose the condition Device is Smartphone at Redirection > Condition.

All website visitors with a smartphone will be redirected to /mobile now. If you create pages

and content on the normal website, you have to create also a corresponding page below 

/mobile and place the content with copy and paste on it.

The Drawer Menu
Since there is usually no space for a regular menu on a mobile website, there are is a special

navigation menu for mobile websites in Goldfish.
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 1. Drag a menu on an Area Template for the mobile website.

 2. Change Menu > Menu Type to Drawer Menu in the properties.

 3. In addition, choose /mobile as Menu > Base Folder.

The menu will open with a touch on the menu icon and will display all mobile pages.

Properties of Pages for Mobile Devices
A Page offers special features for mobile devices. For example, you can specify a home

screen icon, hide the navigation bar or disable Pinch and Zoom.

Read the chapter Pages and Page Templates to learn more about this.
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Extend the functionality of Goldfish with HTML, CSS, PHP and more. Goldfish is very

flexible for web developers.

In Goldfish you can embed small HTML snippets or develop large webapps. Goldfish offers full

flexibility in the development of web applications of all kind.

Small snippets of code like a Google Maps map can be easily integrated and placed on a page

with an HTML Code item. Please read the chapter of the HTML Code item for more

information. The HTML Code item is part of Goldfish Standard and Professional.

For more options use the Code view. Here you can insert your own code at any point in the

document. Select the page on which you want to insert code and click on Code from the

toolbar.
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Goldfish displays the source code of the current page. Write your own code directly into the

source code. The added code appears in red. Click on the Delete button to delete all added

code.

 Delete all custom code from the page

When you edit items on the page and for example delete an item, to that you have added your

own code, Goldfish can't place this code into the generated source code any more, because

the corresponding point is deleted. In this case, the message  Own HTML code could not be

automatically inserted. will be displayed.

 Not automatically inserted HTML code

Then click on the button Not automatically inserted HTML code and delete the code from there

or copy it to the desired location in the document.

INFO: In the Code view, you can insert code at any point. However, deleting the from

Goldfish generated source code is not possible.

With Goldfish it is also possible to integrate individual files and folders into the project. You can

embed all files and scripts that are required by your application. Click on + below the project

list.

 Add External File...

 Add External Folder...

Click on Add External File... to add an external file from your computer to the project and with 

Add External Folder... a folder with files. All added folders and files can be moved up and down

on the project list like a page.

INFO: Inserted files and folders are only shortcuts and are not embedded into the

project. That means changes in this files are recognized from Goldfish. Do not move or

delete added files, otherwise they can't be found any longer by Goldfish when creating

the website.
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For some applications like PHP it is necessary to change the file extension of the pages that

are generated by Goldfish (default is html). Click on PROJECT on the top left of the project list

and change Project > Suffix of Code Files in the properties.

If you choose the file extension php, you can enter php code in the Code view directly and

develop PHP applications.

By default, Goldfish generates the HTML code for the page to that you can add your custom

code in the Code view. If you want to write the complete code of the page, the generated code

from Goldfish is not needed. In this case, enable Page > Disable HTML code output from the

properties of the page. A blank page will be displayed in the Code view then. You can fill it

completely with your own code.

Overwriting Goldfish Generated Files and Scripts
If you don't like the default-generated images in the folder support or you want to make

changes to the scripts, you can overwrite individual files from the folder support.

 1. To do this, select File > Export > Website in Downloads from the menu.

 2. Drag the folder support from the generated website folder to the directory with your project
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file.

 3. Replace there particular pictures, with your own, or edit the scripts.

 4. Delete all other files and folders to which you have not made any changes.

 5. Add the folder support from your project directory with + and Add External Folder.

INFO: If you have changed the name of the support folder in the properties at Project >

Name of Support Folder, you have to drag the folder with the new name from the

generated website (step 1).
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Before you publish your finished website, you can generate a preview in Goldfish.

You can generate a preview of your finished website in Goldfish at any time. Click on Preview

in the toolbar.

Goldfish generates a working preview of the selected page (or the start page, if no page is

selected) and displays it on the tab Preview. There you can also load the preview into the

standard browser of the operating system.

 Loads the preview into the standard browser of the operating system.

Please note that the preview does not matches completely with the final website. Some

functions (e.g. like the contact form or the online shop) must be installed on a web server to

work and can not be used in the preview.

If a function is not available in the preview, an error message will be displayed.
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If your website is complete, you should publish it on the Internet. So visitors can find

and see your website.

You will need a web server to publish your website on the Internet. Usually web hosting

service offers access to a web server, but you can also run your own.

INFO: Goldfish will not help you to find a web hosting service or to register a domain

such as www.mywebsite.com. But you can find a lot of web hosting services with 

Google (http://www.google.de).

The code files that are generated by Goldfish, should be uploaded to a web server (cloud). The

website visitors connect to your web server to request the website.

If your website is complete, you can publish it directly from Goldfish via FTP to your web

server. You will need ftp access to your web server to publish your website. Click on Publish

from the toolbar.
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After generating the website the FTP window will be opened. Enter the ftp address of the web

server, the user name and password. Enable Remember password if you want and click on 

OK. The webserver will be connected.

After connecting, Goldfish shows a list of folders on your web server. On some web servers,

you must publish the website in a certain subfolder. Ask your web hosting service for the

correct folder, if you don't know that. Double-click on a folder to navigate into it. Click on 

Publish if you are in the correct folder.

INFO:  Goldfish remembers all ftp logins which you have entered. You can choose a

recent login from the menu next to the server field.

Goldfish published your website and uploads all the generated files of your website to the web
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server. After a successful upload, a message appears to inform you that the website has been

published successfully.

If you have published your website already and you want to make changes in Goldfish, you

can publish it again. Click again on Publish from the toolbar. Goldfish shows the FTP window

no longer, but uploads only the changed files to the web server. If you want to publish your

website somewhere else, choose File > Publish Website As... from the menu.

INFO: If you do't want to use the built-in Publish function from Goldfish to publish the

website files, you can export them instead. Select File > Export > Website... and you can

save the files on your computer.

Error Messages While Creating the Website
There may occur errors during the creation of the website. There are various types of errors

when creating the website.

 - The e-mail address is missing: There is an e-mail form or shopping cart on the website,

but you did not enter any email address to which the data should be sent. Enter the missing

e-mail address and click on OK.

 - The Internet address is missing: There is a blog with RSS newsfeed on your website, but
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the address of the website was not entered. The Internet address is required for RSS feeds.

Enter the web address (e.g. http://www.mywebsite.com) and click on OK.

 - The admin password is missing: There is a guestbook or blog area on your website, but

the password to edit the entries has not been set. The password is required if you want to

delete guestbook entries or create blog entries. Enter a password and click on OK.

 - There are multiple shopping carts on a page: There is a page with at least two shopping

carts. It makes no sense to have multiple shopping carts on a single page. Delete all

unnecessary Shopping Cart items and publish your website again.

 - The shopping Cart is missing: There is a page with at least one product, but there is no

shopping cart to buy it. Add a shopping cart to the page or area template of the page and

publish your website again.

The Website is Damaged
If your website has display problems or errors occur (displaced items and other stuff), your

website may be damaged and has to be restored.

Select File > Publish Website As..., and log on your web server, but click NOT on Update after

that.

Select the website in the folder list instead (click once) and choose Restore Website (Code

Files) from the gear button menu. Goldfish restores your website and uploads all code files

again.

INFO: If this does not help, repeat the steps, but choose Restore Website (Code Files

and Media) this time. This takes significantly longer, but uploads completely all files of

the website again.

Publishing Using an External FTP App
If errors occur while you publish the website with Goldfish, you can publish it using an external

FTP app. The FTP app used here is Cyberduck.
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 - Download and install the app Cyberduck (http://www.cyberduck.ch).

 - Start Goldfish and open your website.

 - Select the File > Export > Website... and save the files of your website on the Desktop.

 - Start Cyberduck and choose Open Connection. Connect to your web server with your login

credentials.

 - Navigate by double in to correct folder in Cyberduck.

 - Open the folder on the desktop, created by Goldfish  and select all the files and folders in it.

 - Drag all files and folders into the Cyberduck window. The files will now be uploaded.

 - Look for the folder support/saved after the uploading to your web server has finished and

select it, if it exists.

 - Select Action > Info from the toolbar.

 - Enable all checkboxes from the Permissions and click on Apply changes recursively.

INFO: The folder support/saved only exists, when you use features that store data on

your website.
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33. Export Project as a Design
Export your project as Goldfish design template. Create new projects from your design

or hand the design over to your customers.

A Goldfish design is a design template for Goldfish websites. Designs will be installed as

templates in the Design window and can be used for new projects. Choose File > New from

the menu to see all installed designs.

Technically a design is a Goldfish project that contains the complete layout for a website but

no content.

To export your project as a design, choose File > Export > Design in Downloads from the

menu. Click on the design icon and paste a screenshot from your project. This is used in the 

Design window as preview picture. You can also enter a description and copyright text.

INFO: If you use the term mobile in the comment, Goldfish recognises that the design

contains the layout for a mobile website.

Click on OK to save your design in the Downloads folder. Goldfish Design files have the

extension .gfd instead of .gfp.
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34. Preferences
In the preferences, you can change the basic behavior of Goldfish.

Choose Goldfish 4 > Preferences... (Edit > Preferences... on Windows) from the menu and the

window Preferences appears.

The follwoning perferences can be set for Goldfish.

Show area template alignment guides on pages

If you have alignment guides on an area template, they will be shown on a page area that is

based on this template area as well.

Snap alignment guides to object positions

If you move an item around, it will snap to an alignment guide near by.

Magnetic Attraction of Alignment Guides

Set the attraction of the alignment guides, which reposition items.

Use sound effects

Plays sound, if the website is published or an update of the app is available.

Close areas in the properties automatically

If you activate this, there is kept only one area open in the properties.

Hide features of Goldfish Professional

If you don't activate this, all features that are locked, will be marked with PRO in the demo
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version and Goldfish Standard. If you activate this, these features will be hidden.

Port for FTP connections when publishing

Specifies the port for FTP connections. This is 21 by default. In some cases it may be

necessary to change it.

Search for updates at startup

Searches at every startup of Goldfish for updates on our website. You will be notified if there is

an update available. This option is missing in the Mac App Store version. Apps from the Mac

App Store will be automatically updated by Apple.
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35. Troubleshooting
Read what errors may occur with Goldfish and how to fix them.

Wrong Characters on the Website
Characters such as ©, ä and ß do not appear correctly on the published website.

Your Web server expects a different text encoding. Click on PROJECT in the top left corner.

Change Text Encoding in the properties, and select a different encoding. After you have

published your website again, the characters are displayed correctly.

Scripts are displayed in plain text and the visitor counter does not
work
Your web hosting service does not support PHP or PHP is not installed on the Web server.

Upgrade your web hosting package so that PHP is supported. Most web hosters don't offer

PHP support in the cheapest package. Alternatively, you can also remove all items and

functions, that require PHP (counter, redirection, form ...). These items can't be used on your

website then.

Statistics, counter values, comments or blog entries are not stored
Errors appear when saving statistics, counter readings, comments and blog entries, or the data

is gone after reloading the page.
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You have probably not granted writing access at the location for this data on the web server.

Log in with an external FTP program like Cyberduck (http://www.cyberduck.ch) on your Web

server, and change the permissions from the folder support/saved/.

Links do not work or links lead to nowhere
Probably your web server does not deal with short file paths or you try to test the website

locally on your computer. Short file paths do only work on web servers. To resolve the error,

you can disable short file paths. Click on PROJECT in the top left corner. Uncheck Project >

Use short file paths in the properties.

The online shop or the contact form does not send e-mails
Maybe you have incorrect or missing settings for the SMTP server. Read the chapter Form or 

Online Shop to learn how to fix the problem.

The Items on the website are positioned incorrectly
Maybe parts of the old website are still stored in your browser. Click on Reload or Refresh in

the browser to reload the website. If that does not help the Website is possibly Damaged.

Read the chapter Publish Website to learn how to repair the website.

Error Message because of Locked Features or Unavailable
Components
The message This feature is disabled in the trial version. or Your project contains features

which are only available in Goldfish Professional. appears.
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Remove any objects that are marked with PRO, or purchase an upgrade for Goldfish. Just

click on Learn More.

Creating the website causes errors
During the creation of the website error messages occur and the process sometimes stops

completely.

In this case there is some information missing to create the website. Enter the missing

information directly into the dialog box with the error message. Goldfish transfers this info into

your project and continues with the creation of the website. Sometimes it is necessary to make

other changes on the website. What exactly needs to be changed will be told in the error

message.

Publishing via FTP does not work or stops completely
If an error occurs when logging in to an FTP server or during the upload of the website, you

can publish the website manually with an external FTP app. Read the chapter Publish the

website to learn how to publish the website with an external FTP app.
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The project file can't be opened any longer
If the project file can't be opened any longer, you possibly have saved it with a newer version

of Goldfish and try to open it now with an older version.

Update Goldfish to the latest version. If the file is damaged, Goldfish may crash during the

opening process or an internal error occurs. Please contact the Fishbeam Customer Support in

this case. In most cases we can repair your project file.

An internal program error occurred
Goldfish has an internal program error, which can be mostly solved only in a new version.

Please contact the Fishbeam Support and describe all the steps that led to the error. A click on

Copy Bug Report copies the bug report to the clipboard. You can paste it in our contact form or

send an e-mail to us with the report.

Goldfish crashes
If Goldfish completely crashes usually the default crash dialog of the operating system

appears.
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Please contact the Fishbeam Support and describe all the steps that led to the error. 
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36. Goldfish Short Keys
In this chapter you will find a list of keyboard shortcuts that make it easier to work with

Goldfish or gain access to hidden features.

Application Start
 - Reset preferences

Open Preferences
 - Show advanced preferences

Edit Page
 - Delete selected Page Area

 - Leave edit mode

Edit Page Area
 + Click - Add to or remove from selection

 - 1 px. left

 - 1 px. right

 - 1 px. up

 - 1 px. down

 - Delete selected items

 + Resize item - Resizes in aspect ratio

 - Leave edit mode

Edit Item
 - Leave edit mode

Edit Text
 - Go right *

 +  or  + - Line end *

 +  - Next word *

 - Go left *

 +  or  +  - Line start *
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 +  - Last word *

 - Go up*

 +  - Text start *

 - Go down *

 +  - Text end *

 - Delete text left

 - Delete text right

* If you press also , the text will be selected.
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