
Goldfish 3
The Official Guide



A Big Thank You to
Tobias Schilpp

© 2024 Fishbeam Software

Text, Graphics: Yves Pellot

Proofread, Photos: Tobias Schilpp

Publish Code: #251206

www.fishbeam.com



Index

1. Register and Unlock

Learn how to register and unlock Goldfish, so that it works without limitations.

2. Project

Learn how to start a Golfish project. This is the first step if you want to create a website with

Goldfish.

3. Page

Learn how to create the page stucture of your website with pages and subpages.

4. Page Template

Learn how to use page templates. Set the default background and size for all pages of your

website.

5. Page Area

Seperate the pages of your website in areas. E.g. an area for header, navigation, footer and

content.

6. Area Template

Learn how to use area templates. Create the default layout for all pages of your website.

7. Text

Fill your website with content and add text.

8. Picture

Pictures are very important for the design of your website. The picture item in Goldfish has smart

functions for processing and showing pictures.

9. Media

Add QuickTime, Flash, RealMedia and Windows Media files to your website.

10. Navigation Menu

Add a navigation menu to your website. A navigation menu is the most important element what

visitors can use to navigate at your website.

11. Shape

With shapes you can draw, rectangles, rounded rectangles, ovals and lines directly on your

website.

12. Gallery

With a gallery you can present dozens of photos to the visitors of your website in a slide show.
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13. Form

Add a contact form to your website. With this form the visitor can send messages to you.

14. Website Frame

With a website frame, you can show an external page directly within your website.

15. Visitor Counter

Add a visitor counter to your website. With a visitor counter you can show the number of visitors

of your website.

16. HTML Code

Use a html code container to add your own html code to a page and extend Goldfish's

functionality.

17. Path

Show the path to the current page on your website to provide a clearer navigation.

18. Comments and Guestbook

Add a comments field or a guestbook to your website and receive feedback from the visitors of

your website.

19. Store

Create a store and add products and a shopping cart to your website and start your business

online.

20. Publish Website

Publish your website immedialtely on the internet with the built in ftp client.

21. Build your Website

Build your website on the desktop and get all neccessary files, which you can upload to a

webserver.

22. Import Media

Learn how you can import and process media files like images, movies and documents in

Goldfish.

23. Working with Fonts

There are several things you should know if you work with fonts and font styles on websites. 

24. Creating Webapplications

Create web applications with Goldfish Professional in your prefered language (e.g. PHP).
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25. Export a Design

Export your work as Goldfish design. Build websites from your design or deliver it to your clients.

26. Preferences

In the preferences, you can change the behavior of Goldfish.

27. Trouble and Errors

Learn what you can do if errors occure, if you find bugs or if you have trouble using Goldfish.

28. Goldfish Short Keys

Learn how to use Short Keys in Goldfish. This article contains a full list of all short keys for

Goldfish.
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1. Register and Unlock
Learn how to register and unlock Goldfish, so that it works without limitations.

If you work with the test version of Goldfish, you will see the following window on startup. Building

websites and publishing websites is deactivated. Please purchase the full version if you want to

build your website with Goldfish.

Click on Purchase License. This will lead you to our website where you can purchase Goldfish.

You can choose between Goldfish Standard and Goldfish Professional.

If you have purchased Goldfish, you will receive your serial via e-mail. Copy both, the name at 

Registered to and the serial, and paste it into the corresponding fields. Then click on Unlock.
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1: Register and Unlock

Goldfish works without limitations now. If you have entered a serial for an upgrade, Goldfish will

ask you for the serial of an earlier version, which you have purchased. Enter the old serial (if the

fields are not filled yet) and click on OK.

If you have purchased Goldfish Standard, you can always upgrade to Goldfish Professional.

Choose Goldfish > Purchase Goldfish... in the menu (Macintosh) or ? > Purchase Goldfish...

(Windows).
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1: Register and Unlock

Click on Purchase License and buy a license for the upgrade to Goldfish Professional. The

unlocking process is exactly the same as for an upgrade from an earlier version.
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2. Project
Learn how to start a Golfish project. This is the first step if you want to create a website

with Goldfish.

To start a new project, you have to decide if you want to start it from a design or a blank layout.

With a design, you don't have to create the design of your website. With a blank layout it is more

work, but the result is a website with a custom design.

Choose File > New from the menu. A new project window appears and all available designs will

be shown. There are many more designs available on our website. Click on More Designs and

you will be directed to our design download website. Choose a design or Blank Website and click

on OK.
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2: Project

The project window is seperated into 3 different areas: The project list (1). All components of your

website are listed here. Pages (with Start Page as first page), page templates and area

templates. In the editor (2) you can enter text, and edit the content of your website.

The editor is empty at the moment (the Goldfish icon appears), because you have selected

nothing. In the properties (3) you can see and set all properties for the selected component. At

the moment the properies for the project are visible, because you have selected nothing.

Goldfish's Page Model
Goldfish builds pages in an innovative and unique way. You have flexible components to create

your website. E.g. pages, page areas, text frames, picture frames etc. A page is built out of 3

different layers.

A page (grey) is the base. On a page, there are page areas (yellow), which represent areas of

your website (header, footer, navigation, main area etc.). A page area contains items (green).
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2: Project

Items store the content of your website like images, movies, text...

The Project List
Look at the project list: If you have started your project from a design, there are already pages,

page templates and area templates. The start page is the first page of your website. If visitors

enter your website, the start page will be shown.

Usually a website has on all pages the same style. You can store a layout template in Page

Templates and use it on all pages to overwrite their properties with the layout of the page

template. You can store a layout template in Area Templates and use it in page areas on all

pages.

Templates store the design and style for different pages or page areas in one place. This is useful

if you want to change something. Let's say the background color of all pages. If you don't use

page templates, you have to change it for every page seperately. If you have defined a page

template, you can only change it in the template and it will be applied to all pages that use this

template.

If you have started your project from a design, the next step is to create pages. If you have

started your project from a blank layout, you should edit page templates and area templates for

your layout and in the last step create the pages.

Properties for Project
These properties can be set for the project. Select nothing (the Goldfish icon appears in the

editor), to show the properties of the project.
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2: Project

Project > Meta Tags

Meta tags are used by old styled search engines to find your website. Here you can enter project

wide meta tags. Project wide meta tags appear on every page of your website. If you want to set

specific meta tags for a page, you have to use the meta tag property of a page.

 Add a meta tag.

 Delete a selected meta tag.

Enter the value of name or http-equiv at Meta Tag Name in the list. Enter the value of content at 

Meta Tag Value. If the meta tag begins with meta http-equiv=, enable the checkbox at http-equiv.

If you have edited your meta tags, click on OK.

Project > Page Address (URL)

Enter the absolute page URL of your website here. E.g. http://mydomain.com. This is required if

you use rss feeds on your website.

Project > Favorite Icon

Here you can choose a FavIcon for your website. A FavIcon is a small graphic in the adressbar

(this website uses a small fish as FavIcon). FavIcons must be windows .ico files to show up in

Internet Explorer. Firefox, Safari and the others accept .gif and .png as well.

Project > IE 6 Warning

Shows a warning if the visitor of your website uses Internet Explorer 6 or lower. Goldfish

Websites are not compatible with Internet Explorer 6.

Project > IE 6 Warning Explanation

More detailed warning for Internet Explorer 6 users.
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2: Project

Project > Admin Password

The password is required if you want to delete comments from the comments field.

Project > Embedded Media

Click on Choose to see a list of all embedded media files of your project. All images, movies and

other files, which you use at your website are included.

The description of every media file is used differently. E.g. as subtitle of a picture in a picture

gallery, as alt parameter for images or as title for download links. Doubleclick on a name or 

description to edit it. Note that there are restrictions for the name (no blanks, no special

characters, correct suffix). If you have entered a bad name, a beep occures and the old name will

be used.

Click on OK to close the embedded media window.

Project > Font Templates

You can use font templates to store font styles which you use permanently at your website.

Usually a website has only a few different font styles. Click on Choose to open the font templates

window.
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2: Project

The first template on the list is the Master Template. Here you can store the default font style of

your website. If you don't set a special font for all other font templates or items, the style of the

master template is used.

 Add a font template.

 Duplicate a selected font template.

 Delete a selected font template.

 Opens the font editor and you can edit the font template.

Double click on a font template to rename it. Please read the fonts documentation and learn how

to work with fonts.

Project > Name of Index File

Name of index pages. Usually index or start. It depends on your web server which names are

accepted.

Project > Name of Media Folder

Name of the folder for media files. Usually you don't have to change it.

Project > Name of Support Folder

Name of the folder for scripts and support files. Usually you don't have to change it.

Project > Suffix of Code Files

Suffix for all page files. Usually it is htm or html. But you can also use php if you have added PHP

code to some of your pages.
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2: Project

Project > Text Encoding

The Text Encoding for all code files. Usually this is UTF-8 but older web servers may require ISO

Latin 1

Project > JPEG Export Quality

Quality for all generated JPEG images. Better quality leads to clearer images but also bigger file

sizes.

Project > Use Short File Paths

Does not include index file names into file paths. If this is enabled, paths look like folder/ instead

of folder/index.htm

Stats > Include Stats for iPhone

Includes a web application that shows visitor stats of your website directly on your iPhone. Other

mobile phones are not supported.

To get access to the stats application, open safari and enter 

http://www.mywebsite.com/support/stats. Use the address of your website instead of 

http://www.mywebsite.com. If you have changed the value of Name of Support Folder in the

preferences, use the new name instead of support. Add the web application to your home screen

for later access.
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2: Project

Stats > Today

Text in the user interface for Today.

Stats > This Month

Text in the user interface for This Month

Stats > This Year

Text in the user interface for This Year

Stats > Total

Text in the user interface for Total

Stats > Total Format

Format in the user interface for total values. Use %1 as placeholder for the value.

Stats > Time Format

Format in the user interface for the hour of the day. Use %1 as placeholder for the hour.

Stats > Day Format

Format in the user interface for the day of the month. Use %1 as placeholder for the day.

Stats > Month Format

Format in the user interface for the month. Use %1 as placeholder for the month and %2 as

placeholder for the year.

Stats > Open Website

Text in the user interface for Open Website

Google > Google Analytics

Google Analytics is a free service from Google. With Google Analytics you can receive complete

and detaild user acess statistics for your website. Google will provide you a Google Analytics

tracker id to identify your website. Enter the id here in Goldfish. The id is provided in this form: 

UA-XXXXXX-X.

Google > Webmaster Tools

Google Analytics is a free service from Google. With Google Webmaster Tools, you can optimize

your website for the Google search engine. Google will provide you a meta tag in this form: \.

Enter only the content of this meta tag: XXXXXXXXXXXXX.

Typekit > Typekit Kit ID

ID that you receive if you register at the Typekit service.

With Typekit it is possible to use fonts that are not installed on the computers of your web site

visitors. So it is possible to display fonts on your web site as they would be displayed on your
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2: Project

computer.

Here you will find your Typekit Kit ID: If you have registered at the Typekit web site, log in and

click on Launch Kit Editor. Click on Embed Code then.
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3. Page
Learn how to create the page stucture of your website with pages and subpages.

Every website consitst of several pages, which are ordered hierarchically. All pages of your

project are listed in the project list on the left side of a project window.

The first page is the start page of your project (the world icon). This is the page which will be

loaded if the user enters your page address (e.g. http://www.fishbeam.com). All other pages are

sub pages of the start page.

 Click and choose Add Page. A new page will appear under start page.

 Duplicate a selected page with its content.

 Delete a selected page.

A website contains usually a complex page structure with pages and subpages. To create

subpages, drag pages into another pages.

INFO: You can reoder the project list with drag and drop. Move pages up and down to build

the correct page structure.

By default, pages are named page.htm, page_1.htm... To rename a page double click on it's

name. Note that you can only use letters, numbers and _ for the name. If the page has a suffix

(pages with sub pages don't, because they are actually folders with a index file), don't remove the

suffix. If you have entered a bad name, it won't be accepted.

Properties for Page
These properties can be set for a page. Select a page, but select nothing on the page, to show

the properties of the page.
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3: Page

Page > Title

The title of the page. The title will be shown as caption of the browser window.

Page > Menu Title

The menu title will be displayed in all navigation menus, who contain a link to this page. Disable it

and the page is not shown at the menu.

Page > Meta Tags

Here you can edit the meta tags for a page. Unlinke the project wide meta tags, the page meta

tags are only for this page. Please read the documentation for the project, to learn how the meta

tag editor works.

Page > Page Template

Select a page template, if you want to overwrite the style of the page with a template. Note that all

style properties for this page are hidden, if a page template is selected, because the style will be

set in the template then.

Page > Page Width (min)

Sets the minimal width of the page (pixel). If the browser window is smaller, scrollbars will be

shown. The width of a page area must be smaller or the same like the page with. You can't set a

minimal heigt of the page, because the height will be calculated by the minimal height of all page

areas.

Page > Content Alignment

Choose the alignment of the content if the browser window is larger than Page Width (min).

Page > Margin Left

Sets an offset from the left side of the page content.

Page > Margin Right

Sets an offset from the right side of the page content.

Page > Margin Top

Sets an offset from the top side of the page content.

Page > Margin Bottom

Sets an offset from the bottom side of the page content.

Page > Background Color

Select a background color for the page.

Page > Background Picture Clip

Select a background picture from the Goldfish Clips (

http://www.fishbeam.com/en/goldfish/clips.php) library. This option is only available if you have
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3: Page

the Goldfish Clips library installed.

Page > Background Picture

Select a background picture for the page. With Repeat, you can choose how the picture will be

displayed.

Page > Disable HTML Output PRO

Creates a blank page without any content or html code. Use this option only if you want to write a

script that writes HTML code.

Page > Add Code Before Document PRO

Add code before the html document begins. This is needed for some scripts (e.g. if you want to

use sessions in PHP).

Page > Add Header HTML Code PRO

Add custom html code to your page in the header section to extend Goldfish's functionality.

Page > Add HTML Code PRO

Add custom html code to your page in the body section to extend Goldfish's functionality.

Page > Add CSS Code PRO

Add custom css code to your page. The code will be stored in the css section of your website.

You can't change the css code of internal items, but you can use the css code in your custom

html code.

RSS > Enable Newsfeed

Enable this option, if you want to create a blog or newsfeed. A feed icon is displayed in the

webbrowser to show that there is a blog available for this page. With click on this icon, the blog

will be loaded.
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3: Page

The entries of the feed are all text items of the page. If the page has sub pages, the text items of

all subpages will be included too. To prevent a text item from being included into the feed, you

can disable it in the preferences of the text item. Disable RSS > Add Text To Feed.

INFO: You can only create one feed per page. If you are on a sub page and the parent page

contains a feed, you can't create a feed on this page.

RSS > Feed Description

Enter a short description for your news feed.
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4. Page Template
Learn how to use page templates. Set the default background and size for all pages of your

website.

Every website comes with a single layout and style. You can create page templates to store your

layout and style. Apply the page template to all pages of your website so that they have all the

same layout. If you change the layout later on the page template, the changes will automatically

apply on all pages of your website.

All page templates of your project are listed under Page Templates in the project list on the left

side of the project window.

 Click and choose Add Page Template. This creates a new page template.

 Duplicate a selected page template.

 Delete a selected page template.

The page template has the same properties as a page (but only those properties regarding the

style and layout).
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4: Page Template

To applay a page template to a page, select the page in the project list and look at the properties.

Select your page template at Page > Page Template. All properties regarding the style and layout

will disappear. They are now controlled by the page template.

Properties for Page Template
These properties can be set for a page template. Select a page template  to show its properties.

Page Template > Page Width (min)

Sets the minimal width of the page (pixel). If the browser window is smaller, scrollbars will be

shown. The width of a page area must be smaller or the same like the page with. You can't set a

minimal heigt of the page, because the height will be calculated by the minimal height of all page

areas.

Page Template > Content Alignment

Choose the alignment of the content if the browser window is larger than Page Width (min).

Page Template > Margin Left

Sets an offset from the left side of the page content.

Page Template > Margin Right

Sets an offset from the right side of the page content.

Page Template > Margin Top

Sets an offset from the top side of the page content.

Page Template > Margin Bottom

Sets an offset from the bottom side of the page content.

Page Template > Background Color

Select a background color for the page.

Page Template > Background Picture Clip

Select a background picture from the Goldfish Clips (

http://www.fishbeam.com/en/goldfish/clips.php) library. This option is only available if you have

the Goldfish Clips library installed.

Page Template > Background Picture

Select a background picture for the page. With Repeat, you can choose how the picture will be

displayed.

Page Template > Disable HTML Output PRO

Creates a blank page without any content or html code. Use this option only if you want to write a

script that writes HTML code.
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4: Page Template

Page Template > Add Code Before Document PRO

Add code before the html document begins. This is needed for some scripts (e.g. if you want to

use sessions in PHP).

Page Template > Add Header HTML Code PRO

Add custom html code to your page in the header section to extend Goldfish's functionality.

Page Template > Add HTML Code PRO

Add custom html code to your page in the body section to extend Goldfish's functionality.

Page Template > Add CSS Code PRO

Add custom css code to your page. The code will be stored in the css section of your website.

You can't change the css code of internal items, but you can use the css code in your custom

html code.
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5. Page Area
Seperate the pages of your website in areas. E.g. an area for header, navigation, footer and

content.

There are several page areas (e.g. for header, footer, navigation and content) on every page of

your website.

Every page area (yellow) contains the content of your website like menus, images and text. to

understand Goldfish's page model, read the documentation for project.

There are usually more than one page areas on a page. You can set a fixed width and a minimum

height for every page area. The real high of a page area depends on its content and the height of

the other page areas in the row.

To add page areas to a page, select the page and drag a page area from the tools to your page.

 Deletes the selected page area.

If you add page areas, the page will be filled row-wise from top to bottom. There are as many

page areas in a row as their width is smaller than the width of the page. If the row is full, the next

area will be displayed below in the next row.
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5: Page Area

INFO: The high of all page areas in a row is the same. Always the hight of the biggest page

area will be choosen.

Properties for Page Area
These properties can be set for a page area. Select a page area to show its properties.

Page Area > Area Template

Select an area template, if you want to overwrite the style of the page area with a template. Note

that all style properties for this page area are hidden, if an area template is selected, because the

style is controlled by the template.

Page Area > Width

Sets the width of the page area (pixel). The width of a page area must be smaller or the same like

the page with.

Page Area > Height (min)

Sets the minimal height of the page area (pixel). The real height is calculated by the height of the

content and the height of other page areas in the same row.

Page Area > Margin Left

Sets an offset from the left side of the page area content.

Page Area > Margin Right

Sets an offset from the left side of the page area content.

Page Area > Margin Top

Sets an offset from the top side of the page area content.

Page Area > Margin Bottom

Sets an offset from the left side of the page area content.

Page Area > Background Color

Select a background color for the page area.

Page Area > Background Picture Clip

Select a background picture from the Goldfish Clips (

http://www.fishbeam.com/en/goldfish/clips.php) library. This option is only available if you have

the Goldfish Clips library installed.

Page Area > Background Picture

Select a background picture for the page area. With Repeat, you can choose how the picture will

be displayed.
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5: Page Area

Page Area > Border Left Width

Displays a border on the left side of the page area in the choosen width (pixels).

Page Area > Border Left Color

Select a color for the left border.

Page Area > Border Right Width

Displays a border on the right side of the page area in the choosen width (pixels).

Page Area > Border Right Color

Select a color for the right border.

Page Area > Border Top Width

Displays a border on the top side of the page area in the choosen width (pixels).

Page Area > Border Top Color

Select a color for the top border.

Page Area > Border Bottom Width

Displays a border on the bottom side of the page area in the choosen width (pixels).

Page Area > Border Bottom Color

Select a color for the bottom border.

Page Area > Add HTML Code PRO

Add custom html code to the page area to extend Goldfish's functionality.

Page Area > Add CSS Code PRO

Add custom css code to the page area. The code will be stored in the css section of your website.

You can't change the css code of internal items, but you can use the css code in your custom

html code.

Content > Edit Content

Edit the content of the page area and add images, text or other content to your website.
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6. Area Template
Learn how to use area templates. Create the default layout for all pages of your website.

On every page of your website there are several page areas (e.g. for header, footer, navigation

and content). Some of these areas are on every page the same (e.g. navigation, footer, header).

Create area templates for these areas, and display them on every page.

All area templates of your project are listed under Area Templates in the project list on the left

side of the project window.

 Click and choose Add Area Template. This creates a new area template.

 Duplicate a selected area template.

 Delete a selected area template.

The area template has the same properties as a page area (but only those properties regarding

the style and layout).

To applay an area template to a page area, select the page area and look at the properties.
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6: Area Template

Select your area template at Page Area > Area Template. All properties regarding the style and

layout will disappear. They are now controlled by the area template.

Properties for Area Template
These properties can be set for an area template. Select an area template  to show its properties.

Area Template > Area Template

Select an area template, if you want to overwrite the style of the page area with a template. Note

that all style properties for this page area are hidden, if an area template is selected, because the

style is controlled by the template.

Area Template > Width

Sets the width of the page area (pixel). The width of a page area must be smaller or the same like

the page with.

Area Template > Height (min)

Sets the minimal height of the page area (pixel). The real height is calculated by the height of the

content and the height of other page areas in the same row.

Area Template > Margin Left

Sets an offset from the left side of the page area content.

Area Template > Margin Right

Sets an offset from the left side of the page area content.

Area Template > Margin Top

Sets an offset from the top side of the page area content.

Area Template > Margin Bottom

Sets an offset from the left side of the page area content.

Area Template > Background Color

Select a background color for the page area.

Area Template > Background Picture Clip

Select a background picture from the Goldfish Clips (

http://www.fishbeam.com/en/goldfish/clips.php) library. This option is only available if you have

the Goldfish Clips library installed.

Area Template > Background Picture

Select a background picture for the page area. With Repeat, you can choose how the picture will

be displayed.
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6: Area Template

Area Template > Border Left Width

Displays a border on the left side of the page area in the choosen width (pixels).

Area Template > Border Left Color

Select a color for the left border.

Area Template > Border Right Width

Displays a border on the right side of the page area in the choosen width (pixels).

Area Template > Border Right Color

Select a color for the right border.

Area Template > Border Top Width

Displays a border on the top side of the page area in the choosen width (pixels).

Area Template > Border Top Color

Select a color for the top border.

Area Template > Border Bottom Width

Displays a border on the bottom side of the page area in the choosen width (pixels).

Area Template > Border Bottom Color

Select a color for the bottom border.

Area Template > Add HTML Code PRO

Add custom html code to the page area to extend Goldfish's functionality.

Area Template > Add CSS Code PRO

Add custom css code to the page area. The code will be stored in the css section of your website.

You can't change the css code of internal items, but you can use the css code in your custom

html code.
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7. Text
Fill your website with content and add text.

You can add a text box to every page area or area template. To add a text box, edit the content of

a page area or area template and drag the text box from the items to the editor.

A text box displays text. Double click on it and you can edit the text. In the text edit mode, the

properties change. Select text and click on Edit Text > Font Style > Choose... to change the font

style, alignment and size.

The font style is set by the selected font template. Activate a checkbox to overwrite the style

property with your own values.

INFO: If you use a main style on every page and in every text box, it is better to change the

default text template instead of overwriting the style in every text box. Choose nothing (the

project properties appear) and click on Project > Font Templates > Choose....
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7: Text

Another important feature on websites is to add links. Select text and activate Edit text > Use as

link on the properties panel. Click on Choose... to set the link destination.

It is important to set the semantical meaning of your text. Search engines like google handle

headlines different than normal text. Select the text type at Edit Text > Text Type

 - Healine 1 - Headline 6: The selected text is a headline. This changes not the style. This is

important for search engines.

 - List: The selected text is part of a list. Every new line is a seperate list item. A bullet can

displayed before every list item.
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7: Text

Maybe you want to use uncommon fonts for headlines and other text. Usually you can't do this at

websites, because the font must be installed on the visitor's computer. If you use uncommon fonts

it probably won't be displayed correctly.

If you use uncommon fonts, activate Text > Render As Picture in the properties. Goldfish creates

a picture then with the text in the choosen font. It will be displayed on all computers. Even if the

font is missing there.

INFO: It is not recommended to use this option for long text. Use this only for headlines.

Otherwise the size of your website will grow rapidly.

Properties for Text
These properties can be set for a text box. Select a text box to show its properties.

Item > Left

Sets the distance from the left side of the parent element in pixels.

Item > Top

Sets the distance from the top side of the parent element in pixels.

Item > Width

Sets the width of the item in pixels.

Item > Height

Sets the width of the item in pixels.

Item > Padding Left

Sets the distance from the left side of the item to the content in pixels.
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Item > Padding Right

Sets the distance from the right side of the item to the content in pixels.

Item > Padding Top

Sets the distance from the top side of the item to the content in pixels.

Item > Padding Bottom

Sets the distance from the bottom side of the item to the content in pixels.

Item > Background Color

Select a background color for the item.

Item > Background Picture Clip

Select a background picture from the Goldfish Clips (

http://www.fishbeam.com/en/goldfish/clips.php) library. This option is only available if you have

the Goldfish Clips library installed.

Item > Background Picture

Select a background picture for the item. With Repeat, you can choose how the picture will be

displayed.

Item > Border Left Width

Displays a border on the left side of the item in the choosen width (pixels).

Item > Border Left Color

Select a color for the left border.

Item > Border Right Width

Displays a border on the right side of the item in the choosen width (pixels).

Item > Border Right Color

Select a color for the right border.

Item > Border Top Width

Displays a border on the top side of the item in the choosen width (pixels).

Item > Border Top Color

Select a color for the top border.

Item > Border Bottom Width

Displays a border on the bottom side of the item in the choosen width (pixels).
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Item > Border Bottom Color

Select a color for the bottom border.

Item > Add HTML Code PRO

Add custom html code to the item to extend Goldfish's functionality.

Item > Add CSS Code PRO

Add custom css code to the item. The code will be stored in the css section of your website. You

can't change the css code of internal items, but you can use the css code in your custom html

code.

Item > Identifer (Id) PRO

Sets the value for the id property. You can use this id to access the item with JavaScript.

Text > Render as picture

Renders the text as a picture, so that you can use uncommon fonts.

Text > Edit Content

Starts the edit mode of a text box.

Link style > Font style

Sets the font style for links.

Visual Effects
You can specify a visual effect, if the visitor interacts with a link (e.g. change the color if the visitor

moves his mouse over the link). The following properties are the same for Moving mouse over link

effect, Clicking on link effect and Already visited link effect.

Effect > Change font

Changes the font style of a menu item.

Effect > Font style

Sets the font style, to which will be changed.

RSS
The following properties are only visible if the page has a rss news feed.

RSS > Add text to feed

Adds the text box to the news feed of a page.

RSS > Title of the entry

The title of the news feed entry.
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RSS > Date

The date, when the entry of the feed is published.

Properties for Edit Text
These properties can be set in the edit mode of a text box. Select a text box and double click on it

to start the edit mode.

Edit text > Text type

Sets the semantic meaning for selected text (normal text, headlines or list).

Edit text > Padding left

The selected text belongs to a list it sets the space between the list bullet and the text.

Edit text > Bullet picture

Choose a bullet picture for the list (only at Text type: List with bullet picture).

Edit text > Font style

Sets the font style for selected text.

Edit text > Use as link

Use the selected text as link e.g. to another website.
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Pictures are very important for the design of your website. The picture item in Goldfish has

smart functions for processing and showing pictures.

You can add a picture item to every page area or area template. To add a picture item, edit the

content of a page area or area template and drag the picture item from the items to the editor.

A picture item displays a picture on your website. New picture items are still empty. A question

mark icon is displayed. To fill the item with a picture, click on Picture > Picture  in the properties

and choose a picture from your hard disk.

The media import window is displayed. Here you can enter a description (the description is used

as alt text in the html code). You can also resize the picture (recommended for big pictures, which

come directly from a digital camera), rotate or flip it.
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In Goldfish you can change the clipping of the picture. Start the edit mode with a double click on

the picture. Now you can zoom with the slider into the picture and drag the displayed clipping.

INFO: This is only possible if Picture > Calculate New On Export in the properties is

activated.

Attention if you add transparent gif images or gif animations: Deactivate always Picture >

Calculate New On Export. Otherwise the picture won't be exported correctly and the animation

will be destroyed.

Properties for Picture
These properties can be set for a picture item. Select a picture item to show its properties.
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Item > Left

Sets the distance from the left side of the parent element in pixels.

Item > Top

Sets the distance from the top side of the parent element in pixels.

Item > Width

Sets the width of the item in pixels.

Item > Height

Sets the width of the item in pixels.

Item > Padding Left

Sets the distance from the left side of the item to the content in pixels.

Item > Padding Right

Sets the distance from the right side of the item to the content in pixels.

Item > Padding Top

Sets the distance from the top side of the item to the content in pixels.

Item > Padding Bottom

Sets the distance from the bottom side of the item to the content in pixels.

Item > Background Color

Select a background color for the item.

Item > Background Picture Clip

Select a background picture from the Goldfish Clips (

http://www.fishbeam.com/en/goldfish/clips.php) library. This option is only available if you have

the Goldfish Clips library installed.

Item > Background Picture

Select a background picture for the item. With Repeat, you can choose how the picture will be

displayed.

Item > Border Left Width

Displays a border on the left side of the item in the choosen width (pixels).

Item > Border Left Color

Select a color for the left border.
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Item > Border Right Width

Displays a border on the right side of the item in the choosen width (pixels).

Item > Border Right Color

Select a color for the right border.

Item > Border Top Width

Displays a border on the top side of the item in the choosen width (pixels).

Item > Border Top Color

Select a color for the top border.

Item > Border Bottom Width

Displays a border on the bottom side of the item in the choosen width (pixels).

Item > Border Bottom Color

Select a color for the bottom border.

Item > Add HTML Code PRO

Add custom html code to the item to extend Goldfish's functionality.

Item > Add CSS Code PRO

Add custom css code to the item. The code will be stored in the css section of your website. You

can't change the css code of internal items, but you can use the css code in your custom html

code.

Item > Identifer (Id) PRO

Sets the value for the id property. You can use this id to access the item with JavaScript.

Picture > Picture

Select the picture, which you want to display.

Picture > Calculate New On Export

Calculates an optimized version of the picture in the correct size and quality for your website.

Deactivate this for transparent gif images and gif animations.

Picture > Edit Content

Click here to change the clipping for the picture. Note: This option is only available if Picture >

Calculate New On Export is enabled.

Picture > Reflection

Adds a reflection effect to the image. Enter the size in pixel. Note: This option is only available if 

Picture > Calculate New On Export is enabled.
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Picture > Flip Horizontal

Flips the picture horizontally. Note: This option is only available if Picture > Calculate New On

Export is enabled.

Picture > Flip Vertical

Flips the picture vertically. Note: This option is only available if Picture > Calculate New On Export

is enabled.

Picture > Rotation (Degree, Clockwise)

Rotates the picture clockwise by the entered value in degree. Note: This option is only available if 

Picture > Calculate New On Export is enabled.

Picture > Shaddow

Adds a shaddow effect to the picture. Select a color for the shaddow. Note: This option is only

available if Picture > Calculate New On Export is enabled.

Picture > Angel

The angel in degree in which direction the shaddow appears.

Picture > Offset

The offset beween the picture and the shaddow. An offset of 0 means that the shaddow is located

exactly among the picture.

Picture > Blur

Enter a value to blur the shaddow. A higher value blurs the shaddow more.

Picture > Opacity

The opacity of the shaddow. 100 means the shaddow has no transparency.

Link > Use as Link

Uses the picture as link. Select a page where the link should lead to.

Visual Effects
You can specify a visual effect, if the visitor of your website interacts with the picture link (e.g.

change the color if the visitor moves the mouse over the picture). The following properties are the

same for Moving mouse over link effect and Clicking on link effect.   

Effect > Change Picture

Changes the picture. Select the picture to which should be changed.
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Add QuickTime, Flash, RealMedia and Windows Media files to your website.

You can add a media player to every page area or area template. To add a media player, edit the

content of a page area or area template and drag the media player from the items to the editor.

A media player displays media content in many different formats. Add Quicktime, Windows Media

or RealMedia compatible videos and audio files or Flash movies to your website.

INFO: Flash video (.flv files) are not supported. It is required to embed these files into a

normal flash movie (.swf file). You can display the .swf file in a Flash player then.

Select the player, which you want to use on the properties at Media > Player and select a media

file from your harddisk at Media > Media. Every player type has a number of player specific

properties.
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Properties for Media
These properties can be set for a media player. Select a media player to show its properties.

Item > Left

Sets the distance from the left side of the parent element in pixels.

Item > Top

Sets the distance from the top side of the parent element in pixels.

Item > Width

Sets the width of the item in pixels.

Item > Height

Sets the width of the item in pixels.

Item > Padding Left

Sets the distance from the left side of the item to the content in pixels.

Item > Padding Right

Sets the distance from the right side of the item to the content in pixels.

Item > Padding Top

Sets the distance from the top side of the item to the content in pixels.

Item > Padding Bottom

Sets the distance from the bottom side of the item to the content in pixels.

Item > Background Color

Select a background color for the item.
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Item > Background Picture Clip

Select a background picture from the Goldfish Clips (

http://www.fishbeam.com/en/goldfish/clips.php) library. This option is only available if you have

the Goldfish Clips library installed.

Item > Background Picture

Select a background picture for the item. With Repeat, you can choose how the picture will be

displayed.

Item > Border Left Width

Displays a border on the left side of the item in the choosen width (pixels).

Item > Border Left Color

Select a color for the left border.

Item > Border Right Width

Displays a border on the right side of the item in the choosen width (pixels).

Item > Border Right Color

Select a color for the right border.

Item > Border Top Width

Displays a border on the top side of the item in the choosen width (pixels).

Item > Border Top Color

Select a color for the top border.

Item > Border Bottom Width

Displays a border on the bottom side of the item in the choosen width (pixels).

Item > Border Bottom Color

Select a color for the bottom border.

Item > Add HTML Code PRO

Add custom html code to the item to extend Goldfish's functionality.

Item > Add CSS Code PRO

Add custom css code to the item. The code will be stored in the css section of your website. You

can't change the css code of internal items, but you can use the css code in your custom html

code.

Item > Identifer (Id) PRO

Sets the value for the id property. You can use this id to access the item with JavaScript.
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Media > Media

Select the media file from your harddisk that you want to display.

Media > Player

Select the player type that can play the media file.

Media > Start playback automatically

Starts playing automatically after the page is loaded.

Media > Looping

Plays the media file in an endless loop.

Media > Show controller

Shows playback controls like play, stop and pause (QuickTime, RealPlayer, Windows Media

Player only).

Media > Hide menu for saving media file

Hides the menu for saving the media file (QuickTime only).

Media > Transparent background

Displays flash movies with alpha and transparency in front of the page content (Flash only).
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10. Navigation Menu
Add a navigation menu to your website. A navigation menu is the most important element

what visitors can use to navigate at your website.

You can add a navigation menu to every page area or area template. To add a navigation menu,

edit the content of a page area or area template and drag the navigation menu from the items to

the editor.

Usually you should add a navigation menu to an area template and use this area template on

every page of your website. So the navigation menu is displayed on every page of your website at

the same place.

The navigation menu shows automatically the pages of your website as menu entries. Usually

there is one entry for every page of your website. The shown text is always the  Page > Menu

Title property of a page.

To change the text, select the corresponding page and edit the  Page > Menu Title property of the
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page. If you deselect Page > Menu Title, the page does not appear in the navigation menu.

INFO: It is not possible to add a link manually to a navigation menu. The navigation menu

shows always automatically the pages of your website.

There are several types of navigation menus. You can set the type in the properties at Menu >

Menu Type.

 - Simple Menu (1): Shows only one hierarchy level of pages. It displays no submenu. If your

website has pages with sub pages, you need a second navigation menu for them.

 - Menu with Submenu (2): Shows only two hierarchy levels of pages. It displays one submenu.

If you click on a page with sub pages, the submenu appears directly under the main menu

entry of the page.

 - Dropdown Menu right (3): Shows all hierarchy levels of pages in a menu structure. If the

visitors of your website move the mouse over a menu entry of a page with subpages, a

submenu will pop up.

 - Dropdown Menu bottom (4): Shows all hierarchy levels of pages in a menu structure. If the

visitors of your website move the mouse over a menu entry of a page with subpages, a

submenu will pop up.
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By default, the main menu shows the first hierarchy level of pages (the start page and their sub

pages are shown). If you want to create a navigation menu that shows pages from another level,

change the property Menu > Base Folder. Here are all pages listed, that have sub pages. E.g. if

you select products in this example, products and all it's sub pages are shown.

INFO: If you change the size of the menu item, so that there is enough space, the menu

entries are displayed side by side.

Properties for Navigation Menu
These properties can be set for a navigation menu. Select a navigation menu to show its

properties.

Item > Left

Sets the distance from the left side of the parent element in pixels.

Item > Top

Sets the distance from the top side of the parent element in pixels.

Item > Width

Sets the width of the item in pixels.

Item > Height

Sets the width of the item in pixels.

Item > Padding Left

Sets the distance from the left side of the item to the content in pixels.
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Item > Padding Right

Sets the distance from the right side of the item to the content in pixels.

Item > Padding Top

Sets the distance from the top side of the item to the content in pixels.

Item > Padding Bottom

Sets the distance from the bottom side of the item to the content in pixels.

Item > Background Color

Select a background color for the item.

Item > Background Picture Clip

Select a background picture from the Goldfish Clips (

http://www.fishbeam.com/en/goldfish/clips.php) library. This option is only available if you have

the Goldfish Clips library installed.

Item > Background Picture

Select a background picture for the item. With Repeat, you can choose how the picture will be

displayed.

Item > Border Left Width

Displays a border on the left side of the item in the choosen width (pixels).

Item > Border Left Color

Select a color for the left border.

Item > Border Right Width

Displays a border on the right side of the item in the choosen width (pixels).

Item > Border Right Color

Select a color for the right border.

Item > Border Top Width

Displays a border on the top side of the item in the choosen width (pixels).

Item > Border Top Color

Select a color for the top border.

Item > Border Bottom Width

Displays a border on the bottom side of the item in the choosen width (pixels).
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Item > Border Bottom Color

Select a color for the bottom border.

Item > Add HTML Code PRO

Add custom html code to the item to extend Goldfish's functionality.

Item > Add CSS Code PRO

Add custom css code to the item. The code will be stored in the css section of your website. You

can't change the css code of internal items, but you can use the css code in your custom html

code.

Item > Identifer (Id) PRO

Sets the value for the id property. You can use this id to access the item with JavaScript.

Menu > Base Folder

Select a page with subpages that will be shown as main menu entries. By default the start page is

displayed but you can change this property to create submenus.

Menu > Show Base Folder as Menu Entry

Shows the selected page from Menu > Base Folder in the main menu. If you disable this, only its

sub pages will be shown.

Menu > Highlight Parent Entry

If you are on a page from the sub menu, the menu entry of its parent page will be highlighted, too.

If you deactivate this, only the entry of the current page will be highlited.

Menu > Menu Type

Sets the menu type for a page. You can choose between:

 - Simple Menu

 - Menu with Submenu

 - Dropdown Menu right

 - Dropdown Menu bottom

Menu > Margin Horizontal

Sets the space between the bottom of a menu entry and the top of the next entry.

Menu > Margin Vertical

Sets the space between the right of a menu entry and the left of the next entry.

Main Menu Entry and Submenu Entry
The following properties are the same for Main Menu Entry and Submenu Entry. Note that 

Submenu Entry will only be visible, if you don't choose Simple Menu at Menu > Menu Type.

Because a simple menu has no sub menu.
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Menu Entry > Width

Sets the width of a menu entry in pixels.

Menu Entry > Height

Sets the height of a menu entry in pixels.

Menu Entry > Alignment

Sets the alignment of the text in a menu entry.

Menu Entry > Font Style

Sets the font style of the text in a menu entry.

Menu Entry > Padding Left

Sets the distance from the left side of a menu entry to the content in pixels.

Menu Entry > Padding Right

Sets the distance from the right side of a menu entry to the content in pixels.

Menu Entry > Padding Top

Sets the distance from the top side of a menu entry to the content in pixels.

Menu Entry > Padding Bottom

Sets the distance from the bottom side of a menu entry to the content in pixels.

Menu Entry > Background Color

Select a background color for a menu entry.

Menu Entry > Background Picture Clip

Select a background picture from the Goldfish Clips (

http://www.fishbeam.com/en/goldfish/clips.php) library. This option is only available if you have

the Goldfish Clips library installed.

Menu Entry > Background Picture

Select a background picture for a menu entry. With Repeat, you can choose how the picture will

be displayed.

Menu Entry > Border Left Width

Displays a border on the left side of a menu entry in the choosen width (pixels).

Menu Entry > Border Left Color

Select a color for the left border.
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Menu Entry > Border Right Width

Displays a border on the right side of a menu entry in the choosen width (pixels).

Menu Entry > Border Right Color

Select a color for the right border.

Menu Entry > Border Top Width

Displays a border on the top side of a menu entry in the choosen width (pixels).

Menu Entry > Border Top Color

Select a color for the top border.

Menu Entry > Border Bottom Width

Displays a border on the bottom side of a menu entry in the choosen width (pixels).

Menu Entry > Border Bottom Color

Select a color for the bottom border.

Visual Effects
You can specify a visual effect, if a visitor of your website interacts with the navigation menu (e.g.

change the color if the visitor moves the mouse over the menu item). The following properties are

the same for Moving mouse over link effect, Clicking on link effect and Already visited link effect.

Effect > Change Font

Changes the font style of a menu item.

Effect > Font Style

Sets the font style, to which will be changed.

Effect > Change Background

Changes the background of a menu item.

Effect > Background Color

Select a background color for a menu entry.

Effect > Background Picture Clip

Select a background picture from the Goldfish Clips (

http://www.fishbeam.com/en/goldfish/clips.php) library. This option is only available if you have

the Goldfish Clips library installed.

Effect > Background Picture

Select a background picture for a menu entry. With Repeat, you can choose how the picture will

be displayed.
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Effect > Change Border

Changes the border of a menu item.

Effect > Border Left Width

Displays a border on the left side of a menu entry in the choosen width (pixels).

Effect > Border Left Color

Select a color for the left border.

Effect > Border Right Width

Displays a border on the right side of a menu entry in the choosen width (pixels).

Effect > Border Right Color

Select a color for the right border.

Effect > Border Top Width

Displays a border on the top side of a menu entry in the choosen width (pixels).

Effect > Border Top Color

Select a color for the top border.

Effect > Border Bottom Width

Displays a border on the bottom side of a menu entry in the choosen width (pixels).

Effect > Border Bottom Color

Select a color for the bottom border.

Effect > Change Padding

Changes the padding of a menu item.

Effect > Padding Left

Sets the distance from the left side of a menu entry to the content in pixels.

Effect > Padding Right

Sets the distance from the right side of a menu entry to the content in pixels.

Effect > Padding Top

Sets the distance from the top side of a menu entry to the content in pixels.

Effect > Padding Bottom

Sets the distance from the bottom side of a menu entry to the content in pixels.
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With shapes you can draw, rectangles, rounded rectangles, ovals and lines directly on

your website.

You can add a shape to every page area or area template. To add a shape, edit the content of a

page area or area template and drag the shape from the items to the editor.

Shapes are a good choise if you want to create the layout of your website. Shapes can contain

rectangles, rounded rectangles, ovals or lines. Or nothing, if you just want to show a background

image or color in the shape.

The property Shape > Has Shape defines if a shape is shown in the item and what kind of shape

is used. Choose between rectangle, rounded rectangle, oval or line. It depends on your selection

which other options are available.

Every shape has a fill color and a border. If you only want to have a rectangle with a background

or one color, deactivate Has Shape and use the background of the item instead.
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Properties for Shape
These properties can be set for a shape. Select a shape to show its properties.

Item > Left

Sets the distance from the left side of the parent element in pixels.

Item > Top

Sets the distance from the top side of the parent element in pixels.

Item > Width

Sets the width of the item in pixels.

Item > Height

Sets the width of the item in pixels.

Item > Padding Left

Sets the distance from the left side of the item to the content in pixels.

Item > Padding Right

Sets the distance from the right side of the item to the content in pixels.

Item > Padding Top

Sets the distance from the top side of the item to the content in pixels.

Item > Padding Bottom

Sets the distance from the bottom side of the item to the content in pixels.

Item > Background Color

Select a background color for the item.

Item > Background Picture Clip

Select a background picture from the Goldfish Clips (

http://www.fishbeam.com/en/goldfish/clips.php) library. This option is only available if you have

the Goldfish Clips library installed.

Item > Background Picture

Select a background picture for the item. With Repeat, you can choose how the picture will be

displayed.

Item > Border Left Width

Displays a border on the left side of the item in the choosen width (pixels).
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Item > Border Left Color

Select a color for the left border.

Item > Border Right Width

Displays a border on the right side of the item in the choosen width (pixels).

Item > Border Right Color

Select a color for the right border.

Item > Border Top Width

Displays a border on the top side of the item in the choosen width (pixels).

Item > Border Top Color

Select a color for the top border.

Item > Border Bottom Width

Displays a border on the bottom side of the item in the choosen width (pixels).

Item > Border Bottom Color

Select a color for the bottom border.

Item > Add HTML Code PRO

Add custom html code to the item to extend Goldfish's functionality.

Item > Add CSS Code PRO

Add custom css code to the item. The code will be stored in the css section of your website. You

can't change the css code of internal items, but you can use the css code in your custom html

code.

Item > Identifer (Id) PRO

Sets the value for the id property. You can use this id to access the item with JavaScript.

Shape > Has Shape

Select the shape that should be shown. Deactivate this, if you don't want a shape.

Shape > Arc

Sets the arc for the round edges of a rounded rectangle.

Shape > Fill Color

Choose a fill color for the shape or the color of a line shape.

Shape > Size

Sets the size of a line shape in pixels.
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Shape > Border Width

Sets the width for the border of the shape in pixels.

Shape > Border Color

Choose a color for the border of the shape.
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With a gallery you can present dozens of photos to the visitors of your website in a slide

show.

You can add a gallery to every page area or area template. To add a gallery, edit the content of a

page area or area template and drag the gallery from the items to the editor.

A gallery shows a range of pictures as thumbnails. The visitor of your website can click on each

thumbnail to see a larger version. Optional you can add a slideshow, so that the next picture will

be loaded automatically.

To add pictures to your gallery, double click on it to edit its content. Drag the pictures around to

reorder them or click into the close widget of a picture to delete it. In the properties are several

options:

Edit Gallery > Add One Picture

Select a picture from your harddisk to add it to your gallery.

Edit Gallery > Add From Folder

Select a folder with pictures from your harddisk. Goldfish will add all of these pictures to your

gallery.

- 57 -



12: Gallery

Edit Gallery > Delete All Pictures

Removes all pictures from your gallery.

If you add pictures to your gallery, the media import window will appear for every picture. If you

have large pictures (e.g. from a digital camera), you should reduce the size to max. 700 x 700

pixels. You can enter a description for every picture if you want. Check For All if you don't that the

media import window pops up again for every picture.

If a visitor of your website clicks on a thumbnail, the larger version of the picture will be loaded.

There are several display types of the larger version.
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Choose Animated Gallery at Presentation Page > Type in the properties and the pictures will pop

up in the front, while your website is faded dark.
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Choose Image Zoom at Presentation Page > Type in the properties and the pictures will pop up in

the front, while your website keeps in the background.

Choose Classic at Presentation Page > Type in the properties and the pictures will be loaded on

a seperate page.

If you want to load pictures automatically in a slide show, you can enable Presentation Page >

Slide Pause (Sec.) in the properties and enter a time in seconds. Otherwise deactivate this

option. If you want to show the comments, which you have entered in the media import window

below every picture, enable Presentation Page > Show Description.
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To change a comment for a picture, double click on the gallery to edit it and right click (ctrl-click)

on an image and choose Edit Comment....

Properties for Gallery
These properties can be set for a gallery. Select a gallery to show its properties.

Item > Left

Sets the distance from the left side of the parent element in pixels.

Item > Top

Sets the distance from the top side of the parent element in pixels.

Item > Width

Sets the width of the item in pixels.

Item > Height

Sets the width of the item in pixels.

Item > Padding Left

Sets the distance from the left side of the item to the content in pixels.

Item > Padding Right

Sets the distance from the right side of the item to the content in pixels.

Item > Padding Top

Sets the distance from the top side of the item to the content in pixels.
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Item > Padding Bottom

Sets the distance from the bottom side of the item to the content in pixels.

Item > Background Color

Select a background color for the item.

Item > Background Picture Clip

Select a background picture from the Goldfish Clips (

http://www.fishbeam.com/en/goldfish/clips.php) library. This option is only available if you have

the Goldfish Clips library installed.

Item > Background Picture

Select a background picture for the item. With Repeat, you can choose how the picture will be

displayed.

Item > Border Left Width

Displays a border on the left side of the item in the choosen width (pixels).

Item > Border Left Color

Select a color for the left border.

Item > Border Right Width

Displays a border on the right side of the item in the choosen width (pixels).

Item > Border Right Color

Select a color for the right border.

Item > Border Top Width

Displays a border on the top side of the item in the choosen width (pixels).

Item > Border Top Color

Select a color for the top border.

Item > Border Bottom Width

Displays a border on the bottom side of the item in the choosen width (pixels).

Item > Border Bottom Color

Select a color for the bottom border.

Item > Add HTML Code PRO

Add custom html code to the item to extend Goldfish's functionality.
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Item > Add CSS Code PRO

Add custom css code to the item. The code will be stored in the css section of your website. You

can't change the css code of internal items, but you can use the css code in your custom html

code.

Item > Identifer (Id) PRO

Sets the value for the id property. You can use this id to access the item with JavaScript.

Gallery > Edit Content

Click here to edit the content of a gallery or double click on it.

Gallery > Title

The title of your gallery. It is shown on the presentation page in the title bar of the web browser

(only if you choose  Classic as gallery type).

Preview Icon > Icon width (max)

Sets the maximal with of a thumbnail. Maximal because the picture is resized in aspect ratio.

Preview Icon > Icon height (max)

Sets the maximal height of a thumbnail. Maximal because the picture is resized in aspect ratio.

Preview Icon > Margin horizontal

Sets the space between the bottom of a thumbnail and the top of the next thumbnail.

Preview Icon > Margin vertical

Sets the space between the right of a thumbnail and the left of the next thumbnail.

Preview Icon > Padding Left

Sets the distance from the left side of a thumbnail to the content in pixels.

Preview Icon > Padding Right

Sets the distance from the right side of a thumbnail to the content in pixels.

Preview Icon > Padding Top

Sets the distance from the top side of a thumbnail to the content in pixels.

Preview Icon > Padding Bottom

Sets the distance from the bottom side of a thumbnail to the content in pixels.

Preview Icon > Background Color

Select a background color for a thumbnail.
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Preview Icon > Background Picture Clip

Select a background picture from the Goldfish Clips (

http://www.fishbeam.com/en/goldfish/clips.php) library. This option is only available if you have

the Goldfish Clips library installed.

Preview Icon > Background Picture

Select a background picture for a thumbnail. With Repeat, you can choose how the picture will be

displayed.

Preview Icon > Border Left Width

Displays a border on the left side of a thumbnail in the choosen width (pixels).

Preview Icon > Border Left Color

Select a color for the left border.

Preview Icon > Border Right Width

Displays a border on the right side of a thumbnail in the choosen width (pixels).

Preview Icon > Border Right Color

Select a color for the right border.

Preview Icon > Border Top Width

Displays a border on the top side of a thumbnail in the choosen width (pixels).

Preview Icon > Border Top Color

Select a color for the top border.

Preview Icon > Border Bottom Width

Displays a border on the bottom side of a thumbnail in the choosen width (pixels).

Preview Icon > Border Bottom Color

Select a color for the bottom border.

Presentation Page > Type

Choose the type of the gallery. The type affects how the larger version of a thumbnail will be

presented.

Presentation Page > Slide Pause (Sec)

Sets how long a pictures is shown in the slideshow. Deactivate this to have no slideshow.

Presentation Page > Show Description

Shows the comment of a picture below the large version picture on the presentation page.

- 64 -

http://www.fishbeam.com/en/goldfish/clips.php


12: Gallery

Presentation Page > Font Style

Sets the font style for the presentation page.

Presentation Page > Background Color

Select a background color for the presentation page.

Presentation Page > Background Picture Clip

Select a background picture from the Goldfish Clips (

http://www.fishbeam.com/en/goldfish/clips.php) library. This option is only available if you have

the Goldfish Clips library installed.

Presentation Page > Background Picture

Select a background picture for the presentation page. With Repeat, you can choose how the

picture will be displayed.

Presentation Page > Opacity (%)

Sets the opacity of the background (only available for Animated Gallery as gallery type.
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13. Form
Add a contact form to your website. With this form the visitor can send messages to you.

You can add a form to every page area or area template. To add a form, edit the content of a

page area or area template and drag the form from the items to the editor.

A form let the visitors of your website get in touch with you. Usually he fills out the form, sends it

and you receive an e-mail with the form content. But you can also create custom forms, that

communicate with your own web applications and scripts.

Double click on the form to edit its content. You can reorder the form elements by dragging them

around. A click in the close widget of every element removes it from the form. Drag new form

elements from the items to the form. The following elements are available:

 - Text field: Displays an one line text field in the form. This is used for entering short information

like names, e-mail addresses or passwords.

 - Multiline text field: Displays a large text field in the form. This is used for long text with

multiple lines.

 - Selection element: Displays a list box, a popup menu or a set of radio boxes. This is used to

let the visitor descide between multiple options.

 - Checkbox: Displays a checkbox in the form. This is used to accept or don't accept an option.
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Double click on a form element to see its options. The options which are available depend on the

form element on which you have clicked.

Options for Text Field

Name

Enter a name for the form element. This is important for custom forms. The name must be unique

in a form and can only contain letters, digits, _, and -.

Display name

The name, which is displayed in the form and the e-mail with the form content.

Form element required

Enable this and the visitor must enter a value in this element. Otherwise the form can't be sent.

Default text

The text field is filled with this text by default.

Password Field

The text field shows only ******* if the visitor enters text. This is used for passwords.

Allow only e-mail addresses

Only an e-mail address can be entered. You can select the form element as reply address for

e-mail forms.
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Options for Multiline Text Field

Name

Enter a name for the form element. This is important for custom forms. The name must be unique

in a form and can only contain letters, digits, _, and -.

Display name

The name, which is displayed in the form and the e-mail with the form content.

Form element required

Enable this and the visitor must enter a value in this element. Otherwise the form can't be sent.

Default text

The text field is filled with this text by default.

Height (pixels)

The height of the text filed. If the visitor enters more text scrollbars will be shown.

Options for Selection Element

Name

Enter a name for the form element. This is important for custom forms. The name must be unique

in a form and can only contain letters, digits, _, and -.

Display name

The name, which is displayed in the form and the e-mail with the form content.

Form element required

Enable this and the visitor must enter a value in this element. Otherwise the form can't be sent.

Selection kind

Sets the type of the selection element: List, Popup menu or Radio boxes

Options

Add or remove options from which the visitor can choose. Every option has a value for internal

use and a display name which is displayed in e-mails and in the form. If you enable Selected, the

option will be selected by default.

Height (pixels)

The height of the list box (list box only).

Multiple selection

The user can select multiple options in the list box (list box only).
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Options for Selection Element

Name

Enter a name for the form element. This is important for custom forms. The name must be unique

in a form and can only contain letters, digits, _, and -.

Display name

The name, which is displayed in the form and the e-mail with the form content.

Form element required

Enable this and the visitor must enter a value in this element. Otherwise the form can't be sent.

Checked

The checkbox is checked by default.

To deliver the form to your e-mail account is is required that you enter your e-mail address at 

Send page > E-mail address in the properties.

It is possible that Goldfish sets the entered e-mail address of the visitor as reply address for the

e-mail, which you receive. Therefore it is required that you mark at least one text field as e-mail

address field. Double click on a text field and enable Allow only e-mail addresses.
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Leave the edit mode of the form. At Send page > Reply e-mail in the properties, there is a list of

all e-mail text fields. Select an e-mail text field as reply address for your e-mails.

INFO: This item uses PHP. Your webserver must support PHP to use it.

Properties for Form
These properties can be set for a form. Select a form to show its properties.

Item > Left

Sets the distance from the left side of the parent element in pixels.

Item > Top

Sets the distance from the top side of the parent element in pixels.

Item > Width

Sets the width of the item in pixels.

Item > Height

Sets the width of the item in pixels.

Item > Padding Left

Sets the distance from the left side of the item to the content in pixels.

Item > Padding Right

Sets the distance from the right side of the item to the content in pixels.

Item > Padding Top

Sets the distance from the top side of the item to the content in pixels.
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Item > Padding Bottom

Sets the distance from the bottom side of the item to the content in pixels.

Item > Background Color

Select a background color for the item.

Item > Background Picture Clip

Select a background picture from the Goldfish Clips (

http://www.fishbeam.com/en/goldfish/clips.php) library. This option is only available if you have

the Goldfish Clips library installed.

Item > Background Picture

Select a background picture for the item. With Repeat, you can choose how the picture will be

displayed.

Item > Border Left Width

Displays a border on the left side of the item in the choosen width (pixels).

Item > Border Left Color

Select a color for the left border.

Item > Border Right Width

Displays a border on the right side of the item in the choosen width (pixels).

Item > Border Right Color

Select a color for the right border.

Item > Border Top Width

Displays a border on the top side of the item in the choosen width (pixels).

Item > Border Top Color

Select a color for the top border.

Item > Border Bottom Width

Displays a border on the bottom side of the item in the choosen width (pixels).

Item > Border Bottom Color

Select a color for the bottom border.

Item > Add HTML Code PRO

Add custom html code to the item to extend Goldfish's functionality.
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Item > Add CSS Code PRO

Add custom css code to the item. The code will be stored in the css section of your website. You

can't change the css code of internal items, but you can use the css code in your custom html

code.

Item > Identifer (Id) PRO

Sets the value for the id property. You can use this id to access the item with JavaScript.

Form > Form type

Sets the type of the form: E-mail form or Custom form.

Form > Internet address

The internet address to which the form will be sent (custom forms only). At this address there

must be a script which handles the form data.

Form > Send method

Sets the send method Get or Post (custom forms only)

Form > Margin horizontal

Sets the space between two form elements

Form > Font style

Sets the font style for  the form

Form > Send button

Enable this and the form has a send button. Enter the caption of the button.

Form > Reset button

Enable this and the form has a reset button. Enter the caption of the button.

Form > Edit content

Starts the edit mode of the form.

Send page > E-mail address

Sets the e-mail address to which the form should be sent.

Send page > E-mail subject

Sets the subject of the form e-mail.

Send page > Sent message

Sets the message, which is displayed to the visitor if the form is sent successfully.
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Send page > Reply e-mail

Sets the e-mail text field which contains the visitors e-mail addess.

- 73 -



14. Website Frame
With a website frame, you can show an external page directly within your website.

You can add a website frame to every page area or area template. To add a website frame, edit

the content of a page area or area template and drag the website frame from the elements panel

to the editor.

A website frame shows an external website directly on your page. For example you can include a

forum or other web application, which Goldfish does not support directly. Enter the url of the

external website at Website Frame > Url Of Frame Content.

Properties for Website Frame
These properties can be set for a website frame. Select a website frame to show its properties.

Item > Left

Sets the distance from the left side of the parent element in pixels.

Item > Top

Sets the distance from the top side of the parent element in pixels.

Item > Width

Sets the width of the item in pixels.

Item > Height

Sets the width of the item in pixels.

Item > Padding Left

Sets the distance from the left side of the item to the content in pixels.
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Item > Padding Right

Sets the distance from the right side of the item to the content in pixels.

Item > Padding Top

Sets the distance from the top side of the item to the content in pixels.

Item > Padding Bottom

Sets the distance from the bottom side of the item to the content in pixels.

Item > Background Color

Select a background color for the item.

Item > Background Picture Clip

Select a background picture from the Goldfish Clips (

http://www.fishbeam.com/en/goldfish/clips.php) library. This option is only available if you have

the Goldfish Clips library installed.

Item > Background Picture

Select a background picture for the item. With Repeat, you can choose how the picture will be

displayed.

Item > Border Left Width

Displays a border on the left side of the item in the choosen width (pixels).

Item > Border Left Color

Select a color for the left border.

Item > Border Right Width

Displays a border on the right side of the item in the choosen width (pixels).

Item > Border Right Color

Select a color for the right border.

Item > Border Top Width

Displays a border on the top side of the item in the choosen width (pixels).

Item > Border Top Color

Select a color for the top border.

Item > Border Bottom Width

Displays a border on the bottom side of the item in the choosen width (pixels).
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Item > Border Bottom Color

Select a color for the bottom border.

Item > Add HTML Code PRO

Add custom html code to the item to extend Goldfish's functionality.

Item > Add CSS Code PRO

Add custom css code to the item. The code will be stored in the css section of your website. You

can't change the css code of internal items, but you can use the css code in your custom html

code.

Item > Identifer (Id) PRO

Sets the value for the id property. You can use this id to access the item with JavaScript.

Website Frame > Url of frame content

Enter the url of the external website, which you want to display.

Website Frame > Show scrollbars if required

Enable this option and scrollbars will be shown if the external website is bigger than the frame.

Otherwise the content will be cut off.
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Add a visitor counter to your website. With a visitor counter you can show the number of

visitors of your website.

You can add a visitor counter to every page area or area template. To add a visitor counter, edit

the content of a page area or area template and drag the visitor counter from the items to the

editor.

A visitor counter counts every visitor of your website and displays the number of visitors as a

picture. Returning visiors are counted once in 24 hours. Change the properties in the section 

Visitor Counter in the properties to change the style of the counter.

The property Visitor Counter > Style sets the style of the counter. You can choose from a couple

of styles in different colors. Visitor Counter > Digits sets the size of the counter. If the counter

reding is too big for the number of digits, the last digits will be cut off.

INFO: If you have Goldfish Clips (http://www.fishbeam.com/en/goldfish/clips.php) installed,

there are many more counter styles available. If not, there are only seven built in styles.

If you don't like the built in styles, you can create a custom counter picture. The counter picture is
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a small image with the digits 0 to 9 on it. The counter script cuts out every digit which is needed,

and puts them together to the displayed counter reading.

Choose Custom Style at Visitor Counter > Style on the properties pane and select your created

counter picture.

INFO: This item uses PHP. Your webserver must support PHP to use it.

Properties for Visitor Counter
These properties can be set for a visitor counter. Select a visitor counter to show its properties.

Item > Left

Sets the distance from the left side of the parent element in pixels.

Item > Top

Sets the distance from the top side of the parent element in pixels.

Item > Width

Sets the width of the item in pixels.

Item > Height

Sets the width of the item in pixels.

Item > Padding Left

Sets the distance from the left side of the item to the content in pixels.

Item > Padding Right

Sets the distance from the right side of the item to the content in pixels.

Item > Padding Top

Sets the distance from the top side of the item to the content in pixels.

Item > Padding Bottom

Sets the distance from the bottom side of the item to the content in pixels.

Item > Background Color

Select a background color for the item.

Item > Background Picture Clip

Select a background picture from the Goldfish Clips (

http://www.fishbeam.com/en/goldfish/clips.php) library. This option is only available if you have
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the Goldfish Clips library installed.

Item > Background Picture

Select a background picture for the item. With Repeat, you can choose how the picture will be

displayed.

Item > Border Left Width

Displays a border on the left side of the item in the choosen width (pixels).

Item > Border Left Color

Select a color for the left border.

Item > Border Right Width

Displays a border on the right side of the item in the choosen width (pixels).

Item > Border Right Color

Select a color for the right border.

Item > Border Top Width

Displays a border on the top side of the item in the choosen width (pixels).

Item > Border Top Color

Select a color for the top border.

Item > Border Bottom Width

Displays a border on the bottom side of the item in the choosen width (pixels).

Item > Border Bottom Color

Select a color for the bottom border.

Item > Add HTML Code PRO

Add custom html code to the item to extend Goldfish's functionality.

Item > Add CSS Code PRO

Add custom css code to the item. The code will be stored in the css section of your website. You

can't change the css code of internal items, but you can use the css code in your custom html

code.

Item > Identifer (Id) PRO

Sets the value for the id property. You can use this id to access the item with JavaScript.

Visitor Counter > Style

Select style for your counter.
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Visitor Counter > Counter Picture

Select a custom counter picture if you want to use a custom style for your counter.

Visitor Counter > Digits

Sets the number of digits that the counter displays.
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Use a html code container to add your own html code to a page and extend Goldfish's

functionality.

You can add a html code container to every page area or area template. To add a html code

container, edit the content of a page area or area template and drag the html code container from

the elements panel to the editor.

A html code container displays every pice of html code, what you want. For example you can

display a Google Maps (http://www.google.com/maps) map on your website and show your page

visitors where you are.

Enter the html code in the code editor. To open the code editor click on HTML Code > HTML

Code on the properties pane. The html code container is the only place where you can store html

code in Goldfish Standard. If you need more possibilities to enter html or css code, please

upgrade to Goldfish Professional.
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Properties for HTML Code
These properties can be set for a html code container. Select a html code container to show its

properties.

Item > Left

Sets the distance from the left side of the parent element in pixels.

Item > Top

Sets the distance from the top side of the parent element in pixels.

Item > Width

Sets the width of the item in pixels.

Item > Height

Sets the width of the item in pixels.

Item > Padding Left

Sets the distance from the left side of the item to the content in pixels.

Item > Padding Right

Sets the distance from the right side of the item to the content in pixels.
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Item > Padding Top

Sets the distance from the top side of the item to the content in pixels.

Item > Padding Bottom

Sets the distance from the bottom side of the item to the content in pixels.

Item > Background Color

Select a background color for the item.

Item > Background Picture Clip

Select a background picture from the Goldfish Clips (

http://www.fishbeam.com/en/goldfish/clips.php) library. This option is only available if you have

the Goldfish Clips library installed.

Item > Background Picture

Select a background picture for the item. With Repeat, you can choose how the picture will be

displayed.

Item > Border Left Width

Displays a border on the left side of the item in the choosen width (pixels).

Item > Border Left Color

Select a color for the left border.

Item > Border Right Width

Displays a border on the right side of the item in the choosen width (pixels).

Item > Border Right Color

Select a color for the right border.

Item > Border Top Width

Displays a border on the top side of the item in the choosen width (pixels).

Item > Border Top Color

Select a color for the top border.

Item > Border Bottom Width

Displays a border on the bottom side of the item in the choosen width (pixels).

Item > Border Bottom Color

Select a color for the bottom border.
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Item > Add HTML Code PRO

Add custom html code to the item to extend Goldfish's functionality.

Item > Add CSS Code PRO

Add custom css code to the item. The code will be stored in the css section of your website. You

can't change the css code of internal items, but you can use the css code in your custom html

code.

Item > Identifer (Id) PRO

Sets the value for the id property. You can use this id to access the item with JavaScript.

HTML Code > HTML Code

Enter the html code which should be included.
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Show the path to the current page on your website to provide a clearer navigation.

You can add a path to every page area or area template. To add a path, edit the content of a

page area or area template and drag the path from the elements panel to the editor.

A path shows the path from the current website back to the start page. Every page of the path is a

link so that the visitors of your website can navigate to it.

Properties for Path
These properties can be set for a path. Select a path to show its properties.

Item > Left

Sets the distance from the left side of the parent element in pixels.

Item > Top

Sets the distance from the top side of the parent element in pixels.

Item > Width

Sets the width of the item in pixels.

Item > Height

Sets the width of the item in pixels.

Item > Padding Left

Sets the distance from the left side of the item to the content in pixels.

Item > Padding Right

Sets the distance from the right side of the item to the content in pixels.
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Item > Padding Top

Sets the distance from the top side of the item to the content in pixels.

Item > Padding Bottom

Sets the distance from the bottom side of the item to the content in pixels.

Item > Background Color

Select a background color for the item.

Item > Background Picture Clip

Select a background picture from the Goldfish Clips (

http://www.fishbeam.com/en/goldfish/clips.php) library. This option is only available if you have

the Goldfish Clips library installed.

Item > Background Picture

Select a background picture for the item. With Repeat, you can choose how the picture will be

displayed.

Item > Border Left Width

Displays a border on the left side of the item in the choosen width (pixels).

Item > Border Left Color

Select a color for the left border.

Item > Border Right Width

Displays a border on the right side of the item in the choosen width (pixels).

Item > Border Right Color

Select a color for the right border.

Item > Border Top Width

Displays a border on the top side of the item in the choosen width (pixels).

Item > Border Top Color

Select a color for the top border.

Item > Border Bottom Width

Displays a border on the bottom side of the item in the choosen width (pixels).

Item > Border Bottom Color

Select a color for the bottom border.
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Item > Add HTML Code PRO

Add custom html code to the item to extend Goldfish's functionality.

Item > Add CSS Code PRO

Add custom css code to the item. The code will be stored in the css section of your website. You

can't change the css code of internal items, but you can use the css code in your custom html

code.

Item > Identifer (Id) PRO

Sets the value for the id property. You can use this id to access the item with JavaScript.

Path > Font Style

The font style for the delemiter.

Path > Delemiter

Delemiter between two links. The default value is >.

Link Style > Font Style

The font style for links.

Visual Effects
You can specify a visual effect, if your site visitor interacts with the path links (e.g. change the

color if your site visitor moves his mouse over the link). The following properties are the same for

Moving mouse over link effect, Clicking on link effect and Already visited link effect.   

Link Style > Change Font

Changes the font style of a menu item.

Link Style > Font Style

Sets the font style, to which will be changed.
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Add a comments field or a guestbook to your website and receive feedback from the

visitors of your website.

You can add a comments field to every page area or area template. To add a comments field,

edit the content of a page area or area template and drag the comments field from the elements

panel to the editor.

With a comment field the visitors of your website can leave short messages on your website (e.g.

for a blog entry). The same functionality is used by a guestbook. So you can use the comment

field for both: Comments and a guestbook.

You can decide if you want to allow visitors of your website to reply to comments. Enable 

Comments > Allow Replies in the properties to allow replies.  

Everyone can add commets to a comments item but deleting comments is protected by a

password. Click on the project  and enter a password at Project > Admin Password in the

properties. Then click  in the comments field at your website and enter the password. Now
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you can delete comments and send e-mails to comment writers.

INFO: This item uses PHP. Your webserver must support PHP to use it.

Properties for Comments
These properties can be set for a comments field. Select a comments field to show its properties.

Item > Left

Sets the distance from the left side of the parent element in pixels.

Item > Top

Sets the distance from the top side of the parent element in pixels.

Item > Width

Sets the width of the item in pixels.

Item > Height

Sets the width of the item in pixels.

Item > Padding Left

Sets the distance from the left side of the item to the content in pixels.

Item > Padding Right

Sets the distance from the right side of the item to the content in pixels.

Item > Padding Top

Sets the distance from the top side of the item to the content in pixels.

Item > Padding Bottom

Sets the distance from the bottom side of the item to the content in pixels.
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Item > Background Color

Select a background color for the item.

Item > Background Picture Clip

Select a background picture from the Goldfish Clips (

http://www.fishbeam.com/en/goldfish/clips.php) library. This option is only available if you have

the Goldfish Clips library installed.

Item > Background Picture

Select a background picture for the item. With Repeat, you can choose how the picture will be

displayed.

Item > Border Left Width

Displays a border on the left side of the item in the choosen width (pixels).

Item > Border Left Color

Select a color for the left border.

Item > Border Right Width

Displays a border on the right side of the item in the choosen width (pixels).

Item > Border Right Color

Select a color for the right border.

Item > Border Top Width

Displays a border on the top side of the item in the choosen width (pixels).

Item > Border Top Color

Select a color for the top border.

Item > Border Bottom Width

Displays a border on the bottom side of the item in the choosen width (pixels).

Item > Border Bottom Color

Select a color for the bottom border.

Item > Add HTML Code PRO

Add custom html code to the item to extend Goldfish's functionality.

Item > Add CSS Code PRO

Add custom css code to the item. The code will be stored in the css section of your website. You

can't change the css code of internal items, but you can use the css code in your custom html

code.
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Item > Identifer (Id) PRO

Sets the value for the id property. You can use this id to access the item with JavaScript.

Comments > Allow Replies

Allows the visitors of your website to reply to comments.

User Interface > Background Color

Select a background color for the comments field.

User Interface > Background Picture Clip

Select a background picture from the Goldfish Clips (

http://www.fishbeam.com/en/goldfish/clips.php) library. This option is only available if you have

the Goldfish Clips library installed.

User Interface > Background Picture

Select a background picture for the comments field. With Repeat, you can choose how the picture

will be displayed.

User Interface > Padding Left

Sets the distance from the left side of the comments field to the content in pixels.

User Interface > Padding Right

Sets the distance from the right side of the comments field to the content in pixels.

User Interface > Padding Top

Sets the distance from the top side of the comments field to the content in pixels.

User Interface > Padding Bottom

Sets the distance from the bottom side of the comments field to the content in pixels.

User Interface > Border Left Width

Displays a border on the left side of the comments field in the choosen width (pixels).

User Interface > Border Left Color

Select a color for the left border.

User Interface > Border Right Width

Displays a border on the right side of the comments field in the choosen width (pixels).

User Interface > Border Right Color

Select a color for the right border.
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User Interface > Border Top Width

Displays a border on the top side of the comments field in the choosen width (pixels).

User Interface > Border Top Color

Select a color for the top border.

User Interface > Border Bottom Width

Displays a border on the bottom side of the comments field in the choosen width (pixels).

User Interface > Border Bottom Color

Select a color for the bottom border.

User Interface > Date Format

Format in the user interface for dates. Use d for the day, m for the month and Y for the year.

User Interface > Name

Text in the user interface for Name.

User Interface > E-Mail

Text in the user interface for E-Mail.

User Interface > Message

Text in the user interface for Message.

User Interface > Cancel

Text in the user interface for Cancel.

User Interface > Send

Text in the user interface for Send.

User Interface > Password

Text in the user interface for Password. Note: This the text only if you want to translate the user

interface to another language. Change the password itself at Project > Admin Password.
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19. Store
Create a store and add products and a shopping cart to your website and start your

business online.

INFO: The shopping cart and product button is only available in Goldfish professional. 

PRO

Goldfish allows you to add a store to your website in only minues. You need at leat two differnet

items: A product button and a shopping cart. To add product buttons and a shopping cart, edit the

content of a page area or area template and drag the shopping cart and the product buttons from

the elements panel to the editor.

There are now several buttons on your website. A button for the shopping cart and at least one

product button. If the visitor of your website clicks on a product button, the product flies to the

shopping cart and is displayed in a badge. If the visitor clicks on the shopping cart, he can

checkout and submit the order.

To set up the shopping cart, click on it and the properties of the shopping cart are displayed.

Enter your e-mail address at Shopping Cart > E-Mail Address. All orders will be sent to this e-mail

adress via e-mail.
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To set up a product button, click on it and the properties of the product button are displayed.

Enter the product id for your product. Then enter the name, price and the label. The label is

displayed as text in the button.

Now your store is complete and ready for orders.

INFO: This item uses PHP. Your webserver must support PHP to use it.

Properties for Shopping Cart
These properties can be set for a shopping cart. Select a shopping cart to show its properties.

Item > Left

Sets the distance from the left side of the parent element in pixels.

Item > Top

Sets the distance from the top side of the parent element in pixels.
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Item > Width

Sets the width of the item in pixels.

Item > Height

Sets the width of the item in pixels.

Item > Padding Left

Sets the distance from the left side of the item to the content in pixels.

Item > Padding Right

Sets the distance from the right side of the item to the content in pixels.

Item > Padding Top

Sets the distance from the top side of the item to the content in pixels.

Item > Padding Bottom

Sets the distance from the bottom side of the item to the content in pixels.

Item > Background Color

Select a background color for the item.

Item > Background Picture Clip

Select a background picture from the Goldfish Clips (

http://www.fishbeam.com/en/goldfish/clips.php) library. This option is only available if you have

the Goldfish Clips library installed.

Item > Background Picture

Select a background picture for the item. With Repeat, you can choose how the picture will be

displayed.

Item > Border Left Width

Displays a border on the left side of the item in the choosen width (pixels).

Item > Border Left Color

Select a color for the left border.

Item > Border Right Width

Displays a border on the right side of the item in the choosen width (pixels).

Item > Border Right Color

Select a color for the right border.
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Item > Border Top Width

Displays a border on the top side of the item in the choosen width (pixels).

Item > Border Top Color

Select a color for the top border.

Item > Border Bottom Width

Displays a border on the bottom side of the item in the choosen width (pixels).

Item > Border Bottom Color

Select a color for the bottom border.

Item > Add HTML Code PRO

Add custom html code to the item to extend Goldfish's functionality.

Item > Add CSS Code PRO

Add custom css code to the item. The code will be stored in the css section of your website. You

can't change the css code of internal items, but you can use the css code in your custom html

code.

Item > Identifer (Id) PRO

Sets the value for the id property. You can use this id to access the item with JavaScript.

Shopping Cart > E-Mail Address

Enter the e-mail address to which the orders will be sent.

Shopping Cart > E-Mail Subject

Subject in the e-mails for the customer and the store owner.

Shopping Cart > Currency

Currency for orders.

Shopping Cart > Decimal Point

Decimal point for currency formatted numbers.

Shopping Cart > Tax (%)

Tax ammount for all orders.

Shopping Cart > Tax Included

Enable this if the tax is included in the prices of the products. Otherwise the tax will be added to 

Estimated Total.
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Shopping Cart > Shipping Fee

The shippng fee that will be added to all orders.

Shopping Cart > Payment Options

List of payment options, that are supported in the store. Note that payments are not implemented

in the store. The choosen payment will only be included in the e-mail from the store. You must

handle playments manually.

Shopping Cart > Countries

A list of countries to that you want to deliver.

Shopping Cart > State

Adds a field for the state to the order process (needed for US and Canadian addresses).

Shopping Cart > Terms and Conditions

Adds a checkbox for terms and conditions to the order process.

Shopping Cart > Comment

Adds a field for comments to the order process.

Page Background > Background Color

Select a background color for the shopping cart page.

Page Background > Background Picture Clip

Select a background picture from the Goldfish Clips (

http://www.fishbeam.com/en/goldfish/clips.php) library. This option is only available if you have

the Goldfish Clips library installed.

Page Background > Background Picture

Select a background picture for the shopping cart page. With Repeat, you can choose how the

picture will be displayed.

User Interface > Background Color

Select a background color for the shopping cart.

User Interface > Background Picture Clip

Select a background picture from the Goldfish Clips (

http://www.fishbeam.com/en/goldfish/clips.php) library. This option is only available if you have

the Goldfish Clips library installed.

User Interface > Background Picture

Select a background picture for the shopping cart. With Repeat, you can choose how the picture

will be displayed.
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User Interface > Padding Left

Sets the distance from the left side of the shopping cart to the content in pixels.

User Interface > Padding Right

Sets the distance from the right side of the shopping cart to the content in pixels.

User Interface > Padding Top

Sets the distance from the top side of the shopping cart to the content in pixels.

User Interface > Padding Bottom

Sets the distance from the bottom side of the shopping cart to the content in pixels.

User Interface > Border Left Width

Displays a border on the left side of the shopping cart in the choosen width (pixels).

User Interface > Border Left Color

Select a color for the left border.

User Interface > Border Right Width

Displays a border on the right side of the shopping cart in the choosen width (pixels).

User Interface > Border Right Color

Select a color for the right border.

User Interface > Border Top Width

Displays a border on the top side of the shopping cart in the choosen width (pixels).

User Interface > Border Top Color

Select a color for the top border.

User Interface > Border Bottom Width

Displays a border on the bottom side of the shopping cart in the choosen width (pixels).

User Interface > Border Bottom Color

Select a color for the bottom border.

User Interface > Font Style

Choose the font style for the shopping cart.

User Interface > Items

Text in the user interface for Items.
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User Interface > Item Price

Text in the user interface for Item Price.

User Interface > Quantity

Text in the user interface for Quantity.

User Interface > Item Total

Text in the user interface for Item Total.

User Interface > Shipping Fee

Text in the user interface for Shipping Fee.

User Interface > Tax

Text in the user interface for Tax.

User Interface > Estimated Total

Text in the user interface for Estimated Total.

User Interface > Close

Text in the user interface for Close.

User Interface > Checkout

Text in the user interface for Checkout.

User Interface > Back

Text in the user interface for Back.

User Interface > Next

Text in the user interface for Next.

User Interface > Submit Order

Text in the user interface for Submit Order.

User Interface > First Name

Text in the user interface for First Name.

User Interface > Last Name

Text in the user interface for Last Name.

User Interface > Street

Text in the user interface for Street.
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User Interface > Zip/Postal Code

Text in the user interface for Zip/Postal Code.

User Interface > City

Text in the user interface for City.

User Interface > Country

Text in the user interface for Country.

User Interface > Phone

Text in the user interface for Phone.

User Interface > E-Mail Address

Text in the user interface for E-Mail Address.

User Interface > Reenter E-Mail Address

Text in the user interface for Reenter E-Mail Address.

User Interface > Payment

Text in the user interface for Payment.

User Interface > Personal Information

Text in the user interface for Personal Information.

User Interface > Thank You Message

Text in the user interface for the thank you message..

Properties for Product Button
These properties can be set for a product button. Select a product button to show its properties.

Item > Left

Sets the distance from the left side of the parent element in pixels.

Item > Top

Sets the distance from the top side of the parent element in pixels.

Item > Width

Sets the width of the item in pixels.

Item > Height

Sets the width of the item in pixels.
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Item > Padding Left

Sets the distance from the left side of the item to the content in pixels.

Item > Padding Right

Sets the distance from the right side of the item to the content in pixels.

Item > Padding Top

Sets the distance from the top side of the item to the content in pixels.

Item > Padding Bottom

Sets the distance from the bottom side of the item to the content in pixels.

Item > Background Color

Select a background color for the item.

Item > Background Picture Clip

Select a background picture from the Goldfish Clips (

http://www.fishbeam.com/en/goldfish/clips.php) library. This option is only available if you have

the Goldfish Clips library installed.

Item > Background Picture

Select a background picture for the item. With Repeat, you can choose how the picture will be

displayed.

Item > Border Left Width

Displays a border on the left side of the item in the choosen width (pixels).

Item > Border Left Color

Select a color for the left border.

Item > Border Right Width

Displays a border on the right side of the item in the choosen width (pixels).

Item > Border Right Color

Select a color for the right border.

Item > Border Top Width

Displays a border on the top side of the item in the choosen width (pixels).

Item > Border Top Color

Select a color for the top border.
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Item > Border Bottom Width

Displays a border on the bottom side of the item in the choosen width (pixels).

Item > Border Bottom Color

Select a color for the bottom border.

Item > Add HTML Code PRO

Add custom html code to the item to extend Goldfish's functionality.

Item > Add CSS Code PRO

Add custom css code to the item. The code will be stored in the css section of your website. You

can't change the css code of internal items, but you can use the css code in your custom html

code.

Item > Identifer (Id) PRO

Sets the value for the id property. You can use this id to access the item with JavaScript.

Product Button > Product ID

The product id (item number) of the product. If you have two buttons with the same product id,

they refer to the same product.

Product Button > Product Name

Name of the product. This will be shown in the shopping cart.

Product Button > Price

Price of the product. The currency and tax is set in the shopping cart.

Product Button > Differing Tax

Enable this if the tax for this product differs from the global tax which is set in the shopping cart.

Product Button > Label

The text in the product button.

Product Button > Alignment

Alignment of the text in the product button.

Product Button > Font Style

Style of the text in the product button.

Product Button > Padding Left

Sets the distance from the left side of the product button to the content in pixels.
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Product Button > Padding Right

Sets the distance from the right side of the product button to the content in pixels.

Product Button > Padding Top

Sets the distance from the top side of the product button to the content in pixels.

Product Button > Padding Bottom

Sets the distance from the bottom side of the product button to the content in pixels.
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20. Publish Website
Publish your website immedialtely on the internet with the built in ftp client.

You need a web server to publish your website on the internet. Usually a website hosting service

will provide you access to a web server, but you can also operate a web server by yourself.

INFO: Goldfish will not help you to find a hosting service or register a domain like 

www.mywebsite.com. But you can find many hosting services with Google (

http://www.google.com).

The code files which Goldfish creates must be uploaded to your web server (blue cloud). The

visitors of your website get in touch with your webserver and receive your website from there.

If your website is complete you can publish it directly from Goldfish with the built in ftp client. You

need ftp access to your web server to publish your website. Choose File > Publish Website... from

the menu.
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Enter the address of the ftp server, the user name and password. And click on OK. The

webserver will be connected. A list of folders from your web server is shown. You can publish

your website here or navigate to a sub folder with doubleclick. Click on Publish to publish your

website.

INFO: Goldfish remembers all ftp logins which you have entered. You can choose a recent

login with the pulldown menu at the server field. If you activate Remember Password, the

password will be remembered as well.
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If there is an older version of your website on the web server, the button Publish changes to 

Update. Click on Update and Goldfish updates your website. Only the new and changed files are

uploaded.

During the build process, there may occure build errors. There are several types of build errors.

 - The e-mail address is missing: You have an e-mail form or shopping cart on your website,

but there is no e-mail adress to which the data will be sent. Enter the missing e-mail address

and click on OK

 - The internet address is missing: You have a rss newsfeed on your website, but the internet

adress is missing. The internet address is needed, by rss feeds. Enter the internet address

(e.g. http://www.mywebsite.com) and click on OK.

 - The admin password is missing: You have a comment field on your website but the

password administration purposes is missing. The password is needed if you want to delete

comments. Enter a password and click on OK.

 - There are multiple shopping carts on a page: You have a page with at least two shopping
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carts. It makes no sense to have multiple shooping carts on a page. Delete all redundant

shopping carts and built your website again.

 - A shopping cart is missing: You have a page with at least one product but there is no

shopping cart to buy it. Add a shopping cart to the page or area template and built your

website again.

INFO: If you want to build your website on the desktop, choose File > Build Website...

instead of File > Publish Website....
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21. Build your Website
Build your website on the desktop and get all neccessary files, which you can upload to a

webserver.

You need a web server to publish your website on the internet. Usually a website hosting service

will provide you access to a web server, but you can also operate a web server by yourself.

INFO: Goldfish will not help you to find a hosting service or register a domain like 

www.mywebsite.com. But you can find many hosting services with Google (

http://www.google.com).

The code files which Goldfish creates must be uploaded to your web server (blue cloud). The

visitors of your website get in touch with your webserver and receive your website from there.

If your website is complete you have to build all neccessary code files and media for the

webserver. Choose File > Build Website... in the menu and choose a destination on your hard

disk where Goldfish can save the files.

INFO: Don't upload the .gfp file to your webserver. This file contains your website project

and can't be read from a webserver. Always upload the files which you get from File >

Build Website....
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During the build process, there may occure build errors. There are several types of build errors.

 - The e-mail address is missing: You have an e-mail form or shopping cart on your website,

but there is no e-mail adress to which the data will be sent. Enter the missing e-mail address

and click on OK

 - The internet address is missing: You have a rss newsfeed on your website, but the internet

adress is missing. The internet address is needed, by rss feeds. Enter the internet address

(e.g. http://www.mywebsite.com) and click on OK.

 - The admin password is missing: You have a comment field on your website but the

password administration purposes is missing. The password is needed if you want to delete

comments. Enter a password and click on OK.

 - There are multiple shopping carts on a page: You have a page with at least two shopping

carts. It makes no sense to have multiple shooping carts on a page. Delete all redundant

shopping carts and built your website again.

 - A shopping cart is missing: You have a page with at least one product but there is no

shopping cart to buy it. Add a shopping cart to the page or area template and built your

website again.

INFO: If you want to publish your website immediately on the internet, choose File >

Publish Website... instead of File > Build Website...
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22. Import Media
Learn how you can import and process media files like images, movies and documents in

Goldfish.

Every time if you import media files (images, movies, pdf and other media), the media import

window appears. An imported media file gets included into the .gfp file. So if you pass the .gfd file

to others, it's not neccessary to pass the media files as well.

There is a preview, if you import pictures (.jpg, .png, .gif). You can also resize, rotate or flip the

pictures, so that your .gfp file gets not too big. This is recommended if you import large images

directly from a digital camera. 700 x 700 px are adequate in most cases. The resize function

resizes the picture only if it's bigger than the entered values. It resizes in aspect ratio.

INFO: The image manipulation functions are only available for .jpg and .png images. Not

for .gif images.
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You may enter a description for every imported media file. This description is used in many ways:

 - As alt text in html code for images.

 - As tooltip for links to the file (e.g. to a .pfd file).

 - As description for images in a gallery.

To edit the description or a file name, select nothing so that the properties for the project are

shown. Click on Project > Embedded Media > Choose... and the embedded media window

appears. Double click on a description to edit it

Double click on a name to edit it. Note that you can only use letters, numbers and _ for the name.

Don't remove the suffix. There is also a length restriction. If you have entered a bad name, it won't

be accepted.
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23. Working with Fonts
There are several things you should know if you work with fonts and font styles on

websites. 

Fonts and font styles are handled in font templates. Select nothing (the project properties appear)

and click on Project > Font Templates > Choose... on the properties panel. A list of all font

templates appears.

The first template on the list is the Master Template. Here you can store the default font style for

your website. If you don't set a special font for all other font templates, or components, the style of

the master template is used. Double click on a font template to rename it.

 Add a font template.

 Duplicate a selected font template.

 Delete a selected font template.

 Opens the font editor and you can edit the font template.

Click on the Edit Font Template button. The font editor will be opend.
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The following option can be set in the font editor. Note that there are sometimes not all options

avaiable. It depends on the item from which you edit the font style.

Font template

Choose the font template, on which the font style is based. The style is taken from the font

template.

Font

Activate this to overwrite the font from the font template.

Style

Activate this to overwrite the font style of the font template.

Size

Activate this to overwrite the font size of the font template.

Color

Activate this to overwrite the color from the font template.

Line space

Activate this to overwrite the line space from the font template.

Alignment

Activate this to overwrite the alignment of the font template.
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INFO: If you change the style in a font template, this changes apply to all font styles which

use this font template and where the changed style property isn't overwritten.

A font can only be displayed if the visitor has it installed on his computer.  So it's better to declare

a list of fonts, where the first font which is found will be used. Click on the button Alternative font

family next to the font selector.

 Add an alternative font family.

 Delete a selected alternative font family.

The list is processed from the top to the bottom. The first font which is found on the visitor's

computer is used.
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24. Creating Webapplications
Create web applications with Goldfish Professional in your prefered language (e.g. PHP).

INFO: Creating web applications in this form is only possible in Goldfish professional. 

PRO

In this example you will sell how simple it is to create a php web apllication in an external source

code editor and include it in a Goldfish project.

A php script has usually the suffix .php. In Goldfish you can set the suffix for code files in the

preferences. Choose Goldfish > Preferences... from the menu (Edit > Preferences... in Windows).

The preferences window appears. Enter php at Suffix of code files on the tab Create Website.

In this example, we use a simple php script that calculates the time which the visitor of your

website spents there. The program code itself is stored in an external file, created in an external

source code editor.
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 <h1>PHP Session Test</h1>

 <?php

 //Save time of the first visit in the session

 if(!isSet($_SESSION['startTime'])) {

    $_SESSION['startTime']=mktime();

 }

 //Print time delay since now

 echo '<p>You are visiting this website for '.(mktime()-$_SESSION['startTime']).' seconds

now.</p>';

 ?> 

If you have saved the file on your hard disk, drag it into your Goldfish project. It will be included as

an alias. That means only the path to the file is stored in the project. The file itself remains on

your hard disk. You can still modify it with an external editor and Goldfish publishes the changes if

you publish your website.

INFO: Goldfish supports also aliases to folders with subfolders, code files, images and

other media. Just drag everything that is needed by your scripts in the project.

Properties for Alias
These properties can be set for an alias. Select an alias to show its properties.
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Alias > Menu Title

The menu title will be displayed in all navigation menus, who contain a link to this file. Disable it

and the file is not shown in the menu.

We want to execute the script on the start page. Select the start page and click on the page area

on it so that the properties of the page area are visible. Click on Page Area > Add HTML Code

and enter the following code. This connects the script with the start page.

<?php include 'script.php'; ?>

If you want to use sessions in php, it is required to initialize the session before any html output

begins. In Goldfish you have access to the first line even before the html document begins. Select

the start page and click on Page > Add Code Before Document and enter the code below, This

initializes the session so that it can be uses by your script.

<?php session_start(); ?>

The script prints text on the screen. To change the style of the text, click on the page area and
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click on Page Area > Add CSS Code in the properties. Enter the style below. It adds a padding

and sets the page area transculent.

 padding-left:10px;

 filter:alpha(opacity=80);

 -moz-opacity: 0.80;

 opacity: 0.80;

Now your web application is complete. You can change the background and add a border to

make it cooler. Publish the website and reload it several times in the browser. The time display

will increase.

INFO: If you have scripts that handle the complete html output of a page, you can enable 

Page > Disable HTML Code Output. Goldfish creates a blank page then without any html

code. You can add your own html code with Page > Add HTML Code then or connect it

with a script.
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25. Export a Design
Export your work as Goldfish design. Build websites from your design or deliver it to your

clients.

A Goldfish design is a design template for Goldfish websites. Choose File > Designs... from the

menu to see all installed designs. Technically a design is a Goldfish project which contains the

complet layout of a website but no content.

To export a design, choose File > Export > Design... from the menu. Click on the Goldfish icon

and paste a screenshot from your design. This is used in the designs window as preview. You

can also enter a description or copyright text.

Click on OK to save your design. Goldfish Design files have the extension .gfd instead of .gfp.
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26. Preferences
In the preferences, you can change the behavior of Goldfish.

Choose Goldfish > Preferences... (Edit > Preferences... on Windows) and the preferences

window appears. The perefernces are seperated in two areas. General and Craete Website.

General
The follwoning perferences can be set on the General tab.

Search for updates at Startup

Searches at every startup of Goldfish for updates on our website. You will be notified if there is an

update available.

Use alignment guides

Use alignment guides to guide you with the layout of your website. You can drag an alignment

guide from the rulers.

Show area alignment guides on pages

If you have alignment guides on template areas, they will be shown on the page area that uses

the template area.

Snap alignment guides to object positions

if you drag an item, it will snap to an alignment guide near by.
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26: Preferences

Use sound effects

Plays sounds if there is an update available.

Close areas in the properties automatically

If you activate this, there is kept only one area open in the properties.

Create Websites
The follwoning perferences can be set on the Create Websites tab.

Name of index file

Usually, the file, which is loaded at first if the visitor enters your website is named index.htm.

Rename this if your website hosting service requires a differnent name.

Name of media folder

Here you can rename the folder for media files of your website. This is required if you create a

page with subpages which is called media, too.

name of support folder

Here you can rename the folder for support files of your website. This is required if you create a

page with subpages which is called support, too.

Suffix of code files

Here you can change the suffix for code files. Usually the extension is .htm. Some website

hosting services require .html instead.

Text encoding

Change the encoding if special characters (ä, ©, ß...) are displayed wrong on your website

JPEG export quality

Sets the quality for new calculated jpeg images. A lower quality makes smaller file sizes.
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27. Trouble and Errors
Learn what you can do if errors occure, if you find bugs or if you have trouble using

Goldfish.

Letters like ©, ä and ß are not displayed correctly on your website: Choose Goldfish >

Preferences... (Edit > Preferences... on Windows). Change Text Encoding on the tab Create

Website. If you export the website again, the characters will be displayed correctly.

When the visitor sends the form on your website, php code is shown and the visitor counter is not

displayed: Your website hosting service doesn't support php. Upgrade your websosting package

so that php is supported or remove all items which use php (visitor counter and form) from your

website.
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27: Trouble and Errors

Please fill out all fields if you see this message and describe what caused it. This is a bug of

Goldfish and your feedback helps us to improve our software.
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28. Goldfish Short Keys
Learn how to use Short Keys in Goldfish. This article contains a full list of all short keys

for Goldfish.

Application Start
 - Reset preferences

Preferences
 - Show advanced preferences

Edit Page
 - Delete selected Page Area

 - Leave edit mode

Edit Page Area
 + Click - Add or remove to selection

 - 1 px. left

 - 1 px. right

 - 1 px. up

 - 1 px. Down

 - Delete selected items

 + Resize item - Resizes in aspect ratio

 - Leave edit mode

Edit Page Item
 - Leave edit mode

Edit Text
 - Go right *

 +  or  +  - Line end *

 +  - Next word *

 - Go left *

 +  or  +  - Line start *
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28: Goldfish Short Keys

 +  - Last word *

 - Go up*

 +  - Text start *

 - Go down *

 +  - Text end *

 - Delete text left

 - Delete text right

* If you press also , the text will be selected.
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